Datamart & Hyperion: Back to Basics

Last Version Update: 3/24/2015
About the Department of Administrative Services (DAS) – Datamart Team:

The Department of Administrative Services (DAS) Datamart team provides courses with a focus on helping our customers improve their financial and technological skills.

The training materials are for the students’ use both during the course and as a reference guide after the course is complete.

For more information and a list of other available products, please visit us at our website at http://egov.oregon.gov/DAS.

Copyright & Trademarks

Copyright © 2011 by DAS Datamart Team. All rights reserved.

Trademarked names appear throughout this book. Rather than list the names and entities that own the trademarks or insert a trademark symbol with each mention of the trademark name, DAS Datamart team states that it is using the names for editorial purposes and to the benefit of the trademark owner with no intention of infringing upon the trademark.

Disclaimer

The DAS Datamart team has taken every effort to ensure the accuracy of this manual. If you should discover any discrepancies, please notify us immediately.

Department of Administrative Services
155 Cottage St., NE, Salem, OR 97301
Datamart: (503) 373-0269 – Fax: (503) 378-3514
E-mail: Datamart.Support@oregon.gov
Table of Contents

Datamart Basics ........................................................................................................... 1-1
  What is the Datamart? ................................................................................................. 1-2
  How does information get into the Datamart? ......................................................... 1-3
  How can I get current information about the Datamart? ........................................ 1-4
  History of Brio/Hyperion ......................................................................................... 1-5
  Am I ready to work in Hyperion? ............................................................................. 1-5
  Exercise ..................................................................................................................... 1-6

OCE’s and Datamart Tables.......................................................................................... 2-1
  What is an Open Catalog Extension (OCE)? ......................................................... 2-2
  Setting up an SFMA Datamart OCE ..................................................................... 2-3
  Setting up an OSPA Datamart OCE ..................................................................... 2-14
  Modifying an OCE .................................................................................................... 2-15
  Tables on the Datamart ............................................................................................. 2-16
    SFMA Financial Tables ......................................................................................... 2-16
    General Ledger Detail Tables ............................................................................. 2-17
    General Ledger Summary Tables ....................................................................... 2-18
    Other Special Financial Tables ........................................................................... 2-18
    OSPA Datamart Tables ....................................................................................... 2-21
  The Repository ......................................................................................................... 2-22
  Exercise ..................................................................................................................... 2-26

Hyperion Queries .......................................................................................................... 3-1
  Datamart & Hyperion Spider Web ......................................................................... 3-2
  BQY Documents, Sections, and Toolbars ............................................................... 3-3
  Online Help ................................................................................................................ 3-6
  Opening and Saving BQY Documents ................................................................... 3-7
  Processing and Stopping Queries ........................................................................... 3-11
Adding, Duplicating, Renaming, and Deleting BQY Sections ............... 3-15
Hiding a BQY Section ........................................................................... 3-18
Sending BQY Documents as Email Attachments .............................. 3-19
Printing BQY Sections ........................................................................ 3-20
  Adjusting the Page Margins in Print Preview .................................. 3-20
  Adding Headers and Footers ............................................................. 3-21
  Printing Sections ............................................................................ 3-21
Exercise ............................................................................................... 3-22

Hyperion Query Building Processes .................................................. 4-1
  BQY Process .................................................................................... 4-2
  Managing your Table ...................................................................... 4-3
    What can I do to the Table Properties? ....................................... 4-4
  Understanding Joins ....................................................................... 4-5
  Building the Request Line ............................................................... 4-6
  Maximizing the Query Building Process ........................................ 4-8
    Setting Restrictions on Your Query Properties ......................... 4-8
    Estimating the Size of Your Query .............................................. 4-9
  Exercises ......................................................................................... 4-10

Filters and Sorts ................................................................................ 5-1
  Filtering Queries ............................................................................ 5-2
    Setting Filters ............................................................................... 5-2
    Creating Custom Values List ....................................................... 5-6
  Modifying Filters ........................................................................... 5-7
    Ignoring Filters ............................................................................ 5-7
    Removing Filters .......................................................................... 5-7
    Filter line Logic and Order of Operations ................................. 5-8
  Variable Filters .............................................................................. 5-10
Customizing Variable Filters Dialog Box ........................................... 5-11
Sorting Data ....................................................................................... 5-12
Data Functions on the Requested Items ........................................... 5-13
Exercises ............................................................................................. 5-16

Tables and Formatting ................................................................................. 6-1
What's the difference between Results and Table Sections? .................. 6-2
Formatting Data in Results and Table Sections ................................... 6-4
Sorting Data in a Table Section ............................................................. 6-7
Suppressing Duplicate Values ................................................................. 6-8
Setting and Removing Local Filters in Results and Table Sections .......... 6-9
Creating Date Groups ............................................................................ 6-11
Creating Grouping Columns ................................................................. 6-12
Removing and Hiding Data ................................................................. 6-14
Creating Grand Totals and Break Totals ............................................... 6-15
Exercise ......................................................................................... 6-20
Lesson 1

Datamart Basics

✓ What is a Datamart?
✓ How does information get into the Datamart?
✓ How can I get current information about the Datamart?
✓ History of Brio/Hyperion
✓ Am I ready to work in Hyperion?
What is a Datamart?

The Department of Administrative Services (DAS) financial Datamart is your one-stop warehouse for financial transactions, account balances, grant profiles, PCA information, Payroll data and more, which helps employees develop reports for business information and decision making.

Many years ago, the Department of Administrative Services (DAS) State Controller's Division (SCD) sponsored the creation of a Datamart. This initiative brought data from the primary transactional accounting system (SFMA) and the payroll system (OSPA) into a relational database for various agencies and users to easily query against for information using a reporting tool. Recently, Position Information Control System (PICS), PPDB and ORBITS (Budget) data have been added to this Datamart, and many other transactional applications have been created that capture relevant information that users can use to make better business decisions.

The Datamart provides a resource for easy reporting.

In 1997, the SCD developed a Datamart of accounting data from SFMA to meet the ad-hoc reporting needs of state agencies. This became known as the SCD Datamart and later known as the SFMA Datamart. In 1999, the SCD developed a Datamart of payroll data from OSPA, which became known as the OSPA Datamart. The number of active Datamart users has expanded over the past several years, from 145 users in 1999 to an average of 360 users per month in 2007 to over 800 users in 2013.

Many agencies are using these data sources on a regular basis to meet individual agency reporting needs. Some agencies use the Datamart to replace system-generated mainframe reports. This provides agencies with more meaningful, custom designed reports and saves time since data does not need to be re-keyed from hard-copy reports for various analyses.

The Datamart gives the user the ability to create custom reports.
How does information get into the Datamart?

The DAS Datamart contains data from the following statewide systems:

SFMA (Statewide Financial Management Application)

SFMA data is updated weekly with an extract from SFMA on Friday evening and an upload on Saturday evening.

Mid-July through August (considered Month 13) the YE GL Detail, YE GL Summary, and Profile tables are updated three times per week from SFMA.

In addition, the YE Active Accounting Event table is updated the last three Thursdays during the Month 13 time period.

OSPA (Oregon Statewide Payroll Application)

The Payroll or OSPA data is updated monthly after the Final Run 2, approximately the 10th of each month. The data is available the morning after the leave accrual process has completed.

ORBITS (Oregon Relational Budget Information Tracking System)

The Orbits or budget data is loaded weekly along with the normal SFMA load process.

PPDB (Position & Personnel Database)

The PPDB data is loaded and available the first of every month.

PICS (Position Information Control System)

The PICS information is loaded weekly along with the normal SFMA extract process.

**The above dates are subject to change. See the Datamart Processing Calendar on the Datamart website for specific dates throughout the year.**
**How can I get current information about the Datamart?**

If you have any questions, suggestions, problems, or just plain comments please contact the Datamart Business Analyst listed below.

<table>
<thead>
<tr>
<th>Datamart Business Analyst</th>
</tr>
</thead>
<tbody>
<tr>
<td>155 Cottage Street NE, U50</td>
</tr>
<tr>
<td>Salem, OR 97301-3969</td>
</tr>
<tr>
<td>Phone: (503) 373-0269</td>
</tr>
<tr>
<td>Fax: (503) 378-3514</td>
</tr>
<tr>
<td>E-mail: <a href="mailto:Datamart.Support@oregon.gov">Datamart.Support@oregon.gov</a></td>
</tr>
</tbody>
</table>

**Datamart Website**

The main Datamart website is dedicated to providing valuable information on everything about the Datamart, as well as, the Hyperion application. Please visit: [http://www.oregon.gov/DAS/EGS/FBS/Pages/datamart.aspx](http://www.oregon.gov/DAS/EGS/FBS/Pages/datamart.aspx)

**Datamart Payroll Website**

The Datamart Payroll website is dedicated to providing valuable information about OSPS. Please visit: [http://www.oregon.gov/DAS/EGS/FBS/OSPS/pages/datamart.aspx](http://www.oregon.gov/DAS/EGS/FBS/OSPS/pages/datamart.aspx)

**Datamart News List**

To join the Datamart News List, please visit the main Datamart website, shown above, and review the Datamart-News section. There is an additional link on the website that goes to the E-Communications site. Follow the necessary instructions and soon you will be receiving important communication from the Datamart team, as well as, other Datamart users.

**Datamart User Group Survey meetings**

The Datamart team hosts various meetings where users gather to discuss the goals, needs and direction of the Datamart. Meeting dates and times are announced through the Datamart News List.
History of Brio/Hyperion?

Since the DAS Datamart creation in 1997, the State of Oregon has come to rely on the Brio/Hyperion query tool as its primary means of retrieving accounting, payroll and other financial information.

The original application, which was called ‘Brio’ was created by the Brio Software, Inc. and was used extensively throughout the state to access the Datamart. However, in 2003, Brio was acquired by Hyperion Solutions Corporation. Hyperion continued to update the software until March 2007, when Hyperion was acquired by The Oracle Corporation.

Throughout the transition years, the State of Oregon continued to use the product extensively. In May 2010, the State of Oregon purchased an enterprise license for ‘Oracle Enterprise Performance Management System 11’ also known as Hyperion Interactive Reporting Studio (aka IR Studio). This purchase allows the state to use the Brio/Hyperion/Oracle product for years to come.

Am I ready to work in Hyperion?

If you can answer “YES” to all the questions below, you are ready to work in Hyperion.

1. Are you a state employee?
2. Do you have a RACF ID?
3. Do you have an IBM DB2 Open Database Connection (ODBC)?
4. Do you have security access to the Datamart?
5. Is Hyperion installed on your PC?
6. Have you set up an Open Catalog Extension (OCE) for Hyperion?
7. Have you completed Datamart training?
Exercise

1. What is the primary function of the Department of Administrative Services (DAS) Financial Datamart?

2. How often is the SFMA, OSPA, and PICS data updated with new information on the Datamart?

3. Name 3 resources for Datamart information:

4. What are 4 things I need before I can access the Datamart?

5. What is the name of the newest Brio/Hyperion version?
Lesson 2

OCE’s and Datamart Tables

- What is an Open Catalog Extension (OCE)?
- Setting up an SFMA Datamart OCE
- Setting up an OSPA Datamart OCE
- Modifying an OCE
- Tables on the Datamart
  - SFMA Financial Tables
  - General Ledger Detail Tables
  - General Ledger Summary Tables
  - Other Special Financial Tables
  - OSPA Datamart Tables
- The Repository
What is an Open Catalog Extension (OCE)?

In Hyperion, you use an OCE whenever you perform tasks that require you to connect to a database. The OCE is simply a definition of the connection required to view a particular database.

When you open Hyperion to begin a work session (as shown below), you must select the correct OCE for the targeted database. You can select from the list of Recent Database Connection Files or Browse your directory.

Your Recent Database Connection Files list will probably have different names compared to the above diagram because you are able to change the title of your OCE’s. Standard practice is to title the OCE whatever name helps you associate with the database you will access.
Setting up a SFMA Datamart OCE

Creating an Open Catalog Extension (OCE) in Hyperion Interactive Reporting Studio - Version 11

These are the detailed instructions to be used while setting up your Hyperion SFMA OCE. In these instructions, you will connect to the SFMA Datamart only.

1) Open Hyperion and you should see a “Welcome to Hyperion” dialog box.

Select → A New Database Connection File
Select → OK
2) This takes you to the “Database Connection Wizard”

Select **ODBC** from the ‘What connection software do you want to use?’ drop down menu.
Select **DB2** from the ‘What type of database do you want to connect to?’ drop down menu.

Check the following two boxes:
1. **Show Meta Connection Wizard**
2. **Show advanced options**

Select **Next**
3) In the box labeled “User Name” type your **Datamart User Name** (this is your State of Oregon RACF ID).

In the box labeled “Password” type your **DAS Datamart Password** (*not your SFMA password)*.

From the dropdown list select → **SFMSP**

Select → **Next**
4) Leave this screen just as it is shown with “On the current connection” marked. Click ‘Next’, to continue.

5) On this “Meta Connection Wizard” screen select \textbf{Edit}
6) This next screen is the “Meta Data Table Definition” Select the following tab from the top → Joins

7) Select → Custom
The grayed out fields now become white for data entry.
8) Fill in the fields accordingly:

- **Primary Owner**: PKEY_OWNER
- **Primary Table**: PKEY_TABLE_NAME
- **Primary Column**: PKEY_COLUMN_NAME
- **Foreign Owner**: FKEY_OWNER
- **Foreign Table**: FKEY_TABLE_NAME
- **Foreign Column**: FKEY_COLUMN_NAME
- **From**: SFMSPUSR.SFMS_WHSE_JOINS
- **Where**: PKEY_OWNER=:OWNER

Select → **OK**
Then select → **Next** to continue

Note: The above coding helps joins to automatically join together within a query section. If input correctly, this can save a lot of time and effort.
9) Check the boxes for “Allow SQL-92 Advanced Set Operations” and “Exclude Hyperion Repository Tables”.

Next, select the middle **Define** button next to ‘Owner Name’. Click this box!
10) This takes you to a screen where you can choose the table schema to view with your OCE.

Select → **Show Values**

Then, you can select the table names you want. You can select more than one by using "**CTRL+ Left Click**".

Select the following table schema:
- **SFMS**
- **PUSR** → SFMA Accounting Tables (no archived data)
- **SFMSARCH** → SFMS Archive Tables
- **YEAR** → Year-End allows access to the Repository

Select → **OK** (Note: This will close the Filter pop up window)

Then select → **Next** to continue

---

**1. Show Values, and select your table schema**

**2. OK**

**3. Next**
11) Update the next two screens as they appear below. Make changes as necessary.

Select \textbf{Next} to continue on both screens

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{database_connection_wizard1.png}
\end{figure}

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{database_connection_wizard2.png}
\end{figure}

Note: The ‘Oracle buffer size’ can vary from computer to computer.
12) Select **Finish** starting the completion of this process

13) Select **Yes** to save your OCE
14) Give your OCE a name in the **File Name** field

Select → **Save** to finalize the saving of your OCE

---

**You can save Open Catalog Extensions in any directory; however, best practice is to save it to a Network drive. This allows for easy access to all OCE files.**

**You can set your default Open Catalog Extension location in the Hyperion directory (Go to the following menu items to accomplish this task: Tools, Options, Program Options, and File Locations).**

**The standard SFMA OCE is downloadable from the Datamart website: [http://dasapp.oregon.gov/datamart/](http://dasapp.oregon.gov/datamart/)**
Setting up an OSPA Datamart OCE

Follow the same steps as the SFMA Datamart OCE process except replace step 10 above with the following step 10.

10) This takes you to a screen where a selection of tables must be decided for the OCE.

Select → Show Values

Then you can select the table names you want. You can select more than one by using “CTRL+ Left Click”.

Select the following tables:
OSSPUSR
YEAREND

Select → OK
Then select → Next to continue

1. Show Values, and get your tables!

The standard OSPA OCE is downloadable from the Datamart website: http://dasapp.oregon.gov/datamart/
Modifying an OCE

When you create an OCE, you establish a working database connection for querying. You may need to modify an OCE to reflect changes in your network or hardware configuration, or to manage other connection information.

To modify an OCE:

1) Close any open Hyperion documents. This will display a blank grey screen within the Hyperion application.

2) Select → Tools → Connection → Modify

The Modify Connection dialog box appears.

3) Select the connection file you want to modify and select → Open

The Database Connection Wizard appears and displays the information for the OCE you selected.

4) Make any desired changes and then save the OCE when prompted.

Have fun working in Hyperion! You are now ready to create queries and run reports.
Tables on the Datamart

There are two types of tables on the Datamart: Financial and Profile. The main difference between the two is the financial tables contain financial information, such as General Ledger balances, and transaction amounts. While the profile tables provide titles for various data elements, or allows a roll-up of information to a higher level than the financial table can provide.

If you want detail finer than what is on any of the financial tables, you are not going to have much luck. The Datamart and the query tools can only slice and dice the data as deeply as the data goes. For example, if you want to get a subset of your comptroller objects. You will not have a way to tie that subset together using data on the Datamart; you are going to be stuck (likely) having to go to the detailed records or the original documents.

SFMA Financial Tables

Accounting Event Tables

Active Accounting Event - This table mirrors the data from the SFMA system. Data is reflective of the current 3 months of active transactions.

All Accounting Event - This table mirrors the data from the SFMA system. Data is reflective of the current fiscal year and five prior years of transactions. This table may contain up to two years of addition information depending on the purge timetable.

Archive Accounting Event - This table mirrors the data from the SFMA system. Data is reflective of the current fiscal year and seven prior years of transactions. This table may contain up to two years of addition information depending on the purge timetable.

YE Active Accounting Event - This table mirrors the data from the SFMA system. Data is reflective of the current fiscal year of transactions. This table is updated only three times during month 13 and at other times of the year, this table contains zero data.

The accounting event tables are the lowest level of detail in the Datamart. All other financial tables are various summaries of this information.
Note: In the Datamart, ‘date’ fields are actual dates, while date fields in SFMA are ‘text’ fields. This allows SFMA to contain dates not on a standard calendar. Month 13, identified through effective date, is the best example of this occurrence. In SFMA, Month 13 is identified as 6/31/YEAR. In the Datamart, date fields are not allowed to have dates not on the calendar – a data validation feature in DB2. In order for us to move data to the Datamart, we have to do some “data washing”. Dates like 6/31/YEAR are changed to 6/30/YEAR, a new data element is introduced called Batch Date Ci. The download program picks up the last digit in the month and records it in this field. This way, any time an incorrect date is entered into SFMA, it is corrected in the Datamart, and an indicator is provided.

Note: The Fiscal Month field identifies the appropriate fiscal month, including month 13.

**General Ledger Detail Tables**

**General Ledger Detail**→ This table mirrors the data from the SFMA system. This table summarizes General Ledger balances, and summarizes at the object and agency object level.

**YE General Ledger Detail**→ This table mirrors the data from the SFMA system. However, the data on this table is updated only during month 13 close. During the period of approximately mid-July to the close in August, this table is updated with the balances in the **current fiscal year only**. At other times of the year, this table contains zero data.

This table summarizes General Ledger balances, and summarizes at the object and agency object level.

**Arch GL Detail**→ This table mirrors the data from the SFMA system. The period available is dependent on the date of agency implementation onto SFMA.
General Ledger Summary Tables

General Ledger Summary ➔ This table mirrors the data from the SFMA system.

This table summarizes General Ledger balances, but does not contain any object level detail.

YE General Ledger Summary ➔ This table mirrors the data from the SFMA system. However, the data on this table updates only during month 13 close. During the period of mid-July to end of August, this table updates with the balances in the current fiscal year only. At other times of the year, this table does not contain data.

This table summarizes General Ledger balances, but does not contain object level detail.

Arch GL Detail ➔ This table mirrors the data from the SFMA system. The period available is dependent on the date of agency implementation onto SFMA.

The General Ledger Tables are a higher level of summarization in the Datamart than the Accounting Event tables. Balances for the tables are by month, and are cumulative by month. This means that a balance in the ‘M03 Balance GI’ field will contain the total of months one, two and three. Monthly information for nominal GL accounts, except for month just closed, must be created using calculated fields.

Other Special Financial Tables

Appropriation Financial Table

The Appropriation Financial table mirrors the data from the SFMA system. This provides information similar to the “62” screen on SFMA.

Contract Financial Table

The Contract Financial table mirrors the data from the SFMA system. This provides information similar to the “68” screen on SFMA.
Grant Financial Table

The Grant Financial table mirrors the data from the SFMA system. This provides information similar to the “66” screen on SFMA.

Project Financial Table

The Project Financial table mirrors the data from the SFMA system. This provides information similar to the “80” screen on SFMA.

Receipt Extr Sum Table

The Receipt Extr Sum table mirrors the data from the SFMA system. This provides information similar to the “12/13” screen on SFMA.

Document Financial Tables

Doc Financial Table → mirrors the data from the SFMA system. This provides information similar to the “64” screen on SFMA.

Arch Doc Financial Table → mirrors the data from the SFMA system. This provides information similar to the “64” screen on SFMA.

Payment Control Table

The Payment Control table mirrors the data from the SFMA system. This provides information similar to the “47” screen on SFMA.

Currently, this table only contains archived data and is updated on a yearly basis. To obtain current payment control data, please contact Datamart Support.
### Profile Tables

Profile tables contain data back to the beginning of RSTARS, which is 1995.

<table>
<thead>
<tr>
<th>Field</th>
<th>Screen</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agency</td>
<td>D02</td>
</tr>
<tr>
<td>Agency Code 1</td>
<td>D26</td>
</tr>
<tr>
<td>Agency Code 2</td>
<td>D27</td>
</tr>
<tr>
<td>Agency Code 3</td>
<td>D36</td>
</tr>
<tr>
<td>Agy GL</td>
<td>D32</td>
</tr>
<tr>
<td>Agy Obj</td>
<td>D11</td>
</tr>
<tr>
<td>Agy Obj Grp</td>
<td>D25</td>
</tr>
<tr>
<td>Appn No</td>
<td>20</td>
</tr>
<tr>
<td>Appr Fund</td>
<td>D22</td>
</tr>
<tr>
<td>Budget Obj</td>
<td>D01</td>
</tr>
<tr>
<td>Cash Fund</td>
<td>D73</td>
</tr>
<tr>
<td>Compt Obj</td>
<td>D10</td>
</tr>
<tr>
<td>Compt Srce Grp</td>
<td>D09</td>
</tr>
<tr>
<td>Contract</td>
<td>30</td>
</tr>
<tr>
<td>Fund D23</td>
<td>D23</td>
</tr>
<tr>
<td>GAAP Fund</td>
<td>D24</td>
</tr>
<tr>
<td>GL Acct</td>
<td>D31</td>
</tr>
<tr>
<td>Grant No</td>
<td>D47</td>
</tr>
<tr>
<td>Grant Obj</td>
<td>D48</td>
</tr>
<tr>
<td>Grant Phase</td>
<td>29</td>
</tr>
<tr>
<td>Index No</td>
<td>24</td>
</tr>
<tr>
<td>Operator ID</td>
<td>D96A/B</td>
</tr>
<tr>
<td>Org Code</td>
<td>D03</td>
</tr>
<tr>
<td>PCA</td>
<td>26</td>
</tr>
<tr>
<td>PCA Index Rel</td>
<td>21</td>
</tr>
<tr>
<td>Program Code</td>
<td>D04</td>
</tr>
<tr>
<td>Project No</td>
<td>D42</td>
</tr>
<tr>
<td>Project Phase</td>
<td>27</td>
</tr>
<tr>
<td>State Fund Grp</td>
<td>D20</td>
</tr>
<tr>
<td>Sub Grantee</td>
<td>31</td>
</tr>
<tr>
<td>TDate</td>
<td>Generated – not on SFMA</td>
</tr>
</tbody>
</table>
**OSPA Datamart Tables**

The OSPA Datamart contains data processed through the Oregon Statewide Payroll Application. Data is updated monthly following the close of the payroll month, which is around the 10th of the following month. Check the OSPS Datamart Processing Calendar for specific dates.

The OSPA tables on the Datamart do not contain profile table data as the SFMA tables. These tables are each a flat-file database made from report output. This does make querying a bit more difficult, as you really have to know exactly what you are looking for, and where to find it.

**OSPA DED Tables**: OSPA Deductions
- OSPA Ded - Current Biennium
- OSPA Ded B - Current and Prior Biennium
- OSPA Ded PB - Prior Biennium
- OSPA Ded PP - Prior-Prior Biennium (2 prior biennia)

**OSPA JS Lab Adj Tables**: OSPA Job Status, Labor and Gross adjustments
- OSPA JS Lab Adj - Current Biennium
- OSPA JS Lab Adj B - Current and Prior Biennium
- OSPA JS Lab Adj PB - Prior Biennium
- OSPA JS Lab Adj PP - Prior-Prior Biennium (2 prior biennia)

**OSPA Labor Cost Tables**: Labor Costs
- OSPA Labor Cost - Current Biennium
- OSPA Labor Cost B - Current and Prior Biennium
- OSPA Labor Cost PB - Prior Biennium
- OSPA Labor Cost PP - Prior-Prior Biennium (2 prior biennia)

**OSPA LV Accrual Tables**: Leave Accruals
- OSPA LV Accrual - Current Biennium
- OSPA LV Accrual B - Current and Prior Biennium
- OSPA LV Accrual PB - Prior Biennium
- OSPA LV Accrual PP - Prior-Prior Biennium (2 prior biennia)

**OSPA Net Pay Tables**: Net Pay amounts
- OSPA Net Pay - Current Biennium
- OSPA Net Pay B - Current and Prior Biennium
- OSPA Net Pay PB - Prior Biennium
- OSPA Net Pay PP - Prior-Prior Biennium (2 prior biennia)

**OSPA Work Sched Table**: Work Schedule amounts
The OSPA Datamart **does not** contain:

- Confidential Information, such as Social Security numbers, wage withholding, garnishment info, bank account information or certain insurance surcharges
- Data sourced from other applications such as salary range or employee addresses
- Detailed daily time information if not using Online Daily Time
- Furlough savings information

**There are special view tables that agencies request be created to help lock or unlock specific data within the Datamart.**

### The Repository

The ‘Repository’ is a great tool to help share standard reports with users on a statewide level. The purpose of sharing these reports is to allow agencies to have an outlet to access reports created by different agencies. The Datamart team cannot guarantee these reports will function properly for each agency, due to specific agency structure setups; however, please feel free to make modifications to suit your agency.

The Repository contains many files, which access data from SFMA, ORBITS, OSPA, etc. Thanks to users throughout the state, we continually obtain more reports to help with our daily operations.

Below are instructions for accessing the Datamart Repository.

1. Open Oracle Hyperion Interactive Reporting Studio (Formerly known as Brio). Click **Cancel** if you get a ‘Welcome’ dialog box requesting to open files or open a database connection.

2. Select **File > Open from Repository > Select**. Select the Open Catalog Extension (OCE) that connects to the Repository.

3. Select the proper OCE and click **Open**. In this example, the OCE is called “Datamart”. Your OCE name may be different. You should see a screen similar to the following:
4. You will be prompted for your Datamart user name and password. Input the information and click **OK**. You should see a screen similar to the following:

5. If no errors have occurred with your log in data, you should see a screen similar to the following:
If your OCE is set up to go directly to the “YEAREND” directory, instead of seeing the above info, you might see something similar to the following:

Click on the \(\text{+}\) next to “YEAREND”. Your screen should look like the following:

6. Click on the \(\text{+}\) next to “Standard Query with Reports”. Your screen should look like the following (Again this may be somewhat different depending on your OCE setup; you may not see anything but the three folders “Data Model”, “Standard Query” and “Standard Query with Reports”):
7. Scroll down until you find the report you want to use. Once selected a description field for the file will be shown on the right side. Click Open. Your screen should look like the following:

Once the Repository file is open, please review the Dashboard information contained in the file, prior to running the query.
Exercise

1. What is an Open Catalog Extension (OCE)?

2. How many OCE’s can I set up on my machine?

3. Can I modify an existing OCE on my machine?

4. Name the 2 types of tables on the Datamart.

5. Name 3 financial tables found in the Datamart.

6. Name 3 profile tables found in the Datamart.

7. Name 3 OSPA tables found in the Datamart.

8. Name a resource, which provides a great tool to help share standard reports with users on a statewide level.
Lesson 3

Hyperion Queries

- Datamart & Hyperion Spider Web
- BQY Documents, Sections, and Toolbars
- Online Help
- Opening and Saving BQY Documents
- Processing and Stopping Queries
- Adding, Duplicating, Renaming, and Deleting BQY Sections
- Hiding a BQY Section
- Sending BQY Documents as Email Attachments
- Printing BQY Sections
  - Adjusting the Page Margins in Print Preview
  - Adding Headers and Footers
  - Printing Sections
Datamart & Hyperion Spider Web

Let’s talk about the flow of data from the financial world to the Datamart. How does it get to your machine and out on a piece of paper for your boss or meeting?
BQY Documents, Sections, and Toolbars

BQY Documents

A BQY document is a reporting file created in Hyperion and has the file extension of ‘.bqy’. The structure of a ‘bqy’ can contain various sections such as queries, results, tables, pivots, charts, reports, and dashboards.

BQY Sections

Queries ➞ Used to create questions against the Datamart.

Results ➞ Used to display the rows returned/retrieved from a query built in the query section. You can take the results of the query and develop filters, sorts, computed items, and format.

Tables ➞ Used to create organized subsets of your query results. These are tabular-styled simple reports. You can develop filters, sorts, computed items, and format this data.

Pivots ➞ Used to create cross-tabular style reports in which you can analyze data. You can focus or drill-down on data items in this area. Data facts are aggregated (combined) in this area.

Charts ➞ Used to create horizontal and vertical bar, line, pie, cluster, scatter, and ribbon style charts. You can format all areas of your charts.

Reports ➞ Used to develop free-form reports where multiple result sets are displayed in a combined area. This is where you can integrate foreign results that have been imported into your .bqy with current information from the Datamart.

Dashboards ➞ Used to offer a user-friendly interface approach to querying and manipulating results, pivots, charts, and reports. Users are able to check boxes, access drop-down lists, select radio buttons, and filter results based on their specific needs and criteria.
BQY Toolbars

The following figure shows the sections and toolbars of a Hyperion .bqy.

Your Section and Elements Pane will vary depending upon the .bqy you are developing.
The application allows you to hide and unhide the various sections as much as desired. If you can't visually see a toolbar or section, you can select **View** from the **Menu Bar** and choose what you would like to see.

**You can view or hide sections and toolbars by selecting:**

**View** → **Toolbars**

Selecting a section from the View menu list will display or hide that section.

**Additional view options are shown in the ‘toolbars’ section**

**View** → **Toolbars**
Online Help

Online help is available through Hyperion.

To access help:

From the Menu Bar (Note: Must have bqy started)

Help→Help on Content

Or

Select the ‘F1’ key

This will take you to Hyperion online help. You can search for help by three methods:

- Contents→ Allows the user to search for help on a pre-defined topic
- Index→ Search for help on predefined topics alphabetically
- Search→ Type your help issue in the search box for results
Opening and Saving BQY Documents

A .bqy document is just like any other document you would create, edit, save, close, or open; only it lives in Hyperion. The .bqy is the file extension for a Hyperion document.

Opening a BQY Document

From the welcome window, you can double-click on an existing .bqy to open it or you can go into Hyperion and create one from scratch. Below is an example of the opening dialog box you will see when opening the application.

You can choose a Recent Document from the bottom half of this screen or open an OCE from the upper half of this screen.
Starting a new .bqy using the SFMS.oce:

Open the Hyperion application

From the welcome window, select **Browse from Recent Database Connection File**

Select **SFMS.oce** → **OK**

Type **User Name** and **Password** (this is your assigned Datamart security user name and password)

You should now see the following screen:

You may have to click on the + next to **Tables** to see all the topics available to use.
You have the option to right-click on any table within the Elements section to view the full name. This displays not only the standard table name but the schema it is associated.
Saving a BQY Document

Just like any other application, you have several choices for saving your .bqy.

**You can save a .bqy by selecting:**

**File→Save**
This saves the .bqy under the existing name and updates any changes you have made to the opened document. This does not create a new .bqy document unless it has never been saved.

**File→Save As**
This takes an existing .bqy document and saves it as a new document with the changes you have made. Use this option when saving a .bqy for the first time or when you desire to keep the existing .bqy document and create a new .bqy document.

**File→Save Options→Save Query Results With Document**
Use this if you want to perform off-line data analysis of your .bqy. This allows you to view the results of a processed query at any time. If you do not save query results, then they will be erased from the results section, once the file is closed.

**File→Save Options→Compress Document**
This features results in smaller file sizes and can be set as a default (Tools, Options, Program Options, General tab, and check ‘compress all documents’).

**File→Save Options→Password Protect Document**
Users will need a password to access this document. Be careful! You need to remember your password.

**File→Save Options→Password Protect Design Mode**
Password protection used to guard Dashboard designs.
Processing and Stopping Queries

Prior to processing a query, you must complete the following steps:

Add a ‘Table’ to your query section:

Bring a Table over from the Elements Pane to the Content Pane. You can drag and drop or double-click.

Add fields in a Table to the Request line:

All Fields: Right-click → Table Name → Left-click → Add Selected Items
Individual Fields: Right-click → Field Name → Left-click → Add Selected Items
Create a Filter for your query:

Filters are essential to help your query run efficiently and help eliminate any unnecessary data.

There are two standard ways to create a filter:

Double-click \textbf{Field Name}. A ‘Filter’ dialog box pops up. You can manually input a value in the ‘Custom Values’ section and Click \textbf{OK} or;
Click \textbf{Show Values} \rightarrow Select an option \rightarrow Click \textbf{OK}

Right-click \textbf{Field Name} \rightarrow ‘Filter…’ A ‘Filter’ dialog box pops up. You then manually input a value in the ‘Custom Values’ section and Click \textbf{OK} or;
Click \textbf{Show Values} \rightarrow Select an option \rightarrow Click \textbf{OK}

Once the query section has a table to pull data from, the request line and the filter line set up with information, it is time to process the query.

Processing Queries

Processing a query refreshes the data in the .bqy document based on your requested line items and filters specified. When a query is processed Hyperion goes back to the Datamart and retrieves this information for your query. The process time depends on the data you are asking the Datamart to retrieve, the power of the Datamart server and connection to the server.

Due to the fact that your .bqy document could have more than one query, there are three process options to choose from:
Datamart & Hyperion: Back to Basics

Lesson 3

Hyperion Queries

Process Current → Processes the query that is currently active.
Process All → Processes all queries that exist in the .bqy document.
Process Custom → Opens a Process Custom dialog box so you can choose which queries to process. Simply put an X in the box next to the query.

Process Order of Queries

It is important to remember how you develop your queries. If you create a .bqy with multiple queries and some of those queries depend upon others in that .bqy, you will want to make sure you order them to process in the proper order.

Tools → Process Query → Process Order

Click on the up and down arrows to select your order process for the queries.
Stopping Queries

Sometimes when you process a query or queries in a .bqy document you may find the data is not being returned from the Datamart in a timely manner. Users want to be conscious of their query/process time to keep up top performance. It is important that you use the process listed below to stop the query. Exiting out of Hyperion does not stop the query process to the Datamart and it will continue to use resources to process the query.

To stop a query:

Open the Internet
  Go to \[http://dasdm1.iservices.state.or.us/\]
Log in using your Datamart user name and password
  Select \[List or Kill Queries\]
  Select \[Kill Queries\]

Sometimes after you stop a query, you may notice a ‘Results’ set of data is returned. This is called ‘partial data’ and you must be careful because these results are not complete.

You can also stop a query once it starts providing results.
  \[Hold down the ‘alt’ key along with the ‘End’ key\]

Hyperion application ‘Status’ bar:
Adding, Duplicating, Renaming, and Deleting BQY Sections

You can add, duplicate, rename, or delete a .bqy section at any time.

To add a new section:

Insert ➔ New ➔ Select the Section you want to add

Your choices are:

To duplicate a new section:

Edit ➔ Duplicate Section

Right-click on the Section you want to duplicate
To rename a section:

Edit → Rename Section

Right-click on the Section you want to rename

To delete a section:

Edit → Delete Section

Right-click on the Section you want to delete
In the desktop version 11 of Hyperion you cannot re-arrange the sections of your .bqy.
Hiding a BQY Section

Often it is helpful to hide a section on the Section Pane for security reasons or making your .bqy more user friendly for the end user.

To hide a section:

Select View → Hide Section

To show your hidden section:

Select View → Unhide Section  
Select Query → OK
Sending BQY Documents as Email Attachments

Hyperion Interactive Reporting Studio has the capability of sending .bqy as email attachments.

To send a .bqy as an email attachment:

Select File→Send

Note: Hyperion has the ability to send an entire section to another program. For example, you can 'Export' a 'Results' section to Excel, if needed. To accomplish this task, go to the 'file' menu, export, and section.
Printing BQY Sections

Adjusting the Page Margins in Print Preview

When your .bqy is complete, you may want to view your finished product and adjust the margins, add page numbers, and headers and footers before to printing or emailing. Prior to Print Preview, you must select the section you want to preview in the Section Pane. Please note: The Report & Dashboard Sections do not have a Print Preview mode.

To Print Preview a section:

File → Print Preview

To adjust the page margins:

Just put your mouse pointer over the dashed margin lines and click and drag to get your desired margins. You can do this both vertically and horizontally.

<table>
<thead>
<tr>
<th>Fund</th>
<th>GI Acct</th>
<th>M/3 Balance Cs</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>2</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>3</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>4</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>5</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>6</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>7</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>8</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>9</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>10</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>11</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>12</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>13</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>14</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>15</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>16</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>17</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>18</td>
<td>4250</td>
<td>0085</td>
</tr>
<tr>
<td>19</td>
<td>4250</td>
<td>0085</td>
</tr>
</tbody>
</table>
Adding Headers and Footers

Adding a Header or Footer to your .bqy section gives you the opportunity to add page numbers, file names, date and time, and query filters.

To add a Header or Footer:

Select Insert→Page Header or Page Footer

Printing Sections

You can print any section of your .bqy.

To print a Section:

Select File→Print

You can select the correct printer, printer properties, number of copies, and range you would like to print.
Exercise

Name the 6 sections you can create in a .bqy.

a.
b.
c.
d.
e.
f.

1. Create a .bqy file using an oce that accesses SFMS data.

2. Expand the Table list on the Element Pane.

3. Bring the ‘GL Detail’ Table over to the Content Pane.

4. Sort the table fields alphabetically. (Hint: Right-click on the title of the table and select properties).

5. Add the following Items to the Request Line:
   a. Agency
   b. GL Acct
   c. Fund
   d. Fiscal Year
   e. M13 Balance GL

6. Filter the following Items:
   a. ‘Agency’ equal to ‘585’
   b. ‘Fiscal Year’ equal to ‘2012’
   c. ‘M13 Balance GL’ not equal to zero
7. Process the query. Does your query look similar to the examples below? How many rows were returned? (Answer: 103,608)

8. Rename your *Query* section as “Query - GL Detail” and rename your *Results* section as “Results - GL Detail”.

9. Duplicate your “Query - GL Detail” section. Notice it automatically alters the name of the new sections.

10. Add a page header to your *Results* section called “Results - GL Detail”. Note: You can only see the new header if you are in print preview mode.

11. Alert the instructor after correctly completing the exercise.
Lesson 4

Hyperion Query Building Processes

✓ BQY Process
✓ Managing your Table
  o What can I do to the Table Properties?
✓ Understanding Joins
✓ Building the Request Line
✓ Maximizing the Query Building Process
  o Setting Restrictions on your Query Properties
  o Estimating the Size of your Query
BQY Process

BQY documents are files you create and use to retrieve information from a database, analyze the information, and build reports. Because Hyperion is an integrated query, analysis, and reporting tool, documents have multiple sections, each of which governs one part of the query and reporting process. You create sections progressively: first, query a database, then retrieve results, next add tables, pivots, and charts for additional analysis and last generate reports.

Documents can contain data from any number of relational databases queries, multidimensional database queries, and/or from imported data. Documents usually include one or more of the following items:

- A **DataModel**: This is a visual representation of the actual database tables.
  
  Note: Using the ‘Sync with Database’ operation, within the ‘DataModel’ menu, can be very helpful to sync your query with the current database and make sure you have all fields available.

- A **query** or multiple queries for retrieving a subset of data from the database.

- **Join** options, including local joins between different data sets within a single document, local join filters, and optional join path generation.

- **Results and table** sections display data in a table-style format.

- Multidimensional **pivots** that permit drill-down analysis of data results.

- **Charts** that graphically display your query results and allow different angles of vision on the data.

- **Reports** presenting customized hierarchical views of your data.

Most Hyperion documents have at least one Query and one Results section. From the Results section, you can create multiple Pivot, Chart, Table, and Report sections to analyze and present data.
Managing your Table

Shown below is a Table also known as a Topic. By double-clicking on the Topic Title Bar you will open the Properties of this particular Table. You can also right-click on the Title Bar to open the Properties.

Below you can see the Properties of the Table Grant No. Notice the Table Name is more user-friendly than the Physical Name. This is a transition change that happens when the data is uploaded from SFMA to the Datamart.
What can I do to the Table Properties?

**Table Name** ➔ It is possible to change this name to something that is more understandable.

**Physical Name** ➔ Normally, you would not alter this name. This is the full name of the underlying database table.

**Hide/Show All** ➔ Hides or actively shows all table items.

**Up/Down** ➔ Moves selected item up or down one space in the topic display.

**Sort** ➔ Alphabetically sorts listed items.

**Set As Dimension** ➔ Defines the drill-down path or hierarchy for dimensional analysis as shown in the data model.

**Allow Icon View** ➔ Enables the icon view option for the table.

**Allow Detail View** ➔ Enables the detail view option for the table.

**Cause Reload** ➔ Specifies automatic reloading of server values the next time detail view is activated.

**Rows to Load** ➔ Specifies the number of rows to be loaded and displayed in detail view.

---

Be careful if trying to use ‘Icon View’ because it deactivates a table and reduces it to an icon in the Content frame. This feature may break joins within the query section.

**Detail View, Cause Reload & Rows to Load:** If you choose ‘detail view’, you will see the amount of rows identified in the ‘rows to load’. You will receive an updated value, if ‘cause reload’ is checked or ‘rows to load’ is altered.
Understanding Joins

Tables in relational databases share information through a conceptual link, or join, between related columns in different tables. These relationships are displayed in the data model through visual join lines between fields.

Joins enable you to connect or link records in two tables by way of a shared data field. Once a data field is shared, other data contained in the joined tables can be accessed. In this way, each record can share data with another record, however, it does not store or duplicate the same kind of information.

Joins can be automatically created for you, or joined manually.

Join types determine how data is retrieved from a database.

To specify a join type:
1. Double click on a join line and a ‘join type’ window opens, displaying the various joins to select.
2. Select a join type and click OK.

Four types of joins are supported:
- **Simple join** (=, >, <, >=, <=+): A simple (linear) join retrieves the records in both tables that have an identical data in the joined columns. Within the ‘join properties’ window, you can change the default join setting for simple joins by choosing an operator from the drop-down box. The default setting, Equal, is preferred.

- **Left join** (+=): A left join retrieves all rows from the fields on the left and any rows from the fields on the right that have matching values in the join column.

- **Right join** (=+): A right join retrieves all rows from the field on the right and any rows from the field on the left that have matching values in the join column.

- **Outer join** (+ = +): An outer join combines the impact of a left and right join. An outer join retrieves all rows from both tables matching joined column values, if found, or retrieves nulls for non-matching values. Every row represented in both topics is displayed at least once.

**Note:** Not all database servers support all join types.
Building the Request Line

As you build your query, you can reorder, remove, or hide items on the Request line. This allows you to change the way in which the query processes and displays.

Reordering Request Items
You can move requested fields to reorder them for viewing results.

- To reorder items on the Request line, select the item to be moved and drag it to a new location on the Request line.

Removing Request Items
You can remove fields from the Request line to exclude the data from your query or results set.

- To remove a field from the Request line, select the desired item and complete one of the following actions:
  - Click the ‘Remove’ button on the standard toolbar.
  - Right-click on a field and select ‘Remove’.
  - Press the Delete key.

If you have not yet processed the query, Interactive Reporting removes the item from the Request line; however, if you have previously processed the query, the Report Refresh dialog is displayed with this message:

“The section XXXX (section) references the following removed column(s): XXXX (column name). Do you want to keep references to these columns or turn off auto-refresh or remove them with the query is next processed?” You can select to keep the references, or remove them.

Caution! Remove fields with caution as a computed item or report may draw data from the item you delete.

Hiding Request Items
You can hide fields that are displayed on the Request line. This allows you to incorporate data in the results set without displaying it. Hidden request items cannot be referenced for computations.

- To hide a request item, complete one of the following actions:
  - Select the item, right-click and select Hide.
  - Select the item, select the View menu, then Hide Request Items.
➢ To show a hidden request item:

Complete one of the following actions:
• Click in a blank area of the Request line, then select Unhide.
• Select the View menu, then select Unhide Request Items.

When you have identified the fields to include in the query, you can perform a number of other operations before processing the query. You can add filters to the filter line, as well as, add computed items to the Request line, or you can use a Request line fields to specify a sort order within the Sort line.
Maximizing the Query Building Process

It is good practice to routinely manage your query process. Often, you may be processing a query for the first time and will be unsure of your results and want to prevent a runaway query. There are properties you can control in order to view smaller datasets of your query.

Setting Restrictions on Your Query Properties

This process allows you to put restrictions on your query process prior to running the query. You can set a temporary constraint on the query to return a specific number of rows or to process for a specific number of minutes and then stop. You can also set the query to return only unique rows.

To access Query Properties:

Select **Query** ➔ **Query Options**

Or

Double-click ➔ **Request** on the **Request Line**

**Return Unique Rows** ➔ Eliminates duplicate rows from the dataset retrieved by the query. Only unique rows are returned.

**Return First** ➔ Filters the number of database rows retrieved to the number entered. You must enter a row filter and check mark the box.

**Time Limit** ➔ Limits the amount of time the query is allowed to run to the number entered. Seconds are entered as a decimal number. Time limits work for asynchronous (having each operation started only after the preceding operation is completed) database connections and cancel at the earliest opportunity for non-asynchronous connections.
Estimating the Size of Your Query

Queries that sift through and retrieve enormous amounts of data can take a long time to process, and may consume unnecessary system and server resources. If you suspect these factors exist, you may want to limit the size of your query before you hit the process button.

The ‘Estimate Size’ feature is an efficient way to query the database to see how many records you will potentially retrieve. You can use this feature to test a questionable query or to decide whether to prevent or postpone processing a large dataset during peak times.

To Estimate the Size of Your Query:

Select Query → Estimate Query Size

![Query Count]

Query will return 27039 row[s].
Exercise 4A)

1. Create a .bqy file using an oce that accesses SFMS data.
2. Bring the GL Detail table over to the Content Pane.
3. Open the Properties dialog box for the ‘GL Detail’ Table and sort the items.
4. Hide any Items starting with a letter “M”. (Hint – Individually click on the * in front of each item name.)
5. Enter 15 as the value of ‘Rows to Load’ and check the ‘Cause Reload’ box.
6. Select OK.
7. Display the Table in ‘Detail View’. You should see 15 total rows of data.
8. Show all the Items. (Hint: Table properties & ‘show all’ button).
9. Display the Table in ‘Structure View’.
10. Add all the Items to the Request Line.
11. Estimate the size of this query. (Discuss answer with instructor)
12. Remove the Table from the Content Pane, also removing the Items from the Request Line.
13. Once complete, close the bqy document and do not save.
Exercise 4B)

1. Open “GL Detail 12.bqy” (Obtained from instructor.)

2. Click on the Query section and log into the Datamart using an OCE that accesses SFMA information.

3. Process the query and write down the number of rows. (Answer: 1096 of 1853 rows)

4. Go to the query section.

5. Join the ‘Agency’ and ‘Fund D23’ profile tables to the ‘GL Detail’ table. Create ‘simple joins’ on Agency (contained in both tables), Fund and Fiscal Year. (Hint: Drag and Drop).

6. Add the following fields to the Request Line:
   a. Agency table
      i. Agency Title
   b. Fund D23 table
      i. Fund Title
      ii. GAAP Fund
      iii. GAAP Fund Title

7. Process the query.

8. How many rows were returned? (Answer: 1058 of 1256 rows)

9. Compare step 3 data with the new totals from step 8. Discuss the difference with the instructor.
Lesson 5

Filters and Sorts

✔ Filtering Queries
  o Setting Filters
  o Creating Custom Values List
✔ Modifying Filters
  o Ignoring Filters
  o Removing Filters
  o Filter Line Logic and Order of Operations
✔ Variable Filters
  o Customizing Variable Filters Dialog Box
✔ Sorting Data
✔ Data Functions on the Requested Items
Filtering Queries

For most queries it is necessary to set a filter on the amount of data to be returned. The Datamart contains massive amounts of data, and you want to avoid requesting unnecessary information. Before processing a query, set the appropriate filters in the Query Section.

In the Query Section, you can:
- Manually specify filter values
- Query the Datamart for filter values
- Create custom lists of filter values
- Define compound filter formulas on the Filter Line
- Set filters as variables to prompt the user to select certain values

Setting Filters

To set a filter:

1) To show the Filter Line: Select Filters(0) from the Section Title Bar

2) Drag and drop the table field you want to filter to the Filter Line or Double-click the table field

The Filter dialog box will be displayed on your screen if your OCE is active. Otherwise, you must log into your OCE prior to moving forward.
3) From the drop-down list ➔ Select a **Comparison Operator**

4) In the Edit text box ➔ **Type Values** – Separated by commas

5) Select ➔ **Green ✓** to add the values in the Edit text box to the Custom Values List

6) Select ➔ **One or more values**

7) Select ➔ **OK**

**Name** ➔ Displays the name of the filter – it defaults to the field name but you can modify it to say whatever you like.

**Include Nulls** ➔ Check mark this box to include null values.

**Operator** ➔ Select an operator from a drop-down list.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equal (=)</td>
<td>Retrieves records where the filtered item equals the specified value(s).</td>
</tr>
<tr>
<td>Not Equal (=)</td>
<td>Retrieves records where the filtered item does not equal the specified values(s).</td>
</tr>
<tr>
<td>Less Than (&lt;)</td>
<td>Retrieves records where the filtered item is less than the specified values(s).</td>
</tr>
<tr>
<td>Less or Equal (&lt;=)</td>
<td>Retrieves records where the filtered item is equal to or less than the specified value(s).</td>
</tr>
<tr>
<td>Greater Than (&gt;)</td>
<td>Retrieves records where the filtered item is greater than the specified value(s).</td>
</tr>
<tr>
<td>Greater or Equal (&gt;=)</td>
<td>Retrieves records where the filtered item is equal to or greater than the specified value(s).</td>
</tr>
<tr>
<td>Begins With</td>
<td>Retrieves records where the filtered item begins with the specified value(s) up to and including the end value.</td>
</tr>
<tr>
<td>Contains</td>
<td>Retrieves records where the filtered item contains the specified value(s) regardless of location.</td>
</tr>
<tr>
<td>Ends With</td>
<td>Retrieves records where the filtered item ends with the specified value(s).</td>
</tr>
<tr>
<td>Like (with wildcards)</td>
<td>Retrieves records where a text string appears and reflects the placement of the specified values(s).</td>
</tr>
</tbody>
</table>
For example: Names Like %LI_ would retrieve records for all employees whose names have the letters LI followed by a single character at the end.

So, “%” represents multiple characters and “_” represents a single character.

<table>
<thead>
<tr>
<th>Filter Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Is Null</td>
<td>Retrieves records where the filtered item has no value; for example, a field in which no data has been entered.</td>
</tr>
<tr>
<td>Between</td>
<td>Retrieves records where the value of the filtered item lies between (and including) the specified values.</td>
</tr>
<tr>
<td>Not (with operator)</td>
<td>Negates the operator it precedes, reversing the results of the equation.</td>
</tr>
</tbody>
</table>

**Not** Reverses (inverts) the operator selected from the drop-down list. For example, if you select Equal from the operator list and then choose Not, the operator is effectively changed to Not Equal.

**Edit Line** Enter a value or multiple values (separated by a comma, no spaces) and select the green ✓ to add the item(s) to the custom values list to complete the filter information. Select the red X to erase the contents of the Edit field.

**Show Values** Retrieves a list of values directly from the Datamart and allows you to choose a value based on the data available. Show values cannot be used for filtering computed or aggregated items.

**BE CAREFUL!** Because ‘Show Values’ goes directly to the Datamart and searches for the specified values and may take a while to return information. This means it searches all the data for exact values. If you think what you are asking for might be too large, don’t select ‘Show Values’; manually type your request in the Edit Line.

**If you are setting a filter while in the Result Section do not hesitate to use Show Values. Using Show Values in the Results Section only searches the information already gathered by your Query.**

**Transfer** Displays after you’ve selected Show Values – moves values from the Show Values section to the Custom Value list window, allowing the user to select the value from a list.
Custom Values\(\rightarrow\) This is the default value when you set a filter. One reason to use custom lists with .bqy documents is many data items rarely change, if at all. For example, a Gender item has three consistent values (male, female, and unknown). An Agency item has many more values, but may only change every year or so. Data that changes rarely is said to have low cardinality. Under such circumstances, it makes sense for users to select from a custom values list, rather than continuously querying to show Datamart values.

Custom SQL\(\rightarrow\) Displays the custom SQL dialog box for coding filters directly in SQL. The Custom SQL button appears only if you access the filter dialog box from the Query section.

Select All\(\rightarrow\) Selects all values displayed in the displayed value area.

Remove\(\rightarrow\) Removes highlighted values from the custom list or a filter.

Ignore\(\rightarrow\) Temporarily suspends a filter without deleting it.

Advanced\(\rightarrow\) Displays loaded value settings and subquery options.

Loaded Values Settings\(\rightarrow\) Toggles a custom values list to be read from a file or from the Datamart. Change File allows you to specify the file name. If you read values from a text file, vertical tabs or paragraph markers must delimit each value. Use Show Values to display the file contents.
Creating Custom Values List

You don’t always have to know your Filters prior to setting them up. You can directly query the Datamart and obtain all available values to filter. However, you must be careful! It is recommended to only use this on fields that rarely change or are not sizeable.

Once filter values are retrieved from the Datamart, you can then transfer them to a ‘Custom Values List’ so they are stored locally within the .bqy. You should do this if the filter values rarely change. If those values change occasionally, you will need to renew the Custom Values List to keep it current with the values in the Datamart.

To create a Custom Values List:

1) Drag and drop the Table field you want to filter to the Filter Line or Double-click the Table field

   The Filter dialog box will now be displayed on your screen if your OCE is active. Otherwise, you must log into your OCE prior to moving forward.

2) From the drop-down list ➔ Select a Comparison Operator

3) Select ➔ Show Values

4) Select ➔ Select All or Select the specific values you desire

5) Select ➔ Transfer

6) Select ➔ Values you want for the Filter

7) Select ➔ OK
Modifying Filters

A Filter can always be modified. You can change the values and settings permanently, temporarily ignore it, or delete it.

To modify a Filter Item:

1) In the Query Section ➔ Double-click the Filter Item
2) Make your changes to the Filter dialog box
   Operator
   Type and select new values
   Show Values and select from a new values list
   Add or remove values from the Custom Values List
3) Select ➔ OK

Ignoring Filters

You can temporarily ignore a filter without deleting it.

To ignore a Filter Item:

1) In the Query Section ➔ Double-click the Filter Item
2) Select ➔ Ignore

Removing Filters

You can permanently remove a Filter Item.

To remove a Filter Item:

Select the Filter ➔ Right-click ➔ Select Remove
Filter Line Logic and Order of Operations

The Filter Line in the Query Section provides ‘AND’ and ‘OR’ operators as well as parentheses to control the logic and order of operations of the filters. These features are available only in the Query Section, so keep this in mind when creating a query.

By using ‘AND’, ‘OR’, and parentheses, you can create complex filters and use a field on the Filter Line as many times as needed. When you add duplicate items on the Filter Line they are numbered consecutively.

The following rules apply to all Filter Line expressions:

→ By default, all equations are solved from left to right, with enclosed sub-operations evaluated first.

→ **AND** is evaluated before **OR**.

→ The **AND** operator retrieves data that meets **both** conditions. Both conditions have to be true to get information returned. For example, if you query agencies, and filter Agency to ‘100’ AND ‘107’, the dataset returned will include both agencies.

→ The **OR** operator retrieves data that satisfies **either** of two conditions. For example, if you filter Agency to ‘100’ OR Grant No to ‘515000’, the dataset returned would include Agency 100 and information about Grant No 515000.

→ Sub operations override the default evaluation order and may be required for certain operations that involve both **AND** and **OR** operators.
To set AND, OR, or parentheses on the Filter Line in the Query Section:

1) Drag two or more table fields to the Filter Line. Define individual filters in the Filters dialog boxes. (The AND operator is displayed by default.)

2) Select on the left side of the Filter Line

3) Select from the filter controls to complete the equation:
   - To toggle from AND and OR, click the operator.
   - To enclose Sub operations, select items to be enclosed and then click the parentheses button.
   - To remove parentheses, select them and click the parentheses button.
Variable Filters

Once a filter is created in the Query Section, you can construct it using the variable filter feature to prompt for values when the query is processed. Using variable filters eliminates the need for multiple queries using different filter values. You can use one query to return multiple datasets for different users.

Variable filters work great with Custom Values Lists. If a Custom Values List is created, you can answer the prompt with a choice from the Custom Values List. Each time a user processes the query, the filters are selected from the Custom Values List rather than being recreated.

To create a Variable Filter:

1) In the Query Section make sure to display the Filter Line

2) Select

3) Select Filter field → Var on the Filter Line or
   Right-click the Filter field → Select Variable Filter

<table>
<thead>
<tr>
<th>Request</th>
<th>Agency</th>
<th>GL Acct</th>
<th>Fund</th>
<th>Grant No</th>
<th>Fiscal Year</th>
<th>M13 Balance GL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter</td>
<td>[Var]</td>
<td>Grant No</td>
<td>AND</td>
<td>Fiscal Year</td>
<td>OR</td>
<td>Fiscal Year2 V(1)</td>
</tr>
</tbody>
</table>

The Filter field is displayed with a V(1) next to it. If you add other Variable Filters they are numbered V(2), V(3), etc.
**Customizing Variable Filters Dialog Box**

The Custom Filter dialog box allows you to control access to the features available in the Filter dialog window. This is useful when you distribute the .bqy to end users. It may be preferable to disable or even remove such features as Include Null or the Custom Values button. However, please remember, customizing only affects a single filter.

*To customize a variable filter:*

1) Display the Filter Line in the Query Section

2) Select Variable Filter Item to be customized → Right-click → Select Customize Filter

3) From the Customize Filter dialog window box shown above, you can do the following:
   - **Prompt** → Add a user-friendly message for display when prompted
   - **Values** → Select values you are giving end users access to use
   - **Options** → If these are check marked, you are giving the end-user access to update these options
**Sorting Data**

Use the Sort Line in the Query Section to sort data before it is returned from the data warehouse. You can only include fields on the Sort Line that also exist on the Request Line.

The appearance and functionality of the Sort Line is nearly identical in the Query, Results, and Table Sections. In each section, the Sort Line uses a drag-and-drop method similar to the Request and Filter Lines. Data sorted in the Results and Table Sections are sorted on your desktop and not directly from the data warehouse.

### To use the Sort Line in the Query, Results, or Table Sections:

1. Make sure to display the **Sort Line** if needed by selecting **Sort** on the Section Title Bar
2. Select the field on the Request Line you wanted sorted ➔ Drag-and-drop this Table Field onto the Sort Line
3. Select ✈️ on the Standard Toolbar or ➔ Double-click the **Table field** on the Sort Line to toggle **sort ascending** or **sort descending**
4. **Review your Sorted Data**
   ➔ If you are sorting in the Query section, the data is sorted by the Datamart server when you process the query.
   ➔ If the Sort Line is displayed in the Query Section, the field appears on the Sort Line. If you sort in ascending order, an up arrow appears to the right of the field name on the Sort Line; if you sort in descending order, a down arrow appears.
   ➔ If you are sorting in the Results or Table Section you must select ➔ **Sort Now**
**Data Functions on the Requested Items**

You can apply a data function to an Item on the Request Line in the Query Section to compute an aggregated value. An aggregated value is a summarized value. You can summarize items to show averages, sum, minimum, maximum, and count functions to name a few. By setting these aggregated data functions in the request area you are creating a smaller result group and demanding less of the data warehouse.

If you need both summary data and increasing levels of detail within your reporting or analysis, do not aggregate data in the Query Section.

Listed below are the data functions you can choose from using Hyperion. Although most data functions are applied in the Query Section, you can use many of them in the Pivot, Chart, or Results Sections. However, you cannot apply data functions to the Table Section. Although, in Report Sections, you are able to apply data functions but only if you select a single fact column. You can also change the way data functions are computed.

<table>
<thead>
<tr>
<th>Data Function</th>
<th>Description</th>
<th>Where Can I Use This?</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Returns unaggregated values as stored in the database. This is the default option in the Query Section.</td>
<td>Query</td>
</tr>
<tr>
<td>Sum</td>
<td>Returns sum of underlying values.</td>
<td>Query, Pivot, Chart, Results, Report</td>
</tr>
<tr>
<td>Average</td>
<td>Return average of underlying values.</td>
<td>Query, Pivot, Chart, Results, Report</td>
</tr>
<tr>
<td>Minimum</td>
<td>Returns lowest of underlying values.</td>
<td>Query, Pivot, Chart, Results, Report</td>
</tr>
<tr>
<td>Maximum</td>
<td>Returns highest of underlying values.</td>
<td>Query, Pivot, Chart, Results, Report</td>
</tr>
<tr>
<td>Count</td>
<td>Returns number of underlying values.</td>
<td>Query, Pivot, Chart, Results, Report</td>
</tr>
<tr>
<td>Count Distinct</td>
<td>Returns the number of distinct values in a column. This function is not supported by all database servers.</td>
<td>Query, Pivot, Report</td>
</tr>
<tr>
<td>Weight</td>
<td>Use for computing weighted items in pivot tables.</td>
<td>Query</td>
</tr>
<tr>
<td>Function</td>
<td>Description</td>
<td>Examples</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>Null Count</td>
<td>Returns number of nulls among underlying values</td>
<td>Pivot, Chart, Report</td>
</tr>
<tr>
<td>Non-Null Count</td>
<td>Returns number of underlying values; null values excluded</td>
<td>Pivot, Chart, Report</td>
</tr>
<tr>
<td>Non-Null Average</td>
<td>Returns average of underlying values; null values excluded</td>
<td>Pivot, Chart, Report</td>
</tr>
<tr>
<td>Standard Deviation</td>
<td>Returns standard deviation of values. This function is not supported by all database servers.</td>
<td>Query</td>
</tr>
<tr>
<td>Variance</td>
<td>Returns variance of values. This function is available through Oracle servers only.</td>
<td>Query</td>
</tr>
<tr>
<td>% of Column</td>
<td>Returns sum of all underlying values as a percentage of their respective surface column.</td>
<td>Pivot</td>
</tr>
<tr>
<td>% of Row</td>
<td>Returns sum of underlying values as a percentage of their respective surface row.</td>
<td>Pivot</td>
</tr>
<tr>
<td>% of Grand</td>
<td>Returns sum of underlying values as a percentage of all surface values in the report.</td>
<td>Pivot, Chart</td>
</tr>
<tr>
<td>% of Category</td>
<td>Returns group total percentage of the selected value.</td>
<td>Report</td>
</tr>
<tr>
<td>Increase</td>
<td>Calculates the increase between the previous two rows or columns.</td>
<td>Pivot</td>
</tr>
<tr>
<td>% Increase</td>
<td>Calculates the percentage increase between the previous two rows of columns.</td>
<td>Pivot</td>
</tr>
<tr>
<td>Title</td>
<td>Returns column names.</td>
<td>Report</td>
</tr>
</tbody>
</table>

*To use apply a data function to a Request Line Item in the Query Section:*

1) Right-click on the **Item on the Request Line** → **Select Data Function** → **Select desired Data Function**
Here are some examples of non-aggregated data vs. aggregated data:

**Example 1**

This query shows non-aggregated data using the ‘GL Detail’ table.

<table>
<thead>
<tr>
<th>Request</th>
<th>Agency</th>
<th>Gl Acct</th>
<th>Fund</th>
<th>Project No</th>
<th>Project Phase</th>
<th>Pca</th>
<th>M13 Balance Gl</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter</td>
<td>Agency AND Gl Acct AND Fund AND Project No</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Agency</th>
<th>Gl Acct</th>
<th>Fund</th>
<th>Project No</th>
<th>Project Phase</th>
<th>Pca</th>
<th>M13 Balance Gl</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 405</td>
<td>0065</td>
<td>4250</td>
<td>415000</td>
<td>00</td>
<td></td>
<td>(30,000.00)</td>
</tr>
<tr>
<td>2 405</td>
<td>0065</td>
<td>4250</td>
<td>415000</td>
<td>00 41599</td>
<td></td>
<td>30,000.00</td>
</tr>
<tr>
<td>3 405</td>
<td>0065</td>
<td>4250</td>
<td>415000</td>
<td>00</td>
<td></td>
<td>(30,000.00)</td>
</tr>
<tr>
<td>4 405</td>
<td>0065</td>
<td>4250</td>
<td>415000</td>
<td>00 41599</td>
<td></td>
<td>30,000.00</td>
</tr>
<tr>
<td>5 405</td>
<td>0065</td>
<td>4250</td>
<td>415000</td>
<td>00</td>
<td></td>
<td>(30,000.00)</td>
</tr>
<tr>
<td>6 405</td>
<td>0065</td>
<td>4250</td>
<td>415000</td>
<td>00 41599</td>
<td></td>
<td>30,000.00</td>
</tr>
<tr>
<td>7 405</td>
<td>0065</td>
<td>4250</td>
<td>415000</td>
<td>00</td>
<td></td>
<td>(30,000.00)</td>
</tr>
<tr>
<td>8 405</td>
<td>0065</td>
<td>4250</td>
<td>415000</td>
<td>00 41599</td>
<td></td>
<td>30,000.00</td>
</tr>
<tr>
<td>9 405</td>
<td>0065</td>
<td>4250</td>
<td>415000</td>
<td>00</td>
<td></td>
<td>(30,000.00)</td>
</tr>
<tr>
<td>10 405</td>
<td>0065</td>
<td>4250</td>
<td>415000</td>
<td>00 41599</td>
<td></td>
<td>30,000.00</td>
</tr>
</tbody>
</table>

**Example 2**

This query shows a ‘Sum’ Data Function on the M13 Balance Gl.

<table>
<thead>
<tr>
<th>Request</th>
<th>Agency</th>
<th>Gl Acct</th>
<th>Fund</th>
<th>Project No</th>
<th>Project Phase</th>
<th>Pca</th>
<th>SUM(M13 Balance Gl)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter</td>
<td>Agency AND Gl Acct AND Fund AND Project No</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Agency</th>
<th>Gl Acct</th>
<th>Fund</th>
<th>Project No</th>
<th>Project Phase</th>
<th>Pca</th>
<th>M13 Balance Gl</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 405</td>
<td>0065</td>
<td>4250</td>
<td>415000</td>
<td>00</td>
<td></td>
<td>(150,000.00)</td>
</tr>
<tr>
<td>2 405</td>
<td>0065</td>
<td>4250</td>
<td>415000</td>
<td>00 41599</td>
<td></td>
<td>150,000.00</td>
</tr>
</tbody>
</table>
Exercise 5A)

1. Create a .bqy file using an oce that accesses SFMS data.

2. Expand the Table Elements and add the ‘All Acct Event’ Table to the Content Pane.

3. Add the following Items to the Request Line:
   a. Batch Agy
   b. Batch Date
   c. GL Acct
   d. SFMS Trans Amt


5. Filter the Rows Returned to 100 (Hint: Lesson 4 – Return First; p.4-8).

6. Process the query.

7. Sort the Results Section by ‘Batch Date’ and ‘GL Acct’.

8. Go to the Query section and add the ‘GL Acct’ (profile) table from the Elements section to the ‘Content Pane’.

9. Add the ‘GL Acct Title’ field from the ‘GL Acct’ table to the ‘Request Line’.

10. Remove the ‘Return First’ filter of 100 Rows.

11. Add a filter by ‘Batch Date’ using the ‘Between’ data function. Showing data between ‘02/01/13’ and ‘02/14/13’. (Hint: You need to manually type in the dates, separated by a comma because these dates do not show under the ‘Show Values’ button.)
12. Add a Filter for ‘GL Acct’ and make this one a ‘Custom Filter’. (Hint: See p.5-6 for additional help)
   a. From the ‘All Acct Event’ table, add ‘GL Acct’ to the Filter Line
   b. Within the Filter pop up window, select ‘Show Values’
   c. Click on all GL Acct’s within the range of 2700 & 3600
   d. Select the ‘Transfer’ Button (Note: This moves the accounts to the ‘Custom Values’ area)
   e. Once all accounts are selected within the ‘Custom Values’ area, click ‘Ok’.

13. Process the query.

14. In the ‘Result’ Section move the ‘GL Acct Title’ to the right of the ‘GL Acct’.

15. How many rows are returned? (Answer: 1,827)

16. Go back to the ‘Query’ Section and set a ‘Data Function’ on the ‘SFMS Trans Amt’ to ‘Sum’. (Hint: right-click on the ‘Request Line’ field ‘SFMS Trans Amt’).

17. Process the query.

18. How many rows are returned? (Answer: 41)

19. Alert the instructor after correctly completing the exercise.
Exercise 5B)

1. Create a .bqy file using an oce that accesses SFMS data.

2. Expand the ‘Table Elements’ pane and bring the following tables over to the Content Pane:
   a. All Acct Event
   b. PCA
   c. Program Code

3. Sort (alphabetically) the fields in each Table.

4. Add the following fields to the Request Line:
   a. All Acct Event
      i. Batch Agy
      ii. Batch Date
      iii. GL Acct
      iv. PCA
      v. Program Code
      vi. SFMS Trans Amt (‘Sum’ this field using the ‘Data Function’ option)
   b. PCA
      i. PCA Title
   c. Program Code
      i. Program Code Title

5. Filter the ‘Batch Agency’ equal to ‘585’ and filter ‘Fiscal Year’ equal to ‘2012’.

6. Process the query.

7. How many rows are returned? (Answer: 18,128)

8. Go back to the ‘Query’ Section and Filter on ‘Program Code’ equal to 5160 and equal to 7100.

10. In the Results Section  
   a. Sort Ascending: Batch Date, GL Acct and Program Code.

11. How many rows are returned? (Answer: 495)

12. Go back to the ‘Query’ Section and ‘ignore’ the ‘Program Code’ filter.

   a. Drag the ‘GL Acct’ field to the Filter line. You will be prompted by a pop up window.  
   b. Set the ‘Custom Value’ to Begins with 31 and click ‘ok’.  
   c. Right-click on the ‘GL Acct’ Filter and select ‘Variable Filter’.

14. Process the query. (The Variable filter window for ‘GL Acct’ will pop up. Verify selection and click ‘ok’)

15. How many rows are returned? (Answer: 857)

16. Alert the instructor after correctly completing the exercise.
Lesson 6

Tables and Formatting

✓ What’s the difference between Results and Table Sections?
✓ Formatting Data in Results and Table Sections
✓ Sorting Data in a Table Section
✓ Suppressing Duplicate Values
✓ Setting and Removing Local Filters in Results and Table Sections
✓ Creating Date Groups
✓ Creating Grouping Columns
✓ Removing and Hiding Data
✓ Creating Grand Totals and Break Totals
What’s the difference between Results and Table Sections?

The Results and Table Sections are identical in functionality and appearance. So, what’s the difference? The Results Section is the gas tank for your .bqy. This is where all your queried data lives. The Results Section allows you to review your Query and confirm the Results. You can build different tables, which include smaller sections of your Results. Think of a Table Section as a filing cabinet with different files. It is a way to organize your data into smaller sub-sections and then develop Pivots, Charts, and Report from these sub-sets. Frankly, a Table Section keeps you better organized.

**Sections Structure:**

- **Dashboard** ➔ This section does not indent and can contain information from multiple Queries, Results, Tables, Pivots, Charts, and Reports. It appears at the top of the Section Catalog.

- **Report** ➔ This section does not indent and can contain information from multiple Results, Tables, Pivots, and Charts. It appears directly below Dashboard Sections and above all other sections.

- **Query** ➔ This section does not indent and is a stand-alone section in your .bqy. This section comes straight from the Datamart and is the building block for all the other sections.

- **Results** ➔ This section does not indent but resides directly below the Query Section it is dependent upon. This section is directly related to the Query Section.

- **Table** ➔ This section does not indent and resides directly below the Results Section it is associated with. You can have more than one Table Section related to a Results Section. Used primarily for creating tabular-style reports.

Notice the indenting or non-indenting for the different Sections. It is good practice to rename your sections for easier identification.
Pivot ➔ This section does indent and resides below the Table Section it is associated with. You can have more than one Pivot Section related to a Results Section. The Pivot Section is used to create cross-tabular style reports called Pivot Reports.

Chart ➔ This section does indent and resides below the Table and/or Pivot Section it is associated. You can have more than one Chart Section related to a Results Section. Charts are fully interactive, three-dimensional views of data.

Below shows a Table Section before any data is added to the Content Pane. Notice the Data Layout Section.

To create a Table Section (based on the Results section data):

1) Click on the desired Results section, select Insert ➔ New Table

2) If the table Data Layout is not already displayed ➔ Click Data Layout on the Section Title Bar

3) Drag Result Items from the Elements Pane to the table Data Layout to build your Table. (Hyperion automatically populates the table columns.)
# Formatting Data in Results and Table Sections

Use the following techniques to format data in both a Results and a Table Section.

<table>
<thead>
<tr>
<th>Format</th>
<th>Options</th>
</tr>
</thead>
</table>
| Resize a column            | ✓ To resize a column manually, drag the right margin of the column.  
|                            | ✓ To auto size a column, double-click the column margin or select **Format**→**Column**→**Auto-Size Width** (or **Standard Width**). |
| Resize a row               | ✓ To resize a row manually, select a row (click on the left margin), position the cursor on the bottom of the row, and then drag the margin up or down.  
|                            | ✓ To resize a row to a standard size, select a row and then select **Format**→**Row**→**Standard Height**. |
| Modify the font            | ✓ Select a column, select **Format**→**Font**, and then select a font type, style, size, and effect. Columns can have different fonts. |
| Modify a number, date, or time format | ✓ For numeric formatting only, select a column and then on the Formatting toolbar, select numeric formatting options.  
|                            | ✓ For a complete set of formatting options, select a column, select **Format**→**Number**, and then in the **Category** group box, select a format. |
| Justify data               | ✓ Highlight columns, and then on the Formatting toolbar, click a justification button. |
| Display row numbers        | ✓ To toggle row numbers on and off, select **Format**→**Row Numbers**. |
| Format grid lines          | ✓ Select **Format**→**Grid Lines**, and then select properties for horizontal and vertical grid lines. |
| Display or hide column titles | ✓ Select **Format**→**Column Titles**.                                    |
| Wrap text in a column      | ✓ Select a column, and then select **Format**→**Text Wrap**. |
| Modify the border around a table | ✓ Select **Format**→**Border and Background**, select properties for the border, and then click **OK**. |
Modify the table fill

✓ Select a column, multiple columns, or the entire table, select **Format ➔ Border and Background**, select background properties, and then click **OK**.

Modify the text color of a column

✓ Select a column, and then on the **Formatting** toolbar, select a text color.

The following displays the options available under the Format menu.

<table>
<thead>
<tr>
<th>Format Menu Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Font</strong></td>
<td>✓ Opens the Font page of the Properties dialog box.</td>
</tr>
<tr>
<td><strong>Style</strong></td>
<td>✓ Choose between Plain, Bold, Italics, Underline, Overline, Double Underline.</td>
</tr>
<tr>
<td><strong>Number</strong></td>
<td>✓ Opens the Number page of the Properties dialog box.</td>
</tr>
<tr>
<td><strong>Justify</strong></td>
<td>✓ Choose between Left, Center, Right and Top, Middle, Bottom.</td>
</tr>
<tr>
<td>Feature</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Column</td>
<td>✓ By default, Results columns are evenly sized without regard to the length of data. Numeric data that does not fit is replaced with pound signs (#). ✓ To manually resize a column, drag the right edge of the column to a new position. ✓ To automatically size all columns so that the column width fits its contents, press <strong>[Ctrl]+[A]</strong> then <strong>[Ctrl]+[E]</strong>.</td>
</tr>
<tr>
<td>Auto-Size Width</td>
<td>✓ Resizes the selected column to the width of the contents.</td>
</tr>
<tr>
<td>Standard Width</td>
<td>✓ Resizes the selected column to the standard column width.</td>
</tr>
<tr>
<td>Row</td>
<td>✓ Resizes all rows to the standard row height.</td>
</tr>
<tr>
<td></td>
<td>✓ To resize all rows in a table, drag the bottom edge of a row to a new position. All rows in the table are resized.</td>
</tr>
<tr>
<td>Column Titles</td>
<td>✓ Toggles the display of column titles.</td>
</tr>
<tr>
<td>Row Numbers</td>
<td>✓ Toggles the display of row numbers. Row numbers are printed on reports, but are not copied to the clipboard or exported to a file.</td>
</tr>
<tr>
<td>Text Wrap</td>
<td>✓ Wraps text in a column.</td>
</tr>
<tr>
<td>Suppress Duplicates</td>
<td>✓ Suppresses duplicate values in a column. Use this feature if you want to display only the first instance of a duplicate value when individual database records include redundant information.</td>
</tr>
<tr>
<td>Grid Lines</td>
<td>✓ Opens the Gridlines Properties dialog window.</td>
</tr>
<tr>
<td>Border and Background</td>
<td>✓ Opens the Border and Background Properties dialog box.</td>
</tr>
<tr>
<td>Conditional Formatting</td>
<td>✓ Opens the Conditional Formatting dialog box. Use to highlight important values.</td>
</tr>
<tr>
<td>Export Properties</td>
<td>✓ Opens the Export Properties dialog box. Use to set the number of rows that should be included on an HTML page before the data breaks to another page, and to export data that does not contain any quote to a tab-delimited text file.</td>
</tr>
</tbody>
</table>
Sorting Data in a Table Section

You can sort data in the Table Section using the sort options on the Standard Toolbar or the Sort Line.

To sort data using the Standard Toolbar:

1) Select ➔ Column you want sorted

2) Select ➔ Sort Ascending or Sort Descending

To sort data using the Sort Line:

1) Make sure the Sort Line is visible; if it isn’t select ➔ Sort on the Section Title Bar

2) Drag and drop fields from the Content Pane to the Sort Line. By default, fields will be sorted in ascending order.

3) Double-click ➔ Table Field on the Sort Line to toggle sort ascending or sort descending

4) Select ➔ Sort Now on the Sort Line to confirm changes
Suppressing Duplicate Values

Using the ‘Suppress Duplicates’ function will allow you to suppress duplicate values in a column. Use this feature if you want to display only the first instance of a duplicate value when individual database records include redundant information. In order to use this feature correctly, you should first sort your data within the Results or Tables sections.

To suppress duplicate values:

1) Sort the data in the Results or Table Section

2) Select the columns you want to suppress values on ➔ Right-click ➔ Select Suppress Duplicates
Setting and Removing Local Filters in Results and Table Sections

When you set a filter in the Results or Tables Section, you are locally filtering the dataset returned from a query. You are not accessing the Datamart. This is different from setting a filter in a Query Section. When you set a filter in a query, you are sending this filter directly to the Datamart. Because local filters only hide data, it is a good way to test hypothetical situations without accessing the Datamart. You can always reverse the effects of your filter and bring your query back to its original state.

To set a filter in a Results or Table Section:

1) In a Results or Table section, double-click a column and the Filter dialog box is displayed
or
Drag and drop the Table Field from the Elements or Data Layout areas to the Filter Line

The Filter dialog box will now be displayed on your screen.

2) From the drop-down list → Select a Comparison Operator

3) In the Edit text box → Type Values – Separated by commas

4) Select → Green ✔ to add the values in the Edit text box to the Custom Values List

5) Select → OK
To remove a filter in a Results or Table Section:

1) Right-click the Filtered Field ➔ Select Remove

To remove all filters in a Results or Table Section:

1) Right-click the Filter area on the Filter Line ➔ Select Remove
Creating Date Groups

This feature separates regular date type columns into Month, Year, and Quarter columns. This feature only works on columns of a date type. Please notice the before and after diagrams shown below.

### Before Date Groups

<table>
<thead>
<tr>
<th>Batch Agy</th>
<th>Batch Date</th>
<th>Sfms Trans Amt</th>
</tr>
</thead>
<tbody>
<tr>
<td>585</td>
<td>04/01/10</td>
<td>60.74</td>
</tr>
<tr>
<td>585</td>
<td>08/25/09</td>
<td>6,163.92</td>
</tr>
<tr>
<td>585</td>
<td>12/16/09</td>
<td>72.69</td>
</tr>
<tr>
<td>585</td>
<td>01/05/10</td>
<td>4,743.20</td>
</tr>
<tr>
<td>585</td>
<td>08/17/09</td>
<td>81.80</td>
</tr>
<tr>
<td>585</td>
<td>08/27/09</td>
<td>3,502.42</td>
</tr>
<tr>
<td>585</td>
<td>03/31/10</td>
<td>3,403.54</td>
</tr>
<tr>
<td>585</td>
<td>01/11/10</td>
<td>64.17</td>
</tr>
<tr>
<td>585</td>
<td>03/26/10</td>
<td>5,265.35</td>
</tr>
<tr>
<td>585</td>
<td>06/16/10</td>
<td>4,055.84</td>
</tr>
</tbody>
</table>

The first diagram is without Date Grouping.
The second diagram has a Month, Year, and Quarter column in addition to the regular date column.

### Date Groups Applied

<table>
<thead>
<tr>
<th>Batch Agy</th>
<th>Batch Date</th>
<th>Sfms Trans Amt</th>
<th>Batch Date Month</th>
<th>Batch Date Year</th>
<th>Batch Date Quarter</th>
</tr>
</thead>
<tbody>
<tr>
<td>585</td>
<td>04/01/10</td>
<td>60.74</td>
<td>Apr</td>
<td>2010</td>
<td>Q2</td>
</tr>
<tr>
<td>585</td>
<td>08/25/09</td>
<td>6,163.92</td>
<td>Aug</td>
<td>2009</td>
<td>Q3</td>
</tr>
<tr>
<td>585</td>
<td>12/16/09</td>
<td>72.69</td>
<td>Dec</td>
<td>2009</td>
<td>Q4</td>
</tr>
<tr>
<td>585</td>
<td>01/05/10</td>
<td>4,743.20</td>
<td>Jan</td>
<td>2010</td>
<td>Q1</td>
</tr>
<tr>
<td>585</td>
<td>08/17/09</td>
<td>81.80</td>
<td>Aug</td>
<td>2009</td>
<td>Q3</td>
</tr>
<tr>
<td>585</td>
<td>08/27/09</td>
<td>3,502.42</td>
<td>Aug</td>
<td>2009</td>
<td>Q3</td>
</tr>
<tr>
<td>585</td>
<td>03/31/10</td>
<td>3,403.54</td>
<td>Mar</td>
<td>2010</td>
<td>Q1</td>
</tr>
<tr>
<td>585</td>
<td>01/11/10</td>
<td>64.17</td>
<td>Jan</td>
<td>2010</td>
<td>Q1</td>
</tr>
<tr>
<td>585</td>
<td>03/26/10</td>
<td>5,265.35</td>
<td>Mar</td>
<td>2010</td>
<td>Q1</td>
</tr>
<tr>
<td>585</td>
<td>06/16/10</td>
<td>4,055.84</td>
<td>Jun</td>
<td>2010</td>
<td>Q2</td>
</tr>
</tbody>
</table>

This Quarter column is on a Calendar Year & not a Fiscal Year.

To create a date group:

1) Select a regular Date column in the Results or Table Section

2) Right-click ➔ Add Date Groups
Creating Grouping Columns

Grouping columns is a way of creating new data in your results set by grouping values from a column. You can use grouping columns to consolidate non-numeric data values into more general group values and map the group values to a new column in the data set. Grouped columns are new items added to the Results Section and are available for use in a Report Section.

Steps to create a Grouping Column:

1) Notice the Table Section below. The goal is to create an additional new column called ‘Quarter’.

2) Select the column you want to group → Right-click → Select Add Grouping Column

3) The Grouping Column dialog box opens
Column Name ➔ Names the new grouping column in the Results/Table window. This is the column header & should be different than other columns.

New Group ➔ Creates a custom group to be displayed as a value in the new grouping column.

Groups ➔ Select a custom group to define by adding or removing items.

Items in Group ➔ Displays the selected values in a group.

Available Values ➔ Values available to add to a selected custom group.

Options ➔ Indicates how to signify unassigned values within the grouping column. Options include:
   Null ➔ Leaves the values ungrouped and unaggregated.
   Default ➔ Allows you to specify a default name to assign to all ungrouped values.
   Individual Group ➔ Assigns each ungrouped value the name originally assigned to it.

4) In the Column Name field ➔ Name your Grouping Column

5) Select New Group ➔ Enter New Group Name ➔ OK
   Do this process until you have all the new groups set up.

6) Select Group in Group Column ➔ Move Available Values by selecting them and click on ➡️ to move them over to the Items in Group Column.
   Continue this process until you have all your groups set up.
7) Select → OK

<table>
<thead>
<tr>
<th>Batch Agy</th>
<th>Batch Date</th>
<th>Gl Acct</th>
<th>Sfms Trans Amt</th>
<th>Pca</th>
<th>Fiscal Quarter</th>
</tr>
</thead>
<tbody>
<tr>
<td>585</td>
<td>07/27/09</td>
<td>1111</td>
<td>(70.00)</td>
<td>71002</td>
<td>Quarter 1</td>
</tr>
<tr>
<td>585</td>
<td>07/30/09</td>
<td>1011</td>
<td>70.00</td>
<td>71002</td>
<td>Quarter 1</td>
</tr>
<tr>
<td>585</td>
<td>07/27/09</td>
<td>3101</td>
<td>(2,072.25)</td>
<td>71002</td>
<td>Quarter 1</td>
</tr>
<tr>
<td>585</td>
<td>07/30/09</td>
<td>0070</td>
<td>(140.00)</td>
<td>71002</td>
<td>Quarter 1</td>
</tr>
<tr>
<td>585</td>
<td>07/30/09</td>
<td>3500</td>
<td>140.00</td>
<td>71002</td>
<td>Quarter 1</td>
</tr>
<tr>
<td>585</td>
<td>07/30/09</td>
<td>1111</td>
<td>70.00</td>
<td>71002</td>
<td>Quarter 1</td>
</tr>
<tr>
<td>585</td>
<td>12/08/09</td>
<td>1111</td>
<td>(70.00)</td>
<td>71002</td>
<td>Quarter 2</td>
</tr>
<tr>
<td>585</td>
<td>12/08/09</td>
<td>1011</td>
<td>(70.00)</td>
<td>71002</td>
<td>Quarter 2</td>
</tr>
<tr>
<td>585</td>
<td>12/07/09</td>
<td>3500</td>
<td>140.00</td>
<td>71002</td>
<td>Quarter 2</td>
</tr>
<tr>
<td>585</td>
<td>12/07/09</td>
<td>3501</td>
<td>(140.00)</td>
<td>71002</td>
<td>Quarter 2</td>
</tr>
<tr>
<td>585</td>
<td>12/11/09</td>
<td>0501</td>
<td>(405.56)</td>
<td>71002</td>
<td>Quarter 2</td>
</tr>
</tbody>
</table>

*To modify a Grouping Column:*

1) Right-click the Grouping Column → Modify Column
Removing and Hiding Data

You can either Remove or Hide fields from your Query, Results, and/or Table Sections. Make sure to use caution when removing fields from any section. Once a field is removed from the above listed sections, you cannot use it in a Pivot, Chart, or Report. However, if you hide a field, it is still usable in all these sections.

To remove a field in the Query or Table Section:

Remove the Table Field on the Request Line from the Query Section or the Data Layout area in the Table Section.

To hide a field in the Results or Table Section:

Select the Column ➔ Right-click ➔ Hide Column
Creating Grand Totals and Break Totals

Results and Table Sections can display grand totals and break totals. You can display multiple totals each utilizing a different data function. While a grand total would appear at the bottom of a column, a break total will appear at a specified break in the dataset.

To display a grand total:

1) Select the column you want to total → Right-click → Select Grand Total
   The Insert Grand Total dialog box appears.

   You have a choice of Grand and Break Total functions:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>Returns sum of underlying values.</td>
</tr>
<tr>
<td>Average</td>
<td>Returns average of underlying values.</td>
</tr>
<tr>
<td>Minimum</td>
<td>Returns lowest of underlying values.</td>
</tr>
<tr>
<td>Maximum</td>
<td>Returns highest of underlying values.</td>
</tr>
<tr>
<td>Count</td>
<td>Returns number of underlying values.</td>
</tr>
<tr>
<td>Other</td>
<td>Allows you to create a custom function using JavaScript.</td>
</tr>
</tbody>
</table>

2) Select → Grand Total function you desire

3) Select → the column which to add the grand total

4) Select → OK
You can also create a SUM grand total using an icon on the Standard Toolbar:

1) Select→Column you want to total
2) Select→ on the Standard Toolbar

To remove a grand total row:

1) Select→Row containing the grand total
2) Right-click→Remove Row

To add a custom title in the grand total row, not the grand total cell:

1) Double-click on a cell in the same row as the grand total
2) In the Custom Function dialog box enter the title you desire and surround it with quotes ““” as shown below:
3) Select \textbf{OK}

4) From the \textbf{Modify Total Function} dialog box select \textbf{Other}

5) Select \textbf{OK}
To add a custom title in the grand total cell:

1) Double-click on the grand total cell

2) From the Modify Total Function dialog box ➔ Select Other

3) Enter your desired title surrounded by quotes “”, for example “Total: ”. Make sure to insert a space after your title!

4) Concatenate text and functions with a plus sign (+)

   “Total ”+Round(Sfms_Trans_Amt),2)

5) Select ➔ OK

6) In the Modify Total Function dialog box ➔ Select OK
To display break totals:

1) Select column you want to total → Right-click → Select Break Total
   The Insert Break Total dialog box appears.

2) At every break in drop-down menu → Select your break column criteria

3) Break total function → Select the desired function (Sum, Count, etc.)

4) Select one or more columns → Add Break total to

5) Select → OK
Exercise

1. Create a .bqy file using an oce that accesses SFMS data.

2. Include the following tables and fields in the query:
   a. All Acct Event - table:
      i. Batch Agy
      ii. Batch Date
      iii. GL Acct
      iv. PCA
      v. Fund
      vi. SFMS Trans Amt (Use Data Function: Sum)
   b. Agency - table:
      i. Agency Title
   c. Fund D23 - table:
      i. Fund Title
      ii. GAAP Fund
      iii. GAAP Fund Title
   d. GL Acct - table:
      i. GL Acct Title

3. Arrange the fields shown below on the ‘Request Line’ to look like the following:

<table>
<thead>
<tr>
<th>Request</th>
<th>Batch Agy</th>
<th>Agency Title</th>
<th>Batch Date</th>
<th>SFMS Trans Amt</th>
<th>GL Acct</th>
<th>GL Acct Title</th>
<th>PCA</th>
<th>Fund</th>
<th>Fund Title</th>
<th>GAAP Fund</th>
<th>GAAP Fund Title</th>
</tr>
</thead>
</table>

4. Filter the query to ‘Batch Agy’ equal to 585, ‘Batch Date’ between 07/01/12 and 12/31/12 and ‘SFMS Trans Amt’ not equal to zero.

5. Process the query. (Answer: 8,544 rows)

6. Filter the ‘Results’ Section to ‘SFMS Trans Amt’ not equal to zero. (Answer: 8,162 of 8,544 rows)

7. Insert a New Table Section.
8. Within the newly created Table, move the following fields from the ‘Elements Pane’ area to the ‘Data Layout’ section to allow the data to show on the Content Pane:
   a. Batch Date
   b. PCA
   c. GL Acct
   d. GL Acct Title
   e. Fund
   f. Fund Title
   g. SFMS Trans Amt

9. Within the Table section, sort the following fields in Ascending Order: ‘Batch Date’, ‘PCA’, ‘GL Acct’, and ‘Fund’. Also, create a Filter of ‘PCA’ beginning with 2 or 3.

10. Change the font of every column on your Table to Arial - size 9 and auto size the width of your columns. (Hint: To auto size use ‘Ctrl A’ & ‘Ctrl E’).

11. Suppress Duplicate values of the ‘PCA’, ‘Fund’ and ‘Fund Title’ field columns.

12. Add a ‘Date Group’ column from the ‘Batch Date’ data. Then hide the newly created ‘Batch Month’ and ‘Batch Year’ columns. Finally, move the ‘Batch Date Quarter’ column to the right of ‘Batch Date’.


Add the following list of CAFR Account groups to the newly created ‘CAFR Acct’ column.

Note: Input only the number of the group and not the entire CAFR Acct description shown below. For example, ‘010-Cash and Cash Equivalents’ becomes a group called ‘010’. 
CAFR Account - Groups:
  a. 010-Cash and Cash Equivalents
  b. 050-Accounts & Interest Receivable
  c. 060-Inventories
  d. 090-Accumulated Depreciation & Amortization
  e. 120-Accounts & Interest Payable
  f. 160-Trust Funds Payable
  g. 162-Compensated Abs Pay-Current
  h. 175-Compensated Abs Pay-Noncurrent
  i. 271-Encumbrance Control
  j. 301-Reserved for Encumbrances
  k. 307-GAAP Expenditure Offset
  l. 310-Unreserved, Undesignated Fund Balance
  m. 331-Nonspendable Fund Balance-Inventory
  n. 371-Invested in Capital Assets
  o. 375-Net Assets
  p. 999-Default Oregon

14. Assign the ‘Available Values’ to the new groups as follows:
   a. CAFR Acct: 010
      i. 0065
      ii. 0070
      iii. 0075
   b. CAFR Acct: 050
      i. 0501
      ii. 0507
   c. CAFR Acct: 060
      i. 0601
   d. CAFR Acct: 090
      i. Any account beginning with “08”
   e. CAFR Acct: 120
      i. 1211
      ii. 1215
      iii. 1216
   f. CAFR Acct: 160
      i. 1551
g. CAFR Acct: 162
   i. 1605
h. CAFR Acct: 175
   i. 1718
i. CAFR Acct: 271
   i. 2735
j. CAFR Acct: 301
   i. 3011
k. CAFR Acct: 307
   i. 3600
l. CAFR Acct: 310
   i. 3075
   ii. 3100
   iii. 3101
   iv. 3150
   v. 3500
   vi. 3501
   vii. 3503
   viii. 3505
   ix. 3550
m. CAFR Acct: 331
   i. 3031
n. CAFR Acct: 371
   i. 3018
o. CAFR Acct: 375
   i. 3074
p. CAFR Acct: 999
   i. 1011
   ii. 1111
   iii. 2701
   iv. 2901
   v. 2904
   vi. 2954
   vii. 9010
   viii. 9011

15. Select ‘Ok’ when finished, and format the new column as necessary.
16. Modify the newly created ‘CAFR Acct’ grouped column to show all unassigned values as Default → ’Error’.

*Hint:* Right click on the ‘CAFR Acct’ column and select ‘Modify Column’. On the following pop up window, select the ‘Options’ button.

*Note:* This update will allow any future ‘unassigned values’ to show within an ‘Error’ category, thus displaying a reminder to update the unassigned data.

17. Within the Table section, under the ‘SFMS Trans Amt’ column, input a summed ‘Grand Total’.
   (Answer: Grand Total – 742,362.24)

18. Alert the instructor after correctly completing the exercise.