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Introduction 
The Oregon Department of Transportation (ODOT) configures and customizes Bentley 
MicroStation®, InRoads® and other CAD software for agency use. Therefore, the applications may 
perform differently than the typical “out of the box” set up.  The ODOT MicroStation® V8i User 
Guide provides guidance on how ODOT configures the software for its use.   

ODOT and Engineering Automation Administration 

The Automation Engineer administers the CAD tools and their configuration at ODOT.  In this role, 
the Automation Engineer facilitates a support team and three separate committees to create a CAD 
environment that supports the various needs of the agency. This position reports to the Engineering 
Automation Section Manager in the Technical Services Branch of the Highway Division. 

The Engineering Applications Support Team (EAST) works closely with and receives direction from 
the Automation Engineer. The team primarily supports MicroStation and InRoads software along 
with other specialty software.  The EAST members report to the Project Delivery Manager in the 
Transportation Application Development section of the Information Systems branch.  Team 
members are located throughout the state. If you need assistance, contact the Computer Support 
Desk at 503-986-3800.  The Computer Support Desk will submit a trouble ticket and an EAST 
member will return your call. 

The Automation Engineer facilitates the Engineering Automation Steering Committee (EASC). This 
committee provides direction for automation projects, which result in projects led by business or 
Information Systems (IS) personnel. The committee prioritizes projects and promotes committee 
activities as needed.  Membership includes managers representing various engineering disciplines in 
the Technical Services Branch and ODOT Regions. 

Your suggestions are welcome on how to improve the CAD tools available for use at ODOT. Contact 
your CAD Standards or InRoads Standards representative, EAST members or the Automation 
Engineer.  The committee membership is listed on the EAST website at 
https://www.oregon.gov/ODOT/east/Pages/Governance.aspx. 

CAD Standards Committee  

The CAD Standards Committee (CSC) is a standing subcommittee of the Engineering Automation 
Steering Committee (EASC) and derives its authority from the EASC. The CSC defines and maintains 
ODOT CAD standards. (This differs from engineering specifications as this pertains only to 
engineering automation). The EASC has final approval authority for any decisions recommended by 
the CSC.  

The CAD Standards Committee membership may change or rotate based on available resources and 
ODOT needs.  

Whenever possible, the committees elected to use functions and tools provided within the software 
instead of building (or upgrading) custom ODOT tools.  This resulted in removal of macros and other 
applications from the ODOT engineering workspace if the functionality was available with other tools. 

If you have any recommendations for CAD Standards, please contact your department committee 
member.  

https://www.oregon.gov/ODOT/east/Pages/Governance.aspx
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ProjectWise Integration 

This document includes steps and images for operating MicroStation V8i with the integration of 
ProjectWise as a data source. 

More information about using ProjectWise at ODOT may be found at 
https://www.oregon.gov/ODOT/Business/Pages/ProjectWise.aspx. 

https://www.oregon.gov/ODOT/Business/Pages/ProjectWise.aspx
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ODOT Engineering Workspace 
The ODOT Engineering Workspace is comprised of multiple components: 

 Workspace Servers — These servers store ODOT configuration and standards files, and host 
some applications. 

 File Servers — Users save and store project data, user preferences and personal files in their 
Personal Server Share (F: drive) space on the file servers. 

 ProjectWise Data Source – ProjectWise users save and store project data using the 
ProjectWise Integration Server and Data Storage Server.  

 Engineering Workstations — Engineering workstations are set up with video cards optimized 
for graphics and more RAM than standard business computers used at ODOT, so that they 
can run MicroStation and InRoads. ODOT installs these and other engineering applications 
on the hard drive (or C: drive) of an engineering workstation. 

 Licensing Server — This server hosts the SelectServer application that manages ODOT’s 
licenses for Bentley MicroStation, InRoads and other applications.   

 Print Servers — These servers direct the printing from any CAD application to connected 
printers and plotters. 

 
Figure 1. ODOT Engineering Workspace 
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Workspace Servers - ODOT_Space\V8i 

Multiple workspace servers, with a shared folder named ODOT_Space\V8i, and located at ODOT 
offices throughout the state, store ODOT configuration and standards files. Storing these files on 
these servers makes it faster to update engineering workstations with any approved configuration 
or CAD standards changes. This configuration also provides quicker response times to engineering 
workstations and decreased downtime.  

 
Figure 2. Workspace Servers 

ODOT_Space\V8i contains: Standard line styles, fonts, DGN libraries (levels, tasks and workflows), 
MDL applications, macros, and cell libraries used by MicroStation and InRoads.  These are typically 
items that have been adopted by the CAD Standards or InRoads Standards Committee to better 
enable users to produce plans that follow standard ODOT conventions for construction plans. 

 
Note: If you identify items in the ODOT workspace that may require revision, contact EAST or 
your CAD Standards Steering Committee member. A list of the CAD Standards Steering 
Committee members is on the EAST website. 

Some applications (e.g., Serval) are also maintained on the workspace servers and are not installed 
on the hard drive of each engineering workstation. 

 

  

https://www.oregon.gov/ODOT/east/Pages/Governance.aspx
https://www.oregon.gov/ODOT/east/Pages/Governance.aspx
https://www.oregon.gov/ODOT/east/Pages/Governance.aspx
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File Server and F: Drive 

Use of the F: Drive 

Your Personal Server Share (the F: drive) is a server location where you can store work-related 
data. Files stored on the F: drive are backed up and managed to ensure that data is available in the 

case of system failures. You may access files on the F: drive from anywhere on the ODOT network 
and you can share files with others. Customizations made to the engineering applications are also 
stored on the F: drive. The presence of an ODOT_Data folder indicates you may be able to run 
engineering applications.  

Server backups are intended for catastrophic failures, and are not intended to be long-term digital 
archives. The operational procedures on how long backups are kept, how quickly the data is 
restored and how often backups occur may change due to the increased cost of maintenance.   

 Note: In accordance with ODOT policies, you may not store personal data on the F: drive. To 
review the Acceptable Use of State Information Systems and Information Assets policy, go to 
http://transnet.odot.state.or.us/cs/BSS/Policies%20and%20Procedures/ADM%2005-08-
01.pdf.  

 

 Note: The Documents and Pictures libraries are redirected to your F: drive.  Many Microsoft 
Office applications default to saving in the Documents library. 

ProjectWise Datasource PW_ODOT_PROD 

The ProjectWise datasource named PW_ODOT_PROD is another location for storing project data.  
PW_ODOT_PROD is also stored on a server, is backed up, and is accessible to others.  Project data 
that is not stored in PW_ODOT_PROD should be stored on a server in either your F: drive or in a 
crew server share. 

Engineering Personal Server Share  

If you will be using engineering applications, you will be set up with an Engineering Personal Server 

Share. Additional folders and permissions are added to your Personal Server Share (F: drive) with 
files necessary for MicroStation and InRoads to run.   

 
Note: If you are not set up with an Engineering Personal Server Share, you will not be able to 
run MicroStation or InRoads, even if the applications are installed on the computer. Instead a 
black text window will open with the error: 

“ODOT User Configuration not found — Refer to Support for Assistance” 

Contact the Computer Support Desk for assistance with setting up an Engineering Personal 
Server Share. 

ODOT_DATA Folder 

ODOT employees that are set up correctly for MicroStation have a folder called ODOT_DATA in their 
Personal Server Share. Folders beneath ODOT_DATA are shared so that other ODOT employees can 
read the files stored in them: 

 Projects – intended for project-related data that is not stored in PW_ODOT_PROD 
(ProjectWise) 

http://transnet.odot.state.or.us/cs/BSS/Policies%20and%20Procedures/ADM%2005-08-01.pdf
http://transnet.odot.state.or.us/cs/BSS/Policies%20and%20Procedures/ADM%2005-08-01.pdf
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 USERCFG – see specific information below. 

 
Caution! Do not delete the ODOT_DATA folder. If you do, MicroStation and InRoads will not 
work correctly. 

USERCFG Folder 

The USERCFG subfolder contains files and folders used by MicroStation, InRoads and other 
engineering applications for your unique profile. This includes personal cell libraries, plot drivers, 
pen tables and user configuration files.  

In addition to your user-specific files, the USERCFG folder contains predefined directories for you to 
save specific types of files. The MicroStation and InRoads applications search those directories to 
locate required files. 

 

Predefined directories 

 cell:  Use this to store personal cell libraries and those with licensing stamps  

 data:  Contains the AccuDraw shortcuts and Axiom .ini file and the pipe data spreadsheet 
template 

 InRoads: Contains the ODOT InRoads V8i SS2 preference file and template library 
(civil.xin and ODOTseed.itl) and the  

o SS4 folder, which contains the  ODOT InRoads V8i SS4 preference file and template 
library (civilSS4.xin and ODOTSS4_seed.itl  

 Interfaces: 

o Interfaces\Buttons: Stores button settings for the mouse when using MicroStation. 
o Interfaces\Fkeys: Stores personal function key menus that you create. 
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o Interfaces\MicroStation\: Stores custom MicroStation tool boxes, tasks and 
workflows in a personal DGN library. 

 macros: Use this to store personal macros you create.  

 mdlapps: Use this to store user-specific MDL applications. 

 plot:  Use this to store MicroStation pen tables you create. 

 prefs: This is where user-specific preferences and configuration variables and settings for 
toolbar locations are stored. 

o Prefs\civil: Use this to store InRoads user preference XML files and settings for 
toolbar locations. 

o Prefs\DWGdata: Find settings for AutoCAD DWG files in this location. 

 ref: Use this to store your personal standard reference files. 

 vba: Use this to store visual basic applications. 

 
Note: If you are having trouble with MicroStation or another engineering application, the 
Engineering Application Support Team can access the USERCFG folder to troubleshoot your 
situation. 

Naming Files and Folders 

Use care when naming files and folders in engineering data. Certain applications balk when they 
encounter long names or special characters. This may display an error, produce incorrect results, or 
refuse to function.   

Follow these guidelines when naming files and folders: 

 Keep folder and file names short 

 Do not exceed the working limit of 200 characters in the entire path 

 Use only the accepted 63 characters; do not use any special characters 

The following characters are acceptable in engineering file and folder names: 

 A through Z 

 a through z 

 0 through 9 

 _ (underscore) 

Although it is tempting to use them for abbreviations, avoid the use of ampersands, spaces, and 
dashes.  The decimal point (period) character should only be used to separate the name of the file 
from the program extension. 

 
Caution! Do not use the characters  ! @ # $ & ( ) - : ; ” ’ , .  when naming Windows folders 
and files, and keep names short. 
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C: Drive Folders 

You can store your project data in the Share, USR, and Work folders located on the hard drive (C: 
drive) of your engineering workstation. Generally, you will not be able to write to other locations on 
your C: drive. 

 

 Share — This folder allows you to share files with other ODOT users. Anyone in ODOT can 
read and copy files from this location. It is not backed up, so never use it to store your only 
copy of a file.  

 USR — Use the USR folder to store your data. It may be backed up. If you store a large 
amount of data in the USR folder, contact the Computer Support Desk to install the 
Connected back-up software. You can only access this folder when logged on to the 
computer. 

 WORK — The WORK folder is only accessible to the user logged in to the computer. It is not 
backed up, and is not intended to store your only copy of a file.   

 
Tip! The desktop of your engineering workstation is not backed up!  Do not store files on the 
desktop. Instead, store files where they will be backed up and use desktop shortcuts to 
quickly get to the files you create and edit. 

  



ODOT MicroStation® V8i SS4 User Guide 

14 Oregon Department of Transportation November 2018 
Engineering Applications Support Team 

Desktop Shortcuts 

When you have MicroStation installed on your engineering workstation, your desktop displays 
additional shortcuts and folders. These include shortcuts to the Engineering folder, MicroStation, 
ProjectWise Explorer, Serval and InRoads (if installed).  

Engineering Folder 

Double-click the Engineering folder to gain quick access to help documents that 
are specific to the ODOT CAD environment, and shortcuts for launching other 
engineering applications. The Engineering folder typically includes 
ODOT_DGN_seed_files, ODOT_User_Configuration, Offline_Workspace and ODOT 
Help. Other application shortcuts, if installed, may include Descartes, MathCAD 15 
and MathCAD Prime 2.0. 

InRoads 

Double-clicking the InRoads shortcut launches both MicroStation V8i and InRoads 
V8i in the ODOT Engineering workspace. To access additional tools provided with 
InRoads V8i (e.g., Roundabouts, Civil Geometry and Data Acquisition), you may 
launch InRoads from the shortcut or from the Start menu. 

MicroStation V8i (SELECTseries 4) 

Double-click the MicroStation V8i (SELECTseries 4) shortcut to launch 
MicroStation V8i in the ODOT Engineering workspace and open the File Open 
dialog. 

Serval 

Double-click the Serval shortcut to launch a tool developed to simplify finding and 
sharing engineering content stored in F: drives or in computer C:\Share folders 
with others at ODOT. Refer to Appendix A for more detailed instructions on using 
the Serval application. 

ProjectWise Explorer 

Double-click the ProjectWise Explorer shortcut to launch the main user interface 
for ProjectWise, from which you can access the datasources that contain projects, 
folders, and documents.  Integrated applications such as MicroStation, Word, and 
Excel allow you to log into the PW_ODOT_PROD datasource from the File Open 
dialog of the integrated application. 
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Working Offline 

You cannot check out a license for Bentley projects, but any time you launch the application when 
connected to the ODOT network, the count-down for 30-days’ offline use is reset to 30 days. This 
means that if you have launched the application within the last 30 days when connected to the 
ODOT network, a license is available when you are off the network. 

Before working on a laptop offline from the ODOT network, follow these steps:  

1. While still connected to the ODOT network, launch the Offline_Workspace shortcut 
from the Engineering folder on your desktop. This copies your Engineering Workspace, 
along with your user customizations from your Engineering Personal Server Share, to 
the C: drive of your laptop.  

 
Reminder: If you don’t run the Offline_Workspace, you will be unable to run 
MicroStation.  Instead, the following error message appears in a black text window:    
“ODOT Workspace not found — Refer to Support for Assistance” 

When this error message appears, you will be unable to run MicroStation until you 
reconnect to the network. This error typically appears when you work offline without 
copying the local workspace. 

 

 
Note: The Engineering Workspace changes regularly. It is important to have the latest 
customizations and standards available.  After receiving a MicroStation Workspace 
Update email, run Offline_Workspace to copy the latest files to your computer. 

2. Copy the CAD files you will need from your F: drive or wherever else they are stored and 
put them in one of the C: Drive folders described above (see C: Drive Folders) so that 
you can access them while you are offline. 

3. Launch MicroStation and InRoads (or any other Bentley software) you will be using 
while still on the ODOT network to reset the 30-day count down.   

 
Note: The Activation Status dialog may open when you launch Bentley applications 
from the ODOT network. Click Close to close the dialog. It is not necessary to activate 
the license. 
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Getting Technical Support 

When you need technical assistance with MicroStation, contact the ODOT Computer Support Desk 
at 503-986-3800. They will connect you with an EAST member to provide you with technical 
support. 

EAST may also be contacted directly using a group email. 

mailto:Computer_Support.ODOT@odot.state.or.us?subject=Technical%20Assistance%20Needed%20for%20MicroStation
mailto:odot.east@odot.state.or.us?subject=Technical%20Assistance%20Needed%20for%20MicroStation
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MicroStation Basics 

This chapter provides information about customizations that ODOT has made to MicroStation. 

Launching MicroStation 

There are several ways to open MicroStation files. Some launch directly into MicroStation and some 
open a ProjectWise Login dialog first.  

The ProjectWise Login dialog enables you to either [Log in] to a ProjectWise datasource to access 
files there or [Cancel] to access files external to a ProjectWise datasource using the Windows File 
Open dialog.  

Launching MicroStation without a ProjectWise Log in dialog 

To launch MicroStation without a ProjectWise Login dialog opening, do any of the following: 

 In Windows Explorer, double-click on a DGN file, if the file is associated with MicroStation. 

 Hover over a MicroStation icon on the Start menu, to open a menu with the latest opened 
files and click any file to open it directly in MicroStation. 

 Right-click on a MicroStation task that is pinned to your task bar, to open a menu with the 
latest opened files and click any file to open it directly in MicroStation. 

Launching MicroStation with a ProjectWise Log in dialog 

Do any of these things to launch MicroStation with a ProjectWise dialog: 

 Double-click the MicroStation shortcut on the desktop. 

 Click MicroStation icon on the Start menu. 

 Click a MicroStation task that is pinned to your task bar. 

 Right-click on a DGN file in the ProjectWise Explorer, and choose Open (technically, you had 
to log in to the ProjectWise Explorer). 

The ProjectWise Log in dialog opens. 

 

Next Steps 

With the ProjectWise Log in dialog open, you have a choice based on the location of the file that you 
want to access. 

 If you want to open a file that is not stored in a ProjectWise datasource, click [Cancel]. A 
Windows File Open dialog open – see Using the Windows File Open Dialog on page 21. 

 If you want to open a file that is stored in a ProjectWise datasource, continue with the steps 
below, Logging in to a ProjectWise Data Source. 
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Logging in to a ProjectWise Data Source 

1. From the Datasource drop-down, select PW_ODOT_PROD. 

 

2. Select the checkbox “Use Windows Single Sign-On for authentication” and click [Log in]. 
This uses the User Name and Password that you used to log in to your computer to give 
you access to the ProjectWise datasource. 

 

 
Caution! If you are using files in MicroStation from a ProjectWise datasource, and want to 
switch to access a file or files in the Windows file system, Fully exit MicroStation and 
relaunch it.  The same is true if you are using a Windows file in MicroStation and want to 
access a file or files in a ProjectWise datasource. 

Always Fully exit MicroStation and relaunch it, to switch between ProjectWise and non-
ProjectWise files. 

Using the ProjectWise File Open Dialog 

When you log into a ProjectWise datasource to open or save data, you see the integrated dialogs.  
Integrated dialogs have fields and icons that access the ProjectWise datasource, and search or filter 
based upon document properties. 
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The Address Field 

The Address field in the integrated File Open dialog is populated with the MicroStation .dgn file 
that was most recently accessed by you that is stored in ProjectWise. It may be blank if the most 
recently opened files were not in .dgn format. It also has a Most Recently Used (MRU) drop-down 
list.  When expanded, the Address field MRU displays five documents (.txt, .docx, etc.) recently 
opened from ProjectWise, not just with MicroStation.   

Searches and Search Results 

To perform a quick search or a saved global or personal search, click the Search icon. Search 
results are displayed in the Document list. 
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The document list is filtered by the Extension: field at the bottom of the File Open dialog. This list 
displays the same columns or properties as your selected view using View>Manage Views… in the 
ProjectWise Explorer. 

You can sort the list (e.g., by Name, Out to, File Name, date last Updated) by clicking on the column 
headers. 

Opening files 

Once you have found the file you want, select it and click [Open] to open it. The file will be checked 
out to you in ProjectWise, and will show as locked (or Read-Only) for everyone else. 

If you want to open a file for viewing, not editing, you can. The ProjectWise File Open dialog allows 
you to “Open document as read-only” by checking the box in the lower left corner. 

 
Note: Open only one MicroStation design file at a time.  
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Using the Windows File Open Dialog   

The Windows File Open dialog enables you to: 

 Locate and open folders and MicroStation files stored on a server or your computer 

 Create new folders or MicroStation files 

 Access different configurations and customizations 

Only the Windows File Open dialog allows you to change the User Options and Interface. 

 
Warning! When changing design file locations between a project stored in ProjectWise and a 
project stored on a Windows server, exit the MicroStation application and re-launch. Do not 
use File>Open or the file history from within the MicroStation application when the next file is 
stored in a different data source (ProjectWise versus Windows). 

 

Windows File Open Dialog Tips  

 When using the Windows File Open dialog, avoid selecting files on your C:\ drive from the 
Windows history.   

 The Look In: field (Address Bar) in the Windows File Open dialog may be expanded to show 
the entire directory tree.   

 The File name: field is populated with the MicroStation DGN file most recently accessed by 
you that is stored in the Windows file system.  
Be careful! – do not open DGN files stored in ProjectWise from this dialog – use the 
integrated (ProjectWise) File Open dialog.  

 The New File icon enables you to create a new file. It opens the “New” dialog, with the 
File name blank for you to enter in the name of a file you want to create, and a selection box 
from which you can pick the seed file. After you have created the file, you can open it. 
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 The Tools/File History icon opens a list of a few useful tools and a list of recently 
opened design files. 

 
Warning! Never use the Windows File Open dialog or file history to select MicroStation 
design files stored in C:\pw_work!  These files are local copies of files stored in the 
ProjectWise datasource.  

To work in those files, log in to the ProjectWise datasource and use the integrated File Open 
dialog. You may only see the parent folder name of dms#### in the Address Bar.   

User, Project, and Interface Options 

Note the User, Project, and Interface dropdown fields in the lower right of the File Open menu. 
When launching MicroStation, check these Options. It is highly recommended that you chose the 
ODOT interface. 

These fields are not available on the integrated (ProjectWise) File Open dialog. This means that if 
you are working in a ProjectWise Datasource file, and want to change the interface, i.e., from ODOT 
to Survey, you must: 

1. Cancel out of the ProjectWise Log In to get to the Windows File Open dialog. 

2. Make the change. 

3. Open a file in Windows to save the setting change. 

4. Reopen the ProjectWise file. 

User: Options 

For ODOT production drafting, you should always open files with the User set to ODOT. 
To access and open training files or examples from Bentley to improve your MicroStation skills, 
select a User in the lower right corner of the File Open dialog. 

You can choose from several different User options as identified in the table below. 

Table 1. MicroStation User Options 

User Source 

examples Provided by Bentley and typically used in Bentley classes 

ODOT ODOT Production drafting 

Student Optional, Classroom training from CAD Productivity if attended training 

Untitled Delivered by Bentley 

New… Delivered by Bentley, not for ODOT use 



ODOT MicroStation® V8i SS4 User Guide 

November 2018 Oregon Department of Transportation 23 
Engineering Applications Support Team 

Project Options 

For ODOT production work, select No Project. If you have attended vendor training, you may have 
additional choices available to you. 

Interface Options 

The selection in this field determines the workflows that are loaded. The first time you launch 
MicroStation, it sets the Interface option to ODOT, which loads all ODOT workflows. This is the 
recommended setting. 

Selecting a specific discipline interface restricts the workflows available in MicroStation to only 
those for that discipline. 

 
Tip! If you change the interface on the Windows File Open dialog, the next time you launch 
MicroStation the last interface used will open. 

 

The available interface options are listed in the table below. 

Table 2. MicroStation Interface Options 

Interface Select to load… 

Bridge Bridge tasks and workflows 

Geo_Hyd_Env Geo, Hydro and Enviro tasks and workflows 

ODOT All ODOT workflows  

Roadway Roadway tasks and workflows  

Survey Survey tasks and workflows  

Traffic Traffic tasks and workflows  

New… Not used at ODOT - see User Customization chapter for more information 

 

 
Tip! If you typically double-click MicroStation DGN files in Windows Explorer to open them, 
the file opens with the last interface selected.  The only way to change the interface is to 
launch into the Windows File Open dialog from a MicroStation shortcut. 

 

----------------------------------------------------  
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Viewing File History 

There are two easy ways to view a list of recent file activity. You can use the File Open dialog in 
either ProjectWise or MicroStation, or you can use the File menu on the main MicroStation menu 
bar. 

In a File Open Dialog 

Both dialogs open with the last MicroStation file that you opened in the Address or File name field.   

 The ProjectWise File Open dialog has a Most Recently Used (MRU) list of the five most 
recent of any type file under the address bar. 

 The Windows File Open dialog has a File History icon that displays the ten most recent 
MicroStation DGN files.  If the application cannot access a Windows directory or file, 
MicroStation opens to a default location on your computer’s hard drive. 

 
Figure 3. The ProjectWise (integrated) File Open – MRU List – 5 documents, any type 
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Figure 4. The Windows File Open Dialog File – History List – 10 DGN files 

Viewing File History from Main Menu 

Click File in the main menu, and look down to the bottom of the menu that opens. 

 If you are logged into ProjectWise, it displays the last 5 MicroStation design files stored in 
ProjectWise that were opened. 

 If you have a file stored in the Windows file system open, it displays the last 10 files opened 
in MicroStation.  

 
Figure 5. Recently Opened Files under File Menu - ProjectWise (left), Windows (Right) 
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Warning! Never use the Windows file history to select MicroStation design files stored in 
C:\pw_work!  These files are local copies of files stored in the ProjectWise datasource.  To 
work in those files, log in to the ProjectWise datasource and use the integrated File Open 
dialog. 

 

 
Caution! If a design file stored in the Windows file system is renamed or moved, you cannot 
open the file using the file history. Use the Windows File Open dialog to navigate to the file. 

Creating New MicroStation Files 

Regardless of whether you are creating a new file to be stored in ProjectWise or in the Windows file 
system, you need to select a seed file to be used in its creation.  

Seed Files  

Seed files are analogous to templates. They set up how a new file is structured and set standard 
properties in their master model, such as a specific dimensionality (2D or 3D), and line style settings. 
They may have cache files pre-attached or have elements already drawn into the file as a starting 
point. 

There are different seed files, providing templates for different disciplines (e.g., GeoEnvironmental, 
Roadway, Right of Way). 

The Engineering folder on your computer’s desktop contains the shortcut ODOT_DGN_seed_files to 
give you easy access to the seed files in ODOT_Space\V8i that are used when creating new 
MicroStation design files. 

Table 3. Seed Files 

Seed File Name Purpose Distinguishing Characteristics Discipline 
Owner 

Seed.cel Create new cell library Default model may be placed as 
cell. Line style scale set to Global. 
Annotation scale set to Full Size. 

EAST 

Seed_GTsub.dgn Subsurface Geotech 
Sheets 

Based on seed2d.dgn.  Includes 
border, profile grid, tables, legend 
and general notes. 

GeoEnviron
mental 

Seed_OM.dgn Drainage Facility 
drawings 

Based on seed2d.dgn.  Includes 
Notes to Drafters and example 
features and elements to use. 

GeoEnviron
mental 

seed_tse.dgn Landscape orientation 
title sheets for 
construction project 
plans 

Includes border and elements to 
include in the drawing; 
titlesheet.cel  is attached; 
cache_tse reference file is 
attached, annotation scale set in 
default model, Line Style Scale set 
to Annotation Scale. 

Roadway 
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Seed File Name Purpose Distinguishing Characteristics Discipline 
Owner 

Seed_TWM.dgn Temporary Water 
Management drawings 

Based on seed2d.dgn.  Includes 
example sheet with notes. 

GeoEnviron
mental 

Seed2d.dgn Standard 2D file 2D; selected by default, includes 10 
levels that can be renamed, 
annotation scale set in Default 
model, Line Style Scale set to 
Annotation Scale. 

EAST 

Seed3d.dgn Standard 3D file 3D; includes 10 levels that can be 
renamed, annotation scale set in 
Default-3D model, Line Style Scale 
set to Annotation Scale. 

EAST 

Seed811tse.dgn Portrait orientation title 
sheets for construction 
project plans 

Includes border and elements to 
include in the drawing; 
titlesheet.cel is attached; 
cache_tse reference file is 

attached; contents of several cell 
libraries are written into the file. 

Roadway 

SeedRW2d.dgn Several different Right of 
Way products 

Includes a variety of 2D design 
models used for different products; 
instructions are in the Default 
model. Some elements are drawn 
in the various models. 

Cadastral 

Seed_titleblock.dgn Contains project 
information and sheet 
title block; for attaching 
“Sheets” model as 
reference to plan sheet.  

2D; Base model contains title block 
and information that appears on all 
sheets. Sheets models contain 
sheet-specific information. Line 
style scale set to Annotation Scale. 
Annotation scale set to Full Size. 

Roadway 

 

 
Tip! If you have standard features you repeatedly incorporate into files, contact an EAST 
member on how to set those features in your own custom seed file.  Remember that if the 
standard seed files are updated, you will want to apply those changes to your custom seed 
file. 

ODOT Models and Properties 

The default model properties in seed2d.dgn and seed3d.dgn are shown below.  

The annotation scale is set to 1”=100’.  Set the annotation scale in the models you create, for cells, 
text, and line styles to display correctly. 
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Accessing Seed Files in ProjectWise Document Creation Wizards 

When you select File>New or click on the New File icon, and the active MicroStation design file is 
stored in a ProjectWise datasource, a New dialog opens, allowing you to select a “Document 
Creation Wizard.”  

 Advanced Wizard 

 No Wizard 

Using the Advanced Wizard to Open Seed files 

If you select the Advanced Wizard on the “New” dialog, a multi-step dialog opens that enables you 
to select the target folder of the new file, choose a seed file, and fill out document attributes and 
properties, such as the new document name. 

The preferred method for selecting a seed file is to use the ODOT_DGN_seed_files shortcut in the 
Engineering folder on your desktop. 

 

 Tip! Most ODOT cells have been 
reduced in size to work with 
annotation scale.  If you open an 
older file (one created prior to 
2012), annotation scale is not set in 
any of the models. When you place 
cells from the ODOT cell library, 
they will come in very small.  If you 
set the annotation scale that is 
correct for the model, the cells will 
scale to the intended size. 
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1. Choose the radio button “Use external file as a template.”  

2. Click [Browse…]. 

3. Click on the Desktop icon ( ) under Favorites. 

4. Open the Engineering folder.  

5. Double-click on the ODOT_DGN_seed_files shortcut.  

 
6. Select a seed file from the list and click [Open].  

7. Complete the New File process by following the current instructions for creation and 
naming of documents in ProjectWise. 

No Wizard 

The No Wizard option produces a single dialog that allows you to change the target folder and select 
a Source File (seed). This option does not allow you to enter attributes. 

1. Click the [Import…] button. 
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2. Click on the Desktop icon ( ) under Favorites. 

3. Open the Engineering folder.  

4. Double-click on the ODOT_DGN_seed_files shortcut.  
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5. Select a seed file from the list and click [Open].  

This enters that seed file as the Source File on the New dialog. 

6. Complete the New File process by following the current instructions for creation and 
naming of documents in ProjectWise. 

Using the Windows File System 

Launching the MicroStation application to open files stored in the Windows file system (when you 
have cancelled out of the ProjectWise Log in dialog) allows you two methods for creating new files:  

1. Select File > New on the MicroStation menu.  

or 

Click on the New File icon on the Windows File Open dialog:  

 

Both methods open a New – [\\folderpath] dialog, which lists the current seed file in the 
Seed: field at the bottom.  The ODOT defaults set the initial seed file to seed2d.dgn. 



ODOT MicroStation® V8i SS4 User Guide 

32 Oregon Department of Transportation November 2018 
Engineering Applications Support Team 

 

To change the seed file: 

1. Click [Browse]. A Select Seed File dialog opens.   

2. Select a seed file from the list, and click [Open]. 

 

The new seed file name appears in the Seed: field on the New dialog. 

3. Enter a File name for the new file and click [Open]. 

 
Caution! Do not copy existing files, rename them and delete elements out of the file to 
create new files.  Copies of existing files may contain non-visible elements, non-
graphical data, and even corruptions. 

 



ODOT MicroStation® V8i SS4 User Guide 

November 2018 Oregon Department of Transportation 33 
Engineering Applications Support Team 

 
Tip! The seed files delivered in ODOT_Space\V8i are configured to support ODOT 
standard business processes; creating new files from an ODOT seed file ensures that you 
have the latest updates. 

Reference File Attachments and Reference Sets 

Referenced Files in Windows 

Reference attachments can be made in the Windows file system to view other models that are also 
stored in the Windows file system. A reference attachment may be broken by renaming or moving 
the referenced file.  

In Windows, when the reference attachment cannot be found, the data is not displayed, and a 
Reference dialog shows the broken attachment information in red text. 

To find and re-connect broken references: 

1. Double-click on the red file. This opens the Reference Attachment Settings dialog. 

2. Use the [Browse…] button to find the file and reconnect it. 

 

 

Referenced Files in ProjectWise 

ProjectWise documents have globally unique identifiers (GUIDs), which are used in addition to 
folder and document names to maintain reference attachments in a ProjectWise datasource. In 
ProjectWise the relationship between a master document and its attachments is known as a set.  If a 
referenced document’s name or location is changed, when the parent design file is opened, 
MicroStation updates to the new name or location and informs you of the update.  
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Click [OK] to dismiss the Information dialog, then open the References dialog to determine the 
reason for the change. 

 

Attaching Cache Files 

Files containing drafting aids for different disciplines are contained in the ref folder in the workspace 
and may be quickly located and attached using the Directory History icon (outlined in red below) on 
the Attach Reference dialog. 

 

 
Tip! The working directory (location of the active DGN file) is always in line #1. 
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Cache File Name Contents Discipline Owner 

2DMask_Cache.dgn Shapes with priority of -100. Used as masking 
elements between active graphics and reference 
graphics. 

EAST 

cache_tse.dgn Standard drawing lists and drafting aids for title 
sheets. 

Roadway 

ecV8_cache.dgn Erosion Control sheet guidance information, legend 
graphics and notes for copying or matching 
attributes. 

GeoEnvironmental 

msV8_cache.dgn Material Source sheet guidance information, 
legend graphics and notes for copying, and cell 
library locations. 

GeoEnvironmental 

Pipe_####.dgn Pipe Data Sheet with border, columns and notes. 
Use with Axiom Office Importer and spreadsheet. 

Roadway 

plansV8.dgn Example sheet border, title block and professional 
stamp; Sheet Titles and Typical Tools with stack text 
and patterns for copying or matching attributes. 

Roadway 

RDSide_V8_cache.dgn Roadside Development sheet guidance 
information, legend graphics and notes for copying 
or matching attributes, bid item logs, lists, and 
tables. 

GeoEnvironmental 

signcacheV8.dgn Sheet borders containing sign annotation cells of all 
types. Use for visual identification and copying. 

Traffic - Signing 

TCPV8.nam Logical groupings of work zone traffic control sign 
annotation cells and other plan view, typical 
section, and pattern graphics for copying or 
matching attributes. 

Traffic – Work Zone 
Traffic Control 
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Loading Additional Applications 

On the MicroStation main menu is the ODOT menu.  The ODOT drop-down lists other applications 
that are installed on your computer that you can run. You may also access options under ODOT Help 
from the ODOT menu. 

 

Other software applications you can install and access include: 

 AutoTURN 8 

 Descartes 

 GuidSIGN 6 

 InRoads SS2 Lite (a convenient version of InRoads V8i SS2, lite on the MicroStation menus) 

 gINT Civil Tools  

 Axiom Office Importer (server-based application that is available to some MicroStation 
users, but has not been purchased for all ODOT locations, so it is not always available) 

Software must be installed by a FSU technician before it appears on this list. 

Getting Help with MicroStation 

You may obtain help with MicroStation from multiple sources: 

 Select Help on the main menu to open the Bentley-provided help sources. 

 Select ODOT > ODOT Help and select from the various resources on the drop-down menu. 
These include:  

o Tasks Outline 
o EAST Website (link to site) 
o Main Task Reload 

Tasks Outline provides an overview of the ODOT Tasks and Workflows. Use this tool to gain 
familiarity with and search for the locations of tasks and workflows. 

Main Task Reload may be used to re-open the main Tasks if you accidentally close it by clicking the 
X next to the Pushpin icon. 
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MicroStation V8i SS4 Default Preferences 

The ODOT default preferences for MicroStation V8i SS4 were created with drafters in mind.   

 

The Bentley Tasks is open and docked at the left; the ODOT Tasks, showing all disciplines, is open 
and docked at the right.   
The Tool Settings dialog is located at the top and centered with Popset enabled (green ball).   
Infrequently used tools in the docked toolboxes are turned off.   
Preferences for Input, Look and Feel, Operation, Raster Manager, Reference, Text, and View Options 
(including Line Weights) are set to the same default settings used for MicroStation V8i SS3. 
 
If you wish to customize your MicroStation V8i SS4 preferences, some common customizations are 
explained in Setting User Preferences. 

Setting User Preferences 

You can customize the user preferences within MicroStation to meet your specific needs based on 
the how you use MicroStation. 

You can set preferences in many categories including:  

 Database 

 Descartes 

 Input 

 Look and Feel 

 Mouse Wheel 

 Operation 

 Position Mapping 

 Raster Manager 

 Reference 
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 Spelling 

 Tags 

 Task Navigation 

 Text  

 View Options 

How to Set Preferences 

1. Select Workspace > Preferences on the main menu.  

This opens the Preferences dialog. 

 
2. Select a category in the list on the left to view the preference options you can 

customize.  

3. Click [OK]. 

Commonly Modified Preferences 

 Operation Category 

o Open Two Application Windows: Select this if you have dual monitors, and want to 
open two windows that you can adjust to each monitor.  Note that this opens two 
windows for ONE instance of MicroStation. Alternately, you may leave this un-
selected and run with just one window but drag the MicroStation window over both 
monitors. 
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 Text Category 

o You can modify the size of the font displayed in the Text Editor by setting the Text 
Editor Font Size. 

 View Options Category  

o Line Weights…: By default, the user preference for line weights is set to 1.5:1.  Some 
ODOT employees prefer to set this to 1:1 or 2:1.  Click Line Weights to open the 
dialog and set the line weight. 

o Design Model Background Color: If you typically change the background color of the 
files you work in, you can set it as a user preference instead of modifying each file 
you work in.   

o Element Hilite Color: You can set the element hilite color and selection set color to 
override the Design File settings. 

Extra Tools and the Drawing Scale Toolbar 

A customized toolbox called Extra Tools is docked in the ODOT User Preference Files.  In 
MicroStation V8i SS4, the default display for Extra Tools includes the Print Organizer icon, the Add 
Annotation icon, the Lat/Long Labeler, and the subsidiary Drawing Scale toolbar. 

 

This toolbar was made available to provide more ready access to commonly-used tools. 

 The Print Organizer icon opens the Print Organizer. This tool is further described in the 
Error! Reference source not found. section.  

 Use the Add Annotation Scale (+A) button to toggle the annotation scale attribute to true.  

Annotation scale values are model-specific. If you have multiple models in a file, the drawing 
scale can vary from model to model, allowing you to have different scales for each model. 
Additional details for adding annotation are located in the Annotation tools in Appendix E 
or in workflows using InRoads V8i. 

 The Lat/Long Labeler icon invokes the Label Geographic Coordinates dialog for annotating 
latitude and longitude.  See the MicroStation workflow Label Latitude and Longitude on the 
EAST website for more information. 

 The Drawing Scale toolbar contains the Annotation Scale Lock and the Drawing Scale drop-
down. To set a drawing scale for the active model, select one from the Drawing Scale drop-
down. Prior to placing any text, annotation cells or line styles, ensure that the Annotation 
Scale Lock is on. 

 
  

https://www.oregon.gov/ODOT/EAST/Documents/ODOT%20InRoads%20V8i%20User%20Guide.pdf#View_Surface_Features_
https://www.oregon.gov/ODOT/EAST/Documents/Lat_Long_Labeler_Label_Coordinates.pdf#page=1
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Displaying the Extra Tools Toolbars 

If the Extra Tools – Custom toolbox is not showing in the MicroStation menu bar, you can display 
and dock it. 

1. Select Tools > Tool Boxes from the main menu.  
The Tool Boxes dialog opens. 

 
 
2. Scroll down and check the Extra Tools – Custom box  

3. Click [OK].  The extra tools appear on the tool bar.   

 
Tip! You can turn off the display of unneeded tool icons on a toolbar by right-clicking 
on any tool. 
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Closing, Exiting, and Saving Files in a ProjectWise Datasource 

When working in MicroStation DGN files that are stored in a ProjectWise datasource, any time you 
execute a command from the upper section of the File menu, you invoke dialogs that are integrated 
with ProjectWise.  The upper section of the File menu (shown below) deals with opening, closing, 
and creating files. 

 

When another file is opened or created, the current file must be closed and the integrated Check In 
dialog opens to have you choose what is to be done with the current file: Check In, Update Server 
Copy, or Free.  It is not recommended to select Cancel on this dialog.  Cancel does not stop the 
command from completing; it just puts off the ProjectWise decision until later. 

 

 

 Tip! Expect the Check In dialog to appear when changing which file is open from a 
ProjectWise datasource.  It is typical to choose Check In. 

 

 
Caution! Fully exit MicroStation and relaunch to change from accessing data in a 
ProjectWise datasource to the Windows file system.  Also, fully exit an open Windows 
file and relaunch MicroStation to log in to a ProjectWise datasource. 
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Saving Files to Other Formats  

You can use the File>Save As command to save MicroStation files in DWG or DXF file formats or 
MicroStation version 7 format, or to save a MicroStation version 7 file as version 8.   

You can also use the File>Save As command to modify the elements in the file to different line 
styles, fonts, levels, weights and colors. 

No Wizard - To save files to other formats in the ProjectWise datasource: 

1. Select File>Save As on the main menu and choose No Wizard in the Select a Wizard 
dialog. 

 

2. The Save Document As dialog opens. Click the [Format…] button. 

 

3. From the Select Format To Save: drop-down, select the format for the file. Click 
[Options] to set options such as version, units, and how to process reference 
attachments. 

 

4. Click [OK] on the Save As dialog to accept the format. 

5. Click [Save] on the Save Document As dialog to complete the process. 

 Tip! If saving to DWG format, uncheck “Convert Reference Files” on the References tab 
of the Save As DWG/DXF Options dialog. Converted reference files are not created in 
the ProjectWise datasource. 
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Using Advanced Wizard to save files to other formats in the ProjectWise datasource: 

1. Select File>Save As on the main menu and choose Advanced Wizard in the Select a 
Wizard dialog. Advance through the wizard, until the Document Properties step of the 
Advanced Document Creation Wizard. 

 

2. Click the [Format…] button. 

3. On the Save As dialog, from the Select Format To Save: drop-down, select the format 
for the file. Click [Options] to set options such as version, units, and how to process 
reference attachments. 

 

4. Click [OK] on the Save As dialog to accept the format. 

5. Advance through the rest of the wizard by clicking Next; click Finish at the end to 
complete the process and open the file in the new format. 

------------------------------------------------------- 
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Saving files in other formats in the Windows file system 

1. Select File > Save As on the main menu. The Save As dialog opens. 

2. From the Save as type drop-down, select the format for the file that you want to save. 

 

3. Click Options to open the Save As […] Options dialog. 

 

4. On the Remap tab, check any Apply options needed for the file translation. 
If necessary, use the icons to the right of the CSV File field to browse to, edit or create a 
new CSV file. 

5. Review the References and Filter tabs and modify the settings as needed. 

6. Click [OK] to apply the options and close the Save As V8 Options dialog. 

7. Click [Save] on the Save As dialog to save the file. 

------------------------------------------------------- 
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ODOT Tasks and Workflows 
Workflows are specific tasks that you can perform with MicroStation. The selection in the Interface: 
field (when you launch MicroStation from a desktop icon or the Start menu), determines which 
discipline workflows are available to use in that session. The first time you launch MicroStation, it 
sets the Interface option to ODOT. This loads workflows for all disciplines.  

You can select a specific discipline interface, to load only the workflows for that discipline. However, 
unless you have a clear reason to do this, it is recommended that you leave the interface set to 
ODOT.  

 

 Note: The first time you launch MicroStation, it sets the Interface option to ODOT.  If you 
change the interface, the next time you launch MicroStation the last interface used opens. 
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If ODOT is the interface, MicroStation automatically loads all discipline workflows and the main 
ODOT workflow (with an orange flying T icon) appears in the Tasks dialog.  

 

To view the ODOT discipline-specific workflows, click ODOT on the Tasks dialog.  

The ODOT discipline-specific workflows are:  

 Bridge 

 Geo_Hyd_Env 

 Roadway 

 Survey 

 Traffic 

 

You may dock these workflows as tabs on the MicroStation 
window, for easy access to them while working in 
MicroStation.  

 Note: If, when launching MicroStation, you chose one of the other Interface options 
(Bridge, Geo_Hyd_Env, Roadway, Survey or Traffic) on the File Open dialog, only the tasks 
and workflows associated with the selected interface appear on the Tasks dialog.   

To view the custom tasks and workflows within each discipline, click the discipline name on the 
Tasks dialog.  
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General Workflow 

The General workflow is available in all discipline-specific task dialogs. It contains tools and tasks 
common to all disciplines.  

     
  

Within the General workflow are some common tools and sheet elements, including:  

 Sheet Borders (see below) 

 Titleblocks (see below) 

 Status Stamps 

o Advance 
o Draft DAP 
o DAP 
o Preliminary 
o Final Review 
o TS&L 
o V Number 
o Not For Construction 

 Scale Bars  

o 1”=50’ Scale Bar 
o Scale Bar Div 2 
o Scale Bar Div 2 with North Arrow 
o 1”=100 Scale Bar 
o Scale Bar Div 3 
o Scale Bar Div 3 with North Arrow 

 General Arrows (Arrows, including a North Arrow, Water Flow Indicators and Leaders) 

 **Vicinity Map Tools – not in all discipline General workflow tabs (Route shields; City, 
Highway and Street Name text, and Project Location Linestring)  

 Fill/Hatch (Hatch and Cross Hatch; 0° and 45° Angle) 

 General Misc (Check Mark, 2 Line Note Bracket and Revisions – Block, Box and Triangle)  

 Tools – including:

o Modify Elevation 
o Change Direction 
o Fix Range 
o Verify 
o Verify/Repair
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Sheet Borders 

Under Sheet Borders are standard sheet sizes used by ODOT and clip shape cells for 11x17 sheets. 
You can use these tools to create and place sheet borders. 

To create and place a sheet border: 

1. Click on the desired sheet border size to 
activate the tool. An appropriately sized 
border is now displayed on your cursor 
ready to be placed in the file. 

2. Left-click (data point) where you want to 
create and place a border. 

3. To place more borders of the same size, 
continue to left-click in the desired 
locations to create and place the sheet 
borders. 

 

Titleblocks  

After you place a sheet border, you can place title blocks 
within the sheet. Under Titleblocks is a list of available 
title blocks for most needs, along with other elements 
commonly associated with title blocks. 

To create and place a titleblock: 

1. Click on the desired titleblock to activate the 
tool.  

2. Left click (data point) in the sheet border 
where you want to place the title block. 

3. If you require more titleblocks, continue to 
left click (data point) in the desired locations 
to create and place the desired title blocks. 

 

 

------------------------------------------ 



ODOT MicroStation® V8i SS4 User Guide 

November 2018 Oregon Department of Transportation 49 
Engineering Applications Support Team 

Docking Workflows and Toolboxes 

You can dock workflows and toolboxes on either the left or right margin of the MicroStation 
window. By default, the MicroStation Tasks Workflow appears on the left margin. The ODOT 
Workflow is typically docked on the right margin. Docked workflows may be 
expanded (pinned) to show their tree structure of sub-workflows and toolboxes, or, 
unpinned so that they show only as tabs until you hover the cursor over them.  

Toolboxes may be left in the tree structure of the workflow they are under, set as 
floating, resizable dialog boxes, or docked to the outer edge of either side of an 
application window. 

 Tip! The workflow dialog tabs appear in the order (top to bottom) that 
they were unpinned. 

In addition, your MicroStation toolbox positions and docked workflows 
are stored on your F: drive; they will be saved and appear the same no 
matter what ODOT computer you use. 

With the workflow dialog tabs, the active task remains expanded in each tab until 
another task is selected. This reduces the amount of “drilling” into menus. 

Docking a Workflow 

1. Identify available workflows, under Tasks, or Tasks>ODOT.  

 

2. Right-click on the desired workflow and select Open ‘[Workflow Name]’ in new Dialog.  
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The workflow opens as a new dialog, usually docked at the left side.  

3. Drag the title bar of any docked or floating workflow onto a docking icon ( ) near 
the margin and the workflow will snap to that margin. 

Hiding and Removing Docked Workflows 

 To hide a docked workflow dialog, click the Unpin icon ( ). The docked workflow dialog 
collapses and appears as a tab on the margin. 

 To remove a docked workflow dialog tab, click the tab to expand the workflow dialog and 

click the X next to the Pin icon ( ).  

 Note: If you close the Tasks dialog, you can reopen the menu by selecting ODOT > ODOT 
Help > Main Task Reload.  
You can reopen other tasks with the key-in “tasktoolbox open” followed by the name of 
the task or toolbox. E.g., “tasktoolbox open roadway.”  

 

------------------------------------------ 

Element Properties 

Element Templates 

Element templates define properties of elements. Their primary purpose is to increase consistency 
in adhering to CAD standards. A template can store multiple element properties. In a template, you 
can set general properties such as level, color, line style and line weight, as well as text styles, text 
style overrides and cell properties. 
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To activate an element template, select it from the Active Element Template drop-down. Each 
category expands by clicking on the little plus symbol. Find the element template needed, and then 
select it by left-clicking on it. Doing so sets the active attributes. 

    

The active attributes automatically change to reflect the selected template. 

 

You may also select a tool from the ODOT tasks and workflows to activate element templates. These 
tools have been set up to point to the templates wherever possible. 

Text Styles 

Text styles assist in setting up the annotation scale and to standardize the text used in CAD products.  

All ODOT text style names begin with “ODOT” for easy identification. The default style is ODOT 
Notes, an italicized Lucida Sans Unicode. In addition there are two ODOT Bridge text styles, eleven 
ODOT Right of Way (RW) styles, and other general text styles to cover all other disciplines and 
products.  

Some additional information on how to place special characters and Stacked Fractions, based on the 
selected text style in Appendix C: Placing Special Characters and Fractions in MicroStation V8i. 
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 Note: There are also text styles provided by Bentley that are necessary for some Bentley 
products to perform properly. You may ignore these.  

 

You can activate the styles from the Text Styles dialog, but the more common way to select a text 
style is with the tools provided in the ODOT tasks and workflows.  

Below is an example image of a tool that places text and calls a text style (Ditch Text); the image to 
the right shows the settings in the Place Text dialog. 

        

 

Although tools in the ODOT tasks and workflows may 
call up text styles, you can override any attribute.   

For example: If you select a tool that calls up the text 
style ODOT Descriptions. The size and font are 
acceptable, but the Justification is set to Center 
Center, and you need Left Top.  

To change this, expand the Place Text dialog and 
select the desired setting from the Justification drop-
down.  
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Line Styles   

Line styles follow the rules of the Annotation Scale. As long as the Line Style Scale field on the 
Model Properties dialog is set to Annotation Scale, custom line styles dynamically change to 
accommodate any annotation scale applied to your model. 

 

For example, as illustrated below, if you have a project like a small box culvert and you want to print 
it at a scale of 1” = 50’, rather than the more standard 1” = 100’, and you want all line styles to print 
the same size, set your drawing scale to 1” = 50’ to make the custom line styles automatically resize 
smaller. The images below demonstrate this with the fence, ditch, and guardrail line styles. 

  

1” = 100’ 1” = 50’ 

ByLevel Symbology 

ByLevel symbology enables you to change standards by changing the level symbology, causing any 
element template or tool associated with that level’s ByLevel symbology to reflect the new standard 
without further action by you.  

Element attributes that may be set to ByLevel include: color, line style and line weight. This allows 
the level to be set for those attributes rather than individually setting them in an element template 
or each individual element. This assists with consistency in ODOT CAD standards and allows element 
templates to use the already defined ByLevel symbology, reducing potential errors. Whenever 
possible, ODOT has set the ByLevel symbology in the level DGN library as the primary method to 
reflect ODOT CAD standards. 
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The actual symbology is set in the level library, but it can be easily overridden with any of the tools 
used to set element symbology. 

Levels 

Named levels are read from a standard level library. As elements are placed in a file, the level those 
elements are placed on is written to the active file. This means that each level used in a file is 
written directly to that file. If elements are placed on a level that does not exist in the level library, 
there is no impact to the elements and levels already written to the DGN file.  

If files are referenced in and the references contain levels that do not exist in the level library, the 
results are similar. As long as that level exists in the reference, the elements will display properly 
and the level they are on can be manipulated the same as any other level in a reference file.  

If you copy elements out of a reference file into a new file that does not contain the needed level 
and the needed level is not contained in the level library, then the elements will be placed on the 
Default level. Those elements may be manually assigned a named level or level mapping may be 
applied using the process shown in the section above titled “Saving files in other formats in the 
Windows file system” using the Remap tab in the Options. 

------------------------------------------ 

Annotation Scale 

Annotation Scale allows elements such as text, cells, patterning, and line styles to resize 
automatically based on the desired print size.  

Turning the Annotation Scale On and Off  

You can turn the Annotation Scale Lock  on and off from many locations within MicroStation V8i, 
including:  

 The Drawing Scale toolbar 

 The Tool Settings dialogs for Place Active Cell and Replace Cells 

 The Tool Settings dialogs for Place Text and Place Note 

 The Tool Settings dialogs for Patterning and Hatching options 
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 Note: The Scale Annotations check boxes on the Place Active Cell dialog and the Scale dialog 
should be unchecked by default.   

   

Selection of these check boxes causes MicroStation to use the active scale as a multiplier for 
annotation scale elements. For example, if you want to place a cell at twice its normal size, 
but still want it to respond to annotation scale, you could turn these check boxes on and set 
the X, Y and Z scale values to 2. This would result in a cell being placed at twice its normal 
size, but still becoming smaller or larger with any changes to annotation scale. If the check 
box is not checked, the annotation cell being placed ignores the active scale and uses only 
the annotation scale. 

These settings are design file-specific.  Be sure to “Save Settings” after you make changes. 

Annotation Scale Effects on Text and Cells  

Annotation scale works differently for cells and text than it does with line styles. You must place 
cells and text with the annotation scale lock on in order for them to respond to the selected Drawing 
Scale. If the lock is off when you place a cell or text, the element may appear too small. Also, if the 
annotation scale lock is off when you place a cell or text, the cell or text cannot be resized by 
changing the Drawing Scale.  
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Annotation Scale Effects on Line Styles  

Cosmetic custom line styles respond to annotation scale whether the lock is on or off. 

Annotation Cells  

Annotation cells obey the rules of the annotation scale. That is, when you place a cell with the 
annotation scale lock on, the current Drawing Scale affects the size of the cell.  

You can determine which cells are annotation cells on the Cell Library dialog. The annotation symbol 
appears under the Annotation column for a cell that you can place as an annotation cell. If no 
annotation symbol appears, when placed, the cell will remain static in size – not changing in 
response to any changes in the annotation scale. 

 

 Note: Not every cell needs to be an annotation cell. Some cells need to be placed at their 
correct, actual measured size no matter the scale at which the plan sheet will be printed. 
For example, a signal pole with a 25-foot mast arm needs to measure 25 feet no matter at 
what scale the drawing is printed. 
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Hatching and Patterning with the Annotation Scale 

ODOT pattern cells are set up to work with Annotation Scale Lock turned on, and with the lock on it 
is recommended that the scale in the Pattern Area tool dialog be set to a value of 1. The scale field is 
used as a multiplier, so a value of less than one (1.0) results in a scaled-down pattern, while a value 
greater than one (1.0) results in larger patterning. 

Getting the Patterning Result you want 

The following images show the settings to produce correctly patterned stipples in a model with 
drawing scale 1”=100’.  The left image has the Annotation Scale Lock toggled off and a pattern scale 
(factor) that is the same as the drawing scale.  The settings on the right will produce an identically 
patterned area with the Annotation Scale Lock toggled on and the scale set to 1. 

    

Both settings shown above will produce the same pattern, but settings on the right are 
preferred because of the ability to match pattern attributes without unexpected behavior. 

Known Issue with Patterning and Hatching  

Unexpected Behavior 

When using MicroStation V8i SS4, if you Match Pattern Attributes (or use SmartMatch) and select a 
pattern or hatch that you placed using MicroStation V8i SS3 (without the annotation scale lock), the 
Annotation Scale Lock is immediately deactivated and the Drawing Scale is set to Full Size 1=1. 

 

This has also been observed when matching patterns from referenced files. 

How to handle this: 

Watch the drawing scale as you perform the match to a pattern. If the drawing scale changes, 
manually return it to the desired scale. 
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Toggle ON the Annotation Scale Lock, and then set the Drawing Scale to 1”=100’ (or whatever the 
model scale was prior to using the match tool). 

 

When ON, the button has a yellow background outlined with blue and the drawing scale is enabled. 

TCP Patterning tools 

The TCP Patterning tools do not use the Annotation Scale of 
the model, but instead use the Active Scale. 

Prior to using any of the TCP Patterning tools: 

1. Turn the Annotation Scale Lock OFF (when off, icon 
has a gray background and the drawing scale is 
disabled) 

 

2. Set the Active Scale as follows: 
AS=0.5 for 1”=50’ 
AS=1 for 1”=100’ 
AS=2 for 1”=200’ 

The Traffic Control Patterning macros are found on 
Tasks>ODOT>Traffic>Traffic Control>TCP Patterning 

Place Patterned Shapes (TPDT) 
Place Shapes for Future Patterning (TPDT /s) 
Pattern Previously Placed Shapes (Tern.mvba) 

MicroStation Alert 

When patterning with the Annotation Scale Lock turned ON, for every patterned area you have in 
the active file, you will receive an Alert window about placing a large number of patterns.   

For annotatable associative patterning, select [OK].  
(In past versions of MicroStation it was recommended that you select [Cancel] on this dialog.)  

 
  
Changing the Annotation Scale in a model with annotatable associative patterning also opens the 
alert dialog. This is because the patterning must be redrawn into the file at the new annotation 
scale. If more than one instance or area of annotatable associative patterning is in the model and 
the Annotation Scale is changed, the alert appears once for every occurrence of patterning that 
must be redrawn.  

If the pattering is in a reference file, no alert occurs on changing the Annotation Scale. 
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Fully Functional, Fully Annotatable Patterning 

In order to take advantage of hatching and patterning now having integrated Annotation Scale, two 
settings must be considered.  

To have fully functional, fully annotatable patterning: 

The Annotation Scale lock must be ON. 

The “Associative Pattern” box in the Pattern Area tool settings dialog must be checked.  

 

This results in patterning that uses the Annotation Scale in its own active model, and also in a parent 
file when attached as a reference.  

File Size Considerations of Associative Patterning 

It is generally recommended that the Associative Pattern box be unchecked when patterning 
areas. This is because: (1) associative patterning can increase file size (2) may be more likely to 
cause errors when used extensively, and (3) causes your graphics to take a long time to update as 
you pan or zoom.  

Having the Annotation Scale lock ON while the Associative Pattern box is unchecked creates a 
patterned area that recognizes the Annotation Scale at the time of placement, but which becomes 
static once the pattern is placed. This means that changes to Annotation Scale in the active file do 
not result in the size of the pattern changing. Also, patterning placed with these settings in 
reference attachments do not take on the Annotation Scale of the parent file.      

If patterning is placed with the Annotation Scale lock off, the scale field in the Pattern Area dialog 
should be set to something like 1200 for a 1"=100' Annotation Scale model. 

------------------------------------------ 

  



ODOT MicroStation® V8i SS4 User Guide 

60 Oregon Department of Transportation November 2018 
Engineering Applications Support Team 

Level Display 

There is a slight change to way elements drawn on new levels in reference files display in 
MicroStation V8i SS4. If you are accustomed to MicroStation V8i SS3 or earlier functionality, please 
note this change.  

New levels used in a reference file automatically display in the active file. (In the past if you had a 
reference attachment and elements were drawn on a previously unused level, the newly used level 
was not displayed or turned on in the active file.) 

An example of the level display functionality in MicroStation V8i SS4: 

If you have an active plan sheet model open with a design model attached as a reference, levels that 
are not used in the referenced design model do not display in the active file. If the designer opens 
and modifies the design model, adding new elements to levels that were not previously used, the 
active plan sheet model will automatically display those new elements. This is because the newly 
used levels are automatically toggled on or displayed the next time the active plan sheet model is 
opened.  

 
------------------------------------------ 
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Project Explorer 
Project Explorer allows you to manage Windows project data within 
MicroStation. Using it, you may open file locations in the Windows file 
system and launch other applications.  

The Project Explorer icon is on the main toolbar. Click on it to open Project 
Explorer. When open, you can size Project Explorer to float over a view 
window in MicroStation. 

You can use the drag and drop method from Project Explorer into the active view in MicroStation, to 
attach models or saved views as references, and you can drag and drop files from Project Explorer 
into the Print Organizer for creating print definitions.  

 

A link set in Project Explorer named ODOT_DATA has been created 
that provides you with quick access to common locations in the 
Windows file system for storing data and your user configuration. 

 

 Note: Click the + symbols to expand the folder hierarchy. 

Double-click a folder to open it in Windows Explorer. 
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Printing Functions 
Printing in MicroStation can be one-off single-sheet printing that you can set up using the Print 
dialog, or you can use the Print Organizer tool to set up print definitions for entire file sets.  

Both print functions can be used to create enhanced metafiles (.emfs), .pdfs and .jpegs, in addition 
to making hard copies. 

Since there are many selectable attributes for printing, customized Print Styles have been created 
for you to use. Using a Print Style automatically sets print attributes (including printer driver 
configuration and pen tables) to match an ODOT standard. 

Any time that your desired print output must match an ODOT standard, using a Print Style greatly 
streamlines the print setup process.  

Other customized files that can be applied when using print functions include: 

 Printer driver configuration (*.pltcfg) files 

 Pen Tables (*.tbl files) 

Because printer driver configuration files and pen tables are not stored in a ProjectWise datasource, 
if the active MicroStation design file is in a ProjectWise datasource, you will need to click [Cancel] on 
the ProjectWise integrated dialog to close it before you can access them.  

See Printing Files Stored in a ProjectWise Datasource for more detail. 

One-Off Printing 

To print a one-off, single-sheet model, a view, or a fenced area, you can use File>Print from the 
main menu bar to open the Print dialog.  
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Print Preview 

You can use the thumbnail preview in the Print dialog to preview how the printed file will appear, or 

click the  (Print Preview) icon to open a re-sizeable preview for more detail.  

Adjusting Settings on the Print Dialog 

On the main page of the Print dialog, you may individually set print settings such as the area to 
print, the color, selected printer, paper size, page layout, print scale and position, color and rotation. 
As you make adjustments, the thumbnail preview of the drawing adjusts accordingly. Once the 
preview appears as you desire, click the Printer icon in the upper left corner or the [Print] button in 
the lower right corner to send or create the print. 

 Note: If you do not set a fence prior to opening the Print dialog, the ODOT Defaults print 
style (the one that always runs) creates a fenced area around the first border cell that 
was placed in the active model. To print the View, change the Area to View. 

Printing Files Stored in a ProjectWise Datasource 

If the active MicroStation design file is stored in 
a ProjectWise datasource, and you wish to 
change the pen table or printer driver 
configuration file, you will have to cancel out of 
ProjectWise dialogs. This is because the *.tbl 
and *.pltcfg files are stored in ODOT_space in 
the Windows file system, so they cannot be 
loaded using a ProjectWise integrated dialog.  

Specifically, if your active file is in ProjectWise 
and you want to perform any of these actions… 

 Search for a Printer Driver 
Configuration File (Click on the 
magnifying glass icon next to the Printer 
driver drop-down) 

 Search for the Pen Table (i.e., Click on 
the magnifying glass icon for the Pen 
Table: drop-down) 

 Select File>Select Bentley Driver 

 Select  Resymbolization>Attach Pen Table 

…an integrated Select Print Driver Configuration File dialog opens, and you have to cancel out of it 
to continue.  

When you cancel out of the integrated Select…File dialog, the Windows Select … File dialog opens, 
set to the correct location and file type for either printer driver configuration files or pen tables. 

Selecting a Print Driver Configuration File (PLTCFG) 

Printer driver configuration (*.pltcfg) files provide standard output sizes and file formats. ODOT 
customized *.pltcfg files are stored in the ODOT workspaces. Basic descriptions of these files are 
provided in Table 4. Printer Driver Configuration Files. 
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1. On the Print dialog, click the magnifying glass icon next to the driver field . 

2. If the ProjectWise integrated Select Printer Driver Configuration File dialog opens, click 
[Cancel].  

3. On the Windows Select Printer Driver Configuration File dialog, double-click on the 
driver file to select the driver or navigate into the Bentley_Supplied folder to find other 
driver types not configured for standard ODOT use. 

 

 

Table 4. Printer Driver Configuration Files 

Printer Driver Configuration File Function 

BDS_tiff_400DPI_G4.pltcfg Creates TIFF files in G4 format with 400 DPI for uploading into 
the Bridge Data System (BDS). 

emf_odot.pltcfg Use as alternative to “Create metafile” printer option to 
create encapsulated meta files that match line weights of 
images produced for ODOT manuals using MicroStation  V8 
2004. 

jpeg_400dpi_WhiteBkgrd.pltcfg Use to create .jpg format images with 400 DPI and white 
background. 

odotAB_printer.pltcfg Based on ODOT configured printer.pltcfg for line weights with 
only two paper sizes available, ANSI A (8.5x11) or ANSI B 
(11x17). 

odotCD_printer.pltcfg Based on ODOT configured printer.pltcfg for line weights with 
only two paper sizes available, ARCH C (18x24) or ANSI D 
(22x34). 
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Printer Driver Configuration File Function 

odotsizes_PDF.pltcfg PDF printer driver with ODOT line weights and only nine 
different paper sizes including the maximum 200”x200”. 

odotsizes_PDF_1inTo400ft.pltcfg PDF printer driver with fine line weights for clear zooming in 
on text with scales between 1”=300’ and 1”=400’. 

odotsizes_PDF_1inTo800ft.pltcfg PDF printer driver with very fine line weights for clear 
zooming in on text with scales between 1”=500’ and 1”=800’. 

odotsizes_PDF_levels.pltcfg PDF printer driver based on odotsizes_PDF.pltcfg and with 
Enable Optional Content=On and Print Optional Content=As 
Created for creating PDFs with the ability to adjust displayed 
levels in a viewer, without affecting the print. 

printer.pltcfg Default printer driver configured for ODOT line weights. 

 

Print Definition Files (PSET) 

The MicroStation Print dialog can create and reload a single print definition stored in a print set 
(PSET) file.  The command File>Save Print Definition File… on the Print dialog will save every setting 
on the Print dialog, including the file name of the active DGN, as well as the fenced area.  Using 
File>Open Print Definition File… to load a PSET file, will change the active file, if necessary, and 
allow you to quickly print the same area with the same pen table. 

Print Styles 

Print Styles load your print settings, including pen tables, sheet size and layout. Some print styles set 
a PLTCFG, attach a pen table, and set paper size and scale. Other print styles create fences for a 
print definition upon locating specific border cells that have been placed in files. 

To apply a Print Style, select Settings > Apply Print Style from the top menu of the Print dialog. This 
opens a dialog with a drop-down list that allows you to select the Print Style for your print job. For 
one-off printing it is quickest to apply the _PDF__ODOTPlans_B_11x17 print style. 
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Table 5. Print Styles 

Print Style Function 

ODOT Defaults Creates fence locations around cells named Border_*, that 
are found in any model in the added file.  

Limit searched models by dragging and dropping specific 
models or saved views from Project Explorer. 

1Borders_In_Reference_Files_Only Use when creating print definitions to create fence locations 
around border cells found only in any model in files 
referenced into the added file. 

_PDF_*_B_11x17 Selectable from the Print dialog or Print Organizer to apply a 
pen table and odotSizes_pdf.pltcfg for PDF creation with 
paper sizes of 11x17. 

“ODOTPlans” – uses plans.tbl pen table for contract plans. 

“CurbRampDetail” – uses plans_CurbRampDetails.tbl for 
Curb Ramp Detail sheets. 

Use of a PDF print style is preferred. 

_PDF_IntchLayout_D_22x34 Uses Intch_Layout.tbl for Interchange Layout Sheets. 

_PDF_*_A_8.5x11 “PlansMaint” - use for Maintenance-type projects with 
8.5x11 sheet borders.   

“SignShopGS_BW” and “SignShopGS_Color” – locate 
GuidSIGN cells named GSSHT and maximize to ANSI A paper 
size (11x8.5). 

_PDF_*_C_18x24 “Surv_CRR” - use for survey control, recovery or 
retracement; applies the Surv_CRR_BW.tbl pen table which 
can be changed to Surv_CRR_GS.tbl.   

“Surv_RWM” – use for Right of Way monumentation; 
applies the Surv_RWM_BW.tbl pen table which can be 
changed to Surve_RWM_GS.tbl 

_PDFXsections_eBIDS_B_11x17 Use in Print Organizer to create print definitions from 
InRoads cross section set borders that are legible for the 
eBIDS Handoff. 

PrintPlansAB_B_11x17 Use in Print dialog or Print Organizer to apply plans.tbl and 
odotAB_printer.pltcfg for small format printing. 

PrintPlansCD_C_18x24 Use in Print dialog or Print Organizer to apply plans.tbl and 
odotCD_printer.pltcfg for large format printing.   

Default system printer must be set to a large-format plotter. 
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Pen Tables 

Pen tables may be attached to remap characteristics like color and weight.  A number of pen tables 
have been created for producing ODOT Contract Plans and other ODOT products. 

Table 6. Pen Tables 

Name Purpose 

plans.tbl Used for contract plans.   

 Turns everything in active model black; gray shades referenced 
existing features, except utilities.   

 Does not print construction class.   

 Outline color of closed elements in active model with fill 
color=255 (background) is changed to background.   

 Replaces filename location text for actual file name if ODOT 
border cell is used. 

Plans_CurbRampDetail.
tbl 

Used for contract plans curb ramp detail sheets.   

 Turns everything black and gray shades all existing features.   

 Does not print construction class.   

 Outline color of closed elements in active model with fill 
color=255 (background) is changed to background.   

 Replaces filename location text for actual file name if ODOT 
border cell is used. 

Plans_FullPath.tbl Used for non-STIP contract plans that are not stored in ProjectWise.   

 Turns everything black and gray shades existing features, except 
utilities.   

 Does not print construction class.   

 Outline color of closed elements in active model with fill 
color=255 (background) is changed to background.   

 Replaces filename location text for full path file location if ODOT 
border cell is used. 

eBIDSXsections.tbl Used to create legible cross sections for eBIDS Handoff.  Uses same text 
replacement, no plotting of constructions, and modifying masking shape 
outlines from plans.tbl. 

 All elements with color that are yellow hues will plot black.   

 All elements are drawn 0.02 mm in width. 

HeavyColor.tbl  All elements with line weights from 0 to 7 plot two line weights 
heavier. 
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Name Purpose 

Intch_Layout.tbl 
Used for Interchange Layout sheets.  

 Screens referenced elements similarly to plans.tbl, with 
additional sections to screen topo, rw, and contours all 
differently. 

ITS_plans.tbl Similar to plans.tbl, except that it also gray shades existing utilities.   

 Does not print construction class. 

 Does not modify outline of background masking shapes. 

rw.tbl Used by Right of Way to turn everything black, gray shade existing 
features, and fill monuments.   

 Does not print construction class.   

 Outline color of closed elements in active model with fill 
color=255 (background) is changed to background.   

 Uses pen table section priority to control printing of shapes for 
recorded sale, fee, permanent and temporary easement. 

 Replaces filename location text for actual file location in map 
borders. 

SignShopGS_BW.tbl  Does not plot construction class elements. 

 Does not plot level GSColorFill.  

 Turns all elements and element fills to black.   

 Does not print construction class. 

SignShopGS_color.tbl  Does not plot construction class elements. 

 Does not plot level GSBWFill.  

 Turns only elements and text in sheet report to black.   

 Prints GSCOLORFILL level in color.  

 Does not print construction class. 

Surv_CRR_BW.tbl Used for plots that file survey control, recovery and retracement maps in 
counties that don’t allow gray shading.   

 Does not print construction class.   

 Outline color of closed elements in active model with fill 
color=255 (background) is changed to background. 

 Replaces filename location text for actual file location. 

Surv_CRR_GS.tbl Used for plots that file survey control, recovery and retracement maps, 
and gray shades existing topography.   

 Does not print construction class.   

 Outline color of closed elements in active model with fill 
color=255 (background) is changed to background. 

 Replaces filename location text for actual file location. 
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Name Purpose 

Surv_RWM_BW.tbl Used to file right of way monumentation maps in counties that don’t 
allow gray shading.   

 Does not print construction class.   

 Outline color of closed elements in active model with fill 
color=255 (background) is changed to background. 

 Replaces filename location text for actual file location. 

Surv_RWM_GS.tbl Used for right of way monumentation maps and gray shades existing 
topography.   

 Does not print construction class.   

 Outline color of closed elements in active model with fill 
color=255 (background) is changed to background. 

 Replaces filename location text for actual file location. 

Yellowtoblack.tbl  All elements with color 4 (yellow) plot black.   

 Replaces the filename location text for actual file location if 
ODOT border cell is used. 

br_plans.tbl 
No longer used – retained to print older Bridge plans at 22x34 size. 

Similar to plans.tbl, except that it increases line weights of 
proposed features for larger sheets. 

 Does not print construction class.   

 Outline color of closed elements in active model with fill 
color=255 (background) is changed to background. 

 Replaces filename location text for actual file location if ODOT 
border cell is used. 

 

Creating a PDF 

You can use either of the following methods to create a pdf from a design file with a plan sheet 
border: Use a Print Style or Use a Manual Set Up. 

Use a Print Style to Create a PDF file from a single plan sheet: 

1. Open any design file that contains a plan sheet border. 

2. Select File > Print from the main menu. The Print dialog opens. (A fence is automatically 
placed around the plan sheet border) 

3. On the Print dialog main menu, select Settings > Apply Print Style.  

This opens the Print – Apply Print Style dialog. 

4. Select _PDF__ODOTPlans_B_11x17 from the drop-down menu and click [OK].  



ODOT MicroStation® V8i SS4 User Guide 

70 Oregon Department of Transportation November 2018 
Engineering Applications Support Team 

 
The Print Style applies the PDF driver and the pen table, sets the paper size to 11x17, and 
maximizes the border to the paper.  

5. Click [Print to File…].  

If you are working in a MicroStation DGN file that is stored in a ProjectWise datasource, the 
Select a Wizard dialog opens.  

o To save the PDF in the ProjectWise datasource, select a wizard.  

 
 

The resulting PDF is saved in ProjectWise and the local copy opens in the PDF viewer. 

o To save the PDF in the Windows file system, select [Cancel] on the Select a Wizard 
dialog.  You will need to navigate to your Windows directories. 

If you are working in a MicroStation DGN file that is stored in a Windows directory, the 
Windows Save Print As dialog opens. Enter a new name and click [Save]. 

To Create a PDF file from a single plan sheet using a Manual Set Up: 

1. Open any design file that contains a plan sheet border. 

2. Select File > Print from the main menu. The Print dialog opens. (A fence is automatically 
placed around the plan sheet border) 

3. Select File>Select Bentley Driver or click the magnifying glass icon in the driver section 
of the Print dialog.  If you are working in a MicroStation DGN file that is stored in a 
ProjectWise datasource, click the [Cancel] button to open the driver location in the 
workspace. Select odotSizes_PDF.pltcfg and click [Open]. 

4. Verify Paper is set to 11x17 and Scale is matches the drawing scale in the DGN, typically 
100.0000.  

5. Attach the plans.tbl pen table using Resymbolization>Attach Pen Table or the 
magnifying glass icon across from the Pen table field. If you are working in a 
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MicroStation DGN file that is stored in a ProjectWise datasource, click the [Cancel] 
button to open the pen table location in the workspace. 

6. Click [Print to File…]. 

 

7. If you are working in a MicroStation DGN file that is stored in a ProjectWise datasource, 
the Select a Wizard dialog opens. Select a wizard or click [Cancel] to save in the 
Windows file system. 

 
Reminder: The *.tbl and *.pltcfg files are stored in ODOT_space in the Windows file 
system, and cannot be loaded using the ProjectWise integrated dialog.  Click [Cancel] on 
that dialog to open the Windows Select … File dialog when manually loading printer 
driver configuration files or pen tables. 

Using Print Organizer to Create Print Definitions 

You can use Print Organizer to create and manage prints — both paper and digital. Print Organizer 
uses everything from the pen tables and printer driver configuration files to paper sizes and scales, 
to create print definitions for plan sheets automatically. Much of the setup is performed by choosing 
the desired Print Style during print definition creation. 

Print Organizer creates and uses print set (PSET) files as a container to store multiple print 
definitions. When multiple print definitions are stored, they are arranged in a hierarchical structure 
and may be placed into folder groups. 

A seed print set file has been created for use in assembling contract plans. KeyNu.pset is located 
in your F:\ODOT_DATA\USERCFG\plot folder and may be copied into your Windows project 
folders or imported into your project in a ProjectWise datasource. 
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The KeyNu.pset file contains named folders that are in order of the sections that are found in 
plan sets.  

 

The available print styles either search for specific border cells, or rectangular shapes on a specific 
level, in the files you add into Print Organizer.  

Print definitions are created in the same order that the cells and shapes were placed into the model 
originally. It is the order of placement, not the location, which governs the order in which the print 
definitions are created. 

 
Note: You may use the Bring to Front command to re- order of placement of elements in 
a model. The Bring to Front command causes the element to become the last element 
placed in the file. 

 

 
Note: You do not have to select the ODOT Defaults print style, as it always runs.   

To change your search for borders to only look inside referenced files for border cells, on 
the Create Print Definitions dialog select the 1Borders_In_Reference_Files_Only print 
style and apply a PDF or paper print style later, in Print Organizer, by selecting Tools > 
Apply Print Style. 

If you are working within ProjectWise, you will need to Cancel out of the integrated Open Print Set 
File dialog, in order to load a print set that is stored anywhere in the Windows file system, such as 
your F: drive.   

A shortcut named ODOT_User_Configuration has been placed in the Engineering folder on your 
Desktop to provide easy access to KeyNu.pset when working with contract plans. 

Two methods are shown below. The first, for when you are working in a MicroStation DGN file that 
is stored in a ProjectWise datasource, uses KeyNu.pset.  The second method illustrates creating 
print definitions from Windows data in a flat folder structure beginning with an Untitled print set. 
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Creating Print Definitions from Data Stored in ProjectWise 

1. Open the Print Organizer dialog. (Click on the Print Organizer icon: ) 

2. Load the print set seed file KeyNu.pset: 

a. Select File > Open in Print Organizer.   

b. Cancel out of the integrated Open Print Set File dialog to open the Windows Open 
Print Set File dialog.   

c. Click the Desktop shortcut on the left side. 

d. Open the Engineering folder.   

e. Double-click on the ODOT_User_Configuration shortcut. 

 

f. Navigate into the F:\ODOT_DATA\USERCFG\plot folder. 

 

g. Double-click on KeyNu.pset 
This loads the empty folder structure for a contract plans print set. 
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3. Select File>Save As… to save the PSET template to your project folder in ProjectWise.  

4. Select No Wizard, and click [OK] to open the Save Print Set File dialog.  

5. Verify the folder location and click [Save]. This saves the empty folder structure to the 
appropriate project folder in ProjectWise. There is no need to change the name at this 
time. The PSET file will need to have the ProjectWise Document Naming tool run on it in 
ProjectWise later. 

 

6. Select a sub-folder in the left window of the Print Organizer and choose File>Add Files 
to Set…  
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 This opens the Create Print Definitions dialog. 

 

7. Click [Add]. 
The Select Files dialog opens.  

8. Select and add DGN files containing sheet borders to the “Selected Documents” list. 

 

The Select Files dialog stays open while you navigate in the ProjectWise folder structure, if 
necessary, to add files from a different folder.   

9. When done adding files, click [OK]. 

10. On the Create Print Definitions dialog, click the magnifying glass icon.  
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11. Select a print style, such as _PDF__ODOTPlans_B_11x17, from the Apply Print Style 
dialog and click [OK].  

 

12. Click [OK] on the Create Print Definitions dialog. The print definitions are displayed in 
the Print Organizer.  

 

13. Choose File>Save to save the print definitions 

14. When you close the Print Organizer, Check In the PSET file. 

Print preview, sheet order, and renaming print definitions are covered below, in the next 
method of creating print definitions from data stored in the Windows file system. 

Creating Print Definitions in the Windows File System (using Project Explorer) 

1. Open any design file in the Windows file system and then click the Project Explorer icon 

on the main tool bar. The Project Explorer dialog opens. 

2. Click the Print Organizer icon  to open the Print Organizer dialog.  
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3. From the F:\ODOT_DATA\USERCFG\plot folder in the Project Explorer, drag and 

drop the KeyNu.pset into the Print Organizer window. 

 

4. In the Project Explorer, navigate to your files that contain plan sheets. 

5. Drag and drop the plan sheets into the appropriate folder in the left window pane 
within Print Organizer. 

 

The Create Print Definitions dialog opens. 
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6. Click the magnifying glass icon and select a Print style name. 

7. Click [OK] to apply the print style and create the print definitions. 

8. Drag the next set of files from Project Explorer into the corresponding Print Organizer 
folder on the left side and repeat the steps to select and apply a print style to the set of 
files. Repeat until you have created all of the desired print definitions that you want to 
include in your print set. 

To preview the sheets in each Print Organizer folder 

 Right-click the sheet name(s) in the right pane and select Print Preview from the drop-down 
menu.  

To change the sheet order in Print Organizer: 

 Select (in the right-hand pane) the sheet(s) to move, and then drag and drop or use the 
Move buttons to move the sheet(s), even into a different folder. 

 

Drag sheet definitions or 
use the Move buttons to 
change sheet order. 
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Renaming Print Definitions 

Changing a single print definition name to match sheet names or numbers 

 Right-click on a single print definition in the right pane and select Rename from the drop-
down menu, or slowly double-click on a single selection to highlight the name for 
replacement.  

 
 

 
Note: We specify default print definition names by combining the word "Sheet" 
with the print definition number (PrintDefNumber). PrintDefNumber is counted 
from the topmost position beneath the root folder in the Print Organizer. This 
results in names like Sheet 1, Sheet 2, Sheet 3, and so forth. 
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Renaming Multiple Sequential Print Definitions 

Follow these steps to rename multiple sequential print definitions where a numeric sequence can be 
used to rename a group of sheets. 

1. Make a selection set and choose Edit > Rename by Expression… from the Print 
Organizer main menu. 

 
The Rename Print Definitions by Expression dialog opens. 

2. Click the Expression name drop-down arrow and select Custom. 

 
 
This enables editing of the Specify Expression field. The text inside the quotation marks is 
used for each name. 

3. Edit the Expression name as follows: 

a. Replace what's between the quote marks with the part of the name that is 
repeated. 

b. Insert a mathematical expression to calculate the beginning number in the 
series. 

c. Click Preview Names… to open the Print Definition Names dialog and verify the 
print definitions are correctly numbered. 
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d. Click [OK] to rename the print definitions. 

 
 

 Note: To specify the mathematical expression to calculate the beginning number in a Print 
Definitions series, use the following formula: 

Number to subtract = PrintDefNumber - Beginning Number 

For the example shown below: 

1. Replace "Sheet "&System.String.Format ("{0:D1}", 
PrintDefinition.SetPrintDefNumber) with 
"2A- "&System.String.Format ("{0:D1}", PrintDefinition.SetPrintDefNumber-6) 

2. Click Preview Names … to confirm the formula works. If you don't like the names 
you see in the preview, close the preview and click Cancel. 

 

3. Click [OK] to save the print definition expression. 

 

4. After creating, ordering and renaming print definitions, save the print set:   

a. Select File > Save As… on the Print Organizer main menu and navigate to your 
project folders in the Windows file system. 

b. Change the name of the file from KeyNu.pset to use the project key number or 
name. This name will be used when creating a single PDF print job.  Always save 
files prior to printing or creating PDFs. 
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Printing with Print Organizer 

Print Organizer has its own File History, allowing you to quickly open a print set for a project stored 
in a different datasource or folder. The File History will allow you to quickly create a new print set 
from the seed KeyNu.pset file. 

 

With Print Organizer open and a PSET file loaded, 

1. Select File > Print... on the Print Organizer main menu or right click on a sheet and select 
Print… from the drop-down menu to open the Print dialog. 
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2. For the Print Range, select All. 

3. In the Submit as field, select Single print job. 

4. Click [OK] to create one PDF file with all sheets. 

  

 
Note: Only populated folders in the Print Organizer create bookmarks in the resulting PDF. 

Small Format Paper Printing  

When you create print definitions, it is recommended that you choose a print style that creates 
PDFs.  If you would like to print to paper or mylar later, it is best to divert to a printer at print time.  
For small format paper printing, confirm that your default Windows printer has the paper size you 
want to print on. Then, when you choose the appropriate printer driver configuration file, the 
correct paper size will be set.  

 
Reminder: The Print Styles will apply the plans.tbl pen table and a PLTCFG file to control 
the type of printing. 

 

 
Note: The odotAB_printer.pltcfg printer driver configuration file automatically sets a 
paper size of ANSI B -11 x 17. 
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To change from creating a PDF to printing 11x17 on a small format printer: 

1. Select File > Printer Setup… from the main menu on the Print Organizer dialog. 

 
 
The Printer Setup dialog opens. 

 

2. On the Printer Setup dialog, click the Magnifying Glass icon. 

3. Select odotAB_printer.pltcfg and click Open.  
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4. Click [OK] to close the Printer Setup dialog.   
The Print Organizer refreshes to display the selected small format printer in the lower right 
corner; all other properties of the print definitions remain the same as they were. 

 

5. Select File > Print… to send the prints to your default printer. 

 Note: Close Print Organizer without saving to retain the original PDF print definitions. 
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Large Format Paper Printing 

You may also change from small format PDF to large format paper or mylar after the print 
definitions have been created. For large format paper printing, confirm that your default Windows 
printer is set to a plotter and has the paper size you want to print on. Then, when you choose the 
appropriate printer driver configuration file, the correct paper size will be set.  

To change from creating an 11x17 PDF to printing 22x34 on a large format plotter: 

1. From the Control Panel, open the Devices and Printers window and set a plotter to be the 
default printer. 

 

2. Select File > Printer Setup… from the main menu on the Print Organizer dialog. 

3. Follow the steps shown in the Small Format Paper Printing section above to browse to the 
printer driver configuration files and choose odotCD_printer.pltcfg. 

4. Upon clicking [OK] on the Printer Setup dialog to accept the change in the printer driver 
configuration file, the paper size and scale automatically adjust to the larger format. The 
printer path to the plotter displays at the bottom of the Print Organizer window. 

 

5. Select File > Print… to send the prints to your plotter. 
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Save the Print Definition File 

The PSET file contains all the information about the print definitions and can be reopened in Print 
Organizer for printing single sheets from the print set, for reprinting after revisions are made to 
content, or for applying a different print style to create check prints, PDF files or Mylar prints.   

The print definition file does not contain any information about elements in the file.  It does contain 
a fence location and when you request a print preview or a print, the print setup looks at the source 
file to determine which elements are displayed within the fence location. When you save the PSET 
file, it records the fence locations, the path and name of the source files, the paper size and scale. 

 Tip!   Only save one PSET file for a print set, even if you need to print digital and paper 
products.  Multiple print sets for the same project can lead to difficulty synchronizing 
sheet order, etc.  For a temporary change, select File > Printer Setup… on the main 
menu bar.  It is recommended to save only PDF print definitions for consistent paper 
sizes. 

 

 Reminder: Saving changes to a print set takes two steps if your files are stored in a 
ProjectWise datasource.  First, use File>Save in Print Organizer, then select Check In on 
the Check In dialog when you close the Print Organizer. 

 

Source File Data Preparation 

The files that contain the borders must have the last active view left print-ready.  Print-ready means 
the displayed levels and orientation of the last active view are ready for printing without rotation.  
Save the print settings with an active view rotated to align border cells with the view axes.  To do this, 
leave one view oriented to Top rotation, or Unrotated if 2D, and place borders in the unrotated view. 

 Note: If the last active view had the view rotated with respect to the borders, you will 
get strange scales and rotated previews in the Print Organizer. 

 

 Note: You can load Saved Views directly into the Print Organizer by dragging them from 
Project Explorer and dropping them into the Print Organizer window. 
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Correcting File Location paths when print set files have been updated 

Many pen tables replace a string of text in the border cell with the location of the file.  When using 
Print Organizer, the full path to the file is also recorded in the properties of the print definition when 
it is created.  Sometimes the files that make up print set are renamed or moved to another folder.  
When the file is printed at a later date, the location may display an incorrect file location on the 
print, if the files are stored in the Windows file system.  PSETs and DGNs stored in ProjectWise 
should automatically update to new names and locations when the .pset is opened. 

Find and Replace File Paths… can be used to correct the path to DGNs in the Windows file system. 

1. In Print Organizer, select Edit > Find and Replace File Paths… 

 

2. Fill out the Find and Replace File Paths dialog.   

 
 If a folder name has changed, you can update all print definitions by selecting All print 

definitions.   

3. Click [OK]. 

A message dialog indicates how many print definitions were updated. 

 

Now, when Print Organizer applies a pen table that replaces a text string with the file location, it will 
read the Filename: field from the print definition Properties and display the correct file location. 
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Adding Sheets to Print Organizer 

From time to time you will need to add sheets to your .pset file. There are two methods to do this; 
the Standard Method and a Model/File Method for large, complex projects. 

For most projects the Standard Method can be used. 

Standard Method to Add Sheets 

1. Open the file containing your existing sheet borders and add border cells for the new 
sheets. 

2. Open your project PSET with Print Organizer. (The project PSET may be in the Print 
Organizer file history.) 

 
3. With the correct folder active, use File>Add Active File to Set….  Select 

_PDF__ODOTPlans_B_11x17 Print style.  This creates additional print definitions in Print 
Organizer (Sheet 7 through Sheet 14 in this example).  
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4. The last two print definitions listed are the empty sheet borders that were just added to 
the DGN.  Preview the last two print definitions to confirm that you want to add them 
(Sheets 13 and 14 in this example). 

5. Delete the other duplicate print definitions that were just created (Sheet 7 through 
Sheet 12 in this example). 

 

6. Rename the print definitions. 

7. Save the print set. 

 
Reminder: Saving changes to a print set takes two steps if your files are stored in a 
ProjectWise datasource.  First, use File>Save in Print Organizer, then select Check In on 
the Check In dialog when you close the Print Organizer. 
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Model/File Method to Add Sheets 

For some large complex projects the previous method of adding sheets to Print Organizer may not 
be practical. In this case create a model or file just for the additional sheet(s) you want to add to 
Print Organizer. 

1. Add the border cell for the sheet to a new model or design file. 

2. Open your project PSET with Print Organizer.  The project PSET may be in the Print 
Organizer file history. 

3. In Project Explorer expand the design file and drag just the new model from Project 
Explorer into Print Organizer and apply a PDF print style.  This creates additional print 
definitions in Print Organizer (model named Additional Sheets in this example). 

 

4. Rename the print definitions. 

5. Save the print set. 
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MicroStation Add-on Tools 
From the ODOT menu on the main menu, you can access MicroStation add-on tools and applications 
to use.  

 

AutoTURN 10.0 

AutoTURN 10.0 is used for vehicle turn simulation and swept path analysis. If installed, AutoTURN 10 
appears on the ODOT menu.  

 
Note: If you don’t have AutoTURN 10 installed, but need it, call the Computer Support 
Desk to request the tool. 

AutoTURN 10 stores vehicle data in the F:\ODOT_DATA\AutoTURN\database folder.  

To share vehicle data, you must export the VLC and TYP files from the database of one user, and 
then import the vehicle files into the database of the second user.  

Exporting vehicle files using AutoTURN:  

1. On the AutoTURN toolbar, select the Vehicles icon. 

The “Select Current Vehicle” dialog opens. 
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2. Select the Library and the Vehicle Name to export out to VLC and TYP format. 

3. Click the Vehicle Export button.  

 Note: The Vehicle Export button does not appear if custom vehicles are not listed. 

Importing vehicle files using AutoTURN:  

1. On the AutoTURN toolbar, select the Vehicles icon. 

2. On the “Select Current Vehicle” dialog, click the Vehicle Import icon and select a VCL 
Vehicle file to import.  

 Note: The TYP type file must be in the same folder as the vehicle file. If the TYP type 
file is not found, AutoTURN will report the name of the missing type file that needs 
to be in the same folder as the VCL vehicle file.  
Before importing, move your TYP files from the F:\ODOT_DATA\AutoTURN\ 
types user folder to the F:\ODOT_DATA\AutoTURN\vehicles user 
folder where the vehicles are typically located. 

 
3. On the Import Vehicle dialog, select the Library into which you want to import the 

vehicle. You can accept the default of Imported or enter your own library such as 
_ODOT.  

 

4. Click [OK]. The vehicle is imported and listed in the library.   

 
Tip! If you start your library name with an underscore (e.g., “ _ODOT”), it will 
appear at the beginning of the library list so you will not have to scroll through the 
list to find it. 
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Faster Vehicle Library Loading 

The AutoTURN 10 vehicle database is now 10 
times larger and loads slower. To speed up 
the loading of the vehicle libraries, you can 
select just the vehicle libraries in the 
database you want to be displayed. This is 
found under the AutoTURN 10 Program 
Settings > Vehicle Library Display. Check or 
uncheck the vehicle libraries you want to be 
displayed. Note the Select All and Clear All 
buttons below the list of vehicle libraries. 

 

 

 

 

Axiom Microsoft Office 
Importer 

The Axiom Microsoft Office Importer tool produces native MicroStation 
graphics from Microsoft Word and Excel documents.  

Axiom Office Importer is only licensed to use at these ODOT offices:  

 Portland (Flanders only)  

 Salem (Region 2 and TLC) 

 Springfield  

 Roseburg  

 White City  

 Bend 

 Klamath Falls 

 La Grande
 

You can import Word and Excel files into MicroStation using Axiom Microsoft Office Importer, but it 
does not export from MicroStation back to the original Office format.  
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Although you can’t export the graphic from MicroStation back to the original Office format, 
MicroStation stores a reference to the original Office document, which makes it easy to update a 
graphic if needed. Axiom Microsoft Office Importer works with Office Documents stored in 
ProjectWise the same as documents stored in the Windows file system. The settings (*.ini) files are 
located on a network drive and are not stored in ProjectWise.  

 Warning! When updating an Excel or Word document that has been imported into 
MicroStation, open the document and make changes with the application or 
ProjectWise Explorer. After the server is updated, the updated document can be 
reimported with the Axiom Office Importer Manage or List Update command.  Avoid 
using the adjacent Edit Source which creates confusing error messages. 

 

Custom Tools (Pipe Data Sheet) 

A workflow for preparing ODOT Pipe Data Sheets in Excel and importing them in to MicroStation is 
available. The Pipe Data Spreadsheet User Guide can be found on the EAST website. Even if you do 
not use the Pipe Data Sheet, the guide may give you some ideas about using the Axiom Microsoft 
Office Importer. Additional training documents are also available for this tool. 

office.ini 

By default, Axiom Microsoft Office Importer loads a settings file called office.ini and stores it in 
F:\ODOT_DATA\USERCFG\data. You can make your own settings files to configure text, line, 
colors and weights to use when you import Office content into MicroStation. Additional settings 
(*.ini) files have been developed for the Pipe Data Spreadsheet and surveyor coordinate tables. 

 
Caution!  The settings (*.ini) file does have a limitation: TrueType fonts are referred to by 
MicroStation font number rather than by name. TrueType fonts can vary between computers. 
A settings file created on one computer may need the TrueType fonts to be reselected when 
used on another computer. 

Descartes 

Descartes is used to process images, legacy documentation, point cloud data and digital terrain 
models (DTMs). If installed, it appears on the ODOT menu. After Descartes is launched from the 
ODOT menu, Descartes toolbars can be displayed and additional commands are available in the 
MicroStation Raster Manager.  

https://www.oregon.gov/ODOT/EAST/Documents/PipeDataSpreadsheetUserGuide.pdf#page=1
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Note: If you need Descartes but don’t have it installed, ask your manager to fill out and 
send this email template to the ODOT Automation Engineer.  

GuidSIGN 6 

GuidSIGN 6 is for designing roadway signs. If installed, it appears on the ODOT menu.  

 
Note: If you don’t have GuidSIGN 6 installed, but need it, call the Computer Support 
Desk to request the tool. 

 

ODOT Sign Styles 

The ODOT sign style files that conform to MUTCD 2009 have the 
prefix 2009_ and should be used for new projects. The ODOT 
sign style files are automatically copied to your computer from 
the workspace. The GuidSIGN panel styles are documented in 
ODOT_Custom_Panel_Styles_for_GuidSIGN.pdf which includes 
examples of each style. This PDF can be opened from the 
MicroStation Menu ODOT > ODOT Help > GuidSIGN Panel 
Styles. 

Consultants will find the GuidSIGN sign styles files on the local 
computer in the ODOT workspace, which by default is 

C:\ProgramData\odot_space\Standards\data\GuidSIGN. 

Custom and Old ODOT GuidSIGN Panel Styles 

Store your own custom styles that you develop for your projects in the 
F:\ODOT_DATA\GuidSIGN folder. The ODOT GuidSIGN Reports and Sheets are set as the 
default.   

When working on older designs using the 
standard ODOT GuidSIGN panel styles, you may 
get an error message “GuidSIGN cannot find the 
panel style…” because the style file is not 
available to the program. ODOT GuidSIGN users 
can find the older panel styles via the shortcut 
“Old 2009 GuidSIGN ODOT Panel Styles” in the 

Engineering desktop folder. Older ODOT 
panel styles are stored in the 
Old_ODOT_Panel_Styles folder below the 
yearly folder, with the standard panel styles. 
These panel style files have the prefix _2009_ 
(note the leading underscore character). Copy 
any older panel styles you want to use to the 
panel style folder on the F:\ drive e.g. 
F:\ODOT_DATA\GuidSIGN\Styles\2009. 
Even older MUTCD 2003 styles can be found in the adjacent 2003 folder.  

http://www.oregon.gov/ODOT/EAST/Documents/Engineering%20Software%20Request.oft
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Note: When you are using the Panel Styles command, your custom and Old ODOT 
GuidSIGN panel styles are stored on the F:\ drive will have the tool icon in front of the 
file name as shown. 

 

Consultants can find the older panel styles in the local workspace which is typically located at 
C:\ProgramData\odot_space\Standards\data\GuidSIGN\Styles\2009\Old_OD

OT_Panel_Styles. 

GuidSIGN Toolbar 

GuidSIGN Templates and Export on the toolbar are not used. To save screen space, you can hide 
these icons; right click on the icon and uncheck the tool from the list. 

Style Locks 

GuidSIGN 6 provides horizontal and vertical locks for panel styles.  Horizontal locks snap to a left, 
center or right justification instead of just a single locked location. You will want to be careful that 
the text and legends are placed at the correct justification. Vertical locks allow text and legends to 
be placed at a top, center or bottom justification instead of a single locked location. The difference 
can be small as shown by the examples below: 

Top Snap  

Center Snap  

Bottom Snap  

You can use the Move Multiple Objects tool to correct a misplaced object. It also snaps to multiple 
lock locations like placing objects. 

 
Tip! For more information about how locks in GuidSIGN 6 work, contact the Sign Design 
Specialist at the ODOT Technical Leadership Center. 

InRoads SS2 Lite 

InRoads SS2 Lite is a version of InRoads V8i SS2 launched on demand within MicroStation from the 
ODOT menu, rather than from the InRoads desktop shortcut. InRoads SS2 Lite is provided as a 
convenience for simpler tasks. InRoads SS2 Lite does not load all of the tools such as Roundabouts, 
Data Acquisition and Civil Geometry. These tools are available when you use the InRoads desktop 
shortcut to launch InRoads V8i SS2. 
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gINT Civil Tools 

gINT Civil Tools is activated only after launching InRoads V8i SS2 or InRoads SS2 Lite.   gINT Civil 
Tools can be used to extract information from a gINT database and uses a loaded InRoads alignment 
to allow placement of borehole locations in plan view.  Borehole profiles and cross sections can also 
be placed in InRoads profiles and cross sections.  Methods are described in a separate user guide on 
the EAST website in the MicroStation Drafting | Geology category of the Tips & Workflows – “Draw 
and Pattern Boreholes in Plan, Profile, and Cross Section using gINT Civil Tools”. 

https://www.oregon.gov/ODOT/CS/east/Pages/TipsAndWorkflows.aspx
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MDL Applications 
You can load add-on applications written in MicroStation Development Language (MDL). 

 
Tip! The ODOT mdl is required for many drafting tools including the Bubble tools and Leader 
macros. If you have launched InRoads from a desktop shortcut instead of from MicroStation, 
you will receive errors and those commands will not run. 

“Unknown key-in or command” or “Execution failed at line 168. Error: 1702” 

To resolve this, exit InRoads, and then launch just MicroStation, and if you need InRoads, 
launch it from within MicroStation using ODOT>InRoads SS2 Lite.  

Alternatively, you can leave InRoads running, use a key-in and assign it to a function key. Key 

in: mdl load odot.  

Loading an MDL application 

1. On the main menu, select Utilities > MDL Applications  
or  
Key-in mdl load. This opens the MDL dialog. 

  

2. In the Available Applications list, select the MDL to load.  
The Available Applications list includes both standard MDLs bundled with MicroStation 
and MDLs in the ODOT Workspace. 

3. Click Load.  

Assigning an MDL application to a function key 

1. Click Workspace> Function Keys… 
This opens the Function Keys dialog. 

2. Either: Select the function key (or key combination) from the list 
or… 
Select the checkboxes for the key or key combination. 
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3. In the Action field, enter “mdl load” followed by the application name.   

For example:  mdl load atool 

4. Click [OK]. 

MDL Application Descriptions 

Atool (Area Tool) 

File: (Workspace)\V8i\Standards\mdlapps\intelnt\Atool.ma  

Description: Enables you to identify, trace or place areas, and measure them. The Atool 
toolbar/dialog offers four icons that measure and label areas. The measurements can be scaled so 
that areas are labeled in acres instead of square feet. 

You can place the resulting area measurements as text on the drawings. 

Loading the Tool  

To load Atool, key in mdl load atool in the MicroStation command window. For your own 

convenience you can assign this key-in to a function key Workspace > Function Keys… so you can 
quickly load it. 

Setting Text Parameters  

The Area tools Text tab parameters control the area labels that are placed. There are parameters for 
level, color, font, weight and text size. When the checkbox for Match Element Symbology is checked 
the label symbology will be the same as the shape measured, unless Level, Color, and Weight boxes 
are selected as well.  

Normally Atool will prompt the user to locate were the text label should be placed. If Place Text 
Automatically at Center is checked the text will be placed at the center of the area automatically. 

 
Tip! For more information about using the Atool, see the article Measure and Annotate 
Areas (Acreage) with Atool on the EAST website. 

Cellcounter (Cell Counter) 

File: (Workspace)\V8i\Standards\mdlapps\intelnt\Cellcounter.ma  

Description: Scans the DGN file for cells and produces a report listing Cell Name, Description, and 
the Count. 

Celltool (Cell Tool) 

File: (Workspace)\V8i\Standards\mdlapps\intelnt\Celltool.ma  

Description: Provides you with the ability to: 

 Place Active Cell with an interactive rotation angle. 

 Place Active Cell on a selected element with interactive rotation angle. 

 Place Active Cell on an element by partial deleting the target element to fit the cell. 

https://www.oregon.gov/ODOT/EAST/Documents/MDL-Atool-Measuring_Acreage.pdf#page=1
https://www.oregon.gov/ODOT/EAST/Documents/MDL-Atool-Measuring_Acreage.pdf#page=1
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 Place multiple copies of the active cell along or offset from a selected element at a given 
distance between each copy. 

Cellutil (Cell Utility) 

File: (Workspace)\V8i\Standards\mdlapps\intelnt\cellutil.ma  

Description: Allows you to group cells in a grid to be placed in a design file. You can plot the grid to create 
a book of the cells. The dialog now displays the modification time date stamp of the Model or cell. 

Civtools (Civil Tools) 

File: (Workspace)\V8i\Standards\mdlapps\intelnt\civtools.ma  

Description: Designed for Civil/Site users. Opens a palette that allows you to: place, label and 
modify 3D linestrings as contours; set element elevations; place coordinates and marker elevations; 
and set level, symbology and size of all elements placed with civtools.ma. 

HSP – Highway Spiral 

File: (Workspace)\V8i\Standards\mdlapps\intelnt\hsp.ma  

Description: Places a clothoid spiral with inputs of beginning and ending radii and length; result is a 
curve with 64 vertices. This is a counterpoint to MicroStation's onboard Place Spiral: Clothoid on the 
Create Curves toolbar that uses initial and final degree of curve to create a B-spline curve with 4 poles. 

InfoSnap 

File: (Workspace)\V8i\Standards\mdlapps\intelnt\infosnap.ma  

Description: Provides element information in a banner next to the cursor.  

Includes the Abilities to: 

 Make those attributes active and reuse them for new element 

 Gain full control over AccuSnap's balloon.  

 Navigate across reference files and DGN models. 

 Hide or shrink (and expand) MicroStation dialog boxes on cursor flyover 

The Bubble/Place Note tools  

The “bubble” or Place Note tools draw bubbles for: 

 Roadway Plans 

 Illumination 

 ITS (Intelligent Transportation Systems) 

 Signals 

 Signing 

 Striping plans 

Bubble tools are typically launched from an ODOT discipline workflow, but may also be launched 
using the Key-in toolbar. 

Bubbles can be drawn with or without a leader line as shown in the examples below. 
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The bubbles are orphan (no name) cells. The active scale is automatically set based on the 
annotation scale that is set for the model. Legend text and leader lines are separate from the cell, 
but are included in the same graphics group. Each tool has a help button that opens a web page to 
the current help documentation for each tool. 

The Signals and Striping bubble tools have predesigned bubbles and legend text. These are selected 
on the Note Type, Category and Note drop-down menus. 

  

 

  

Table 7. Bubble Tool Keyin and Workflow Location 

Bubble Type Keyin Workflow 

Roadway Plans place notes fdplans Roadway > Notes > Bubble Notes 

Illumination place notes illumination Traffic > Illumination > Bubble/Notes 

ITS place notes its Traffic > ITS > Bubble Notes 

Signals place notes signals Traffic > Signal > Signal Plans > Bubble Notes 

Signing place notes signing Traffic > Signing > Sheets >Hex and Hex with Leader 

Striping place notes striping Traffic > Striping > Striping Notes > Bubble Notes 
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Macros and Other Tools 
Macro tools written in MicroStation Basic are available to use. Most of the macros are called by the 
tasks and workflows, so it may be only seldom that you need to load a macro using Macros dialog or 
the Key-in toolbar.    

Loading BASIC Macros 

1. Select Utilities > Macros > MicroStation BASIC from the main menu.   
The Macros dialog opens.  

  

2. Select the macro to load from the Macro Name list and click [Run]. 

Activating BASIC Macros 

To activate a BASIC macro via function key or key-in, enter macro and the application name; for 

example: macro modz. 

 

MicroStation BASIC Macros in the ODOT Workspace 

AnchorM 

Description: Places a guy line with an anchor. 

Location:  Several ODOT Tasks place a pole anchor. 

Steps to Use:  

1. Use the Cell Library dialog to select a cell for [Placement] to be the anchor. 

2. Activate the macro. 

3. Left-click in the active view to start the guy line.  
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4. Left-click to end the guy line and place the anchor cell. 

CkLev 

Description: Check Level 

Location: Not used in ODOT Tasks. 

Steps to Use: 

1. Activate macro. 

2. Key-in the number of the level to display (e.g., For P_RDWY_ALIGN_Main, key-in 348). 

3. Left-click to show the next higher level number or key-in another level number. 

4. Right-click to exit. 

Cleanup 

Description: Restores state after another macro runs. Restores settings saved by the setup macro. 

Location:  Called by most macros at exit; not intended to be used directly. 

CtlPntEd 

Description: Changes the text of a PI station flag generated by InRoads to match the ODOT standard. 

Location: Not used in ODOT Tasks. 

Steps to Use: 

1. Place PI station flag with InRoads Horizontal Annotation with RW or Survey preference. 

2. Activate macro.  

3. Left-click on the PI text.  

4. Left-click again to accept.  

5. Right-click to exit. 

Emb 

Description: Places an embankment line on earthwork diagrams for profile sheets and places text 
centered below the line. 

Location: ODOT Tasks>Roadway>Profiles>Earthwork Brackets>Embankment 

Steps to Use: 

1. Activate macro.  

2. Left-click to begin embankment line. 

3. Left-click to end line.  

4. Enter the text.  

5. Macro repeats.  

6. Right-click to exit. 
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Exc 

Description: Places an excavation line on earthwork diagrams for profile sheets and places text 
centered below the line. 

Location: ODOT Tasks>Roadway>Profiles>Earthwork Brackets>Excavation 

Steps to Use: 

1. Activate macro.  

2. Left-click to begin excavation line. 

3.  Left-click to end line.  

4. Enter the text.  

5. Macro repeats.  

6. Right-click to exit. 

Leader1b 

Description: Places a curved leader line with an arrowhead at one end.  
Note: arc radius is scaled by the active scale factor. 

Location: Location: ODOT Tasks>Roadway>General>General Arrows 

Steps to Use: 

1. Activate macro without or with options – 

o leader1b gives arc radius = active text height 
o leader1b /f gives 10’ arc radius 
o leader1b /v gives 130’ arc radius 
o leader1b /r=N gives N’ arc radius 
o leader1b /L gives sharp vertex and Project Limit Arrow.   

2. Choose the type of arrow.  

3. Left-click to place tail of leader line. 

4. Left-click to place the angle point.  

5. Left-click to place the arrow head.  

6. Macro repeats. 

7. Right-click to exit. 

Leader2 

Description: Places a leader line with arrowheads at both ends. 

Location: ODOT Tasks>Survey>Cadastral>Misc>Survey Double Headed Arrow 

Steps to Use: 

1. Activate macro. 

2.  Choose the type of arrow. 
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3. Left-click to place one end of the leader line. 

4. Left-click to place the other end of the leader line. 

5. Macro repeats.  

6. Right-click to exit.  

LWidth0 

Description: Sets the custom line style width to zero. 

Location: Used in many commands in ODOT Tasks; not intended to be used directly. 

LWidthOff 

Description: Turns the custom line style width off. 

Location:  Not used in ODOT Tasks; not intended to be used directly. 

ModClass 

Description: Toggles an element's class between PRIMARY and CONSTRUCT modes. 

Location:  Not used in ODOT Tasks. 

Steps to Use: 

1. Activate macro.  

2. Left-click to select an element. Element’s current class is shown in the status area.  

3. Left-click to toggle the class or right-click to continue without toggling the class.  

4. Macro repeats.  

5. Right-click to exit. 

Modz 

Description: Modifies the Z values of all vertices of an element. 

Location: ODOT Tasks>Roadway>General>Tools>Modify Elevation 

Steps to Use: 

1. Activate macro. 
2. Enter the new Z value. 
3. If there are… 

 …selected elements or an active fence:  

 click [Yes] to change the Z value of all selected or fenced elements 

 click [No] to manually select elements 

 click [Cancel] to quit – command exits after the change is made.  

… no elements selected and no active fence:  

 click [OK] to select elements one at a time or [Cancel] to quit. 

 Left-click to select each element and change its Z value.   

 Command repeats – click [OK] to change another element or [Cancel] to quit. 
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North 

Description: Places a north arrow (odot.cel, Arrow), that automatically rotates to point north 
regardless of view rotation. 

Location: Not used in ODOT Tasks. 

Steps to Use: 

1. Activate macro.  

2. Left-click to place the north arrow.   

3. Macro repeats.  

4. Right-click to exit. 

RWcir 

Description: Places Subdivision Block Number, Parcel Number or Access Point Symbol with a leader 
line. 
Locations: ODOT Tasks>Survey>Cadastral>Proposed R/W>Misc>File Parcel Number and Access 
Point Symbol; ODOT Tasks>Survey>Cadastral>Properties>Subdivision Block Number 

Steps to Use: 

1. Activate macro.   
If leader - Left-click on an element to place the end of the leader line;  
symbol will be rotated to match the element’s rotation.  

2. Type <Ctrl>+E to add a vertex to the leader if desired. 

3. Left-click to place the vertex. 

4. Block and Parcel Number or Symbol - Left-click to place the symbol.   

5. Macro repeats.  

6. Right-click to exit. 

SecCor 

Description: Places section corner monument with section numbers. 

Location: ODOT Tasks>Survey>Cadastral>Monuments>Found Section Corner 

Steps to Use: 

1. Activate macro.   

2. Enter upper-right section number.  

3. Left-click to place cell. Remaining section numbers are automatically filled in.  

4. Macro repeats.  

5. Click [Cancel] to exit. 
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SetTxScl 

Description: Scales text width, height and line spacing by the active scale. 

Location: Used in many commands in ODOT Tasks; not intended to be used directly 

Setup 

Description: Saves current settings, gathers information and checks scale 

Location:  Called by every macro at startup; not intended to be used directly 

SlabE 

Description: Places a slope label given any two points and a vertical exaggeration factor.  Uses three 
possible switches to vary: snap mode, vertical exaggeration (of profile), or set decimal format 

 Key-ins: macro slabe [/k or /n] [/d or /f or /t or /v] [/x] 

 Snap modes: /k – keypoint or /n – nearest 

 Exaggeration: /d – none or /f – 5 or /t – 10 or /vN – N (any number) 

 Format:  /x – decimal 

Location: Not used in ODOT Tasks. 

Steps to Use: 

1. Activate macro. If switches not specified, macro dialogs open to request snap mode and 
exaggeration input. 

2. Enter snap mode and exaggeration input and click [OK].  

3. Left-click on line to be measured. (Note: Type <Ctrl + E> before selecting the first point 
on a line to change the vertical exaggeration). 

4. Left-click again on another part of the line. The slope between the two points is 
displayed in a text dialog.  

5. Type <Ctrl + T> to toggle the slope format between ratio, decimal, and percentage.  

6. Left-click to place the text (uses active text settings) at the same slope as the line.  

7. Macro repeats.  

8. Right-click to Exit.  

TPDT Macros 

Description: Places traffic pattern shapes with patterns. 
Note: Uses annotation scale for pattern scale. 

Location:  Location: ODOT Tasks>Traffic>Traffic Control>TCP Patterning 
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o Place Patterned Shapes (TPDT) 
o Place Shapes for Future Patterning (TPDT /s) 
o Pattern Previously Placed Shapes (Tern.mvba) 

Turn Annotation Scale lock OFF prior to running TCP Patterning commands. 

Key-in:  macro tpdt [/s] (“/s” switch causes only the outline shape to be placed; shape can be 

patterned later using Tern mvba.) 

Steps to Use: 

1. Activate macro (use appropriate switch).  

2. Select the pattern type from the dialog and click [OK].  

3. Left-click to draw a shape. When shape is closed the pattern is drawn.  

4. Continue to draw shapes, or right-click to return to pattern selection dialog.  

5. Click [Cancel] to exit. 
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Geographic Coordinate Systems 
A geographic coordinate system (GCS) is a method for uniquely defining a location on the earth. The 
Oregon State Plane coordinate systems are examples of geographic coordinate systems. 

Many applications assign geographic coordinate systems (also known as projections) to the data 
that is related to a location in the world.   

 ArcGIS shapefiles include a file with a PRJ extension that contains information about the 
geographic coordinate system and the units in which the features are displayed. 

 Various types of raster imagery (JPEG, GEOTIFF, TIFF) may either include the geographic 
coordinate information within the raster header information, or in a sister or world file text 
file. 

MicroStation “On-the-Fly” Projection 

MicroStation V8i can project data with assigned coordinate systems (such as shape files and raster 
imagery) into the same geographic coordinate system assigned to the vector data. You may hear 
people refer to this as “on the fly projection.”  For this functionality to work, you must assign a 
geographic coordinate system to the model containing the MicroStation vector data.  The surveyors 
for the project can provide information about the correct geographic coordinate system to use.  Not 
all raster imagery includes geographic coordinate system information, so you may still need to 
manually copy, move and rotate the raster data to align with your vector data.   

 
Note: In MicroStation V8i, the geographic coordinate system is assigned to a model.  This 
means you could have several different geographic coordinate systems in one MicroStation 
DGN file.  Also, if MicroStation has to project a large data set on the fly, it will impact how 
quickly the data refreshes as you pan and zoom.  You may find that it is better to save the 
data in the same geographic coordinate system as the vector data. 

Imperial Versus Metric Resolution 

The MicroStation seed files have an advanced resolution that is set to meters, but ODOT sets the 
file’s master and sub units to feet and inches. Do not change the settings of the advanced resolution 
because it will change the distance between elements in the file if it is not done correctly.  The 
geographic coordinate systems in the ODOT_Favorites library are set up with units set to metric to 
match the units of resolution in most ODOT seed files.   

The OR83_SSCGIS geographic coordinate system is set up with units of international foot because 
you will typically be setting it for raster or shape files that were created with foot units. 

Assigning Geographic Coordinate System 

The ability to select or assign a geographic coordinate system enables you to bring data together 
from disparate sources. 
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To assign or select a geographic coordinate system: 

1. Open Tools > Geographic > Select Geographic Coordinate System. 

 

 
Note: If you select Open as Toolbox, the Geographic toolbox opens. Click the Select 
Geographic Coordinate System icon. 

The Geographic Coordinate System toolbox opens and displays the current system set in the 
model. 

 
 

2. Click the Geographic Coordinate Systems Library icon ( ).  
The Select Geographic Coordinate System window opens, from which you can access a 
library of geographic coordinate systems.  
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3. Select the geographic coordinate system that matches your vector data and click [Ok]. 

 

 
Note: If the geographic coordinate system is already set in another file (such as a 

basemap provided by a surveyor), click the From File  icon in the Geographic 
Coordinate System toolbox to open the “Select Geographic Coordinate System Source” 
dialog to select the file and set the coordinate system. 
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Oregon Coordinate Reference System (OCRS) 

ODOT has developed a series of low-distortion map projection coordinate reference systems.  You 
can find the details about these on the ODOT Engineering Automation website at: 

https://www.oregon.gov/ODOT/ETA/Pages/OCRS.aspx 

ODOT_Favorites Geographic Coordinate Systems 

You can also find Oregon geographic coordinate reference systems typically used for datasets in a 
custom library called ODOT_Favorites. The naming conventions are: 

 Oregon Coordinate Reference System: OCRS_* 

 Oregon State Plane Zones, North and South with NAD83 datum: OR83_* 

 Oregon State Plane Zones, North and South with the HARN datum: ORHP_* 

 Oregon GIS Coordinate System designed for coverage of the entire state: OR83_SSCGIS* 

 Universal Transverse Mercator Projections that cover Oregon: UTM84* 

 

You can access other geographic coordinate reference systems in the MicroStation-provided library. 

 
Note: You can create custom geographic coordinate systems using MicroStation. For a 
geographic coordinate system that is not available in ODOT_Favorites or the Library, 
contact the Engineering Applications Support Team (EAST) for assistance.  

Once a geographic coordinate system is assigned to a model, the latitude and longitude can be 
displayed within MicroStation. 

https://www.oregon.gov/ODOT/ETA/Pages/OCRS.aspx
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To display the latitude and longitude: 

1. Select Tools > Coordinate System > ACS > Auxiliary Coordinates. 

2. Select (double-click) the Geographic Coordinate System in the Auxiliary Coordinates 
dialog.  It should appear below the line. 

3. Close the dialog box. 

4. Right-click in the status bar area of the MicroStation interface (where the active level, 
locks, and snaps are shown) and select Running Coordinates. 

5. Left-click on the Running Coordinates and select the ACS Position Option. 

 

The running coordinates at the bottom reflect latitude and longitude values.  The AccuDraw 
dialog displays the x, y and z coordinates. 



ODOT MicroStation® V8i SS4 User Guide 

November 2018 Oregon Department of Transportation 115 
Engineering Applications Support Team 
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Raster and GIS Files  
Raster data, including aerial photography and GIS data, is available from a variety of sources. It’s 
important you understand the raster and GIS data that you gather from others and use the 
information appropriately. Information you will want to gather before viewing the raster and GIS 
files includes: 

 Geographic coordinate system for the data 

 Units of measure  

 Accuracy 

 Use restrictions 

Displaying Raster Images 

The ODOT GIS Unit maintains raster imagery on the following server: 

 \\GIS_resources\gis\IMAGES in Salem 

Imagery is available in a wide variety of formats in different projections on this server.  Aerial 
photography, USGS scanned topographic maps (DRGs for Digital Raster Graphics), USGS orthophoto 
quads (DOQs), and USGS digital elevation models (DEMs) are available. 

Data in the gis\IMAGES folder includes:  

 Bypass_images 

 Climate 

 Color_IR 

 County_aerial 

 DOQs_00 

 DOQs_05_NAIP_UTM 

 DOQs_95 

 DRG100K 

 DRG250K 

 DRGs 

 ESRI 

 GRID_from10mDEM 

 Hillshade 

 Image_Servers 

 Land_Cover 

 LANDSAT 

 Misc_images 

 NAIP_CCM_2009 

 Relief_Images 

 Scnd_img 

 Urban_other 

 

  

file://///GIS_resources/gis/IMAGES
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Oregon Explorer 

The Oregon Explorer is an imagery portal (https://oregonexplorer.info/). You can use it to either 
stream imagery or to download imagery as defined by the end user.  You can define the imagery 
format, the geographic coordinate system and the extents. 

 

To stream the imagery data from within MicroStation: 

1. Assign a geographic coordinate system to the model in which you will view the image. 

2. Open the Raster Manager dialog.  

3.  Select File > New > WMS from the main menu. 

4. Paste the following URL in the Servers field at the top of the WMS Map Editor dialog, 
then press <Enter>: 
http://navigator.state.or.us/arcgis/services/Framework/Imagery_Mosaic2009/ImageSer
ver/WMSServer. 

5. From the Available Layers box (left-hand side), select Imagery_Mosaic2009 

6. Click the [Add to Map] button below the available layer. 

7. Choose Save and Attach 

https://oregonexplorer.info/
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8. Name the XWMS file and Save. 

9. Complete the attachment by following the prompts and dialog boxes from the Raster 
Manager. 

 

 
Note: The imagery is stored in the State GIS Service Center Geographic Coordinate system.  
If you are using a different coordinate system, then you must project the imagery to the 
coordinate system in the model.  Consider which data set will take the most effort to project 
when setting up your models and the referencing. 

To reduce the time it takes to manipulate and pan: 

1. Create a model for the streamed imagery. 

2. Set the geographic coordinate system to OR83_SSCGIS_NAD83 Oregon GIS, 
International Foot. 

3. Set the geographic coordinate system in the model with the vector data. 

4. Reference the vector data model in the streamed imagery model with the option to 
re-project. 

 

 
Warning!  Some WMS URLs have extra information that does not work with MicroStation.  A 
link such as 
http://imagery.oregonexplorer.info/arcgis/services/NAIP_2011/NAIP_2011_IR_SL/ImageServ
er/WMSServer?request=GetCapabilities&service=WMS 
should have the question mark and all text following it removed before using with 
MicroStation. Use the Notepad++ text editor to remove the extra characters from the WMS 
URLs so that they look as shown below: 
http://imagery.oregonexplorer.info/arcgis/services/NAIP_2011/NAIP_2011_IR_SL/ImageServ
er/WMSServer  
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Displaying .shp Files 

The ODOT GIS Unit maintains GIS Data on the following server: 

 \\GIS_resources\gis\DATA\shp in Salem 

MicroStation can read GIS data stored in shape file format.  The shape files are further subdivided by 
the type of information they contain.  The GIS Unit can provide more information or you can refer to 
their Data & Maps web page located at https://www.oregon.gov/ODOT/Data/Pages/index.aspx. 

The ODOT GIS Unit shapefiles are typically stored in the State GIS Service Center Geographic Coordinate 
System.  In MicroStation, this is listed as OR83_SSCGIS_NAD83 Oregon GIS, International Foot. 

 
Note: The shape files are stored in the State GIS Service Center Geographic Coordinate 
system.  If you are using a different coordinate system, then the data will need to be 
projected to the coordinate system in the model.  Consider which data set will take the 
most effort to project when setting up your models and the referencing. For example, if you 
are displaying contours within MicroStation and Wetland boundaries from a shapefile, it 
would be best to project the Wetland boundaries to the projection used for the contours. 

 

Although, ArcGIS Desktop is able to read DGN files, it only displays vector data stored in the default 
model, and it does not read the geographic coordinate system information associated with a model.  
If you are intending to load DGN data into ArcGIS, you should attach the OR83_SSCGIS_NAD83 
Geographic Coordinate System to the MicroStation design file first. 

file://///GIS_resources/gis/DATA/shp
https://www.oregon.gov/ODOT/Data/Pages/index.aspx
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User Customization  
You can customize your workspace by creating your own tools, toolboxes, tasks and workflows. 
Most of the user interface aspect can be modified to suit your own needs or preferences.  

You can customize any or all of the parts of your workspace, including: 

 Tools 

 Toolboxes 

 Tasks 

 Main tasks 

 Menus 

 Context menus 

 View pop-up menu 

 Tentative pop-up menu 

 Icons

Customizing Your Workspace 

To customize your workspace and make user interface changes, you must work directly in your DGN 
library (DGNLIB) file.  

Your personal custom DGNLIB is located on your Personal Server Share (F:\ drive) at 
YourServerName\Userseng\LogonID\ODOT_DATA\USERCFG\Interfaces\MicroSt

ation. The file name is LogonID.dgnlib where LogonID is your user Logon ID.  

Opening your DGNLIB File 

1. From within MicroStation V8i, select Workspace > Customize from the main menu.  

 
 
The Customize dialog opens. 
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2. From the list under the File menu, select the path to your logonID.dgnlib. 

 

This closes your active file and loads your LogonID.dgnlib file.  

You are now ready to create or customize your workspace. 

Creating New Customized Toolboxes and Tools 

You can create and customize new toolboxes and tools on the Tools tab of the Customize dialog. 

Creating a New Toolbox 

1. On the Tools tab, expand User Tools and select your LogonID.dgnlib file from the 
list of DGN libraries on the left side. The V8 icon is blue, indicating you can make 
changes to it.  

 

2. With your custom DGNLIB file selected, click the New Tool Box icon on the tool bar.  
New Tool Box appears beneath your DGNLIB file.  
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3. Select New Tool Box and enter a name for the toolbox.  

Creating a New Tool 

1. Click the New Tool icon on the tool bar.  
A new tool named New Tool appears beneath your new tool box.  

 
2. Select New Tool and enter a name for the tool.  

3. In the Properties panel at the bottom of the Customize dialog, you may build the 
functionality of the tool. Refer to the Help files within MicroStation for information on 
how to do this. 
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Copying Existing Tool Boxes and Tools 

You can create custom tool boxes and tools to fit your needs by copying and modifying standard 
MicroStation or DGN library tool boxes and tools on the Tools tab of the Customize dialog. You can 
copy entire tool boxes and tools from any DGNLIB file to your custom DGNLIB file, and then modify 
them.  

Copying an existing tool box or tool 

1. On the Tools tab, expand User Tools and select the DGNLIB file from which you want to 
copy a tool box or tool.  

2. Expand the DGNLIB file and select the tools or tool boxes you want to copy 

3. Copy the tools or toolboxes by one of the following methods: 

o Drag them to the desired location in your custom DGNLIB file, or 
o Copy the tools or toolboxes and paste them into your file 

In the Properties panel at the bottom of the Customize dialog, you may modify the functionality of 
the tool box or tool. Refer to the Help files within MicroStation for information on how to do this. 

Setting Custom Tool Boxes to Show in the Tool Menu 

After you create custom tool boxes, you can set them to appear in the Tool menu. 

1. Select Tools > Tool Boxes on the main menu. The Tool Boxes dialog opens. 

 

2. Scroll through the listed Tool Boxes/Frames until you find the tool box you created. 

3. Check the box in front of the tool box and click [OK].  

Like all tool boxes, you can dock any custom tool box on the edge of your MicroStation window. 

mk:@MSITStore:C:/Program%20Files%20(x86)/Bentley/MicroStation%20V8i%20(SELECTseries%203)/Documentation/MicroStation.chm::/ustnhelp331.html#P4EEC
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Creating Custom Tasks and Workflows 

You create custom tasks and workflows on the Customize dialog.  

 

To create a custom task or workflow: 

1. On the Customize dialog, click the down arrow on the Tasks bar to expand the Tasks 
panel.  

2. Under User Tasks, select your LogonID.dgnlib file.  

3. From the Tools tab, select a tool box, and then drag and drop it in your 

LogonID.dgnlib file in the Tasks panel. The toolbox becomes a task; any tools 
contained inside it are inside the task.  

4. If the task does not open, it may have to be opened with a keyin. Key-in the command 
tasktoolbox open [mytaskname] where “mytaskname”is the name of the task you 
created. 

 
Tip! A workflow is a task with the Treat Task as Workflow property set to True. One 
advantage to making tasks into workflows is that a workflow can contain many subtasks 
that show up in your panels where a task cannot. 

 
You may also customize Main Tasks, the Menu Bar, Context Menus, View Popup Menu and 
Tentative Popup Menu functions from the Customize dialog.  

For more information on creating tasks and workflows, or customizing your workspace, refer to 
vendor-provided training documents or the MicroStation Help files.  



ODOT MicroStation® V8i SS4 User Guide 

November 2018 Oregon Department of Transportation 125 
Engineering Applications Support Team 

Appendix A: How to Use the Serval Application 

Serval Function 

Serval provides a shortcut to a Visual Basic application that is contained in the engineering 
workspace. It enables you to connect to another user’s data space, ODOT_DATA\Projects, on a 
server. You do not need to know the server the data space resides on, nor the user’s PC name. 

Serval uses several other processes to combine attributes of employees, so that it is only necessary 
to know an employee’s last name.  The attributes are: full name, userID, homeshare (server), 
computer name, and computer description in Active Directory.  The processes that combine the 
attributes are run separately on a Ctrl-M server.  They automatically run at 6:30 a.m. each weekday.  
The results are replicated out to two text files in the engineering workspaces on 20 servers 
throughout the state. 

 
Note: Changes to computer descriptions and homeshare servers are not immediately seen in 
Serval, but are updated shortly after 6:30 a.m. the following weekday. 

Accessing Files From a User’s ODOT_Data\Projects Folder on a Server  

1. Open Serval (double-click on the Serval icon on the desktop). 

 

2. Select the Download files from … option. 

3. Select User Name from the drop-down menu. 

4. (Optional) Select a Map Drive. 

5. Click [Connect]. 

An Explorer window opens showing the other user’s ODOT_DATA server share folder.  
Retrieve the desired files using standard drag and drop. 

Accessing Files From a User’s Local PC:\Share Folder 

1. Open Serval (double-click on the Serval icon on the desktop). 
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2. Select the Connect to user’s PC:\share folder option. 

3. Select User Name from the drop-down menu. 

4. (Optional) Select a Map Drive. 

5. Click [Connect]. 

An Explorer window opens showing the other user’s c:\share folder.  Retrieve the desired 
files using standard drag and drop actions. 

Troubleshooting Serval 

Q:  Why isn’t my name and computer in the User Name list?  

A: The list is generated from the General Description in the Active Directory account.  Your 
computer account may have someone else’s name, Vacant or Crew Share listed as its 
description.  Vacant and Crew Share are filtered out from the drop-down list. 

Troubleshooting: 

Contact the Computer Support Desk, FSU Technician or Engineering Support personnel to 
correct this problem using Active Directory Users and Computers or Hyena.  It is not 
necessary to log on to the machine or even have it powered on.  Open the Properties dialog 
for the computer using either tool.  In Active Directory Users and Computers, on the 
General tab, enter Lastname, Firstname of the current user in the Description field.  In 
Hyena, on the Directory tab, enter Lastname, Firstname of the current user in the 
Description field.  

 
Tip! The browser comment (net view) can be updated using Hyena and the 
computer properties. The browser comment is on the General tab in Hyena; a 
computer needs to be powered on and connected to the network to edit this 
field. 

 

 Note: Serval does not use the browser comment. 

 

Q: Why do the names of people who no longer work for ODOT appear in Serval?  
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A: You may see a person’s server share (ODOT_DATA\Projects) folder because their files were 
not unshared when they left state service.  You may see a PC:\share folder associated with a 
person who is gone because the Active Directory account properties for the computer were 
not updated to Vacant or a new user status. 

Troubleshooting: 

Refer to the Troubleshooting for the prior question for a PC:\share folder still associated 
with a person who has left state service or changed crews.  Update the Description to 
Vacant if computer is not used.   

For a server share folder that is still seen or is in the wrong location, a common problem is 
that a Computer Security Delete User or Update User Request was never submitted for the 
person.  These names and user IDs can be submitted to Computer Security, but if a User 
Request was never submitted, the previous employee’s last known manager must rectify 
the situation. 

 



ODOT MicroStation® V8i SS4 User Guide 

128 Oregon Department of Transportation November 2018 
Engineering Applications Support Team 

Appendix B:  Working With Raster and GIS Data 

ODOT Tutorials 

A set of ODOT tutorial files are available for learning about how to select Geographic Coordinate 
Systems. Contact odot.east@odot.state.or.us to request the Raster and GIGS ODOT Tutorial files. 

Several different files are provided in the example set.  The files are from different sources, and 
different Geographic Coordinate Systems may be associated with each file. 

Table 8. Example Set Files 

Folder/File Name Source Format Projection Units 

DouglasCounty Douglas 
County 

SHP State Plane South International 
Feet 

GISU_CountyMap ODOT GISU DGN OGIC International 
Feet 

GISU_ShpFiles ODOT GISU SHP OGIC International 
Feet 

MetroImage Portland 
Metro 

TIF State Plane North  (SPC 
5076) 

International 
Feet 

OregonCoastOCRS Region 3 
Survey 

DGN OCRS Oregon Coast International 
Feet 

PortlandOCRS Region 1 
Survey 

DGN OCRS Portland International 
Feet 

CombinedFactor Region 3 
Survey 

DGN LDP International 
Feet 

 

Other files include: 

 OregonExplorer.xwms: Connection to Web Mapping Service (WMS) for raster imagery 
supplied by Oregon Explorer 

 Example_NoCoordSystem.dgn: Empty file with no coordinate system set 

 Example_SPN: Empty file set to State Plane North, NAD 83 and International Feet 

 

  

mailto:odot.east@odot.state.or.us
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Tutorial 1. Set DGN File to Project Reference Data “On the Fly” 

1. Open the file …\ODOTExampleData\Example_OCRSSalem.dgn. 

2. Select Tools > Geographic > Select Geographic Coordinate System and set the 
Geographic Coordinate System to OCRS Salem as follows. 

a. In the Geographic Coordinate System dialog top menu, click the second icon 
from the left (From Library). 

 

In the ODOT_Favorites folder, under the Library tab, are the Geographic Coordinate 
Systems set up for the Oregon Coordinate Reference System (OCRS) and other 
coordinate systems typically used at ODOT. 

b. Click OCRS_SLE – Salem Zone to review the Coordinate System parameters.  
(You won’t be able to edit them. If they appear wrong, contact the Engineering 
Applications Support Team.) 

 

c. Click [OK] to set up the .dgn file with the selected coordinate system.  
The Geographic Coordinate System dialog updates with the selected coordinate 
system. 
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d. Close the dialog. 

3. Open the Reference dialog and attach the shape files ... 

o \DouglasCounty\Township.shp 
o \GISU_ShpFiles\counties.shp  
o \GISU_ShpFiles\state.shp 

 
Note: Be sure to change Files of type to either All Files (*.*) or Shape Files (*.shp). 

4. In the Reference dialog Settings, change the Orientation View to “Geographic – 
Reprojected.” 

The Township.shp file from Douglas County appears within the Douglas County border. 

5. Add ... GISU_CountyMap\doug1.dgn file.  

The Orientation View option Geographic – Reprojected is not listed.  You will have to set up 
the Geographic Coordinate System so that MicroStation V8i recognizes it. 

a. Open the doug1.dgn file. 

b. Assign the Geographic Coordinate System titled OR83-SSCGIS – NAD83 Oregon 
GIS, International Foot from the ODOT_Favorites library. 

c. Save Settings. 

You can alternatively navigate through the folders to find it: Library > Projected (northing, 
easting, _) > North America > United States of America > Oregon 

6. Use the arrow in the lower left to return to the Example_OCRSSalem.dgn file. 

7. Reference in the DGN file ...\GISU_CountyMap\doug1.dgn.  
The Orientation View option Geographic – Reprojected is listed. Select it and when the 
reference file loads, it should line up with the shape files. 

8. To add DGN files surveyed in OCRS coordinates, set the Geographic Coordinate System 
in the files in order to use the Geographic – Reprojected view. 

9. Open up the file …\OregonCoastOCRS\EX_OregonCoastOCRS.dgn.   

10. From the ODOT_Seed library, select OCRS_ORC – Oregon Coast Zone and click [OK].   

11. Open the Example_OCRSSalem.dgn file, and reference in the 
...\OregonCoastOCRS\EX_OregonCoastOCRS.dgn file with the Orientation View set to 
Geographic – Reprojected.   
If the file is hard to see, turn off the display of doug1.dgn and zoom to it. 

----------------------------------------------  
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Tutorial 2. Reproject DGN File From One Coordinate System to 
Another 

 
Note: You cannot change units using this method, even if the dialogs suggest you can. 

You may wonder why you would want to do this since MicroStation will project on the fly.  
I’m not really sure why either, once everyone is using MicroStation V8i in ODOT.  

There are likely some glitches in how the reprojection technique works.  Take a look at 
what happens when you edit a text node, drop cells, or check to see if your leader lines 
and dimensions are exhibited correctly. 

 

1. Make a copy of the file 
...\ODOTExampleData\OregonCoastOCRS\EX_OregonCoastOCRS.dgn 
and rename it EX_OregonGIS.dgn. You’ll transform the file into this coordinate 
system. 

2. Open the file EX_OregonGIS.dgn. 

3. Select Tools>Geographic>Select Geographic Coordinate System.  

 
Note: The Geographic Coordinate System should already be set in this file as you 
set it in Tutorial 1. 

4. Click on the second icon from the left, From Library.  

5. Either: 

o In the ODOT_Favorites, click on OR38_SSCGIS and click [OK]. 
…or… 

o Navigate to the Coordinate System titled OR83-SSCGIS by selecting Library > 
Projected (northing, easting, _) > North America > United States of America > 
Oregon and click [OK].  

The Geographic Coordinate System Changed dialog opens. 

 
6. Select Reproject the data to the new Geographic Coordinate System and click [OK]. 
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7. The Current Geographic Coordinate System information in the Geographic Coordinate 
System dialog changes to reflect the Geographic Coordinate System now set in the file. 

 
8. Edit the file information to reflect that the coordinates are associated with a different 

Geographic Coordinate System. You could update the File Properties, add text in the 
title block area describing what you did, edit the existing text, by updating the table.   

9. Click the Remove the Coordinate System icon with the red X to verify that the 
coordinates really did change, and that the Geographic Coordinate System is not being 
used to “project on the fly” when you reference in another file drawn in the NAD83 
Oregon GIS, International Foot Geographic Coordinate System.   

 Note: In the future when you re-project files, you may skip this step. 

10. Click Save Settings. 

11. Reference the file ...\ODOTExampleData\GISU_CountyMap\doug1.dgn.   

12. Choose the Orientation Coincident – World view.  The files should match up. 

------------------------------------------- 
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Tutorial 3. View Geographic Coordinates (Latitude and Longitude) 

1. Open the file ...\ODOTExampleData\OregonCoastOCRS\EX_OregonCoastOCRS.dgn. 

2. Select Tools > Geographic > Select Geographic Coordinate System and confirm that the 
Geographic Coordinate System is set to OCRS Oregon Coast.   

3. Go to Tools > Coordinate Systems > ACS > Auxiliary Coordinate Systems.  
You should see two auxiliary coordinate systems (View 1:Unnamed and OCRS Oregon 
Coast).  

 
4. Double-click OCRS Oregon Coast to activate it, and then close the Auxiliary Coordinates 

dialog. 

5. Right-click in the status bar area of the MicroStation interface (where the active level, 
locks and snaps are shown) and select Running Coordinates. 

 
The running coordinates now show in the Status Bar section. 

6. Left-click on the Running Coordinates and select ACS Position from the pop-up menu. 

 
The message center displays “Tentative Point Mode – ACSLOCATE”.   
The AccuDraw dialog displays the x, y and z coordinates.   

------------------------------------------- 
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Tutorial 4. Set DGN File in LDP to Align with Data in Other 
Coordinate Systems 

1. Create a new file and call it 
...\ODOTExampleData\CombinedFactor\StatePlaneSouth.dgn. 

 
Note: This is an empty file into which you will reference a CAD file set up in an 
LDP.  Text in the file reports:  
“Basis of Bearing:  Oregon South Zone, NAD_83(91)  
Coordinates shown are LDP Coordinates.  
Vertical Datum based on VNAVD88 elevations 
To convert LDP Coordinates to SPC ORS, multiply LDP Coordinates by 
0.99987087. 

2. Select Tools>Geographic>Select Geographic Coordinate System to set the Geographic 
Coordinate System to match.   

a. Click the second icon from the left From Library. 

 
b. From the ODOT_Favorites Folder, select the Geographic Coordinate System 

listed as ORHP_S.  

c. Click [OK]. 

3. Add a text box in the file that describes the purpose of the file and the coordinate 
system with which it has been set up.  For example: 

“This file 15186E_SPS.dgn was assigned the Coordinate System Oregon South 

Zone, NAD_83(91) using MicroStation V8i SS4 for the purpose of demonstration. 

The file 15186E.dgn was referenced in at a scale of master(ref) of 1(0.99987087). 

You can reference this file into other files set up with a coordinate system.” 

4. Reference in the file ...\ODOTExampleData\CombinedFactor\15186E.dgn with: 

Orientation set to Coincident – World Global Origin Aligned with Master File  
Scale (Master: Ref): set to 0.99987087:1.  

 
Note: After the file is referenced in, MicroStation sets the Ref to 1 and the Master to 
the correct value. 

5. Merge the reference file into the master. 

6. Open the file ...\ODOTExampleData\EX_OregonCoastOCRS.dgn. 

7. Reference in the file you just created 
...\ODOTExampleData\CombinedFactor\StatePlaneSouth.dgn with the Orientation set 
to Geographical - Reprojected. 
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8. Confirm that the reference file appears in the correct location relative to the other 
reference files. 

------------------------------------------------------------ 
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Tutorial 5. Raster Imagery  

It helps to know something about the coordinate systems and the imagery, before you get started.  
Open the XML files associated with the images to review information about the image including 
coordinate system and unit details. Below are the basics. 

2s1w10u.tif 

There is a sister file (with the TFW extension), but you need to know the units for the file. The XML 
file contains information about how the file was created. It states that the image units are 
international feet. 

horizsys> -<planar> -<gridsys> <gridsysn>State plane coordinate system 1983.</gridsysn> -<spcs> 
<spcszone>5076</spcszone> </spcs> </gridsys> -<planci> <plance/> <plandu>International 
feet</plandu> </planci> </planar> -<geodetic> <horizdn>North American Datum of 1983/1991 
(HPGN)</horizdn> 

Multnomah.sid 

This file also has a sister file (SDW), and an XML file, which reports units are set to meter.  

The XML file says: 

<SRS>PROJCS["UTM Zone 10, Northern 
Hemisphere",GEOGCS["NAD83",DATUM["North_American_Datum_1983",SPHEROID["GRS 
1980",6378137,298.257222101,AUTHORITY["EPSG","7019"]],TOWGS84[0,0,0,0,0,0,0],AUTHORITY["
EPSG","6269"]],PRIMEM["Greenwich",0,AUTHORITY["EPSG","8901"]],UNIT["degree",0.01745329251
99433,AUTHORITY["EPSG","9108"]],AXIS["Lat",NORTH],AXIS["Long",EAST],AUTHORITY["EPSG","426
9"]],PROJECTION["Transverse_Mercator"],PARAMETER["latitude_of_origin",0],PARAMETER["central
_meridian",-
123],PARAMETER["scale_factor",0.9996],PARAMETER["false_easting",500000],PARAMETER["false_
northing",0],UNIT["Meter",1],AUTHORITY["EPSG","26910"]]</SRS> <GeoTransform> 
5.0455100000000000e+005, 1.0000000000000000e+000, 0.0000000000000000e+000, 
5.0666120000000000e+006, 0.0000000000000000e+000,-
1.0000000000000000e+000</GeoTransform> -<Metadata> <MDI 
key="GEOTIFF_CHAR__GTModelTypeGeoKey">ModelTypeProjected</MDI> <MDI 
key="GEOTIFF_CHAR__GTRasterTypeGeoKey">RasterPixelIsArea</MDI> <MDI 
key="GEOTIFF_CHAR__ProjLinearUnitsGeoKey">Linear_Meter</MDI> <MDI 
key="GEOTIFF_CHAR__ProjectedCSTypeGeoKey">PCS_NAD83_UTM_zone_10N</MDI> <MDI 
key="GEOTIFF_NUM__1024__GTModelTypeGeoKey">1</MDI> <MDI 
key="GEOTIFF_NUM__1025__GTRasterTypeGeoKey">1</MDI> <MDI 
key="GEOTIFF_NUM__1026__GTCitationGeoKey">IMAGINE GeoTIFF Support 

EX_PortlandOCRSrw_set.dgn 

Preferences affect how raster files open in MicroStation V8i. It helps if you know something about 
the raster data that you want to view. 

Open Files and set Raster Manager Preferences 

1. Open the file ...\EX_PortlandOCRSrw_set.dgn.  The coordinate system has already been 
set in this file.  Shape files have been referenced in to provide a frame of reference. 



ODOT MicroStation® V8i SS4 User Guide 

November 2018 Oregon Department of Transportation 137 
Engineering Applications Support Team 

2. Reference in a .tif file from Portland Metro.  The “sister file” with a .tfw extension is 
associated with it, and the units are set to international feet.  To set the Preferences 
correctly, select Workspace > Preferences and the category Raster Manager.   

3. Set your settings as shown below.  

 

Attach the Raster File 

4. Open Raster Manager and choose File > Attach > Raster. 

 
5. Navigate to the file 2s1w10u.tif and click [Open]. 

6. In the Raster Attachment Options dialog, expand the Geometry category. 

7. Change the Geo Priority option to Sister File. 
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8. Click [Attach]. 

9. In Raster Manager, right-click on the file and choose Coordinate System > Select from 
library. 

10. Choose ORHP-NIF – HARN (HPGN) Oregon State Planes, North Zone, International Foot.  
Add it to your favorites if you typically use raster files provided by Portland Metro. 

11. Select Fit View and zoom in to compare the vector data to the raster data.  They should 
match up fairly close without needing to rotate, move or scale the raster image. 

12. Add a large MrSID image by detaching all of the images to make things display more 
quickly.  Change the Preferences for Raster Manager again as shown below: 
 

 

13. In the Attachment setting, change GeoPriority to Sister File, and change Inherit GeoCS 
from Model to Not Inherited; it should line up with Multnomah county boundaries.  

14. Right-click on the file in Raster and select Geographic Coordinate System. 
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Note: During the time that the imagery is being reprojected, it may take a while to 
display as you zoom in and out. 

15. Detach the raster references again. 

Try a Web Mapping Service (WMS)   

This one is from the Oregon Explorer portal that is located at OSU.  The parameters are set in a file 
titled OregonExplorer.xwms.   

1. In the Raster Manager dialog, select File > Attach > WMS and navigate to 
...ODOTExampleData\OregonExplorer.xwms.   

2. Select the file and click Open. It defaults to Raster Header. 

3. Choose the defaults and click Attach. Wait for the image to appear.   

 Note: If you are working on a very slow network, this may not work. 

4. When the image appears, right-click on OregonExplorer.xwms and select Edit WMS to 
determine the coordinate system for the web mapping service.   

 

5. Click [Save] (or Cancel). 

6. Right-click on OregonExplorer.xwms in the Raster Manager dialog and select Coordinate 
System > Select from Library. 

7. Select Library > Projected (northing, easting, …) > North America > United States of 
America > Oregon and select the coordinate system with a name similar to EPSG:2992.  

 
Note: You may want to add it to your favorites. 
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------------------------------------------------ 
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Appendix C: Placing Special Characters and Fractions in 
MicroStation V8i 

Special Characters and Fractions in ODOT Fonts 

ODOT fonts have the ability to place special characters that may be required by the different 
disciplines. Starting with the MicroStation V8i, special characters are displayed with the Word 
Processor Text Editor. For people who use a Text Editor Style of Dialog Box, each letter is remapped 
to the special character when the text block is placed into the file.  

Two preferred ways to place special characters are: 

 Using a keyboard remapping -where a key symbol on your keyboard places a different 
symbol in the text block 

OR 

 Using %% to indicate that the letter that follows is placed as a special character 

Table 9. Special Characters in ODOT Fonts 

Font Number Special Character Type Description of Type 

24-33-34-2 Squared (superscripted 2) %%2 or \2 Percent percent 2 

24-33-34-2 Cubed (superscripted 3) %%3 or \3 Percent percent 3 

24-33-34-2 Degree        %%d or ^ Percent percent d or Caret 

24-33-34 Angle Point      } Right curly bracket 

24-33-34 Delta              < “less than” symbol 

24-33-34 Centerline      { Left curly bracket 

24-33-34 Bridge Plate      \ Back slash 

24-33-34 Plus or Minus        | Pipe (<shift+back slash>) 

24 Diameter       ` Accent grave (upmost left key) 

Special Characters and Fractions in TrueType Fonts 

As of October 2016, ODOT uses the TrueType font Lucida Sans Unicode instead of ODOT fonts 2 
(vertical) and 24 (slant), although these are still available (see below). The use of a TrueType font 
allows the delivery of “Symbol Favorites” for most of the special characters that ODOT uses; only the 
Bridge Plate symbol (overlapping P and L) has not been retained from previous.  

The TrueType fonts have been incorporated into the ODOT text styles that previously used ODOT 
Vertical and ODOT Slant fonts. When you select a note or text item from an ODOT discipline task, 
the correct text style according to the CAD standards will be used. 

Table 10. Special Characters in TrueType Fonts 

Lucida Sans 
Unicode Symbol 

What you see in the 
Word Processor 

Description of Symbol 
*Keyboard 
entry 
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Squared X2 Superscripted 2 <Alt>+0178 

Cubed X3 Superscripted 3 <Alt>+0179 

Degree 90° or 90%%d Small superscripted circle <Alt>+0176 

Delta Δ Triangle meaning change  

Centerline ℄ C and L overlapped  

Plus or Minus        ± + stacked over - <Alt>+0177 

Diameter ø Circle with slash through it  

Greek letter Mu (micro) μ “u” with a leading tail <Alt>+0181 

 
*Keyboard entry:  Using TrueType font, to use the keystrokes, you must use the numeric key pad, press 

<Num Lock>:  
1. Place your cursor in the location in the Word Processor where you wish to insert a special character.  
2. While pressing down the <Alt> key, type the four-digit code on the numeric key pad on the right side of the 
keyboard.  
3. Release the <Alt> key. The character will appear when the <Alt> key is released.  
NOTE: You must include the initial zero in the code.  
 

Symbols or special characters can be placed in the Text Editor – Word 
Processor, at the insertion point (cursor), by clicking on the drop-down menu 
to the right of the Insert Symbol icon, and then selecting the character.  
 

Items above the horizontal line are ODOT favorites; items below the line are 
recently used. 

Stacked Fractions 

Stacked fractions, with any denominator, may be placed in any font by surrounding the fraction with 
space characters. 

Example 1: 

 

NOTE: In the Text Editor, as you type the second space, a hash symbol 
appears between the numerator and denominator, and the characters all 
display gray. 

It becomes a stacked fraction once you left-click to place it: 

The space characters surrounding the stacked fraction are part of the special 
character, so if you want to have an actual space before or after the fraction, enter two spaces. 

Example 2: 

 

------------------------------------------- 
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Appendix D: PDF Layers 
County and City PDFs created by the ODOT Transportation Data GIS Unit have layers in a hierarchy 
of layer groups. Every item displayed on each map is assigned to a particular layer. The user may 
customize the display of the map in a PDF viewer by turning off layers or layer groups. 

To open the Layer Display dialog in MicroStation, select an attached PDF in the Raster Manager 
dialog and then select Utilities>Layers…. 

 

------------------------------------------- 
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Appendix E: Using MicroStation V8 2004 files in 
MicroStation V8i 
MicroStation V8 2004 files will open directly into MicroStation V8i without any conversion process. 
The file will look similar to what is expected with a few exceptions. The exceptions are caused by 
Annotation Scale.  

If early in the project phases, you may want to totally update your files to MicroStation V8i 
standards and adopt Annotation Scale. To do that, you will need to make several changes to the 
model properties as well as possible changes to the line style, text and cells in the model. 

Line Styles 

Any custom line style patterning will appear very small, such that the lines appear as single 
continuous lines. 

To correct the line styles: 

1. Open the Model Properties dialog. 

 
2. Select the Annotation Scale drop down and choose the appropriate scale (usually 1”=100’). 

 
3. From the Line Style Scale drop-down menu, select Annotation Scale. 
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4. Click OK.  

 
Note: Print borders placed with Plotypus in MicroStation V8 2004 will be found and presented 
for printing by the Print Organizer using ODOT print styles.  Once the line styles look correct, 
you will be able to print without placing fences. 

 

 
Note: You may have existing references to MicroStation V8 2004 files whose line styles do not 
display correctly. To correct this, edit the reference attachment settings by clicking on the 
Display Raster References icon at the bottom of the References dialog and then reopen the 
active file.  After reopening the active file, the referenced line styles will display correctly. 

5. Zoom Out or Fit the View. 
a. If very large text or cells are seen, use Edit > Undo to undo setting the model 

properties,  

b. then use Annotation Scale Select icon ( ) to select all of the text and cells in the 
model that have that Annotation Scale attribute set to True, 

c. finally, use Remove Annotation Scale icon ( ) to set the Annotation Scale 
attribute to False for the selection set, and perform steps 1 through 4 again before 
proceeding. 

 

Cells 

Cells placed from the custom ODOT tasks and workflows will appear too small. You may use 
different methods to correct the appearance of cells in the older 2004 file. The method chosen 
depends primarily on what use you have for the file. 
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Detach any old cell libraries to ensure that new cells placed in your file will be from the correct 
library and annotatable. 

To detach old cells: 

1. Select Elements > Cells from the MicroStation menu to open the Cell Library dialog. If the 
dialog is empty and the title bar indicates NONE, there are no old cells to detach. 

 

2. If a list of cells appears in the Cell Library dialog, and the title bar indicates a cell library is 
attached, select File > Detach. 
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3. In the Place Active Cell dialog, uncheck the Scale Annotations check box. 

 

4. Save the design file settings using File > Save Settings or Ctrl+F. 
5. Replace cells, if desired. If you placed cells in an old MicroStation V8 2004 file, they will not 

respond to Annotation Scale. You may either leave them (provided they were placed at the 
correct size) or update them with the new cells set up to respond to Annotation Scale.  

6. To update the cells, use the Replace Cells tool on the Cells Toolbox on the Drawing Task. 

 

7. Use Method Update and Mode Global. Select each cell used in the file and update it with 
the corresponding new cell. 

Text 

Issues with text may not be noticed until you try to place text from the ODOT Tasks and Workflows. 
Text placed from these tasks, invokes a text style with Annotation Scale enabled. This may cause 
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new text to be placed very small in a new file. There are a few different ways to correct the 
appearance of text in the older 2004 file. The method chosen depends primarily on what use you 
have for the file. 

Update text, if desired. Annotation Scale uses Text Styles. Several text styles respond to Annotation 
Scale. If desired, you can modify your text to match the correct text style. Use the Change Text 
Attributes tool in conjunction with selection sets to accomplish this. An alternate method might be 
to simply toggle on the Annotation Scale check box in the Change Text Attributes tool and not 
associate a style. 

 

------------------------------------------- 
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