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Initial CAiCE Training DTM Boundary and Export to InRoads

Purpose

In this tutorial we will demonstrate how to delete erroneous triangles, DTM points and DTM
breaklines on the DTM surface and to create a DTM boundary. A boundary chain may be used
by the designers to recreate the DTM surface in InRoads.

Concepts

One application could be in projects where data is collected through photogrammetric
means. What happens in these types of projects is that data is collected over a large area,
and some areas are impossible to get to such as underneath tree canopies and large areas
covered by trees. Surveyors then end up collecting data in those areas manually, which is
to be then merged into the DTM that was created from aerial data. The Save Boundary
command will allow saving a boundary chain from a DTM created by manual survey data,
and then use it to clip data out of the photogrammetric DTM and merge in the ground survey
data.

Another useful application of saving a boundary chain could be after a DTM has been
cleaned up with all unwanted DTM data removed and triangles obscured. This boundary
chain can then be saved for later use to obscure triangles outside the limits of it, in case a
DTM is ever rebuilt due to merging or clipping.

Steps

TO EDIT TRIANGLES IN CAICE:

Open CAICE.

Remember: When you Build Triangles the initial Model Boundary will automatically be
displayed. This can be redisplayed, at any time, from the main menu by selecting View >
DTM > Model Boundary.

Clear the active view window graphics by selecting the Clear View button or using the F8
key.

To View DTM Triangles from the main CAICE menu select View > DTM > Triangles.
Note: If you View > DTM > Surface you will not be able to edit any triangles.

To remove unwanted or erroneous triangles from your DTM surface; From the main CAICE
menu select DTM > Edit DTM Triangle Feature Codes.
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e Click on the picker control for the List Triangles field and select an appropriate Snap

option.
Edit DTM Triangles =]
— Triangles
- Snapl |
Ligt Triangles Ii J
] I Snapw |
Feature Code | [ —
b axirnurm G ap gicelhL ﬂl
Diztance | Snap Window SetCriteria |
Stap Eiange
—\ithin Chaing [ IR [
o Cloze Object List
Chair Lizt Snapl
[ " Inzert Gap —DI
Eramm atabase,.
_ﬂelp
= From Test File... -
Append Mode
" 554 -1 5h4.-1"
II"EEE-_-I "
" BE7 -1 .86E.-1"

e Snap on the erroneous triangles that occur in the DTM surface. The selected triangles are
then highlighted and listed in the List Triangle field.

o Enter OBSC in the Feature Code field. Feature Code defines the feature code to be
applied to the selected triangles. The CAICE reserved feature code OBSC is used to mark
triangles in obscured areas and effectively deletes these triangles from the surface.
Triangles with feature code OBSC are ignored in all DTM operations.

Edit DTHM Triangles

— Triangles

]|

Snapl
S hapia

Lizt Triangles I

=

Feature Code IEI BSC

bl asirnurn Gap

Digitize

Digtance

|1.un

SetCriteria

Chain List

—%ithin Chainz [azzignz Chain feature code]

Snapl

&pply I

Cloze |

Help

L

¢ Click on the Apply button to obscure the selected triangles.
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Initial CAiCE Training DTM Boundary and Export to InRoads

The Edit DTM Triangle Feature Codes procedure can be repeated, as necessary, until all
erroneous triangles have been obscured.

Close the dialog box.

Clear the active view window graphics by selecting the Clear View button or using the F8
key, then View > DTM > Triangles again. For the same results you could also use
View > Clear Selected Elements (if command is not grayed out).

Triangles can also be edited by using boundaries. From the main menu select
DTM > Apply Feature Codes to Triangles.

Apply Feature Codes To Triangles |

Default Feature Code for Surface

| |

— Objects [Lists, ar @<file-names]

Apply Features Tao Enclozed Triangles

| i

Breakline [Geametr Survey
Feature Codes Chairz Chairz

Obzcure Enclozed Trangles

| 5

Breakline = Clip Geometmy Survey
Feature Caodes File Chainz Chainz

Obszcure Outside Triangles

Breakline
Feature Code

Geometmy Survey
Chain Chait

[T apply To &l Active Sufaces

Cloze | Help |

e Select boundary.
e OK

e Close the dialog box.
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DTM Boundary and Export to InRoads Initial CAiCE Training

e Clear the active view window graphics by selecting the Clear View button or using the F8
key.

e View > DTM > Triangles again.

o To redisplay or see the Obscured Triangles again select DTM > Edit DTM Triangle Feature
Codes > SetCriteria

%]

Set Triangle Selection Criteria |

¥ Feature IUE 5C

[ Triangle Length < I

[ Trangle Length » I

[ Elewation < I

[ Elewation » I

% Choose triangle if all selected conditions are met

" Choose triangle if any of the selected conditions is met

ok | Eancell Help |

e OK will select the Triangles that have been Obscured to edit their features again so they can
be redisplayed.

e OK automatically creates a file named @kctemp.lis (that may be renamed and saved if you
wish) containing all your Triangles with the feature OBSC.

Edit DTM Triangles |

— Triangles
Lizt Triangles I@KETEMF’ J ﬂl
I J S hapia I
Feature Code

Digitize |

b aximum Gap |1 o J

Digtance

—%ithin Chainz [azzignz Chain feature code]

Chainlist | v Snapl |
Apply Dlose | Help |
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Initial CAiCE Training DTM Boundary and Export to InRoads

e You may also assign a Feature Code, e.g. TEMP, to the triangles. This will allow you to
view only those TEMP triangles for further editing if desired.

e Clear the active view window graphics by selecting the Clear View button or using the F8
key.

e If you assign a Feature Code, e.g. TEMP, to the triangles by entering TEMP in the Feature
Code field and you wish to view and edit only the TEMP triangles go to DTM > Edit DTM
Triangle Feature Codes > SetCriteria.

Set Tnangle Selection Critena

¥ Feature IT EMP

[ Trangle Length < I

[ Trangle Length » I

[" Elewation < I

[ Elewation > |

¥ Choose tiangle if all selected conditions are met

" Chooge tiangle if any of the selected conditions is met

ok Cancel | Help |

e OK
Edit DTM Triangles =]
— Triangles
Shapl
List Triangles I@KETEMF" J _DI
Snapt I
Feature Code ITEMF'I J Diigih
igitize: I
bl axirnurn Gap
Distance I-I 00 J SetCrtera I
—%fithin Chainzg [azzigns Chain Feature code]
Chainlist | v Snapl |
Apply I Cloge | Help |
e Apply
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TO SAVE A DTM BOUNDARY:

From the main menu select DTM > Save Boundary.

Check all the boxes.

Save DTM Boundary

DTM Surface Name [39933 |

]|

¥ Save To Clip File

File Marne: IE:'\LIS R“PROJECTS%3995549333981 .CLP J

¥ Save &z Survey Chain

M arne IKJ:1 P
Feature IBL J
Plalyl= ISEI J
Desc.  |TERRAIN BREAKLINE o

¥ Save &z Geometry Chain

Mame |KCI P
Feature |BL P
Lo ISEI J
Desc.  |TERRAIN BREAKLINE o

k. | | F'reviewl Cloze | Help |

Preview allows viewing of the DTM boundary on the screen.

OK

Close the dialog box.

Note: A clip boundary (.CLP) file can be used for clipping (DTM) points and (DTM)
breaklines from a DTM surface database. CAICE will not build triangles in these clipped
areas, but can build triangles across them. (These erroneous triangles will then have to be
edited as previously discussed.)

The CAICE clip boundary options are accessed from the main menu by:
DTM > DTM Clipping >
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Initial CAiCE Training DTM Boundary and Export to InRoads

[l CAICE - (C\USR\PROJECT 5193395\99999) - (Int. Feet) & [|SIEAIFIRlES]) . | dRalivab= 1Pk RS | i AL <I R EN e = TEANSTIBIRS] I ES
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A4 0DOT Tughoat  A4ASC to EFB.CTL Transfom DTM Surface -
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Fiefine Triangles Built fram Contours
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FCQ Apply Featurs Codes to Triangles
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O Build Contours

Build 30 Grid
281 Cut Freshand X-5 ection
,ﬂ Cut Freehand Profile

Build Breaklines File fram Geometry Chains

Build Breaklines File fram Survey Chains

Cieate Clipping Eoundary

§¥ Edit DTM Eaints Ciip Inside Boundary
D_) Edit DTM Breaklines Clip Outside Boundary

Dr"‘c‘ Edit DTM Triangle Feature Codes
Edit DTH Points and Breaklines

Surface Yolumes/dreas
Save Boundary
Save DT Points and Breaklines to SRV

o8 G

QR

CAP |NUM

Inbox-Micmso...|WMicrosoftWold..| @. 837 AM

:\ﬁ |T'-|E.Ail:E - [C:\...  Diskesper _JQ Exploring - C:hu. | @Visual FE Orlin..| g 99933.dgn (30...

fStant | | &

TO EXPORT CAICE DTM TO INROADS:

e File > Export Translators > To Inroads > DTM Surface to XYZ Format.
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Save DTM surface to Inroads XY2Z format - Save As |

Savein: | (i 99399

= & & =2 E

Kl

Lorre. dp! Lorre. I ] LORMER. dat
Lorne. dtm Lorne. pul @ LORMEbr.dat
Lorne. hdtt LORME. srv Odat.ccl

2] LORME.ini ] LORME.tgtt (8] Ddat ftb
lorme |IMP Loarre. bl segrnent. |3
Larre. Indt Loarre, spit @ grvsum. rpt

I

File name: {93994

Save I

Save as ype: I.-i'-.LL Files [%.7]

j Cancel |

e Save will automatically create 2 files (from the example above):

1. 99999br.dat is an ascii file of all the DTM (random points).
2. 99999b.dat is an ascii file of all the DTM breaklines.

TO EXPORT CAICE BOUNDARY TO INROADS:

e To save a CAICE boundary (for later export to InRoads) see the previously covered
information, in this handout, on 'TO SAVE A DTM BOUNDARY:' Note: Boundaries to be

exported to InRoads are best saved as 'Save As Survey Chain'.

e DTM > DTM Database Manager > to create a new surface.

e With the new DTM surface Active; DTM > Load DTM Database > From Survey Points and

Chains.

e Check 'Load From Survey Chains' and select the Object(s) or survey chain.

Geometronics
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DTM Data Load
[ Load From Pointz

=]|

— Points .
_ Optians
Object(z] I"é"LL [ j ¥ Ground Objects 'G
Feature(s] I,.-l-.,l_|_ J j ™ Feature Objects 'F
[+ Section Objects
Zonels) [ALL ] 2|7 Dser objects U
Segment|(z] I.-“-‘-.LL J j
¥ Load From Survey Chainz
— Chainz :
. Optians
Object(z] |RYEY CHAIM [EEISISR ... j ¥ Ground Objects ‘G
Feature(s) I,.-:-.,|_|_ o j ™ Feature Objects T
Uszer Objects 'L
Zonels] I.":".LL J j I- EEI LDjecks
Segment[z] I.-’-'-.LL J j
Eancell Help |

o File > Export Translators > To Inroads > DTM Surface to XYZ Format.

Save DTM surface to Inroads XY2Z format - Save As |

Save in: I {24 93399 j gl

TIEET 99933 99999 cr$ 99999 dtm
52992, ittt 99999 au$ 99999 ] 99999 dv§
] 89555 ini 99999.btt 99999, dit# 99999, g%
58955 Intt 99999.cdg 99999.dan 99999.gbl
58955 1t 99999.cl 93999.dp! 99999, 904
58958, yH 99999, cmd 99999.dt4 99999 hi
Kl R o
File name: {98888 Save |

Save as ype: I.-i'-.LL Files [%.7]

j Cancel |

e Save will automatically create 2 files (from the example above):

3. 88888br.dat is an ascii file reserved for DTM (random points) therefore it contains zero
data as all we need to load is the Survey Chain.
4. 88888b.dat is an ascii file of the Survey Chain.
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DTM Boundary and Export to InRoads Initial CAiCE Training

TO EXPORT CAICE GRAPHICS TO MICROSTATION:

o Display any boundaries (Clip Boundaries, Survey Chains, Geometry Chains) and/or
Triangles you would like to export to MicroStation. Note: In CAICE, if the Object does not
have an attached feature (from the Feature Table) it will be displayed at the active Level as
set in Settings > Global Options > Graphics. Object(s) may be displayed at different
levels and exported separately, if desired, and appended to the DGN.

e Export to MicroStation: File > Export Translators > To Intergraph/MicroStation > Screen
Graphics to DGN File.

¢ Note: These Boundaries and Triangles should be on separate levels for later use in a
temporary quality check in InRoads.

Save Screen Graphics To DGHM File |

Seed File: ING_D.&T.MEISEEIEIHSEEDWMIS.DGNﬂ Files...l

Cell Librany: IE:EUSH'&F‘L&NS&EELKDDDTE.EEL J Files...l

DGM File: [C\USRYPROJECTS199999+93993. ...| Files... |

[T Use User Defined Line Styles Line Styles Scals IEI_EI

T ext "idth/Height B atio ID.E
Save DGMN | Cancel I Help |

e Select Save DGN.

e Note: If the DGN file is open in MicroStation, when you select Save DGN, this ERROR
message will appear:
- ERROR -

Error when reading or writing CEL, DG, or zeed file

e If you get this error message, close the DGN in MicroStation and Save DGN again.

¢ Note: Files from CAICE should not be introduced into MicroStation without first cleaning the
files using FIXDGN.
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DTM Boundary and Export to InRoads

TO IMPORT A CAICE DTM AND BOUNDARY INTO INROADS:

e Open InRoads and create a surface file: File > Import > ASCII Surface.

e Shown below are the settings for importing a .dat file of DTM points:

Preferences

Import ASCIl Surface

Surface:

Default I

Mame: | 33339br dat
Drirechony:
Filter:
Filez

o huarhprojectz 333335
* dat

Directaries

larneb. dat
larnebr. dat

Faint Type:

cadlinkz
dgn

el

azi

mi1

R andom |

FPen Order:

One Then Zeroes |

File Type:!

E azting Marthing Elewation

o Shown below are the settings for importing a .dat file of DTM breaklines:

Import ASCIl Surface [ ]

Preferences

Fence Mode:

|gnore |

Surface:

Default |

Mame: | 99999b. dat

Drirectony:
Filter:

b.dat

93993br.dat
lorne. dat
larneh. dat
lornebr. dat

cohusrhprojects 393995
* dat

Directories

cadlinksz
dgn

el

gz

i

Foint Type:
Pen Order:
File Type:
Fence kode:

Breakline |

Zemn Then Ones |

E asting Morthing Elewation

lgnore |

Oregon Department of Transportation
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DTM Boundary and Export to InRoads Initial CAiCE Training

¢ Shown below are the settings for importing a .dat file of an exterior boundary. There is also
a 'Point Type' for an Interior (boundary) option:

Import ASCIH Surface Eq
Preferences

Surface;  Default |

Mame: | 585550, dat
Directony: o:husrhprojects 339394

Filter: | *.dat
Filez Directories
SB8550r. dat | |cadinks B
99999b. dat L1 [dan —
999390080, dat el
999330 080r. dat gz
99993br. dat = B 3
Foint Tupe:  Euterior |
Pen Order:  Zero Then Ones |
File Type:  Easting Morthing Elewation |
Fence Mode:  lgnore |
Cloze I
Geometronics Oregon Department of Transportation
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Initial CAiCE Training DTM Boundary and Export to InRoads

e Or another method to Import any Boundaries (from CAICE): File > Import > Surface From
Graphics.

e Boundaries can be imported as either Interior or Exterior boundaries.

“Impult Surface oo oh
Breferences Riandorm
Breakline B
Surface: Contour
Paint Type:
Elevations: E sterior
Curve Stingz: Stroke
Mode:  Lewvel |
Fence Mode: _Inside -|
Levek |1

[ Maximum Segment Length
Lenath: | 0.00

™ Thin
Toleranee: | 5.00

Re=zults

Mumber of Points;

Mumber of Lines;

[ Apply | Cloze |

e Save the Surface in InRoads: File > Surface > Save.
e Continue with the normal process of triangulating in InRoads.

e Do a quality check by displaying the InRoads DTM triangles and then displaying the
triangles from the CAICE DTM in a different color.
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