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Introduction 
The Oregon Department of Transportation (ODOT) configures and customizes Bentley 
MicroStation®, InRoads® and other CAD software for agency use. Therefore, the applications may 
perform differently than the typical “out of the box” set up.  The ODOT MicroStation® V8i User 
Guide provides guidance on how ODOT configures the software for its use.   

ODOT and Engineering Automation Administration 

The Automation Engineer administers the CAD tools and their configuration at ODOT.  In this role, 
the Automation Engineer facilitates a support team and three separate committees to create a CAD 
environment that supports the various needs of the agency. This position reports to the Strategic 
Systems and Data Management Manager in the Technical Services Branch of the Highway Division. 

The Engineering Applications Support Team (EAST) works closely with and receives direction from 
the Automation Engineer. The team primarily supports MicroStation and InRoads software along 
with other specialty software.  The EAST members report to the Project Delivery Manager in the 
Transportation Application Development section of the Information Systems branch.  Team 
members are located throughout the state. If you need assistance, contact the Computer Support 
Desk at 503-986-3800.  The Computer Support Desk will submit a trouble ticket and an EAST 
member will return your call. 

The Automation Engineer facilitates the Engineering Automation Steering Committee (EASC). This 
committee provides direction for automation projects, which result in projects led by business or 
Information Systems (IS) personnel. The committee prioritizes projects and promotes committee 
activities as needed.  Membership includes managers representing various engineering disciplines in 
Technical Services Branch and ODOT Regions. 

The Automation Engineer facilitates two additional committees, CAD Standards and InRoads 
Standards. Committee members provide direction on the standards enforced through automation 
tools.  Membership includes senior drafters and designers located in each Region and in Technical 
Services Branch. 

Your suggestions are welcome on how to improve the CAD tools available for use at ODOT. Contact 
your CAD Standards or InRoads Standards representative, EAST members or the Automation 
Engineer.  The committee membership is listed on the EAST website at 
http://www.oregon.gov/ODOT/CS/east. 

CAD Standards Committee 

The CAD Standards Committee (CSC) is a standing subcommittee of the Engineering Automation 
Steering Committee (EASC) and derives its authority from the EASC. The CSC defines and maintains 
ODOT CAD standards. (This differs from engineering specifications as this pertains only to 
engineering automation). The EASC has final approval authority for any decisions recommended by 
the CSC.  

The CAD Standards Committee membership may change or rotate based on available resources and 
ODOT needs.  

The Bentley V8i Steering Committee, the CAD Standards Committee and the CAD Configuration 
Committee for the Bentley V8i Project elected to make some changes in how ODOT works with the 

http://www.oregon.gov/ODOT/CS/east
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upgrade to the V8i application suite.  More information on how to work with the ODOT 
customizations and configuration settings are included in this User Guide. 

Whenever possible, the committees elected to use functions and tools provided within the software 
instead of building (or upgrading) ODOT tools.  This resulted in removal of macros and other 
applications from the ODOT engineering workspace if the functionality was available with other tools. 

The CAD Standards Committee elected to adopt annotation scale use with the deployment of the 
Bentley V8i software suite. This resulted in changes to cells, line styles and text styles used in 
previous versions of MicroStation to accommodate annotation scale settings.  Using annotation 
scale will require the use of a model set correctly for the intended print scale.  In other words, you 
will need to separate elements intended for printing at different scales into different models.  
Additional details are provided in Appendix A on how to work with files created in versions of 
MicroStation prior to V8i.   

If you have any recommendations for CAD Standards, please contact your department committee 
member.  

ProjectWise Integration 

This document was significantly rewritten in March 2016 to add steps and update pictures for 
operating MicroStation V8i with the integration of ProjectWise as a data source. 
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ODOT Engineering Workspace 
The ODOT Engineering Workspace is comprised of multiple components: 

 Workspace Servers — The servers store ODOT configuration and standards files, and host 
some applications. 

 File Servers — Users save and store project data, user preferences and personal files on 
Personal Server Share (F: drive) space on the file servers. 

 ProjectWise Data Source – ProjectWise users save and store project data using the 
ProjectWise Integration Server and Data Storage Server.  

 Engineering Workstations — Engineering workstations typically have better video cards and 
additional RAM to run MicroStation and InRoads than business computers used at ODOT. 
ODOT installs these and other engineering applications on the hard drive (or C: drive) of an 
engineering workstation. 

 Licensing Server — This server hosts the SelectServer application that manages ODOT’s 
licenses for Bentley MicroStation, InRoads and other applications.   

 Print Servers — These servers direct the printing from any CAD application to connected 
printers and plotters. 

 

Figure 1. ODOT Engineering Workspace 
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Workspace Servers and ODOT_Space\V8i 
Multiple workspace servers identified as ODOT_Space\V8i, and located at ODOT offices throughout 
the state, store ODOT configuration and standards files. Storing these files on these servers makes it 
faster to update engineering workstations with any approved configuration or CAD standards 
changes. This configuration also provides quicker response times to engineering workstations and 
decreased downtime.  

Figure 2. Workspace Servers 

 

ODOT_Space\V8i contains standard line styles, fonts, DGN libraries (levels, tasks and workflows), 
MDL applications, macros and cell libraries used by MicroStation and InRoads.  These are typically 
items that have been adopted by the CAD Standards or InRoads Standards Committee to better 
enable users to produce plans that follow standard ODOT conventions for construction plans. 

 
Note: If you identify ODOT_Space\V8i items that may require revision, contact EAST or 
your CAD Standards Steering Committee member. A list of the CAD Standards Steering 
Committee members is on the EAST website. 

 

Some applications (like Serval) are also maintained on the workspace servers and are not installed 
on the hard drive of each engineering workstation.   

 

http://www.oregon.gov/ODOT/CS/east/Pages/Committees.aspx
http://www.oregon.gov/ODOT/CS/east/Pages/Committees.aspx
http://www.oregon.gov/ODOT/CS/east
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File Server and F: Drive 
Your Personal Server Share (referred to as the F: drive) is a server location where you can store 
work-related data. Files stored on the F: drive are backed up and managed to ensure that data is 
available in the case of system failures. You may access files on the F: drive from anywhere on the 
ODOT network and you can share files with others working with you. The ProjectWise datasource 
named PW_ODOT is another location for storing project data.  PW_ODOT is also stored on a server, 
is backed up, and is accessible to others.  Project data that is not stored in PW_ODOT should be 
stored on a server in either your F: drive or in a crew server share.  Please refer to other 
documentation on usage of the ProjectWise data source. 

Server backups are intended for catastrophic failures, and are not intended to be long-term digital 
archives. The operational procedures on how long backups are kept, how quickly the data is 
restored and how often they occur may change due to the increased cost of maintenance.   

If you will be using engineering applications, you will be set up with an Engineering Personal Server 
Share. Additional folders and permissions are added to your Personal Server Share (F: drive) with 
files necessary for MicroStation and InRoads to run.   

Customizations made to the engineering applications are also stored on the F: drive. The presence 
of an ODOT_Data folder indicates you may be able to run engineering applications. 

 
Reminder: If you are not set up with an Engineering Personal Server Share, you will not 
be able to run MicroStation or InRoads, even if the applications are installed on the 
computer. Instead a black text window will open with the error: 

“ODOT User Configuration not found — Refer to Support for Assistance” 

Contact the Computer Support Desk for assistance with setting up an Engineering 
Personal Server Share. 

 

 
Note: In accordance with ODOT policies, you may not store personal data on the F: 
drive. To review the Acceptable Use of State Information Systems and Information 
Assets policy, go to 
http://transnet.odot.state.or.us/cs/BSS/Policies%20and%20Procedures/ADM%2005-08-
01.pdf.  

 

 
Note: The Documents and Pictures libraries are redirected to your F: drive.  Many 
Microsoft Office applications will default to saving in the Documents library. 

 

ODOT_Data Folder 

ODOT employees that are set up correctly for MicroStation are set up with a folder called 
ODOT_DATA in their Personal Server Share. Folders beneath ODOT_DATA are shared so that other 
ODOT employees can read the files stored in them: 

 PROJECTS – intended for project-related data that is not stored in PW_ODOT (ProjectWise) 

 USERCFG – see specific information below 

 

http://transnet.odot.state.or.us/cs/BSS/Policies%20and%20Procedures/ADM%2005-08-01.pdf
http://transnet.odot.state.or.us/cs/BSS/Policies%20and%20Procedures/ADM%2005-08-01.pdf
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USERCFG Folder 

Within the ODOT_DATA folder in your Engineering Personal Server Share (or F: drive), you will find 
the USERCFG folder. It contains files and folders used by MicroStation, InRoads and other 
engineering applications for your unique profile. This includes personal cell libraries, plot drivers, 
pen tables and user configuration files.  

 

 

 
Warning: Do not delete the ODOT_DATA folder. If you do, MicroStation and InRoads 
will not work correctly. 

 

In addition to your user-specific files, the USERCFG folder also contains predefined directories for 
you to save specific types of files. When using MicroStation or InRoads, the application will search 
those directories to locate required files. The predefined directories include: 

 cell: Store personal cell libraries and those with licensing stamps  

 data: Find AccuDraw shortcuts and Axiom INI and the pipe data spreadsheet template here. 

 InRoads: Find ODOT InRoads preference files including the civil.xin and ODOTseed.itl here.  

 Interfaces: 

o Interfaces\Buttons: Button settings for the mouse when using MicroStation stored 
here. 

o Interfaces\Fkeys: Create and save personal function key menus in this location. 

o Interfaces\MicroStation\: Store custom MicroStation tool boxes, tasks and 
workflows in a personal DGN library. 

Predefined directories. 
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 macros: Store personal macros you create in this location 

 mdlapps: Store user-specific MDL applications in this location. 

 plot:  Store MicroStation pen tables you create in this location. 

 prefs: User-specific preferences and configuration variables and settings for toolbar 
locations are stored here. 

o Prefs\civil: Store InRoads user preference XML files and settings for toolbar 
locations in this location. 

o Prefs\DWGdata: Find settings for AutoCAD DWG files in this location. 

 ref: Store your personal standard reference files in this location. 

 vba: Store visual basic applications in this location. 

 

 
Note: If you are having trouble with MicroStation or another engineering application, 
the Engineering Application Support Team can access the USERCFG folder to 
troubleshoot your situation. 

 

Naming Files and Folders 
It is important to consider the effect of using special characters when naming folders and files in the 
Windows file system.  Different applications have particular limitations when they encounter a 
special character, some will pop up an error, another will produce incorrect results, and still another 
may refuse to function.  Best practices for managing Windows data encourage you to be brief with 
folder and file names and to not exceed the working limit of 200 characters in the entire path.  
When you are abbreviating, avoid the use of special characters to represent longer groups of letters 
and do not use spaces.  The following is a list of all characters that will not cause problems with your 
engineering applications: 

 A through Z 

 a through z 

 0 through 9 

 underscore 

There are 63 characters that are recommended to use when naming folders and files for use with 
engineering applications; no space, no hyphen or dash.  The decimal point or period character 
should not be used in a Windows folder name and should only appear in a file name to separate the 
name of the file from the program extension. 

 
Warning: The characters !@#$&()-:;”’,.  can all adversely affect the functioning of your 
engineering applications.  Avoid their use in naming Windows folders and files, and 
keep names short. 
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Engineering Workstation and C: Drive  
You can store your project data in the USR, Share and Work folders located on the hard drive (C: 
drive) of your engineering workstation. Generally, you will not be able to write to other locations on 
your C: drive.   

 USR — Use this folder to store your data. It is typically backed up. If you store a large 
amount of data in the USR folder, contact the Computer Support Desk to install the 
Connected back up software. You can only access this folder when logged on to the 
computer. 

 Share — This folder allows you to share files with other ODOT users and for other users to 
place files on your hard drive. Anyone in ODOT can read, write and delete files from this 
location. It is not backed up, so do not use it to store your only copy of a file.  

 WORK — This folder is only accessible to the user logged in to the computer. It is not backed 
up, and is not intended to store your only copy of a file.   

 

 
Tip! The desktop of your engineering workstation is not backed up!  Do not store files on 
it. Instead, consider using other methods, such as desktop shortcuts, to quickly get to the 
files you create and edit. 
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Desktop Shortcuts 
Your desktop will display additional shortcuts and folders when you have MicroStation installed on 
your engineering workstation. These include shortcuts to MicroStation, ProjectWise, Serval and 
InRoads (if installed) and the Engineering folder.  

Engineering Folder 

Double click the Engineering folder to open it and gain quick access to help 
documents specific to the ODOT CAD environment and shortcuts for launching 
other engineering applications. Files, folders and shortcuts typically found in the 
Engineering folder include ODOT_DGN_seed_files, ODOT_User_Configuration, 
Offline_Workspace, TeamViewer and ODOT Help. Other application shortcuts, if 
installed, may include Create Project, Descartes, MathCAD 15 and MathCAD Prime 
2.0. 

InRoads 

Double-click the InRoads shortcut to launch both MicroStation V8i and InRoads V8i 
in the ODOT Engineering workspace. To access additional tools provided with 
InRoads V8i (e.g., Roundabouts, Civil Geometry and Data Acquisition), you may 
launch InRoads from the shortcut or the Start menu. 

MicroStation V8i (SELECT SERIES 3) 

Double-click the MicroStation V8i (SELECT SERIES 3) shortcut to launch 
MicroStation V8i in the ODOT Engineering workspace and open the File Open 
dialog.   

Serval 

Double-click the Serval shortcut to launch a tool developed to simplify finding and 
sharing engineering content stored in F: drives or in computer C:\Share folders 
with others at ODOT. Using Serval, you only need to know the name of the person 
with whom you want to copy files to or from. Refer to the Appendix B for more 
detailed instructions on using the Serval application. 

ProjectWise Explorer 

Double-click the ProjectWise Explorer shortcut to launch the main user interface 
for ProjectWise, from which you can access the datasources that contain projects, 
folders, and documents.  Integrated applications such as MicroStation, Word, and 
Excel will allow you to log into the PW_ODOT datasource from the File Open dialog 

of the integrated application. 

Working Offline 

Before working on a laptop offline from the ODOT network, follow these steps:  

1. While still connected to the ODOT network, launch the Offline_Workspace shortcut from the 
Engineering folder on your desktop. This will copy your Engineering Workspace, along with your 
user customizations from your Engineering Personal Server Share, to the C: drive of your laptop.  

 
Reminder: If you don’t run the Offline_Workspace, you will be unable to run 
MicroStation.  Instead, the following error message will appear in a black text 
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window:    “ODOT Workspace not found — Refer to Support for Assistance” 

When this warning appears, you will be unable to run MicroStation until you 
reconnect to the network. This error typically appears when you work offline 
without copying the local workspace. 

 

 
Note: The Engineering Workspace changes regularly and it’s important to have the 
latest customizations and standards available.  After receiving a MicroStation 
Workspace Update email, run Offline_Workspace to copy the latest files to your 
computer. 

2. Copy the CAD files you will need from your F: drive or wherever else they may be stored. 

3. Launch MicroStation and InRoads (or any other Bentley software) you will be using while on 
the ODOT network.  You cannot check out a license, but as long as you have launched the 
application within the last month, when connected to the ODOT network, a license will be 
available when you are off the network.   

 
Note: The Activation Status dialog may open when you launch Bentley 
applications from the ODOT network. Click Close to close the dialog. Do not 
activate the license. 

 

Obtaining Technical Support 

When you need technical assistance with MicroStation, contact the ODOT Computer Support Desk. 
They will connect you with an EAST member who may use the TeamViewer application to provide 
you with technical support. TeamViewer is similar to the Remote Assistance tool the ODOT 
Computer Support Desk uses when providing technical support. EAST members use TeamViewer to 
easily view both of your monitors and all of the InRoads dialog boxes. When needed, you will be 
instructed on how to launch this application.   

Click Close. Do 
not activate the 
license.  
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Creating a Survey Project  

Surveyors using MicroStation and InRoads have an additional tool available from the Engineering 
Folder called Create Project. You can use this tool to create a standard folder structure with some 
standard default files that can be used to organize survey data.  Geometronics defines and manages 
the files and folders that are set up. 

 
To create a standard survey project folder structure: 

1. Click the shortcut to open the ODOT Survey Project Creation Utility window. 

  

2. Navigate to the folder to which you have “write” permissions. 

3. Enter Project Key Number in the field on the right. 

4. Click Create to create the folder.  

5. Repeat steps 1 through 4 to create several folders without closing the tool.   

6. When finished, click Exit. The folder structure created appears as follows: 

 

Folder structure created. 
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The Inroads_Survey folder contains several key number named files (ALG, DGN, DTM, FWD, 
RWK and XIN). You can use the RWK file to launch InRoads and automatically open the 
corresponding files. The #####.XIN file contains the standard ODOT InRoads preferences 
which can be customized for a survey project. 
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MicroStation Basics 
This chapter provides information about customizations that ODOT has made to MicroStation. 

Launching MicroStation 
There are several methods to open MicroStation files. Some methods launch directly into 
MicroStation and some will cause a ProjectWise Log in dialog to appear. The ProjectWise Log in 
dialog allows you to choose the location of your data and controls whether the next window is the 
ProjectWise File Open dialog or the Windows File Open dialog. When you log into a ProjectWise 
datasource to open or save data, you will see the integrated dialogs.  The integrated dialogs have 
fields and icons that access the ProjectWise datasource, and search or filter based upon document 
properties.  Only the Windows File Open dialog allows you to change the User Options and 
Interface. User Options and Interfaces are discussed in “Using the Windows File Open Dialog” 
section below. 

To launch MicroStation with a ProjectWise Log in dialog: 

 Double-click the MicroStation shortcut on the desktop 

 Click MicroStation on the Start menu 

 Click a MicroStation task that is pinned to your task bar 

 Right-click on a DGN file found in the ProjectWise Explorer, and choose Open (technically, 
you had to log in to the ProjectWise Explorer) 

To launch MicroStation without a ProjectWise Log in dialog: 

 Double-click on a DGN file in Windows Explorer if the file is associated with MicroStation 

 Hover over MicroStation on the Start menu, to open a menu with the latest opened files 
and click a specific file to open it directly in MicroStation 

 Hover over a MicroStation task that is pinned to your task bar, to open a menu with the 
latest opened files and click a specific file to open it directly in MicroStation 

 

 
Caution! Fully exit MicroStation and relaunch to change from accessing data in a 
ProjectWise datasource to the Windows file system.  Also, fully exit an open Windows 
file and relaunch MicroStation to log in to a ProjectWise datasource. 

 

 
Tip! You may prefer to hold off checking “Remember me” when logging into a 
ProjectWise datasource until more than half your projects are stored in PW_ODOT.  
Make the choice of where to look for your data right after launching MicroStation.  If 
the data is stored in the Windows file system (F: drive, crew share, or C: drive), choose 
Cancel to access the Windows File Open dialog; if the data is stored in PW_ODOT, then 
choose Log in to access a ProjectWise datasource. 
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Click Cancel to 
access data in F: 
or C: 
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Using the ProjectWise File Open Dialog 
The integrated File Open dialog allows you to locate and open existing folders and MicroStation files 
stored in a ProjectWise datasource.  

 

The address bar in the integrated File Open dialog contains a Most Recently Used list.  When 
expanded, the MRU list will display all documents (.txt, .docx, etc.) recently opened from 
ProjectWise, not just with MicroStation.  The address field will be populated with the MicroStation 
DGN file that was most recently accessed by you that is stored in ProjectWise or may be blank if the 
most recently opened files were not DGNs. 

  

Most Recently Used list 

Document list is filtered by 
Extension: *.dgn;*.dwg;*.dxf 

Up One Level icon 
Search icon 

Address Bar 
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A quick search can be performed or a saved global or personal search can be executed by clicking 
the Search icon. Search results are displayed in the document list. 

 

The document list is always filtered by the Extension: field at the bottom of the integrated File Open 
dialog. The document list displays the same columns or properties as your selected view using 
View>Manage Views… in the ProjectWise Explorer.  Columns may be sorted by clicking on the 
column headers in the document list. 

 

 
Note: You may open only one MicroStation design file at a time.  The ProjectWise File 
Open dialog allows you to “Open document as read-only” by checking the box in the 
lower left corner. 

 

 
Warning: When changing design file locations between a project stored in ProjectWise 
and a project stored on a Windows server, exit the MicroStation application and re-
launch. Do not use File>Open or the file history from within the MicroStation 
application when the next file is stored in a different data source (ProjectWise versus 
Windows). 
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Using the Windows File Open Dialog   
The Windows File Open dialog allows you to locate and open existing folders and MicroStation files 
stored on a server or your computer, create new folders or MicroStation files, or allows access to 
different configurations and customizations. 

 

 

The address bar in the Windows File Open dialog may be expanded to show the entire directory 
tree.  The File History icon shows a list of recently opened design files.  The File name: field will be 
populated with the MicroStation DGN file that was most recently accessed by you that is stored in 
the Windows file system. Be careful – only open DGN files stored in ProjectWise from the integrated 
(ProjectWise) File Open dialog. When using the Windows File Open dialog, avoid selecting files on 
your C:\ drive from the Windows history.   

 
Warning: Do not use the Windows File Open dialog or file history to select MicroStation 
design files stored in C:\pw_work – ever!  You may only see the parent folder name of 
dms#### in the Address Bar.  These files are local copies of files stored in the 
ProjectWise datasource.  To work in those files, log in to the ProjectWise datasource 
and use the integrated File Open dialog. 

 

User Options — Training and Example Files 

On the Windows File Open dialog, you may access and open training files or examples from Bentley 
to improve your MicroStation skills. To access these files, you need to select a User in the lower right 
corner of the File Open dialog. 

Up One Level icon File History Directory History 

Windows Shortcuts 

File list is filtered by Files 
of type: *.dgn;*.dwg;*.dxf 

Address Bar 
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You can choose from several different User options as identified in the table below. For ODOT 
production drafting, you should always open with the User set to ODOT. 

The Options area is not available on the integrated (ProjectWise) File Open dialog. 

 

Table 1. MicroStation User Options 

User Source 

Examples Provided by Bentley and typically used in Bentley classes 

ODOT ODOT Production drafting interface 

Student Optional, Classroom training from CAD Productivity if attended training 

Untitled Delivered by Bentley 

New Delivered by Bentley, not for ODOT use 

 

Project Options 

For ODOT production work, you should select the Project option of No Project. If you have attended 
vendor training, you may have additional choices available to you. 

 

Interface Options 

The first time you launch MicroStation, it sets the Interface option to ODOT.  If you change the 
interface on the Windows File Open dialog, the next time you launch MicroStation the last interface 
used will open. The available interface options are listed in the table below. 

The Interface Options are not available on the ProjectWise File Open dialog. To change the interface, 
i.e. from ODOT to Survey, you must cancel out of the ProjectWise Log In to get to the Windows File 
Open dialog.  Make the interface change and open a file in Windows to save the change of interface. 

 

Table 2. MicroStation Interface Options 

Interface Select to … 

Bridge Load Bridge tasks and workflows 

Geo_Hyd_Env Load Geo, Hydro and Enviro tasks and workflows 
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Interface Select to … 

ODOT Load all ODOT workflows  

Roadway Load Roadway tasks and workflows  

Survey Load Survey tasks and workflows  

Traffic Load Traffic tasks and workflows  

New Not used at ODOT, see User Customization chapter for more information 

 

 
Tip! If you typically double-click MicroStation DGN files in Windows Explorer to open them, the 
file opens with the last interface selected.  The only way to change the interface is to launch into 
the Windows File Open dialog from a MicroStation shortcut. 
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Viewing File History 
To quickly view a list of recent file activity, you can: 

 Use either the ProjectWise or Windows File Open dialog.  Both dialogs open with the last 
MicroStation file that you opened in the Address or File name field.  The ProjectWise File 
Open dialog has a Most Recently Used list of the five most recent of any type file under the 
address bar, while the Windows File Open dialog has a File History icon that displays the ten 
most recent MicroStation DGN files.  If the Windows directory or file cannot be accessed, 
MicroStation will open to a default location on your computer’s hard drive. 

 

 

The ProjectWise (integrated) File Open – MRU List – 5 documents, any type 
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The Windows File Open File – History List – 10 DGN files 

 Select File on the main MicroStation menu. If you are logged into ProjectWise, it will display 
the last 5 MicroStation design files stored in ProjectWise that were opened. If you have a file 
stored in the Windows file system open, it will display the last 10 files opened in 
MicroStation. 

 

ProjectWise data – 5 DGN files     Windows data – 10 DGN files 

 

 
Warning: Do not use the Windows file history to select MicroStation design files stored 
in C:\pw_work – ever!  These files are local copies of files stored in the ProjectWise 
datasource.  To work in those files, log in to the ProjectWise datasource and use the 
integrated File Open dialog. 
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 Right-click MicroStation on the Task Bar to view recent file activity of MicroStation design 
files stored in the Windows file system only. 

 

 
Caution! If a design file stored in the Windows file system is renamed or moved, you 
cannot open the file using the file history. Use the Windows File Open dialog to 
navigate to the file. 
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Creating New MicroStation Files 
No matter whether you are creating new files to be stored in ProjectWise or in the Windows file 
system in a crew share or your F:\ drive, you will need to select a seed file or template to be used in 
that creation. The seed files have particular properties set in their master model, a specific 
dimensionality (2D or 3D), and may have cache files pre-attached or have elements already drawn 
into the file as a starting point. 

Seed Files  

ODOT delivers several seed files in ODOT_Space\V8i that are used for different MicroStation products. 
A shortcut to the seed files in the workspace closest to your location is stored on your computer’s 
desktop in the Engineering folder. The ODOT_DGN_seed_files shortcut is there to make the seed files 
more easily accessible when creating new MicroStation design files. 

Table 3. Seed Files 

Seed File Name Purpose Distinguishing Characteristics Discipline 
Owner 

Seed.cel Create new cell library Default model may be placed as 
cell. Line style scale set to Global. 
Annotation scale set to Full Size. 

EAST 

Seed_OM.dgn Drainage Facility 
drawings 

Based on seed2d.dgn.  Includes 
Notes to Drafters and example 
features and elements to use. 

GeoEnviron
mental 

seed_tse.dgn Landscape title sheets 
for construction project 
plans 

Includes border and elements to 
include in the drawing; 
titlesheet.cel is attached; 
cache_tse reference file is 
attached, annotation scale set in 
default model, Line Style Scale set 
to Annotation Scale. 

Roadway 

Seed_TWM.dgn Temporary Water 
Management drawings 

Based on seed2d.dgn.  Includes 
example sheet with notes. 

GeoEnviron
mental 

Seed2d.dgn Standard 2D file 2D seed file; includes 10 levels 
that can be renamed, annotation 
scale set in default model, Line 
Style Scale set to Annotation 
Scale. 

EAST 

Seed3d.dgn Default 3D file 3D seed file selected by default; 
includes 10 levels that can be 
renamed, annotation scale set in 
default model, Line Style Scale set 
to Annotation Scale. 

EAST 
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Seed File Name Purpose Distinguishing Characteristics Discipline 
Owner 

Seed811tse.dgn Portrait title sheets for 
construction project 
plans 

Includes border and elements to 
include in the drawing; 
titlesheet.cel is attached; 
cache_tse reference file is 
attached; contents of several cell 
libraries are written into the file 

Roadway 

SeedRW2d.dgn Several different Right 
of Way products 

Includes a variety of sheet and 
drawing models used for different 
products; instructions and 
elements are drawn in the various 
models 

Cadastral 

SeedV8.nam Two stacks of title 
blocks, 1”=200’ and 
1”=100’ for use as 
reference or cell  

2D, Default model can be placed 
as a cell, Line style scale set to 
Global. Annotation scale set to 
Full Size. 

Roadway 

 

 
Tip! If you have some standard features you repeatedly incorporate in files, contact an 
EAST member on how to set those features in your own custom seed file.  Remember, 
that if the standard seed files are updated, you will want to apply those changes to your 
custom seed file. 

 

ODOT Models and Properties 

The default model properties in the seed2d.dgn and seed3d.dgn files are shown below. The 
annotation scale is set to 1”=100’.  Set the annotation scale in the models you create for cells, text 
and line styles to display correctly. 

 

  

 
Tip! Most ODOT cells have been 
reduced in size to work with 
annotation scale.  If you open an 
older file (one created prior to 
2012), annotation scale is not set in 
any of the models. When you place 
cells from the ODOT cell library, 
they will come in very small.  If you 
set the annotation scale that is 
correct for the model, the cells will 
scale to the intended size. 

 

Annotation 
Scale 
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Using the ProjectWise Document Creation Wizards 

When File>New or the New File icon is selected, and the active MicroStation design file is stored in a 
ProjectWise datasource, a New dialog appears allowing you to select a “Document Creation 
Wizard”, either the Advanced Wizard or No Wizard. 

The Advanced Wizard 

When you select the Advanced Wizard, a multi-step dialog opens that allows you to select the target 
folder of the new file, select a template (choose a seed file), and fill out document attributes and 
properties, such as the new document name. 

The preferred method for selecting a template is to use the ODOT_DGN_seed_files shortcut in the 
Engineering folder on your dekstop. 

 

 

 

1. Choose “Use external 
file as a template” – then 
[Browse…]. 

2. Click on the Desktop 
favorite, and then open 
the Engineering folder. 

3. Double-click on the 
ODOT_DGN_seed_files 
shortcut. 

4. Select a seed file from 
the list and click [Open]. 
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At the “Document Properties” step, name the document with the file extension (.dgn). 

 

After you click Finish on the Advanced Document Creation Wizard, the new file will be created in 
ProjectWise with the attributes and properties that you set. A MicroStation Check In dialog will 
open for you to make a choice about freeing or checking in the current design file; once that is done, 
the new file will be opened. 

No Wizard 

The No Wizard option produces a single dialog that allows you to change the target folder and select 
a Source File (seed) using an Import… button. This option does not allow attributes to be entered. 

The preferred method for selecting a Source File is to use the ODOT_DGN_seed_files shortcut in the 
Engineering folder on your dekstop. 

 

1. Choose [Import…]. 
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2. Click on the Desktop 
favorite, and then open 
the Engineering folder. 

3. Double-click on the 
ODOT_DGN_seed_files 
shortcut. 

4. Select a seed file from 
the list and click [Open]. 



ODOT MicroStation® V8i User Guide 

March 2016 Oregon Department of Transportation 33 
Engineering Applications Support Team 

Before clicking Apply or OK, it is important to name your document. Make certain that you include 
the file name extension in the document name so that the document and file name are the same.  

 

After you click Apply or OK on the New dialog, the new file will be created in ProjectWise. A 
MicroStation Check In dialog will open for you to make a choice about freeing or checking in the 
current design file; once that is done, the new file will be opened. 

Using the Windows File System 

Launching the MicroStation application to open files stored in the Windows file system (this means 
you have cancelled out of the ProjectWise Log in dialog) allows you two methods for creating new 
files:  

 Clicking on the New File icon on the Windows File Open dialog, or  

 

 Selecting File > New on the MicroStation menu. 

Both methods for creating a new file in the Windows file system will cause a New dialog to open, 
which lists the current seed file at the bottom.  The ODOT default preferences set the initial seed file 
to seed3d.dgn. 

New File icon 
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To change the seed file, click the Browse… button and a Select Seed File dialog will open.  Select a 
seed file from the list and click Open. 

 

With the correct seed file listed on the New dialog, name the new file and click Open. 

 
Caution! Do not copy existing files, rename them and delete elements out of the file to 
create new files.  Copies of existing files may contain non-visible elements, non-
graphical data, and even corruptions. 

 

 
Tip! The seed files delivered in ODOT_Space\V8i are configured to support ODOT 
standard business processes; creating new files from an ODOT seed file ensures that you 
have the latest updates. 
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Reference File Attachments and Reference Sets 
Reference attachments can be made in the Windows file system to view other models that are also 
stored in the Windows file system. It is fairly easy to break a reference attachment by renaming or 
moving the referenced file. In Windows, when the reference attachment cannot be found, the data 
is not displayed and the attachment information appears in the Reference dialog with red text. 

 

ProjectWise documents have globally unique identifiers (GUIDs), which are used in addition to 
folder and document names that make it difficult to lose reference attachments in a ProjectWise 
datasource. In ProjectWise the relationship between a master document and its attachments is 
known as a set.  If a referenced ProjectWise document’s name or location is changed, when the 
parent design file is opened, MicroStation updates to the new name or location and informs you of 
the update. Because of the GUID, it is difficult to lose a reference in a ProjectWise datasource. 

 

After clicking OK to dismiss the Information dialog, you should open the References dialog to 
determine the reason for the change. 

 

Missing reference file 

Name was changed to prompt changing the 
attachment to a different file. 
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Loading Additional Applications 
On the main menu is the ODOT menu. When you select ODOT, a drop-down menu lists other 
application you can install or access on your workstation’s hard drive. You may also access different 
ODOT Help options from the ODOT menu. 

 

 

Other software applications you can install and access include: 

 AutoTURN 8, Descartes, GuidSIGN 6, InRoads Lite (a convenient version of InRoads but with 
reduced capability), and gINT Civil Tools.  Additional software must be installed by a FSU 
technician before it will appear on this list. 

 Axiom Office Importer. This server-based application is available to some MicroStation 
users.  The software has not been purchased for all ODOT locations, so it is not always 
available. 

 

Other available 
applications 

ODOT Help 



ODOT MicroStation® V8i User Guide 

March 2016 Oregon Department of Transportation 37 
Engineering Applications Support Team 

Getting Help with MicroStation 
You may obtain help with MicroStation from multiple sources: 

 Select Help on the main menu to open the Bentley-provided help sources. 

 Select ODOT > ODOT Help and select from the various resources on the drop-down menu. 
These include:  

o Tasks Outline 

o EAST Website (link to site) 

o Main Task Reload 

o TeamViewer 

Tasks Outline provides an overview of the ODOT Tasks and Workflows. Use this tool to gain 
familiarity with and search for the locations of tasks and workflows. 

Main Task Reload may be used to re-open the main Tasks if you accidentally close it by clicking the 
X next to the Pin icon. 

TeamViewer is the tool that allows EAST analysts to remotely assist you with technical issues 
associated with MicroStation.   
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Setting User Preferences 
You can customize the user preferences within MicroStation to meet your specific needs based on 
the how you use MicroStation. 

You can set preferences for the database, Descartes, input, look and feel, operation, position 
mapping, raster manager, reference, spelling, tags, task navigation, text and view options. 

To make changes to the MicroStation preferences, select Workspace > Preferences on the main 
menu.  

 

This will open the Preferences dialog. 

 

Select Workspace > Preferences 
to open the Preferences dialog. 

Select a Category to view 
available options to customize. 
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Select a category in the list on the left to view the options you can set for the selected preference. In 
general, the Default Preferences are the same as the defaults provided by Bentley.   

Preference categories that you may want to modify include the following: 

 Operation Category:  

o Open Two Application Windows: Select if you have dual monitors, you may want to 
open two different windows that you can adjust to each monitor.  Alternatively, you 
may prefer to run with just one window but drag the MicroStation window over 
both monitors.   

 Text Category:  

o You can modify the size of the font displayed in the Text Editor by setting the Text 
Editor Font Size. 

 View Options Category:   

o Line Weights…: By default, the user preference for line weights is set to 1.5:1.  Some 
ODOT employees prefer to set this to 1:1 or 2:1.  Click Line Weights to open the 
dialog and set the line weight. 

o Design Model Background Color: If you typically change the background color of the 
files you work in, you can set it as a user preference instead of modifying each file 
you work in.   

o Element Hilite Color: You can set the element hilite color and selection set color to 
override the Design File settings. 
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Accessing Extra Tools – Custom  
A toolbox called Extra Tools – Custom has been docked in the ODOT User Preference Files (UPF) for 
ODOT users.   

If the Extra Tools – Custom toolbox is not available, you can display it and dock it for your use: 

1. Select Tools > Tool Boxes from the main menu.  

 
The Tool Boxes dialog opens. 

 

2. Scroll down and check the Extra Tools – Custom box and click OK.  The extra tools appear on 
the tool bar.  These include the Drawing Scale toolbar, the Print Organizer icon, the 
Add/Remove/Select Annotation icons, and the Lat/Long Labeler. 

 

 

 

 

 Click the Print Organizer icon to open Print Organizer.   

 Use the Add/Remove Annotation (+A and –A) buttons to add or remove annotation scale 
attribute.  Find additional details in Appendix A or the InRoads User Guide - Workflows. 

 Use the Select Annotation (A) button to select previously placed annotation. 

 
Caution! Use these with a selection set or the results may impact your 
annotation in unexpected ways. 

 

Click to launch 
Print Organizer. 

Add/Remove/Select 
Annotation buttons. 

Drawing Scale toolbar 

Scroll down and check 
Extra Tools - Custom and 
then click OK. 
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 The Lat/Long Labeler icon invokes the Label Geographic Coordinates dialog for annotating 
latitude and longitude. 

 The Drawing Scale toolbar contains the Annotation Scale Lock and the Annotation Scale.  

 

To select an annotation scale for the active model, click the Annotation Scale to choose 
one from the drop-down list. Prior to placing any text, annotation cells or line styles, 
ensure that the Annotation Scale Lock is on. 

These two settings are model specific. If you have multiple models in a file, the settings 
can vary from model to model allowing you to have different scales and lock settings for 
each model.   

 
Tip! You can turn off the display of unneeded tool icons on a toolbar by right-clicking on 
any tool. 

 

Annotation Scale Lock Annotation Scale 
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Closing, Exiting, and Saving Files Stored in a ProjectWise Datasource 
When working in MicroStation DGN files that are stored in a ProjectWise datasource, any time you 
execute a command from the upper section of the File menu, you will invoke dialogs that are 
integrated with ProjectWise.  The upper section of the File menu deals with opening, closing, and 
creating files. 

 

When another file is opened or created, the current file must be closed and the integrated Check In 
dialog opens to have you choose what is to be done with the current file:  Check In, Update Server 
Copy, or Free.  It is not recommended to select Cancel on this dialog.  Cancel does not stop the 
command from completing; it just puts off the ProjectWise decision until later. 

 

 

 
Tip! Expect the Check In dialog to appear when changing which file is open from a 
ProjectWise datasource.  It is typical to choose either Check In or Free. 

 

 
Caution! Fully exit MicroStation and relaunch to change from accessing data in a 
ProjectWise datasource to the Windows file system.  Also, fully exit an open Windows 
file and relaunch MicroStation to log in to a ProjectWise datasource. 
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Saving Files to Other Formats  
You can use the File Save As dialog to save MicroStation files in DWG and DXF file formats, 
MicroStation version 7 format, and to save a MicroStation version 7 file as version 8.   

You can also use the File Save As dialog to modify the elements in the file to different line styles, 
fonts, levels, weights and colors. 

 
Note: When the MicroStation DGN file that you are working in is stored in a 
ProjectWise datasource, the Save As command produces an Information dialog after 
the process has completed informing you that if the file had references, the format of 
the references is not changed by this procedure.  It goes on to explain that the new 
parent is not the master of a reference set until you scan references.  Be cautious saving 
to DWG format in a ProjectWise datasource.  Each reference file is required to be saved 
to the DWG format individually and then the final step is to run Scan References and 
Link Sets from within the ProjectWise Explorer to create the set relationship with the 
master DWG file. 

No Wizard - To save files to other formats in the ProjectWise datasource: 

1. Select File > Save As on the main menu and choose No Wizard in the Select a Wizard 
dialog. 

2. Click the Format… button on the Save Document As dialog. 
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3. From the Select Format to Save drop-down menu, select the format for the file that you 
want to save. Click Options to open the Save a DWG/DXF Options dialog. 

 
 

4. After clicking OK on the Save As dialog to accept the format, click Save on the Save 
Document As dialog to complete the process. 

 

 
Tip! If saving to DWG format, you may as well uncheck “Convert Reference Files” on the 
References tab of the Save As DWG/DXF Options dialog. Converted reference files will 
not be created in the ProjectWise datasource.  See the Note at the beginning of this 
topic. 

 

Advanced Wizard - To save files to other formats in the ProjectWise datasource: 

1. Select File > Save As on the main menu and choose Advanced Wizard in the Select a Wizard 
dialog. 

2. Click the Format… button on the Document Properties step of the Advanced Document 
Creation Wizard. 

Select the format you 
want to use to save 
the project file. 

Choose a tab to set up 
the save options.  
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3. From the Select Format to Save drop-down menu on the Save As dialog, select the format 

for the file that you want to save. Click Options to open the Save as V8 Options dialog. 

 

4. After clicking OK on the Save As dialog to accept the format, click Save on the Save 
Document As dialog to complete the process. 

 

Select the format you 
want to use to save 
the project file. 

Choose a tab to set up 
the save options.  
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To save files in other formats in the Windows file system: 

1. Select File > Save As on the main menu. The Save As dialog opens. 

2. From the Save as type drop-down menu, select the format for the file that you want to 
save. 

 

3. Click Options to open the Save As Options dialog. 

 

4. Use the icons to the left of the CSV File name to browse to, edit or create a new CSV file 

5. On the Remap tab, check the Apply options needed for the file translation. 

6. Review the References and Filter tabs and modify as needed. 

7. Click OK to apply the options and close the Save As Options dialog  

8. Click Save on the Save As dialog to save the file. 

Click Options to 
open the Save As 
V8 Options dialog. 

Select the format you 
want to use to save 
the project file. 

Click to browse, edit or 
create a new CSV file.  
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ODOT Tasks and Workflows 
Workflows are specific tasks that you can perform with MicroStation. When you launch 
MicroStation from a desktop icon or the Start menu, the File Open dialog opens. On the File Open 
dialog, you may select the desired interface that will automatically load tasks and workflows for you 
to use.  

 

 
Note: The first time you launch MicroStation, it sets the Interface option to ODOT.  If 
you change the interface, then the next time you launch MicroStation the last interface 
used will open. 

 

If you choose ODOT as the interface, MicroStation automatically loads all ODOT workflows and the 
ODOT task (with an orange flying T icon) appears in the Tasks dialog.  

 

From the ODOT workflow, you may view the ODOT discipline-specific workflows.  
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To view the ODOT discipline-specific workflows, click 
ODOT on the Tasks dialog.  

To view the custom tasks and workflows within each 
discipline, click the discipline on the Tasks dialog.  

For easy access to the workflows while working in 
MicroStation, you may dock them as dialog tabs on the 
MicroStation window. 

 

 

 

 
Note: If you choose one of the other Interface options (Bridge, Geo_Hyd_Env, 
Roadway, Survey or Traffic) on the File Open dialog, only the tasks and workflows 
associated with the selected interface will appear on the Tasks dialog.   

General Workflow 

The General workflow contains most of the tools and tasks common to all disciplines and can be 
found as a workflow on most discipline-specific task dialogs.  

    

Within the General workflow you will find some common tools and sheet elements, including: 

 Sheet Borders  

 Title Blocks 

 Status Stamps 

 Scale Bars 

 General Arrows (which has different types of arrows including a North Arrow) 

 Vicinity Map Tools (route shields, name text, and project linestring)  

 Fill/Hatch 

 General Misc. (with items like Check Mark, Bracket and Revision Triangle) 

 Tools – include the following: 

Modify Elevation Fixrange 

Change Direction Verify 

 Verify Repair 
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Sheet Borders 

Under Sheet Borders, you will find five standard sheet sizes used 
by ODOT. You can create and place sheet borders using this tool. 

To create and place a sheet border: 

1. Click on the desired sheet border size to activate the tool. 
An appropriately sized border is now displayed on your cursor 
ready to be place in the file. 

2. Left click (data point) to create and place a border. 

3. If you require more borders of the same size, continue to 
left click (data point) in the desired locations to create and place 
the desired borders. 

The sheet borders are cells that you may copy and move as 
needed. 

 

 

 

 

 

Title Blocks 

After you place a sheet border, you can place title blocks within 
the sheet. Under Titleblocks, you will find a list of available title 
blocks for most needs, along with other elements commonly 
associated with title blocks such as Sheet Number and Project 
Title. 

To create and place title blocks: 

1. Click on the desired title block to activate the tool.  

2. Left click (data point) in the sheet border where you want 
to place the title block. 

3. If you require more title blocks, continue to left click (data 
point) in the desired locations to create and place the desired title 
blocks. 
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Using Tasks and Workflow Tabs 
You can dock workflows as a dialog tab on either the left or right margin of the 
MicroStation window. By default, the MicroStation dialog tab appears on the left 
margin. Therefore, the ODOT dialog tab is typically docked on the right margin. 

 
Tip! The workflow dialog tabs appear in the order that you dock 
them on the MicroStation window. Therefore, plan ahead if you 
want them docked in a particular order.  

In addition, your MicroStation dialog positions and docked 
workflows are stored on your F: drive; they will appear the same no 
matter what ODOT computer you use. 

 

With the workflow dialog tabs, the active task remains expanded in each tab until 
another task is selected. This reduces the amount of “drilling” into menus. 

To dock or set up a workflow tab: 

1. Review the Tasks list to identify available workflows. 

 



ODOT MicroStation® V8i User Guide 

March 2016 Oregon Department of Transportation 51 
Engineering Applications Support Team 

2. Right click on the desired workflow and select Open ‘Workflow Name’ in new Dialog. 

 
The workflow opens as a new dialog. 

3. Navigate to the tasks for each of the workflows that you want to dock and repeat step 2 to 
open them as dialogs.  

 
 

 
Note: Most discipline-specific tasks include the General workflow. 

Right click on the desired 
workflow name and select 
Open ‘Workflow Name’ in 
new Dialog. 
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4. Drag each workflow dialog by the title onto the docking icon, in the order you want them to 
appear. 

 

 
 
The dialog is docked to the window margin. 

 
 

 
Reminder: The dialogs dock on the margin of the MicroStation window in the order 
you place them. Also, don’t drag the dialog titled Tasks to the docking icon. 
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5. To hide/collapse a docked workflow dialog, click the Pin icon. The docked workflow dialog 
appears as a tab on the margin. 

   

6. Continue to dock workflow dialogs, as desired. 

7. To remove a docked workflow dialog tab, click the tab to expand the workflow dialog and 
click the X next to the Pin icon. 

 
Note: If you close the task dialog, you can select the menu ODOT >  ODOT Help 
> Main Task Reload to re-open the menu. Other tasks can be re-opened with 
the keyin “tasktoolbox open” and name of the task or toolbox. For example 
“tasktoolbox open roadway.” 

 

Element Templates 

Element templates define properties of elements. The primary purpose of these templates is to 
increase consistency in adhering to CAD standards. 

A template can store multiple element properties. General properties such as level, color, line style 
and line weight can be set in a template as well as text styles, text style overrides and cell properties. 

You can activate an element template by selecting it from the Active Element Template drop-down 
list. Each category will expand by clicking on the little plus symbol. Find the element template 
needed then select it by left clicking on it. This will set the active attributes. 

Click the Pin icon to 
collapse the dialog as 
a tab on the margin. 

To remove a docked dialog 
tab, click the tab to expand 
the dialog and click the X 
next to the Pin icon. 
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The active attributes automatically change to reflect the selected template. 

 

You may also select a tool from the ODOT tasks and workflows to activate element templates. These 
tools have been set up to point to the templates wherever possible. 

 

Text Styles 

Text styles assist in setting up the annotation scale and to standardize the text used in CAD products.  

ODOT has two bridge styles, eight right of way (RW) styles, and six general styles to cover all other 
disciplines and products. All the ODOT text style names begin with “ODOT” for easy identification. 

 

 
Note: There are also six Bentley provided text styles that are necessary for some Bentley 
products to perform properly. You may ignore these.  

 

You may activate the styles from the Text Styles dialog, but the more common way to select a text 
style is with the tools provided in the ODOT tasks and workflows. Tools that place text, will call a text 
style as well as the Place Text and Text Editor – Word Processor dialog boxes as illustrated below.   

ODOT Text Styles 
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Even though the tools in the ODOT tasks and 
workflows call up text styles, you can override any 
attribute of the text style.  

For example, you select a tool that calls up the text 
style ODOT Notes. The size and font are acceptable, 
but the Justification is set to Left Top, and you need 
Center Center.  

To change this, expand the Place Text dialog and 
select the desired style from the Justification drop 
down menu.  

 

 

 

 
Note: Because of the Annotation Scale, the font height and width will not be the same 
as in MicroStation V8 2004. The text styles dynamically change based on the scale set in 
the model in which the text is being displayed. This means that the numbers for height 
and width will be small compared to previous methods, but the text should display and 
print at the appropriate size. 

 

 
Note: In previous versions of MicroStation, the line spacing was a distance, so to create 
a space between lines of text that was half the height of the text, you divided the font 
height by two and entered that value (e.g., font height 7.5, line spacing 3.75). In 
MicroStation V8i, line spacing is a ratio. To set the line spacing to half the text height, 
you enter 0.5 in the line spacing field regardless of the font height. 
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Line Styles   

Line styles follow the rules of the Annotation Scale. As long as the Line Style Scale field on the 
Model Properties dialog is set to Annotation Scale, custom line styles will dynamically change to 
accommodate any annotation scale applied to your model. 

  

 

For example, previously when you had a project like a small box culvert and you wanted to print it at 
a scale of 1” = 50’, rather than the more standard 1” = 100’, the custom line styles would often show 
up very large. Lines like fences and utilities had such a large line style that they detracted from the 
drawing. Now, if you set your model properties to 1” = 50’, the custom line styles automatically 
scale down. The image below demonstrated this with the fence, ditches, guardrail and other custom 
line styles. 

 

  

1” = 100’ 1” = 50’ 

 

ByLevel Symbology 

ByLevel symbology enables you to change standards by changing the level symbology, causing any 
element template or tool associated with that level’s ByLevel symbology to reflect the new standard 
without further action by you.  
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Several of the element attributes may be set to ByLevel. This includes color, line style and line 
weight. This allows the level to be set for those attributes rather than individually setting them in an 
element template or each individual element. This assists with consistency in ODOT CAD standards 
and allows element templates to use the already defined ByLevel symbology, reducing potential 
errors. Whenever possible, ODOT has set the ByLevel symbology in the level DGN library as the 
primary method to reflect ODOT CAD standards.   

The actual symbology is set in the level library, but it can be easily overridden with any of the tools 
used to set element symbology. 

 

Annotation Scale 

Annotation Scale allows elements like text, cells and line styles to automatically resize based on the 
desired print size.  

You can turn the Annotation Scale Lock on and off from many locations within MicroStation V8i, 
including:  

 The Drawing Scale toolbar 

 The Place Active Cell dialog 

 The Place Text dialog 
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Note: The Scale Annotations check box appears on the Place Active Cell dialog and the 
Scale dialog. By default, these check boxes should be unchecked.  These settings are 
design file specific.  Be sure to “Save Settings” after you make the changes. 

   

The purpose of these check boxes is to use the active scale as a multiplier for annotation 
scale elements. For example if you want to place a cell at twice its normal size, but still 
want it to respond to annotation scale, you could turn these check boxes on and set the 
X, Y and Z scale values to 2. This would result in a cell being placed at twice its normal 
size, but still becoming smaller or larger with any changes to annotation scale. If the 
check box is not checked, the annotation cell being placed ignores the active scale and 
uses only the annotation scale. 

 

Annotation scale works differently with cells and text than it does with line styles. You must place 
cells and text with the annotation scale lock on in order to respond to the selected annotation scale. 
If it is off when you place a cell or text, the element may appear too small. Also if the annotation 
scale lock is off when you place a cell or text, the cell or text cannot be resized by changing the 
annotation scale in the model properties.  

In contrast, line styles respond to annotation scale whether the lock is on or off.   

 
Note: When moving from older MicroStation files that did not utilize annotation scale, 
you must update cells to the newer cells with the Can be placed as annotation cell 
checked and that have been resized. You must either replace text with text generated 
from one of the new text styles, or resize the text and add the annotation scale to it. 
(See below.) Again, by contrast, line styles automatically update when the file is opened. 

 

Annotation Cells  

Annotation cells obey the rules of the annotation scale. That is, when you place a cell with the 
annotation scale lock on, the current annotation scale scales the cell.  
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To convert standard ODOT cells into annotation cells: 

1. On the Model Properties dialog, check the Can be placed as annotation cell check box. 

 

2. Scale cells down by a factor of the scale at which they are designed to be printed. For 
example if a cell was normally placed at an active scale of 1 on a 1”=100’ plan sheet, you 
need to scale it down by a factor of 1200. All the annotation cells in the ODOT standard cell 
libraries have been scaled down. 

You can determine which cells are annotation cells on the Cell Library dialog. The annotation symbol 
appears under the Annotation column for a cell that you can place as an annotation cell. If no 
annotation symbol appears, then the cell cannot be placed as an annotation cell. 

 

Not every cell needs to be an annotation cell. Some cells need to be placed at their correct actual 
measured size no matter at what scale the plan sheet will be printed. For example, a signal pole with 
a 55-foot mast arm needs to measure 55 feet no matter at what scale the drawing is printed; 
therefore, you should place the cell as an actual scale not an annotation scale.  

To prevent cells from being placed incorrectly as annotation cells, uncheck the Can be placed as an 
annotation cell box on the Model Properties dialog.  
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Levels 

The standard ODOT levels have been modified to reduce the total number of levels and remove 
redundant levels.  

Levels read from a level library. As elements are placed in a file, the level those elements are placed 
on is written to the active file. This means that each level used in a file is written directly to that file. 
If elements are placed on a level that does not exist in a level library, there is no impact to the 
elements and levels already written to the DGN file.  

If files are referenced in and the references contain levels that no longer exist in a level library, the 
results are similar. As long as that level existed in the reference, the elements will display properly 
and the level they are on can be manipulated the same as any other level in a reference file.  

If you copy elements out of a reference file into a new file that does not contain the needed level, 
then the elements will be placed at the default level. To move those elements in the reference to 
other levels, you can follow the process shown in the section above titled “To save files in other 
formats in the Windows file system” and apply level mapping on the Remap tab for the Options. 
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Project Explorer 
Project Explorer allows you to manage Windows project data 
within MicroStation. Using it, you may open file locations in the 
Windows file system and launch other applications. The Project 
Explorer icon is on the main toolbar. 

You can use the drag and drop method to attach models or saved 
views as references and to load files into the Print Organizer for 
creating print definitions. When open, you can size Project 
Explorer to float over a view window in MicroStation. 

A link set named ODOT_DATA has been created that provides you 
with quick access to common locations in the Windows file system for 
storing data and your user configuration. 

For example, you can open Print Organizer and load the seed plan set 
file (F:\ODOT_DATA\USERCFG\plot\KeyNu.pset) at the same time. 

 

 
Note: Click the + signs to expand the folder hierarchy. 
Double-click a folder to open it in Windows Explorer. 

 

 

Click to open 
Project Explorer. 
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Print Function 
To print a view or fence area, select File > Print from the main menu bar to open the Print dialog.  

From the Print dialog, you may set up the properties of the print by selecting the printer or loading a 
printer driver configuration file. To apply Print Styles, select Settings > Print Styles. This will load pen 
tables and set paper sizes and scale. You may individually set all print settings, including rotation, on 
the Print dialog. As you make adjustments, the preview of the drawing adjusts accordingly. Once the 
preview appears as you desire, click the Printer icon in the upper left corner to send or create the 
print. 

 

 

 
Note: If you do not set a fence prior to opening the Print dialog, the ODOT Defaults print 
style (the one that always runs) will create a fenced area around the first border cell that 
was placed in the active model. To print the View, change the Area to View. 

 

You can use Print Organizer to create and save multiple print definitions and print styles for applying 
print property values like pen tables, paper size and scale.  

Using the ProjectWise Integrated Select … File Dialogs  

When File>Select Bentley Driver, Resymbolization>Attach Pen Table, or the magnifying glass icons 
for selecting the Printer Driver Configuration File or the Pen Table are chosen, and the active 
MicroStation design file is stored in a ProjectWise datasource, an integrated Select … File dialog 
appears.  The *.tbl and *.pltcfg files are stored in ODOT_space in the Windows file system, and 

Click to maximize 
scale. 

Enter the desired 
degrees to rotate the 
print’s angle to align 
with the view axis. 

Click to locate and 
attach a pen table or 
to detach a pen table. 
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cannot be loaded using the integrated dialog.  Click Cancel to open the Windows Select … File 
dialog. 

 

The Windows Select … File dialog will automatically open to the correct location for either printer 
driver configuration files or pen tables. 

Print Driver Configuration Files (PLTCFG) 

Printer driver (PLTCFG) files are configured to provide standard output sizes and file formats and are 
located in the ODOT workspaces. On the Print dialog, click the magnifying glass icon to load a Bentley 
driver. Cancel out of the integrated Select Printer Driver Configuration File dialog. On the Windows 
Select Printer Driver Configuration File dialog, select a driver or navigate into the Bentley_Supplied 
folder for other driver types not configured for standard ODOT use. 
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Table 4. Printer Driver Configuration Files 

Printer Driver Configuration File Function 

BDS_tiff_400DPI_G4.pltcfg Creates TIFF files in G4 format with 400 DPI for uploading 
into the Bridge Data System (BDS). 

emf_odot.pltcfg Use as alternative to “Create metafile” printer option to 
create encapsulated meta files that match line weights of 
images produced for ODOT manuals using MicroStation  V8 
2004. 

jpeg_400dpi_WhiteBkgrd.pltcfg Use to create .jpg format images with 400 DPI and white 
background. 

odotAB_printer.pltcfg Based on ODOT configured printer.pltcfg for line weights 
with only two paper sizes available, ANSI A (8.5x11) or ANSI 
B (11x17). 

odotCD_printer.pltcfg Based on ODOT configured printer.pltcfg for line weights 
with only two paper sizes available, ARCH C (18x24) or ANSI 
D (22x34). 

odotsizes_PDF.pltcfg PDF printer driver with ODOT line weights and only nine 
different paper sizes including the maximum 200”x200”. 

odotsizes_PDF_1inTo400ft.pltcfg PDF printer driver with fine line weights for clear zooming in 
on text with scales between 1”=300’ and 1”=400’. 

odotsizes_PDF_1inTo800ft.pltcfg PDF printer driver with very fine line weights for clear 
zooming in on text with scales between 1”=500’ and 
1”=800’. 

odotsizes_PDF_levels.pltcfg PDF printer driver based on odotsizes_PDF.pltcfg and with 
EnableOoptional Content=On and Print OptionalContent=As 
Created for creating PDFs with the ability to adjust displayed 
levels in a viewer, without affecting the print. 

printer.pltcfg Default printer driver configured for ODOT line weights. 

 

Print Definition Files (PSET) 

MicroStation Print can create and use a single print definition stored in a print set (PSET) file. If you 
are working in MicroStation DGN file that is stored in a ProjectWise datasource, when you execute a 
command to open or save a print definition file, you will invoke dialogs that are integrated with 
ProjectWise. See previous sections on “Using the ProjectWise Document Creation Wizards” and 
“Closing, Exiting, and Saving Files Stored in a ProjectWise Datasource” for more information. 
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Print Organizer creates and uses print set (PSET) files as a container to store print definitions. Print 
definitions are arranged in a hierarchical structure and may be placed into folder groups. 

A seed print set file has been created for use in assembling contract plans. KeyNu.pset is located in 
your F:\ODOT_DATA\USERCFG\plot folder and may be copied into your Windows project folders or 
imported into your project in a ProjectWise datasource. 

KeyNu.pset contains named folders that are in order of the sections that are found in plan sets. 
After creating print definitions, select File > Save As … on the Print Organizer dialog and save the 
print set file using the 5-digit project Key Number in the name. 

 

Print Styles 

Print Styles are available from a DGNLIB in the workspace. Some print styles set a PLTCFG, attach a 
pen table, and set paper size and scale. Some print styles will create fences for a print definition 
upon locating specific border cells that have been placed in files. 
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Table 5. Print Styles 

Print Style Function 

ODOT Defaults Creates fence locations around cells named Border_*, found 
in any model in the added file. Limit searched models by 
dragging and dropping specific models or saved views from 
Project Explorer. 

1Borders_In_Reference_Files_Only Use when creating print definitions to create fence locations 
around border cells found only in any model in files 
referenced into the added file. 

_PDF*_ODOT Use in Print dialog or Print Organizer to apply a pen table 
and odotSizes_pdf.pltcfg for PDF creation with paper size 
11x17 for Plans, 18x24 for Survey, and 22x34 for Bridge.  Use 
of a PDF print style is preferred. 

_PDF*_ansiA “PlansMaint” - use for Maintenance-type projects with 
8.5x11 sheet borders.  “SignShopGS_BW” and 
“SignShopGS_Color” – locate GuidSIGN cells named GSSHT 
and maximize to ANSI A paper size (11x8.5). 

_PDFXsections_11x17 Use in Print Organizer to create print definitions from 
InRoads cross section set borders. 

PrintPlansAB_ODOT Use in Print dialog or Print Organizer to apply plans.tbl and 
odotAB_printer.pltcfg for small format printing. 

PrintPlansCD_ODOT Use in Print dialog or Print Organizer to apply plans.tbl and 
odotCD_printer.pltcfg for large format printing.  Default 
system printer must be set to a large-format plotter. 

 

Pen Tables 

Pen tables may be attached to remap characteristics like color and weight.  A number of pen tables 
have been created for producing ODOT Contract Plans and other ODOT products. 

 

Table 6. Pen Tables 

Name Purpose 

plans.tbl Used for contract plans.  Turns everything black and gray 
shades existing features, except utilities.  Does not print 
construction class.  Outline color of closed elements in active 
model with fill color=255 (background) is changed to 
background.  Substitutes filename location text for actual file 
location if ODOT border cell is used. 



ODOT MicroStation® V8i User Guide 

March 2016 Oregon Department of Transportation 67 
Engineering Applications Support Team 

Name Purpose 

ITS_plans.tbl Similar to plans.tbl, except that it also gray shades existing 
utilities.  Does not print construction class. 

br_plans.tbl Similar to plans.tbl.  Bridge users may prefer it to increase line 
weights of proposed features.  Does not print construction 
class.  Outline color of closed elements in active model with fill 
color=255 (background) is changed to background. 

rw.tbl Used by Right of Way to turn everything black, gray shade 
existing features, and fill monuments.  Does not print 
construction class.  Outline color of closed elements in active 
model with fill color=255 (background) is changed to 
background.  Uses pen table section priority to control printing 
of shapes for recorded sale, fee, permanent and temporary  
easement. 

SignShopGS_BW.tbl Does not plot construction class elements. Does not plot level 
GSColorFill. Turns all elements and element fills to black.  Does 
not print construction class. 

SignShopGS_color.tbl Does not plot construction class elements. Does not plot level 
GSBWFill. Turns only elements and text in sheet report to 
black.  Prints GSCOLORFILL level in color. Does not print 
construction class. 

Surv_CRR_BW.tbl Used for plots that file survey control, recovery and 
retracement maps in counties that don’t allow gray shading.  
Does not print construction class.  Outline color of closed 
elements in active model with fill color=255 (background) is 
changed to background. 

Surv_CRR_GS.tbl Used for plots that file survey control, recovery and 
retracement maps, and gray shades existing topography.  Does 
not print construction class.  Outline color of closed elements 
in active model with fill color=255 (background) is changed to 
background. 

Surv_RWM_BW.tbl Used to file right of way monumentation maps in counties that 
don’t allow gray shading.  Does not print construction class.  
Outline color of closed elements in active model with fill 
color=255 (background) is changed to background. 

Surv_RWM_GS.tbl Used for right of way monumentation maps and gray shades 
existing topography.  Does not print construction class.  
Outline color of closed elements in active model with fill 
color=255 (background) is changed to background. 
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Name Purpose 

HeavyColor.tbl All elements with line weights from 0 to 7 will plot two line 
weights heavier. 

Yellowtoblack.tbl All elements with color 4 (yellow) will plot black.  Substitutes 
filename location text for actual file location if ODOT border 
cell is used. 
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Creating a PDF 
To create a PDF file from a single plan sheet: 

1. Open any design file that contains a plan sheet border. 

2. Place a fence around the plan sheet border.  

3. Select File > Print from the main menu. The Print dialog opens. 

4. Choose one of the following methods to print (A – uses print style, B – uses manual set up): 

A. Select Settings > Apply Print Style on the Print dialog main menu to open the Print – 
Apply Print Style dialog, select _PDFPlans_ODOT from the drop-down menu and click 
OK.  
 

 
 
The Print Style applies the PDF driver and the pen table, sets the paper size to 11x17, 
and maximizes the border to the paper. Click Print.  

 If you are working in MicroStation DGN file that is stored in a ProjectWise 
datasource, the Select a Wizard dialog will open. Select a wizard to save the PDF 
in the ProjectWise datasource.  

 

The resulting PDF will be saved in ProjectWise and the local copy will be opened 
in the PDF viewer. 

Select Cancel on the Select a Wizard dialog to save the PDF in the Windows file 
system.  You will need to navigate to your Windows directories. 

  If you are working in a MicroStation DGN file that is stored in a Windows 
directory, the Windows Save Print As dialog opens. Enter a new name and click 
Save. 

Select _PDFPlans_ODOT 
and click OK. 
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B. Select File > Select Bentley Driver (odotSizes_pdf.pltcfg) on the Print dialog main menu 
or select Bentley driver from the Printer and Paper Size drop-down menu. Verify Paper 
is set to 11x17 and Scale is set to 100.0000. Attach the plans.tbl pen table. Click Print. 
The Save Print As dialog opens. Enter a new name and click Save. 
 

 

 

 
Reminder: The *.tbl and *.pltcfg files are stored in ODOT_space in the Windows file 
system, and cannot be loaded using the integrated dialog.  Click Cancel to open the 
Windows Select … File dialog when manually loading printer driver configuration files or 
pen tables. 

 

Locate and attach, or 
detach a pen table. 
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Using Print Organizer to Create Print Definitions 
You can use Print Organizer to create and manage prints — both paper and digital. Print Organizer 
uses everything from the pen tables and printer driver configuration files to paper sizes and scales to 
automatically create print definitions for plan sheets. Much of the setup is performed automatically 
by choosing the desired Print Style during print definition creation. 

The available print styles either search for specific border cells, or rectangular shapes on a specific 
level, in the files you add into Print Organizer. Print definitions are created in the same order that 
the cells and shapes were placed into the model originally. It is the order of placement, not the 
location, that governs the order in which the print definitions are created. 

 
Note: You may use the Bring to Front command to change the order of placement of 
elements in a model. The Bring to Front command causes the element to become the 
last element placed in the file. 

 

 
Note: You do not have to select the ODOT Defaults print style as it always runs.  If you 
want to change your search for borders to only look inside referenced files for border 
cells, on the Create Print Definitions dialog select the 
1Borders_In_Reference_Files_Only print style and apply a PDF or paper print style later, 
inside Print Organizer, by selecting Tools > Apply Print Style. 

 

Print Organizer can be used to create a print set stored in a flat structure from a new, empty print 
set (PSET), or print definitions can be created inside a contract plans folder structure by using a print 
set seed file named KeyNu.pset.  KeyNu.pset is only stored in the Windows file system in your 
F:\ODOT_DATA\USERCFG\plot folder, making the two methods of creating print definitions shown 
below, with ProjectWise data or with Windows data, similar.  You will need to Cancel out of the 
integrated Open Print Set File dialog when working in ProjectWise, in order to load KeyNu.pset from 
your F:\ drive.  A shortcut named ODOT_User_Configuration has been placed in the Engineering 
folder on your Desktop to provide easy access to KeyNu.pset. 

Two methods are shown below. The first, with ProjectWise, will use KeyNu.pset.  The second will 
illustrate creating print definitions from Windows data in a flat folder structure. 

Creating Print Definitions from Data Stored in ProjectWise 

1. When working in a MicroStation DGN file that is stored in a ProjectWise datasource, Click 
the Print Organizer icon or File>Print Organizer… to open the Print Organizer dialog. 

 

  

Click icon to open 
Print Organizer. 
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2. Load the print set seed file KeyNu.pset by selecting File>Open in Print Organizer.  Cancel out 
of the integrated Open Print Set File dialog to open the Windows Open Print Set File dialog.  
Click the Desktop shortcut on the left side, and double-click to open the Engineering folder.  
Double-click on the ODOT_User_Configuration shortcut to get to the 
F:\ODOT_DATA\USERCFG folder. 

 

3. Open the plot folder, select KeyNu.pset and click Open to load the empty folder structure 
for a contract plans print set. 

 

4. Use File>Save As, select No Wizard, and click OK to open the Save Print Set File dialog. Save 
the empty folder structure to the appropriate folder in ProjectWise, using the key number in 
the name. 
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5. Select a sub-folder in the left window of the Print Organizer and choose File>Add Files to 
Set… to open the Create Print Definitions dialog, then click the Add button. 

 

 

Click Select to change 
the ProjectWise folder. 
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6. The Select Files dialog stays open while you navigate in the ProjectWise folder structure, if 
necessary, to Add files to the “Selected Documents” list at the bottom of the dialog.  When 
done adding files, click OK. 

 

7. On the Create Print Definitions dialog, click the magnifying glass icon. Select a print style, 
like _PDFPlans_ODOT, from the Apply Print Style dialog and click OK.  Finally, click OK on the 
Create Print Definitions dialog to search for borders and create print definitions. 

 

Navigate if necessary. 

Select files. 

Always select a Print Style. 
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8. The print definitions will be displayed in the Print Organizer.  Choose File>Save to save the 
print definitions and when you close the Print Organizer, Check In the PSET file. 

 

Print preview, sheet order, and renaming print definitions is covered below, in the next 
method of creating print definitions from data stored in the Windows file system. 

Creating Print Definitions in the Windows File System (using the Project Explorer) 

1. Open any design file in the Windows file system and then click the Project Explorer icon on 
the main tool bar to open Project Explorer. 

 
 
The Project Explorer dialog opens. 

2. Click the Print Organizer icon on the Extra Tools – Custom tool bar to open the Print 
Organizer dialog.  

 

3. From the F:\ODOT_DATA\USERCFG\plot folder in Project Explorer, select the KeyNu.pset, 
then drag and drop it into Print Organizer.  

4. In Project Explorer, navigate to your files that contain plan sheets, select the plan sheets, 
then drag and drop them into the appropriate folder in the left window pane within Print 

Click to open Project 
Explorer. 

Click icon to open 
Print Organizer. 
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Organizer. For example, drop files named *.dt* into the Details folder. 

 

 

The Create Print Definitions dialog opens. 

 

5. On the Create Print Definitions dialog, click the magnifying glass icon and select a _PDF 
Print style name and click OK to apply the print definition to the set of files. 

6. Drag the next set of files from Project Explorer into the corresponding Print Organizer folder 
on the left side and repeat step 5 to select and apply a print style to the set of files. Repeat 
until you have loaded all of the desired files that you want to include in your print set. 

Click the magnifying glass 
to select a _PDF Print 
style name, then click OK. 
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7. To preview the sheets in each Print Organizer folder, right click the sheet name in the right 
pane and select Print Preview from the drop-down menu.  

 

8. To change the sheet order in Print Organizer, select the sheet(s) to move in the right pane, 
then drag and drop or use the Move buttons to move the sheet(s), even into a different 
folder. 

9. To change a single print definition name to match sheet names or numbers, right click on a 
single print definition in the right pane and select Rename from the drop-down menu, or 
slowly double click on a single selection to highlight the print definition name for 
replacement.  

Drag sheet definitions or 
use the Move buttons to 
change sheet order. 
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Note: We specify the default print definition names by combining the word 
"Sheet" with the print definition number (PrintDefNumber). PrintDefNumber is 
counted from the topmost position beneath the root folder in the Print 
Organizer. This results in names like Sheet 1, Sheet 2, Sheet 3 and so forth. 

 
10. To rename multiple and sequential print definitions where a numeric sequence can be 

used to rename a group of sheets, make a selection set and choose Edit > Rename by 
Expression … from the Print Organizer main menu. 
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The Rename Print Definitions by Expression dialog appears. 

 

11. Click the drop down arrow and change Expression name to Custom. 

 
 
This activates the Specify Expression field to allow editing. The text inside the quotation 
marks is always used for each name. 

12. Edit the Expression name as follows: 
- Replace what's between the quote marks with the part of the name that repeats. Be sure 
to leave a space at the end, just before the closing quote mark. 
- Insert a mathematical expression to calculate the beginning number in the series. 
- Click Preview Names to open the Print Definition Names window and verify the print 
definitions are correctly numbered. 
- Click OK to rename the print definitions. 

 

Click down arrow 
and select Custom. 
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Note: To specify the mathematical expression to calculate the beginning number in a Print 
Definitions series, use the following formula: 

Number to subtract = PrintDefNumber - Beginning Number 

For the example shown below: 

1. Replace "Sheet "&System.String.Format ("{0:D1}", 
PrintDefinition.SetPrintDefNumber) with 
"2A- "&System.String.Format ("{0:D1}", PrintDefinition.SetPrintDefNumber-6) 

2. Click Preview Names … to confirm the formula works. If you don't like the names 
you see in the preview, close the preview and click Cancel. 

 

3. Click OK to save the print definition expression. 

 

Replace what's between the quotes with 
the part of the name that repeats (there is 
a space at the end). 

 

Insert a mathematical 
expression to calculate 
the beginning number 
in the series. 

Click Preview Names … to 
open the Print Definition 
Names window. 

Beginning 
number 

PrintDefNumber 
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13. After creating, ordering and renaming print definitions, save the print set:  Select File > Save 
As… on the Print Organizer main menu and navigate to your project folders and change the 
name of the seed KeyNu.pset to the project key number or name. This name will be used 
when creating a single PDF print job.  It is important to save prior to printing or creating 
PDFs. 
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Printing with Print Organizer 
Print Organizer has its own File History, allowing you to quickly open a print set for a project stored 
in a different datasource or folder or allowing you to create a new print set from the seed 
KeyNu.pset file. 

 

With Print Organizer open and a PSET file loaded, 

1. Select File > Print... on the Print Organizer main menu or right click on a sheet and select 
Print… from the drop-down menu to open the Print dialog. 

From 
ProjectWise 

The seed PSET file 
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2. For the Print Range, select All. 

3. In the Submit as field, select Single print job. 

4. Click OK to create one PDF file with all sheets. 

  

 

 
Note: Only populated folders in the Print Organizer create bookmarks in the resulting PDF. 

Small Format Paper Printing  

When you create print definitions, it is recommended that you choose a print style that creates 
PDFs.  If you would like to print to paper or mylar later, it is best to divert to a printer at print time.  
For small format paper printing, confirm that your default Windows printer has the paper size you 
want to print on. Then, when you choose the appropriate printer driver configuration file, the 
correct paper size will be set.  

Check Open print file 
after creation to open 
PDF after creating it. 

 

The Destination is to the 
folder that contains the 
open DGN file and the 
default PDF name matches 
the PSET file name. 



ODOT MicroStation® V8i User Guide 

84 Oregon Department of Transportation March 2016 
Engineering Applications Support Team 

 
Reminder: The Print Styles will apply the plans.tbl pen table and a PLTCFG file to control 
the type of printing. 

 

 
Note: The odotAB_printer.pltcfg printer driver configuration file automatically sets a 
paper size of ANSI B -11 x 17. 

 

To change from creating a PDF to printing 11x17 on a small format printer: 

1. Select File > Printer Setup… from the main menu on the Print Organizer dialog. 

 
 
The Printer Setup dialog opens. 

 

2. On the Printer Setup dialog, click the Browse button, select odotAB_printer.pltcfg and click 
Open.  

Browse, select 
odotAB_printer.pltcfg 
and click Open.  
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3. Click OK to close the Printer Setup dialog.  The Print Organizer refreshes to display the 
selected small format printer in the lower right corner; all other properties of the print 
definitions remain the same as they were. 

 

4. Select File > Print… to send the prints to your default printer. 

 

 
Note: Close Print Organizer without saving to retain the original PDF print definitions. 

  

The paper size and scale remain 
the same, while the updated 
printer path displays at the bottom 
of the Print Organizer window. 
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Large Format Paper Printing 

You may also change from small format PDF to large format paper or mylar after the print 
definitions have been created. For large format paper printing, confirm that your default Windows 
printer is set to a plotter and has the paper size you want to print on. Then, when you choose the 
appropriate printer driver configuration file, the correct paper size will be set.  

To change from creating an 11x17 PDF to printing 22x34 on a large format plotter: 

1. From the Control Panel, open the Devices and Printers window and set a plotter to be the 
default printer. 

 

2. Select File > Printer Setup… from the main menu on the Print Organizer dialog. 

3. Follow the steps shown in the Small Format Paper Printing section above to browse to the 
printer driver configuration files and choose odotCD_printer.pltcfg. 

4. Upon clicking OK on the Printer Setup dialog to accept the printer driver configuration file 
change, the paper size and scale will adjust to the larger format. The printer path to the 
plotter displays at the bottom of the Print Organizer window. 

Select Set as default printer.  
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5. Select File > Print… to send the prints to your plotter. 

Save the Print Definition File 

The PSET file contains all the information about the print definitions and can be reopened in Print 
Organizer for printing single sheets from the print set, for reprinting after revisions are made to 
content, or for applying a different print style to create check prints, PDF files or Mylar prints.   

The print definition file does not contain any information about elements in the file.  It does contain 
a fence location and when you request a print preview or a print, the source file is looked at to 
determine which elements are displayed within the fence location. When you save the PSET file, it 
records the fence locations, the path and name of the source files, the paper size and scale. 

 
Tip!   Only save one PSET file for a print set, even if you need to print digital and paper 
products.  Multiple print sets for the same project can lead to difficulty synchronizing 
sheet order, etc.  For a temporary change, select File > Printer Setup on the main menu 
bar.  It is recommended to save PDF print definitions for consistent paper sizes. 

 

 
Reminder: Saving changes to a print set takes two steps if your files are stored in a 
ProjectWise datasource.  First, use File>Save in Print Organizer, then select Check In on 
the Check In dialog when you close the Print Organizer. 
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Source File Data Preparation 

The files that contain the borders must have the last active view left print-ready.  Print-ready means 
the displayed levels and orientation of the last active view are ready for printing without rotation.  
Save the print settings with an active view rotated to align border cells with the view axes.  To do this, 
leave one view oriented to Top rotation, or Unrotated if 2D, and place borders in the unrotated view. 

 
Note: If the last active view had the view rotated with respect to the borders, you will 
get strange scales and rotated previews in the Print Organizer. 

 

 
Note: You can load Saved Views directly into the Print Organizer by dragging them from 
Project Explorer and dropping them into the Print Organizer window. 

 

Printing the File Location 

Many pen tables replace a string of text in the border cell with the location of the file.  When using 
Print Organizer, the full path to the file is also recorded in the properties of the print definition when 
it is created.  Sometimes the files that make up print set are renamed or moved to another folder.  
When the file is printed at a later date, the location will not be automatically updated and will 
display an incorrect file location on the print.  Find and Replace File Paths… can be used to correct 
the path. 

Manually replace the file paths by selecting Edit > Find and Replace File Paths… in Print Organizer. 

 

Fill out the Find and Replace File Paths dialog.  If a folder name has changed, all print definitions can 
be updated by selecting All print definitions.  After clicking OK, a message will display indicating 
how many print definitions were updated. 
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Now when Print Organizer applies a pen table that replaces a text string with the file location, it will 
read the Filename: field from the print definition Properties and display the corrected file location. 

Adding a Sheet to Print Organizer 

 
Occasionally you will need to add sheets to your .pset file. For most projects the following steps can 
be used to add sheets to Print Organizer. 

Standard Method to Add Sheets 

1. Open the file containing your existing sheet borders and add a border cells for the new 
sheets. 

2. Open your project PSET with Print Organizer.  Note that the project PSET may be in the Print 
Organizer file history. 
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3. With the correct folder active, use File>Add Active File to Set….  Select _PDFPlans_ODOT 

Print style.  This creates additional print definitions in Print Organizer (Sheet 7 through Sheet 
14 in this example).  

 

4. The last print definitions listed are the sheets just added to the DGN.  Preview the last print 
definitions to confirm that you want to add them (Sheets 13 and 14 in this example). 

 
5. Delete the other duplicate print definitions that were just created (Sheet 7 through Sheet 12 

in this example). 

Print definitions added to 
Print Organizer 
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6. Rename the print definitions. 
7. Save the print set. 

 
Reminder: Saving changes to a print set takes two steps if your files are stored in a 
ProjectWise datasource.  First, use File>Save in Print Organizer, then select Check In on 
the Check In dialog when you close the Print Organizer. 
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Model/File Method to Add Sheets 

For some large complex projects the previous method of adding sheets to Print Organizer may not 
be practical. In this case create a model or file just for the additional sheet(s) you want to add to 
Print Organizer. 

1. Add the border cell for the sheet to a new model or design file. 
2. Open your project PSET with Print Organizer.  The project PSET may be in the Print Organizer 

file history. 
3. In Project Explorer expand the design file and drag just the new model from Project Explorer 

into Print Organizer and apply a PDF print style.  This creates additional print definitions in 
Print Organizer (model named Additional Sheets in this example). 

 

4. Rename the print definitions. 
5. Save the print set. 

 

 

Note different model name, 
same file for added sheets. 

Note the model name is 
listed after the file name. 
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MicroStation Add-on Tools 
From the ODOT menu on the main menu, you can access MicroStation add-on tools and applications 
to use.  

 

AutoTURN 8.0 

AutoTURN 8.0 is used for vehicle turn simulation and swept path analysis. If installed, AutoTURN 8.0 
appears on the ODOT menu.  

 
Note: If you don’t have AutoTURN 8.0 installed, but need it, call the Computer Support 
Desk to request the tool. 

 

AutoTURN 8.0 stores vehicle data in the F:\ODOT_DATA\AutoTURN\database folder. You can import 
previous AutoTURN vehicle VLC and type TYP vehicle files into the database and export them from 
it. AutoTURN 7.0 vehicles must be exported. To share vehicle data, you must export the VLC and TYP 
files from the database of one user, and then import the vehicle files into the database of the 
second user.  

To import and export vehicle files using AutoTURN:  

1. On the AutoTURN toolbar, select the Vehicles icon.  

 
 
The Select Current Vehicle dialog opens. 

Select ODOT to view add-on 
tools and applications. 

Select Vehicles icon. 
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2. To share a vehicle, select the Library and the Vehicle Name to export out to VLC and TYP 
format, and click the Vehicle Export button.  

 
Note: The Vehicle Export button will not appear if custom vehicles are not 
listed. 

 
3. To import vehicles into the AutoTURN 8.0 database, click the Import Vehicle icon and 

select a VCL Vehicle file to import.  

 
Note: The TYP type file must be in the same folder as the vehicle file. If the TYP 
type file is not found, AutoTURN will report the name of the missing type file 
that needs to be in the same folder as the VCL vehicle file. The vehicle and type 
files must be in the same folder. Before importing, move your TYP files from the 
F:\ODOT_DATA\AutoTURN\ types user folder to the 
F:\ODOT_DATA\AutoTURN\vehicles user folder where the vehicles are typically 
located. 

 
4. On the Import Vehicle dialog, select the Library within the database in to which you want to 

import the vehicle. You can accept the default of Imported or enter your own library such as 
_ODOT.  

 

5. Click OK. The vehicle is imported and listed in the library.   

 
Tip! If you start your library name with an underscore (such as _ODOT, it will 
appear at the beginning of the library list so you will not have to scroll through 
the list to find it. 

 

Select a library name 
and click OK. 

Selected Library 

Selected Vehicle 

Vehicle Import  

Vehicle Export  
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Axiom Microsoft Office Importer 

The Axiom Microsoft Office Importer tool will produce native 
MicroStation graphics from Microsoft Word and Excel documents. You 
can import Word and Excel files into MicroStation using the tool, but it 
does not export from MicroStation back to the original Office format.  

  

Although you can’t export the graphic from MicroStation back to the original Office format, 
MicroStation stores a reference to the original Office document, which makes it easy to update a 
graphic if needed. Axiom Microsoft Office Importer works with Office Documents stored in 
ProjectWise the same as documents stored in the Windows file system. The settings (*.ini) files are 
located on a network drive and are not stored in ProjectWise.  

 
Warning: When updating an Excel or Word document that has been imported into 
MicroStation, open the document and make changes with the application or 
ProjectWise Explorer. After the server is updated, the updated document can be 
reimported with the Axiom Office Importer Manage or List Update command.  Avoid 
using the adjacent Edit Source which creates confusing error messages. 

 

Axiom Office Importer is only licensed to use at these ODOT offices:  

 Portland (Flanders only)  

 Salem (Region 2 and TLC) 

 Springfield  

 Roseburg  

 White City  

 Bend 

 Klamath Falls 

 La Grande   
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Custom Tools (Pipe Data Sheet) 

A workflow for preparing ODOT Pipe Data Sheets in Excel and importing them in to MicroStation is 
available. The Pipe Data Spreadsheet User Guide can be found on the EAST website. Even if you do 
not use the Pipe Data Sheet, you may get some ideas about using the Axiom Microsoft Office 
Importer. Additional training documents are also available for this tool. 

By default, Axiom Microsoft Office Importer loads a settings file called office.ini and stores it in 
F:\ODOT_DATA\USERCFG\data. You can make your own settings files to configure text, line, colors 
and weights to use when you import Office content into MicroStation. Additional settings (*.ini) files 
have been developed for the Pipe Data Spreadsheet and surveyor coordinate tables. 

The settings (*.ini) file does have a limitation: TrueType fonts are referred to by MicroStation font 
number rather than by name. TrueType fonts can vary between computers. A settings file created 
on one computer may need the TrueType fonts to be reselected when used on another computer. 

Descartes 

Descartes is used to process images, legacy documentation, point cloud data and digital terrain 
models (DTMs). If installed, it appears on the ODOT menu. After Descartes is launched from the 
ODOT menu, Descartes toolbars can be displayed and additional commands are available in the 
MicroStation Raster Manager.  

 
Note: If you need Descartes but don’t have it installed, call the Computer Support Desk 
to request the tool.  

 

GuidSIGN 6 

GuidSIGN 6 is for designing roadway signs. If installed, it appears on the ODOT menu.  

 
Note: If you don’t have GuidSIGN 6 installed, but need it, call the Computer Support 
Desk to request the tool. 

ODOT Sign Styles 

The ODOT sign style files that conform to MUTCD 2009 have 
the prefix _2009_ and should be used for new projects. The 
ODOT sign style files are copied to your computer from the 
workspace. Store your own custom styles that you develop for 
your projects in the F:\ODOT_DATA\GuidSIGN folder. The 
ODOT GuidSIGN Reports and Sheets are set as the default.   

The GuidSIGN panel styles are documented in 
ODOT_Custom_Panel_Styles_for_GuidSIGN.pdf which 
includes examples of each style. This PDF can be opened from 
the MicroStation Menu ODOT > ODOT Help > GuidSIGN Panel 
Styles. 

Consultants will find the GuidSIGN sign styles files on the local 
computer in the ODOT workspace, which by default is 
C:\ProgramData\odot_space\Standards\data\GuidSIGN. 
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GuidSIGN Toolbar 

GuidSIGN Templates and Export on the toolbar are not used. To save screen space, you can hide 
these icons; right click on the icon and uncheck the tool from the list. 

Style Locks 

GuidSIGN 6 provides horizontal and vertical locks for panel styles.  Horizontal locks snap to a left, 
center or right justification instead of just a single locked location. You will want to be careful that 
the text and legends are placed at the correct justification. Vertical locks allow text and legends to 
be placed at a top, center or bottom justification instead of a single locked location. The difference 
can be small as shown by the examples below: 

Top Snap  

Center Snap  

Bottom Snap  

You can use the Move Multiple Objects tool to correct a misplaced object. It also snaps to multiple 
lock locations like placing objects. 

 
Tip! For more information about how locks in GuidSIGN 6 work, contact the Sign Design 
Specialist at the ODOT Technical Leadership Center 

Old ODOT GuidSIGN Panel Styles 

When working on older designs using the standard ODOT GuidSIGN panel styles, you may get an 
error message “GuidSIGN cannot find the panel style…” because the style file is not available to the 
program. ODOT GuidSIGN users can find the older panel styles via the shortcut “Old 2009 GuidSIGN 
ODOT Panel Styles” in the Engineering desktop folder. Older ODOT panel styles are stored in the 
Old_ODOT_Panel_Styles folder below the yearly folder, with the standard panel styles. The older 
panel style can be then copied and pasted into the personal panel style folder on the F:\ drive e.g. 
F:\ODOT_DATA\GuidSIGN\Styles\2009. Even older MUTCD 2003 styles can be found on the local 
computer in C:\Program Files\Transoft Solutions\GuidSIGN 
6\Contents\Styles\2003\Old_ODOT_Panel_Styles folder. 

Consultants can find the older panel styles in the workspace which is typically located at 
C:\ProgramData\odot_space\Standards\data\GuidSIGN\Styles\2009\Old_ODOT_Panel_Styles. 



ODOT MicroStation® V8i User Guide 

98 Oregon Department of Transportation March 2016 
Engineering Applications Support Team 

InRoads Lite 

InRoads Lite is simply InRoads launched on demand within MicroStation from the ODOT menu, 
rather than from the InRoads desktop shortcut. InRoads Lite is provided as a convenience for 
simpler tasks. InRoads Lite does not load all of the tools such as Roundabouts, Data Acquisition and 
Civil Geometry. These tools are available when you use the InRoads desktop shortcut to launch 
InRoads V8i. 

gINT Civil Tools 

gINT Civil Tools is activated only after launching InRoads or InRoads Lite.   gINT Civil Tools can be 
used to extract information from a gINT database and uses a loaded InRoads alignment to allow 
placement of borehole locations in plan view.  Borehole profiles and cross sections can also be 
placed in InRoads profiles and cross sections.  Methods are described in a separate user guide on 
the EAST website in the MicroStation Drafting | Geology category of the Tips & Workflows – “Draw 
and Pattern Boreholes in Plan, Profile, and Cross Section using gINT Civil Tools”. 

http://www.oregon.gov/ODOT/CS/east/Pages/TipsAndWorkflows.aspx


ODOT MicroStation® V8i User Guide 

March 2016 Oregon Department of Transportation 99 
Engineering Applications Support Team 

MDL Applications 
You can load add-on applications written in MicroStation Development Language (MDL).  

To load an MDL application: 

1. On the main menu, select Utilities > MDL Applications or enter the key-in mdl load. This 
opens the MDL dialog. 

  

2. On the Available Applications list, select the MDL to load and click Load. The Available 
Applications list includes both standard MDLs bundled with MicroStation and MDLs in the 
ODOT Workspace.  

3. To assign a MDL application to a function key, select the function key.  In the Action field, 
enter mdl load followed by the application name.  For example: mdl load atool. 

Atool (Area Tool) 

File: (Workspace)\V8i\Standards\mdlapps\intelnt\Atool.ma  

Description: Allows you to identify, trace or place areas and measure them. You can place the 
resulting area measurements as text on the drawings.  

 
Tip! For more information about using the Atool, see the article Measuring Acreage 
with the Area Tools on the EAST website. 

Celltool (Cell Tool) 

File: (Workspace)\V8i\Standards\mdlapps\intelnt\Celltool.ma  

Description: Provides you with the ability to: 

 Place Active Cell with an interactive rotation angle. 

 Place Active Cell on a selected element with interactive rotation angle. 

 Place Active Cell on an element by partial deleting the target element to fit the cell. 

 Place multiple copies of the active cell along or offset from a selected element at a given 
distance between each copy. 

Select the MDL to 
load and click Load. 
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Cellutil (Cell Utility) 

File: (Workspace)\V8i\Standards\mdlapps\intelnt\cellutil.ma  

Description: Allows you to group cells in a grid to be placed in a design file. You can plot the grid to create 
a book of the cells. The dialog now displays the modification time date stamp of the Model or cell. 

Civtools (Civil Tools) 

File: (Workspace)\V8i\Standards\mdlapps\intelnt\civtools.ma  

Description: Designed for Civil/Site users. Opens a palette that allows you to place, label and modify 
3D linestrings as contours; set element elevations; place coordinates and marker elevations; and set 
level, symbology and size of all elements placed with civtools.ma. 

HSP – Highway Spiral 

File: (Workspace)\V8i\Standards\mdlapps\intelnt\hsp.ma  

Description: Places a clothoid spiral with inputs of beginning and ending radii and length; result is a 
curve with 64 vertices. This is a counterpoint to MicroStation's onboard Place Spiral: Clothoid on the 
Create Curves toolbar that uses initial and final degree of curve to create a B-spline curve with 4 poles. 

InfoSnap 

File: (Workspace)\V8i\Standards\mdlapps\intelnt\infosnap.ma  

Description: Provides element information in a banner next to the cursor. Ability to make those 
attributes active and reuse them for new elements. Gain full control over AccuSnap's balloon. 
Navigate across reference files and DGN models. Hide or shrink (and expand) MicroStation dialog 
boxes on cursor flyover. 

Bubble Tools  

The “bubble” or Place Note tools draw bubbles for Final Design (FD) Plans, Illumination, ITS 
(Intelligent Transportation Systems), Signals, Signing and Striping plans. Bubbles can be drawn with 
or without a leader line as shown in the examples below.  

 

The bubbles are orphan (no name) cells. The active scale is automatically set based on the 
annotation scale that is set for the model. Legend text and leader lines are separate from the cell, 
but are included in the same graphics group. Each tool has a help button that will open a web page 
to the current tool documentation for each tool 

The Signals and Striping bubble tools have predesigned bubbles and legend text. These are selected 
on the Note Type, Category and Note drop-down menus. 
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Table 8. Bubble Tool Keyin and Workflow 

Bubble Type Keyin Workflow 

Final Design Plans place notes fdplans Roadway > Notes > Bubble Notes 

Illumination place notes illumination Traffic > Illumination > Bubble/Notes 

ITS place notes its Traffic > ITS > Bubble Notes 

Signals place notes signals Traffic > Signal > Signal Plans > Bubble Notes 

Signing place notes signing Traffic > Signing > Sheets >Hex and Hex with Leader 

Striping place notes striping Traffic > Striping > Striping Notes > Bubble Notes 

 

 
Tip! The ODOT mdl is required for many drafting tools including the Bubble tools and 
Leader macros. If you have launched InRoads from a desktop shortcut instead of just 
MicroStation, you will receive errors and those commands will not run. 

“Unknown key-in or command” or “Execution failed at line 168. Error: 1702” 

It might be easiest to exit InRoads, then launch just MicroStation and if you need 
InRoads, launch it using ODOT>InRoads Lite. Alternatively, a key-in can be used leaving 
InRoads running and can be assigned to a function key. Key in: mdl load odot.  
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Macros and Other Tools 
Macro tools written in MicroStation Basic are available to use. Most of the macros are called by the 
tasks and workflows, so loading a macro directly may not be needed.    

To load a BASIC macro: 

1. Select Utilities > Macros > MicroStation BASIC from the main menu.  The Macros dialog 
opens.  

  

2. Select the macro to load from the Macro Name list and click Run. 

To activate a BASIC macro function key or key-in, enter macro and the application name, for 
example macro modz. 

Table 7. MicroStation BASIC Macros in the ODOT Workspace 

Macro Description 

AnchorM 
Places a guy line with an anchor. 
Usage: Select a cell for placement to be the anchor.  Activate the macro. 
<DP> to start the guy line. <DP> to end the guy line and place the anchor 
cell. 
Location:  Several ODOT Tasks that place a pole anchor.   

CkLev 
Check Level. 
Usage: Activate macro. Key-in the number of the level to be displayed (eg. 
For P_RDWY_ALIGN_Main key-in 348). <DP> to show the next higher level 
number or key-in another level number. Right-click to exit. 
Location: Not used in ODOT Tasks. 

Cleanup 
Restores state after another macro runs. Restores settings saved by the 
setup macro. 
Usage: Activate the macro. 
Location:  Called by most macros at exit; not intended to be used directly. 

Select the macro to 
run and click Run. 
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Macro Description 

CtlPntEd 
Change the text of a PI station flag generated by InRoads to match the 
ODOT standard. 
Usage: Place PI station flag with InRoads Horizontal Annotation with RW or 
Survey preference. Activate macro. <DP> on the PI text. <DP> again to 
accept. Right-click to exit. 
Location: Not used in ODOT Tasks. 

Emb 
Places an embankment line on earthwork diagrams for profile sheets and 
places text centered below the line. 
Usage: Activate macro. <DP> to begin embankment line. <DP> to end line. 
Enter the text. Macro repeats. Right-click to exit. 
Location: ODOT Tasks>Roadway>Profiles>Earthwork 
Brackets>Embankment. 

Exc 
Places an excavation line on earthwork diagrams for profile sheets and 
places text centered below the line. 
Usage: Activate macro. <DP> to begin excavation line. <DP> to end line. 
Enter the text. Macro repeats. Right-click to exit. 
Location: ODOT Tasks>Roadway>Profiles>Earthwork Brackets>Excavation. 

Leader1b 
Places a curved leader line with an arrowhead at one end. 
Usage: Activate macro without or with options – leader1b gives arc radius 
= active text height; leader1b /f gives 10’ arc radius; leader1b /v gives 130’ 
arc radius; leader1b /r=N gives N’ arc radius; leader1b /L gives sharp vertex 
and Project Limit Arrow.  Choose the type of arrow. <DP> to place tail of 
leader line. <DP> to place the angle point. <DP> to place the arrow head. 
Macro repeats. Right-click to exit. 
Note: arc radius is scaled by the active scale factor. 
Location: ODOT Tasks>Roadway>General>General Arrows. 

Leader2 
Places a leader line with arrowheads at both ends. 
Usage: Activate macro. <DP> to place one end of the leader line. <DP> to 
place the other end of the leader line. Macro repeats. Right-click to exit. 
Location: ODOT Tasks>Survey>Cadastral>Misc>Survey Double Headed 
Arrow. 

LWidth0 
Sets the custom line style width to zero.  Key-in: macro lwidth0. 
Usage: Activate the macro. 
Location:  Used in many commands in ODOT Tasks.   

LWidthOff 
Turns the custom line style width off.  Key-in: macro lwidthoff. 
Usage: Activate the macro. 
Location:  Not used in ODOT Tasks. 

ModClass 
Toggles an element's class between PRIMARY and CONSTRUCT modes, 
wasn't easily accessible. 
Usage: Activate macro. <DP> to select an element. Element’s current class 
is shown in the status area. <DP> to toggle the class or right-click to 
continue without toggling the class. Macro repeats. Right-click to exit. 
Location:  Not used in ODOT Tasks. 
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Macro Description 

Modz 
Modifies the Z values of all vertices of an element. 
Usage: Activate macro. Enter the new Z value. If there are selected 
elements or an active fence: click [Yes] to change the Z value of all selected 
or fenced elements; click [No] to manually select elements; click [Cancel] 
to quit – command exits after the change is made. If there are no elements 
selected and no active fence: click [OK] to select elements one at a time or 
[Cancel] to quit. <DP> to select each element and change its Z value.  
Command repeats – click [OK] to change another element or [Cancel] to 
quit. 
Location: ODOT Tasks>Roadway>General>Tools>Modify Elevation. 

North 
Places a north arrow (odot.cel, Arrow), automatically rotated to point 
north regardless of view rotation. 
Usage: Activate macro. <DP> to place the north arrow.  Macro repeats. 
Right-click to exit. 
Location: Not used in ODOT Tasks. 

RWcir 
Places Subdivision Block Number, Parcel Number or Access Point Symbol 
with a leader line. 
Usage: Activate macro.  If leader - <DP> on an element to place the end of 
the leader line; symbol will be rotated to match the element’s rotation. 
Type <Ctrl>+E to add a vertex to the leader if desired, then <DP> to place 
the vertex. Block and Parcel Number or symbol - <DP> to place the symbol.  
Macro repeats. Right-click to exit. 
Location: ODOT Tasks>Survey>Cadastral>Proposed R/W>Misc>File Parcel 
Number and Access Point Symbol, and ODOT 
Tasks>Survey>Cadastral>Properties>Subdivision Block Number. 

SecCor 
Places section corner monument with section numbers. 
Usage: Activate macro.  Enter upper-right section number. <DP> to place 
cell. Remaining section numbers are automatically filled in. Macro repeats. 
Click [Cancel] to exit. 
Location: ODOT Tasks>Survey>Cadastral>Monuments>Found Section 
Corner. 

SetTxScl 
Scales text width, height and line spacing by the active scale. 
Usage: Activate the macro. 
Location:  Used in many commands in ODOT Tasks; not intended to be 
used directly. 

Setup 
Saves current settings, gathers information and checks scale. 
Usage: Activate the macro. 
Location:  Called by every macro at startup; not intended to be used 
directly. 
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Macro Description 

SlabE 
Places a slope label given any two points and a vertical exaggeration 
factor.  Uses three possible switches to vary snap mode, vertical 
exaggeration, and set decimal format. 
Key-ins: macro slabe [/k or /n] [/d or /f or /t or /v] [/x] 
Snap modes: /k – keypoint or /n – nearest 
Exaggeration: /d – none or /f – 5 or /t – 10 or /vN – N (any number) 
Format:  /x – decimal 
Typical Usage: Assign key-in to function key.  Activate macro. If switches 
not specified, macro dialogs will request snap mode and exaggeration 
input, enter and click [OK]. <DP> on line to be measured, then <DP> again 
on another part of the line. The slope between the two points will be 
displayed in a text dialog. Type <Ctrl>+T to toggle the slope format 
between ratio, decimal, and percentage. <DP> to place the text at the 
same slope as the line. Macro repeats. Right-click to Exit. Type <Ctrl>+E 
before selecting the first point on a line to change the vertical 
exaggeration. 
Location: Not used in ODOT Tasks. 

TPDT 
Places traffic pattern shapes with patterns. 
Key-in:  macro tpdt [/s] (/s switch causes only the outline shape to be 
placed; shape can be patterned later using the Tern mvba.) 
Usage: Activate macro. Select the pattern type from the dialog and click 
[OK]. Place <DP>s to draw a shape. When shape is closed the pattern will 
be drawn. Continue to draw shapes or right-click to return to pattern 
selection dialog. Click [Cancel] to exit. Uses annotation scale for pattern 
scale. 
Location: ODOT Tasks>Traffic>Traffic Control>TCP Patterning: 

Place Patterned Shapes (TPDT) 
Place Shapes for Future Patterning (TPDT /s) 
Pattern Previously Placed Shapes (Tern.mvba) 

 

 

 
Tip! The ODOT mdl is required for many drafting tools including the Bubble tools and 
Leader macros. If you have launched InRoads from a desktop shortcut instead of just 
MicroStation, you will receive errors and those commands will not run. 

“Unknown key-in or command” or “Execution failed at line 168. Error: 1702” 

It might be easiest to exit InRoads, then launch just MicroStation and if you need 
InRoads, launch it using ODOT>InRoads Lite. Alternatively, a key-in can be used leaving 
InRoads running and can be assigned to a function key. Key in: mdl load odot.  
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Geographic Coordinate Systems 
A geographic coordinate system is a method for uniquely defining a location on the earth. The 
Oregon State Plane coordinate systems are examples of geographic coordinate systems. 

Many applications assign geographic coordinate systems (also known as projections) to the data 
that is related to a location in the world.   

 ArcGIS shapefiles include a file with a PRJ extension that contains information about the 

geographic coordinate system and the units the features will display in. 

 Various types of raster imagery (JPEG, GEOTIFF, TIFF) may either include the geographic 

coordinate information within the raster header information, or in a sister or world file text 

file. 

MicroStation V8i is able to project data with assigned coordinate systems (like shape files and raster 
imagery) into the same geographic coordinate system assigned to the vector data. You may hear 
people refer to this as “on the fly projection.”  For this functionality to work, a geographic 
coordinate system must be assigned to the model containing the MicroStation vector data.  The 
surveyors for the project can provide information about the correct geographic coordinate system 
to use.  Not all raster imagery includes geographic coordinate system information, so you may still 
need to manually copy, move and rotate the raster data to align with your vector data.   

 

 
Note: In MicroStation V8i, the geographic coordinate system is assigned to a model.  This 
means you could have several different geographic coordinate systems in one MicroStation 
DGN file.  Also, if MicroStation has to project a large data set on the fly, it will impact how 
quickly the data refreshes as you pan and zoom.  You may determine that it is better to save 
the data in the same geographic coordinate system as the vector data. 

The MicroStation seed files have an advanced resolution that is set to meters, but ODOT sets the 
file’s master and sub units to feet and inches. Do not change the settings of the advanced resolution 
because it will change the distance between elements in the file if it is not done correctly.  The 
geographic coordinate systems in the ODOT_Favorites library are set up with units set to metric to 
match the units of resolution in most ODOT seed files.   

The OR83_SSCGIS geographic coordinate system is set up with units of international foot because 
you will typically be setting it for raster or shape files that were created with foot units. 
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Assigning Geographic Coordinate System 
The ability to select or assign a geographic coordinate system enables you to bring data together 
from disparate sources. 

To assign or select a geographic coordinate system: 

1. Select Tools > Geographic from the menu bar and select Select Geographic Coordinate 
System from the drop-down menu. 

 

 
Note: If you select Open as Toolbox, the Geographic toolbox opens. Click the 
Select Geographic Coordinate System icon. 

 

The Geographic Coordinate System toolbox opens and lists the current system set in the model. 

 

2. Click the Geographic Coordinate Systems Library icon. The Select Geographic Coordinate 
System window opens from which you can access a library of geographic coordinate 
systems.  
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3. Select the geographic coordinate system that matches your vector data and click Ok. 

 

 
Note: If the geographic coordinate system is already set in another file (such as a 

basemap provided by a surveyor), click the From File  icon in the Geographic 
Coordinate System toolbox to open the Select Geographic Coordinate System Source 
dialog to select the file and set the coordinate system. 

 

  

Select the geographic coordinate 
system and click Ok. 
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Oregon Coordinate Reference System (OCRS) 

ODOT has developed a series of low-distortion map projection coordinate reference systems.  You 
can find the details about these on the ODOT Geometronics website at: 

http://cms.oregon.gov/ODOT/hwy/geometronics/Pages/ocrs.aspx 

ODOT_Favorites Geographic Coordinate Systems 

You can also find Oregon geographic coordinate reference systems typically used for datasets in a 
custom library called ODOT_Favorites. The naming conventions are: 

 Oregon Coordinate Reference System: OCRS_* 

 Oregon State Plane Zones, North and South with NAD83 datum: OR83_* 

 Oregon State Plane Zones, North and South with the HARN datum: ORHP_* 

 Oregon GIS Coordinate System designed for coverage of the entire state: OR83_SSCGIS* 

 Universal Transverse Mercator Projections that cover Oregon: UTM84* 

 

 

 

You can access other geographic coordinate reference systems in the MicroStation-provided library. 

http://cms.oregon.gov/ODOT/hwy/geometronics/Pages/ocrs.aspx
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Note: You can create custom geographic coordinate systems using MicroStation. For a 
geographic coordinate system that is not available in ODOT_Favorites or the Library, 
contact the Engineering Applications Support Team (EAST) for assistance.  

 

Once a geographic coordinate system is assigned to a model, the latitude and longitude can be 
displayed within MicroStation.   

To display the latitude and longitude: 

1. Select Tools > Coordinate System > ACS > Auxiliary Coordinates. 

2. Select (double-click) the Geographic Coordinate System in the Auxiliary Coordinates 
dialog.  It should appear below the line. 

3. Close the dialog box. 

4. Right click in the status bar area of the MicroStation interface (where the active level, 
locks and snaps are shown) and select Running Coordinates. 

5. Data point on the Running Coordinates and select the ACS Position Option. 
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The running coordinates at the bottom reflect latitude and longitude values.  The 
AccuDraw dialog displays the x, y and z coordinates. 
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Raster and GIS Files  
Raster data, including aerial photography and GIS data, is available from a variety of sources. It’s 
important you understand the raster and GIS data that you gather from others and use the 
information appropriately. Information you will want to gather before viewing the raster and GIS 
files includes: 

 Geographic coordinate system for the data 

 Units of measure  

 Accuracy 

 Use restrictions 
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Displaying Raster Images 
The ODOT GIS Unit maintains raster imagery on the following server: 

 \\wpdotfill13\gis\IMAGES in Salem 

Imagery is available in a wide variety of formats in different projections on this server.  Aerial 
photography, USGS scanned topographic maps (DRGs for Digital Raster Graphics), USGS orthophoto 
quads (DOQs), and USGS digital elevation models (DEMs) are available. 

Data in the gis\IMAGES folder includes:  

 Bypass_images 

 Climate 

 Color_IR 

 County_aerial 

 DOQs_00 

 DOQs_05_NAIP_UTM 

 DOQs_95 

 DRG100K 

 DRG250K 

 DRGs 

 ESRI 

 GRID_from10mDEM 

 Hillshade 

 Image_Servers 

 Land_Cover 

 LANDSAT 

 Misc_images 

 NAIP_CCM_2009 

 Relief_Images 

 Scnd_img 

 Urban_other 

 

The Oregon Explorer is an imagery portal (http://oregonexplorer.info/) you can use to either stream 
imagery or to download imagery as defined by the end user.  You can define the imagery format, the 
geographic coordinate system and the extents. 

 

file://///wpdotfill13/gis/IMAGES
http://oregonexplorer.info/
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To stream the imagery data from within MicroStation: 

1. Assign a geographic coordinate system to the model in which you will view the image. 

2. Open the Raster Manager dialog.  

3.  Select File > New > WMS from the main menu 

4. Paste the following URL in the Servers field at the top of the WMS Map Editor dialog, then 
press the <Enter> key: 
http://navigator.state.or.us/arcgis/services/Framework/Imagery_Mosaic2009/ImageServer
/WMSServer. 

5. From the Available Layers box (left-hand side), select Imagery_Mosaic2009 

6. Click on the Add to Map button below the available layer. 

7. Choose Save and Attach; name the XWMS file and Save. 

8. Complete the attachment by following the prompts and dialog boxes from the Raster 
Manager. 

 

http://navigator.state.or.us/arcgis/services/Framework/Imagery_Mosaic2009/ImageServer/WMSServer
http://navigator.state.or.us/arcgis/services/Framework/Imagery_Mosaic2009/ImageServer/WMSServer
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Note: The imagery is stored in the State GIS Service Center Geographic Coordinate system.  
If you are using a different coordinate system, then the imagery will need to be projected 
to the coordinate system in the model.  Consider which data set will take the most effort 
to project when setting up your models and the referencing.   

To reduce the time it takes to manipulate and pan: 

1. Create a model for the streamed imagery. 

2. Set the geographic coordinate system to OR83_SSCGIS_NAD83 Oregon GIS, 
International Foot. 

3. Set the geographic coordinate system in the model with the vector data. 

Reference the vector data model in the streamed imagery model with the option to re-
project. 

 

 
Warning:  Some WMS URLs have extra information that does not work with MicroStation.  A 
link like 
http://imagery.oregonexplorer.info/arcgis/services/NAIP_2011/NAIP_2011_IR_SL/ImageServ
er/WMSServer?request=GetCapabilities&service=WMS 
should have the question mark and following text removed before using with MicroStation. 
Use the Notepad++ text editor to remove the extra characters from the WMS URLs as in the 
example below: 
http://imagery.oregonexplorer.info/arcgis/services/NAIP_2011/NAIP_2011_IR_SL/ImageServ
er/WMSServer  

 

http://imagery.oregonexplorer.info/arcgis/services/NAIP_2011/NAIP_2011_IR_SL/ImageServer/WMSServer?request=GetCapabilities&service=WMS
http://imagery.oregonexplorer.info/arcgis/services/NAIP_2011/NAIP_2011_IR_SL/ImageServer/WMSServer?request=GetCapabilities&service=WMS
http://imagery.oregonexplorer.info/arcgis/services/NAIP_2011/NAIP_2011_IR_SL/ImageServer/WMSServer
http://imagery.oregonexplorer.info/arcgis/services/NAIP_2011/NAIP_2011_IR_SL/ImageServer/WMSServer
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Displaying SHP Files 
The ODOT GIS Unit maintains GIS Data on the following servers: 

 \\wpdotfpsr832\gis\DATA\shp in Roseburg 

 \\wpdotfpsr825\gis\DATA\shp in La Grande 

 \\wpdotfill13\gis\DATA\shp in Salem 

MicroStation can read GIS data stored in shape file format.  The shape files are further subdivided by 
the type of information they contain.  The GIS Unit can provide more information or you can refer to 
their web page located at 
http://transnet.odot.state.or.us/tdd/GIS/Shared%20Documents/Data.aspx.   

The ODOT GIS Unit shapefiles are typically stored in the State GIS Service Center Geographic Coordinate 
System.  In MicroStation this is listed as OR83_SSCGIS_NAD83 Oregon GIS, International Foot. 

 
Note: The shapefiles are stored in the State GIS Service Center Geographic Coordinate 
system.  If you are using a different coordinate system, then the data will need to be 
projected to the coordinate system in the model.  Consider which data set will take the 
most effort to project when setting up your models and the referencing. For example, if 
you are displaying contours within MicroStation and Wetland boundaries from a 
shapefile, it would be best to project the Wetland boundaries to the projection used for 
the contours. 

 

Although, ArcGIS Desktop is able to read DGN files, it will only display vector data stored in the 
default model, and it does not read the geographic coordinate system information associated with a 
model.  If intending to load DGN data into ArcGIS, you should attach the OR83_SSCGIS_NAD83 
Geographic Coordinate System to the MicroStation design file first. 

file://///wpdotfpsr832/gis/DATA/shp
file://///wpdotfpsr825/gis/DATA/shp
file://///wpdotfill13/gis/DATA/shp
http://transnet.odot.state.or.us/tdd/GIS/Shared%20Documents/Data.aspx
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User Customization  
You can customize your workspace by creating your own tools, toolboxes, tasks and workflows. 
Most of the user interface aspect can be modified to suit your own needs or preferences.  

You can customize any or all of the parts of the active workspace's user interface. Those aspects 
include tools, toolboxes, tasks, main tasks, menus, context menus, view pop-up menu, tentative 
pop-up menu and icons. 
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Customizing Your Workspace 
To customize your workspace and make user interface changes, you must work directly in your DGN 
library (DGNLIB) file. Your personal custom DGNLIB is located on your personal server share space 
(F: drive) at YourServerName\Userseng\LogonID\ODOT_DATA\USERCFG\Interfaces\MicroStation. 
The file name is LogonID.dgnlib where LogonID is your user Logon ID.  

Open your DGNLIB file:  

1. From within MicroStation v8i, Select Workspace > Customize from the main menu.  

 
 

2. The Customize dialog opens. Select File and then your LogonID.dgnlib. This will close any 

open files and load your LogonID.dgnlib file. 

 

 You are now ready to create or customize your workspace. 
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Creating New Toolboxes and Tools  
You can create and customize new tools on the Tools tab of the Customize dialog.  

 

 

To create a new toolbox and tool: 

1. On the Tools tab, expand User Tools and select your custom DGNLIB file from the list of 
DGN libraries. It appears as a blue V8 icon indicating you can make changes to it, but not the 
other DGN libraries.  
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2. With your custom DGNLIB file selected, click the New Tool Box icon on the tool bar. New 
Tool Box appears beneath your DGNLIB file.  

3. Select New Tool Box and enter a name for the toolbox.  

4. To create and add a tool to the new tool box, click the New Tool icon on the tool bar. New 
Tool appears beneath your new tool box.  

 

5. Select New Tool and enter a name for the tool.  

6. In the Properties panel at the bottom of the Customize dialog, you may build the 
functionality of the tool. Refer to the Help files within MicroStation for information on how 
to do this. 
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Copying Existing Tool Boxes and Tools 
You can create custom tool boxes and tools to fit your needs by copying and modifying standard 
MicroStation or DGN library tool boxes and tools on the Tools tab of the Customize dialog. You can 
copy entire tool boxes and tools from any DGNLIB file to your custom DGNLIB file, and then modify 
them.  

To copy and modify an existing tool box or tool: 

1. On the Tools tab, expand User Tools and select the DGNLIB file from which you want to 
copy a tool box or tool.  

2. Expand the DGNLIB file and select the tools or tool boxes you want to copy. Either drag 
them to the desired location in your custom DGNLIB file, or right click and copy the tools or 
toolboxes and paste them into your file. 

3. In the Properties panel at the bottom of the Customize dialog, you may modify the 
functionality of the tool box or tool. Refer to the Help files within MicroStation for 
information on how to do this. 

 

mk:@MSITStore:C:/Program%20Files%20(x86)/Bentley/MicroStation%20V8i%20(SELECTseries%203)/Documentation/MicroStation.chm::/ustnhelp331.html#P4EEC
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Viewing Custom Tool Boxes 
After you create custom tool boxes, you need to make them visible from the Tool menu on the main 
menu bar. 

To view a custom tool box and its tools: 

1. Select Tools > Tool Boxes on the main menu. The Tool Boxes dialog opens. 

 

2. On the Tool Boxes dialog, scroll through the listed Toolboxes/Frames until you find the tool 

box you created. 

3. Check the box in front of the tool box and click OK.  

Like all tool boxes, you can dock any custom tool box on the edge of your MicroStation window. 
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Creating Custom Tasks and Workflows 
You create custom tasks and workflows on the Customize dialog.  

To create a custom task or workflow: 

1. On the Customize dialog, click the down arrow on the Tasks bar to expand the Tasks panel.  

 

2. Under User Tasks, select your LogonID.dgnlib file.  

3. From the Tools tab, select a tool box, then drag and drop it in your LogonID.dgnlib file in the 

Tasks panel. The toolbox becomes a task; any tools contained inside it are inside the task.  

4. The task may not open so it may have to be opened with a keyin. Keyin the command 

tasktoolbox open mytaskname where “mytaskname”is the name of the task you created. 

 
Tip! A workflow is a task with the Treat Task as Workflow property set to True. One 
advantage to making tasks into workflows is that a workflow can contain many 
subtasks that will show up in your panels where a task cannot. 

 
You may also customize Main Tasks, the Menu Bar, Context Menus, View Popup Menu and 
Tentative Popup Menu functions from the Customize dialog.  

For more information on creating tasks and workflows, or customizing your workspace, refer to 
vendor-provided training documents or the MicroStation Help files.  
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Appendix A. Using MicroStation V8 2004 file in MicroStation V8i 
MicroStation V8 2004 files will open directly into MicroStation V8i without any conversion process. 
The file will look similar to what is expected with a few exceptions. The exceptions are caused by 
Annotation Scale.  

If early in the project phases, you may want to totally update your files to MicroStation V8i 
standards and adopt Annotation Scale. To do that, you will need to make several changes to the 
model properties as well as possible changes to the line style, text and cells in the model. 

Line Styles  

Any custom line style patterning will appear very small, such that the lines appear as single 
continuous lines.  

To correct the line styles: 

1. Open the Model Properties dialog. 

 

2. Select the Annotation Scale drop down and choose the appropriate scale (usually 1”=100’). 

 



ODOT MicroStation® V8i User Guide 

March 2016 Oregon Department of Transportation 125 
Engineering Applications Support Team 

3. From the Line Style Scale drop-down menu, select Annotation Scale. 

 

4. Click OK.  

 

 
Note: Print borders placed with Plotypus in MicroStation V8 2004 will be found and 
presented for printing by the Print Organizer using ODOT print styles.  Once the line 
styles look correct, you will be able to print without placing fences. 

 

 
Note: You may have existing references to MicroStation V8 2004 files whose line styles 
do not display correctly. To correct this, edit the reference attachment settings by 
clicking on the Display Raster References icon at the bottom of the References dialog 
and then reopen the active file.  After reopening the active file, the referenced line styles 
will display correctly. 

 

5. Zoom Out or Fit the View. 

a. If very large text or cells are seen, use Edit > Undo to undo setting the model 
properties,  

b. then use Annotation Scale Select to select all of the text and cells in the model that 
have that Annotation Scale attribute set to True, 

c. finally, use Remove Annotation Scale to set the Annotation Scale attribute to False 
for the selection set, and perform steps 1 through 4 again before proceeding. 

  

b.  Select Annotation 
button. 

c.  Remove Annotation 
button. 
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Cells  

Cells placed from the custom ODOT tasks and workflows will appear too small. You may use 
different methods to correct the appearance of cells in the older 2004 file. The method chosen 
depends primarily on what use you have for the file. 

Detach any old cell libraries to ensure that new cells placed in your file will be from the correct 
library and annotatable.  

To detach old cells:  

1. Select Elements > Cells from the MicroStation menu to open the Cell Library dialog. If the 
dialog is empty and the title bar indicates NONE, there are no old cells to detach. 

 

2. If a list of cells appears in the Cell Library dialog, and the title bar indicates a cell library is 
attached, select File > Detach. 

 

If empty and title bar 
displays [NONE], then no 
old cells exist to detach. 
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3. In the Place Active Cell dialog, uncheck the Scale Annotations check box. 

 

4. Save the design file settings using File > Save Settings or Ctrl+F. 

5. Replace cells, if desired. If you placed cells in an old MicroStation V8 2004 file, they will not 
respond to Annotation Scale. You may either leave them (provided they were placed at the 
correct size) or update them with the new cells set up to respond to Annotation Scale.  

6. To update the cells, use the Replace Cells tool on the Cells Toolbox on the Drawing Task. 

 

7. Use Method Update and Mode Global. Select each cell used in the file and update it with 
the corresponding new cell. 
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Text 

Text may not be noticed until you try to place text from the ODOT Tasks and Workflows. Text placed 
from these tasks, invokes a text style with Annotation Scale enabled. This may cause new text to be 
placed very small in a new file. There are a few different ways to correct the appearance of text in 
the older 2004 file. The method chosen depends primarily on what use you have for the file. 

Update text, if desired. Annotation Scale uses Text Styles. Several text styles respond to Annotation 
Scale. If desired, you can modify your text to match the correct text style. Use the Change Text 
Attributes tool in conjunction with selection sets to accomplish this. An alternate method might be 
to simply toggle on the Annotation Scale check box in the Change Text Attributes tool and not 
associate a style. 
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Appendix B. How to Use Serval Application 
Serval provides a shortcut to a VB application that is contained in the engineering workspace. It 
allows you to connect to another user’s data space, ODOT_DATA\Projects, on a server. You do not 
need to know which server the data space resides on.  A connection to another user’s \share folder 
may also be made without knowing the PC name. 

Serval uses several other processes to combine attributes of employees, so that it is only necessary 
to know an employee’s last name.  The attributes are full name, userID, homeshare (server), 
computer name, and computer description in Active Directory.  The processes that combine the 
attributes are run separately on a Ctrl-M server.  They automatically run at 6:30 a.m. each weekday.  
The results are replicated out to two text files in the engineering workspaces on 20 servers 
throughout the state. 

 
Note: Changes to computer descriptions and homeshare servers are not immediately 
seen in Serval, but are updated shortly after 6:30 a.m. the following weekday. 

 

Accessing Files From a User’s ODOT_Data\Projects Folder on a Server  

Follow steps 1 through 4 below.  An Explorer window will open showing the other user’s 
ODOT_DATA server share.  Retrieve the desired files using standard drag and drop actions. 

 

 

 

 

 

 

3. Select a Map 
Drive (optional). 

The Connection 
Status updates. 

4. Click Connect to 
process. 

Check the Open in Windows Explorer box if 
you want the folder to open in Explorer. If you 
do not select a Map Drive, this is automatically 
checked and cannot be unchecked. 

1. Select the Download 
files from … option. 

2. Select User Name 
from the drop-down 
menu. 

Click Close to close 
Serval. 

The Server/PC Path lists 
the server. 
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Placing Files in User’s Local PC:\Share Folder 

Follow steps 1 through 4 below. An Explorer window will open showing the other user’s c:\share 
folder.  Place the desired files using standard drag and drop actions. 

 

 
 

FAQ and Troubleshooting Information 

Q:  Why doesn’t my name and computer in the User Name list?  

A: The list is generated from the General Description in the Active Directory account.  Your 
computer account may have someone else’s name, Vacant or Crew Share listed as its 
description.  Vacant and Crew Share are filtered out from the drop-down list. 

Troubleshooting: 

Contact the Computer Support Desk, FSU Technician or Engineering Support personnel to 
correct this problem using Active Directory Users and Computers or Hyena.  It is not 
necessary to log on to the machine or even have it powered on.  Open the Properties dialog 
for the computer using either tool.  In Active Directory Users and Computers, on the 
General tab, enter Lastname, Firstname of the current user in the Description field.  In 
Hyena, on the Directory tab, enter Lastname, Firstname of the current user in the 
Description field.  

 
Tip! The browser comment (net view) can be updated using Hyena and the 
computer properties. The browser comment is on the General tab in Hyena; a 
computer needs to be powered on and connected to the network to edit this 
field. 

 

 
Note: Serval does not use the browser comment. 

 

Q: Why do the names of people who no longer work for ODOT appear in Serval?  

4. Click Connect 
to process. 

3. Select Map 
Drive (optional).  

2. Select User Name 
from the drop-down 
menu. 

1. Select Connect to 
user’s PC:\share 
folder. 
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A: You may see a person’s server share (ODOT_DATA\Projects) folder because their files were 
not unshared when they left state service.  You may see a PC:\share folder associated with a 
person who is gone because the Active Directory account properties for the computer were 
not updated to Vacant or a new user status. 

Troubleshooting: 

See the Troubleshooting for the prior question for a PC:\share folder still associated with a 
person who has left state service or changed crews.  Update the Description to Vacant if 
computer is not used.   

For a server share folder that is still seen or is in the wrong location, a common problem is 
that a Computer Security Delete User or Update User Request was never submitted for the 
person.  These names and user IDs can be submitted to Computer Security, but if a User 
Request was never submitted, that situation will have to be rectified by the previous 
employee’s last known manager. 
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Appendix C. Viewing Raster and GIS Data 

ODOT Tutorials 
A set of ODOT tutorial files can be provided to you for learning about how Geographic Coordinate 
Systems are selected in MicroStation V8i SELECT Series 3. 

Several different files are provided in this example set.  The files are from different sources and 
different Geographic Coordinate Systems may be associated with each file. 

 

Table 9. Example Set Files 

Folder/File Name Source Format Projection Units 

DouglasCounty Douglas 
County 

SHP State Plane South International 
Feet 

GISU_CountyMap ODOT GISU DGN OGIC International 
Feet 

GISU_ShpFiles ODOT GISU SHP OGIC International 
Feet 

MetroImage Portland 
Metro 

TIF State Plane North  (SPC 
5076) 

International 
Feet 

OregonCoastOCRS Region 3 
Survey 

DGN OCRS Oregon Coast International 
Feet 

PortlandOCRS Region 1 
Survey 

DGN OCRS Portland International 
Feet 

CombinedFactor Region 3 
Survey 

DGN LDP International 
Feet 

 

Other files include: 

 OregonExplorer.xwms: Connection to Web Mapping Service (WMS) for raster imagery 
supplied by Oregon Explorer 

 Example_NoCoordSystem.dgn: Empty file with no coordinate system set 

 Example_SPN: Empty file set to State Plane North, NAD 83 and International Feet 
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Tutorial 1. Set DGN File to Project Reference Data “On the Fly” 
 

1. Open the file …\ODOTExampleData\Example_OCRSSalem.dgn. 

2. Select Tools > Geographic > Select Geographic Coordinate System and set the Geographic 
Coordinate System to OCRS Salem.   

3. Click the second icon from the left From Library.  From the ODOT_Favorites Folder, locate 
the Geographic Coordinate Systems set up for the Oregon Coordinate Reference System 
(OCRS) and other coordinate systems typically used at ODOT.   

4. Click OCRS_SLE – Salem Zone to review the Coordinate System parameters. You won’t be 
able to edit them. If wrong, contact the Engineering Application Support Team (EAST). 

 

5. Click Ok to set up the DGN file with the selected coordinate system. The Geographic 
Coordinate System dialog updates with the selected coordinate system. 

 

 



ODOT MicroStation® V8i User Guide 

134 Oregon Department of Transportation March 2016 
Engineering Applications Support Team 

6. Open the Reference dialog and attach the files ...\DouglasCounty\Township.shp, 
...\GISU_ShpFiles\counties.shp and ...\GISU_ShpFiles\state.shp. 

 
Note: Be sure to change Files of type to either All Files (*.*) or Shape Files 
(*.shp). 

7. In the Reference Dialog Settings, change the Orientation View to Geographic - Reprojected. 
The Township.shp file from Douglas County appears within the Douglas County border. 

8. Add ... GISU_CountyMap\doug1.dgn file. The Orientation View option Geographic – 
Reprojected is not listed.  You will have to set the Geographic Coordinate System up so that 
MicroStation V8i SELECT Series 2 will recognize it. 

9. Open the doug1.dgn file and assign the Geographic Coordinate System titled OR83-SSCGIS – 
NAD83 Oregon GIS, International Foot from the ODOT_Favorites library and Save Settings. 
 
You can also navigate through the folders Library > Projected (northing, easting, _) > North 
America > United States of America > Oregon to find it. 

10. Use the arrow in the lower left to return to the Example_OCRSSalem.dgn file. 

11. Reference in the DGN file ...\GISU_CountyMap\doug1.dgn. The Orientation View option 
Geographic – Reprojected is listed. Select it and when the reference file loads it should line 
up with the shape files. 

12. To add DGN files surveyed in OCRS coordinates, set the Geographic Coordinate System in 
the files in order to use the Geographic – Reprojected view. 

13. Open up the file …\OregonCoastOCRS\EX_OregonCoastOCRS.dgn.   

14. From the ODOT_Seed library, select OCRS_ORC – Oregon Coast Zone and click Ok.   

15. Open the Example_OCRSSalem.dgn file, and reference in the 
...\OregonCoastOCRS\EX_OregonCoastOCRS.dgn file with the Orientation View set to 
Geographic – Reprojected.  If file is hard to see, turn off the display of doug1.dgn and zoom 
to it.   
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Tutorial 2. Reproject DGN File From One Coordinate System to Another 
 

 
Note: You cannot change units using this method, even if the dialogs suggest you can. 

You may wonder why you would want to do this since MicroStation will project on the 
fly.  I’m not really sure why either, once everyone is using MicroStation V8i in ODOT.  

There are likely some glitches in how the reprojection technique works.  Take a look at 
what happens when you edit a text node, drop cells, or check to see if your leader lines 
and dimensions are exhibited correctly. 

 

1. Make a copy of the file ...\ODOTExampleData\OregonCoastOCRS\EX_OregonCoastOCRS.dgn 
and rename it EX_OregonGIS.dgn. You’ll transform the file into this coordinate system.   

2. Open the file EX_OregonGIS.dgn. 

3. Select Tools > Geographic > Select Geographic Coordinate System.   

 
Note: The Geographic Coordinate System should already be set in this file as 
you set it in Tutorial 1. 

4. Click on the second icon from the left From Library. In the ODOT_Favorites, click on 
OR38_SSCGIS and click OK. 
Or, navigate to the Coordinate System titled OR83-SSCGIS by selecting Library > Projected 
(northing, easting, _) > North America > United States of America > Oregon and click OK. 
The Geographic Coordinate System Changed dialog opens. 

 

5. Select Reproject the data to the new Geographic Coordinate System and click OK.  
The Current Geographic Coordinate System information in the Geographic Coordinate 
System dialog will change to reflect the Geographic Coordinate System now set in the file. 
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6. Edit the file information to reflect that the coordinates are associated with a different 
Geographic Coordinate System. You could update the File Properties, add text in the title 
block area describing what you did, edit the existing text, by updating the table.   

7. Click the Remove the Coordinate System icon with the red X to verify the coordinates really 
did change, and that the Geographic Coordinate System is not being used to “project on the 
fly” when you reference in another file drawn in the NAD83 Oregon GIS, International Foot 
Geographic Coordinate System.   

 
Note: In the future when you reproject files, you may skip this step. 

8. Click Save Settings. 

9. Reference the file ...\ODOTExampleData\GISU_CountyMap\doug1.dgn.  Choose the 
Orientation Coincident – World view.  The files should match up. 
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Tutorial 3. View Geographic Coordinates (Latitude and Longitude) 
 

1. Open the file ...\ODOTExampleData\OregonCoastOCRS\EX_OregonCoastOCRS.dgn. 

2. Select Tools > Geographic > Select Geographic Coordinate System and confirm the 
Geographic Coordinate System is set to OCRS Oregon Coast.   

3. Go to Tools > Coordinate Systems > ACS > Auxiliary Coordinate Systems. Two auxiliary 
coordinate systems should appear (View 1 and OCRS Oregon Coast).  

 

4. Double-click OCRS Oregon Coast to activate it. 

5. Close the Auxiliary Coordinates dialog. 

6. Right-click in the status bar area of the MicroStation interface (where the active level, locks 
and snaps are shown) and select Running Coordinates. 

7. Data point on the Running Coordinates and select the ACS Position Option. 

 
Note: Your image will be different than the own shown below as you selected a 
different geographic coordinate system. 
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The running coordinates should appear at the lower edge, reflecting latitude and longitude 
values.  The AccuDraw dialog displays the x, y and z coordinates.   
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Tutorial 4. Set DGN File in LDP to Align with Data in Other Coordinate Systems 
 

1. Create a new file and call it ...\ODOTExampleData\CombinedFactor\StatePlaneSouth.dgn. 

 
Note: This will be an empty file that you will reference a CAD file set up in an 
LDP into.  Text in the file reports:  
“Basis of Bearing:  Oregon South Zone, NAD_83(91)  
Coordinates shown are LDP Coordinates.  
Vertical Datum based on VNAVD88 elevations 
To convert LDP Coordinates to SPC ORS, multiply LDP Coordinates by 
0.99987087. 

2. Select Tools > Geographic > Select Geographic Coordinate System to set the Geographic 
Coordinate System to match.   

3. Click the second icon from the left From Library.  From the ODOT_Favorites Folder, select 
the Geographic Coordinate System listed as ORHP_S.  Click OK. 

4. Add a text box in the file that describes the purpose of the file and the coordinate system it 
has been set up with.  For example: 
 
This file 15186E_SPS.dgn was assigned the Coordinate System Oregon South Zone, 
NAD_83(91) using MicroStation V8i Select Series 2 for the purpose of demonstration. The file 
15186E.dgn was referenced in at a scale of master(ref) of 1(0.99987087). 
You can reference this file into other files set up with a coordinate system. 

5. Reference in the file ...\ODOTExampleData\CombinedFactor\15186E.dgn with the 
Orientation set to Coincident – World Global Origin Aligned with Master File and the Scale 
(Master: Ref): set to 0.99987087:1.  

 
Note: After it is referenced in, MicroStation will set the Ref to 1 and the Master 
to the correct value. 

6. Merge the reference file into the master. 

7. Open the file ...\ODOTExampleData\EX_OregonCoastOCRS.dgn. 

8. Reference in the file you just created 
...\ODOTExampleData\CombinedFactor\StatePlaneSouth.dgn with the Orientation set to 
Geographically Reprojected. 
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9. Confirm that the reference file appears in the correct location relative to the other 
reference files. 
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Tutorial 5. Raster Imagery  
 

 
Note: It helps to know something about the coordinate systems and the imagery, 
before you get started.  Open the XML files associated with the images to review 
information about the image including coordinate system and unit details. 

 

2s1w10u.tif 

There is a sister file (with the TFW extension), but you need to know the units for the file.  The XML 
file contains information about how the file was created. It states that the image units are 
international feet. 

horizsys> -<planar> -<gridsys> <gridsysn>State plane coordinate system 1983.</gridsysn> -<spcs> 
<spcszone>5076</spcszone> </spcs> </gridsys> -<planci> <plance/> <plandu>International 
feet</plandu> </planci> </planar> -<geodetic> <horizdn>North American Datum of 1983/1991 
(HPGN)</horizdn> 

 

Multnomah.sid 

This file also has a sister file (SDW) and an XML file which reports units are set to meter. The XML file says: 

<SRS>PROJCS["UTM Zone 10, Northern 
Hemisphere",GEOGCS["NAD83",DATUM["North_American_Datum_1983",SPHEROID["GRS 
1980",6378137,298.257222101,AUTHORITY["EPSG","7019"]],TOWGS84[0,0,0,0,0,0,0],AUTHORITY["
EPSG","6269"]],PRIMEM["Greenwich",0,AUTHORITY["EPSG","8901"]],UNIT["degree",0.01745329251
99433,AUTHORITY["EPSG","9108"]],AXIS["Lat",NORTH],AXIS["Long",EAST],AUTHORITY["EPSG","426
9"]],PROJECTION["Transverse_Mercator"],PARAMETER["latitude_of_origin",0],PARAMETER["central
_meridian",-
123],PARAMETER["scale_factor",0.9996],PARAMETER["false_easting",500000],PARAMETER["false_
northing",0],UNIT["Meter",1],AUTHORITY["EPSG","26910"]]</SRS> <GeoTransform> 
5.0455100000000000e+005, 1.0000000000000000e+000, 0.0000000000000000e+000, 
5.0666120000000000e+006, 0.0000000000000000e+000,-
1.0000000000000000e+000</GeoTransform> -<Metadata> <MDI 
key="GEOTIFF_CHAR__GTModelTypeGeoKey">ModelTypeProjected</MDI> <MDI 
key="GEOTIFF_CHAR__GTRasterTypeGeoKey">RasterPixelIsArea</MDI> <MDI 
key="GEOTIFF_CHAR__ProjLinearUnitsGeoKey">Linear_Meter</MDI> <MDI 
key="GEOTIFF_CHAR__ProjectedCSTypeGeoKey">PCS_NAD83_UTM_zone_10N</MDI> <MDI 
key="GEOTIFF_NUM__1024__GTModelTypeGeoKey">1</MDI> <MDI 
key="GEOTIFF_NUM__1025__GTRasterTypeGeoKey">1</MDI> <MDI 
key="GEOTIFF_NUM__1026__GTCitationGeoKey">IMAGINE GeoTIFF Support 

 

  



ODOT MicroStation® V8i User Guide 

March 2016 Oregon Department of Transportation 143 
Engineering Applications Support Team 

EX_PortlandOCRSrw_set.dgn 

 

1. Open the file ...\EX_PortlandOCRSrw_set.dgn.  The coordinate system has already been set 
in this file.  Shapefiles have been referenced in to provide a frame of reference. 

2. Preferences affect how raster files open in MicroStation V8i. It helps if you know something 
about the raster data that you want to view.  First, you will reference in a TIF file from 
Portland Metro.  The “sister file” with a TFW extension is associated with it and the units are 
set to international feet.  To set the Preferences correctly, select Workspace > Preferences 
and the category Raster Manager.  Set your settings as shown below.  

 

3. Open Raster Manager and choose File > Attach > Raster.  Navigate to the file 2s1w10u.tif 
and click Open.   
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4. In the Raster Attachment Options dialog, expand the Geometry category and change the 
GeoPriority option to Sister File and click Attach. 

 

5. In Raster Manager, right-click on the file and choose Coordinate System > Select from 
library. 

6. Choose ORHP-NIF – HARN (HPGN) Oregon State Planes, North Zone, International Foot.  
Add it to your favorites if you typically use raster files provided by Portland Metro. 

7. Select Fit View and zoom in to compare the vector data to the raster data.  It should match 
up fairly close without needing to rotate, move or scale the raster image. 

8. Add a large MrSID image by detaching all of the images to make things display more quickly.  
Change the Preferences for Raster Manager again as shown below: 
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9. In the Attachment setting, change GeoPriority to Sister File, and change Inherit GeoCS from 
Model to Not Inherited; it should line up with Multnomah county boundaries.   

10. Right-click on the file in Raster and select Geographic Coordinate System. 

 
Note: As the imagery is being reprojected, it may take awhile to display as you 
zoom in and out. 

 

11. Detach the raster references again. 

12. Try a Web Mapping Service (WMS).  This one is from the Oregon Explorer portal that is 
located at OSU.  The parameters are set in a file titled OregonExplorer.xwms.   

13. In the Raster Manager dialog, select File > Attach > WMS and navigate to 
...ODOTExampleData\OregonExplorer.xwms.  Select the file and click Open. It will default 
to Raster Header. 

14. Choose the defaults and click Attach. Wait for the image to appear.   

 
Note: If you’re on a really slow network, this may not work. 
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15. When the image appears, right-click on OregonExplorer.xwms and select Edit WMS to 
determine the coordinate system for the web mapping service.   

 

16. Click Save (or Cancel). 

17. Right-click on OregonExplorer.xwms in the Raster Manager window and select Coordinate 
System > Select from Library. 

18. Select Library > Projected (northing, easting, …) > North America > United States of 
America > Oregon and select the coordinate system with a name similar to EPSG:2992.  

 
Note: You may want to add it to your favorites. 
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