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Lesson 1

Datamart
Basics

v" What is a Datamart?

v" How does information get into the Datamart?

v' How can I get current information about the Datamart?
v’ History of Brio/Hyperion

v' Am I ready to work in Hyperion?




What is a Datamart?

The Department of Administrative Services (DAS) financial Datamart is your
one-stop warehouse for financial transactions, account balances, grant profiles,
PCA information, Payroll data and more, which helps employees develop reports
for business information and decision making.

Many years ago, the Department of Administrative Services (DAS) State Controller’s
Division (SCD) sponsored the creation of a Datamart. This initiative brought data
from the primary transactional accounting system (SFMA) and the payroll system
(OSPA) into a relational database for various agencies and users to easily query against
for information using a reporting tool. Recently, Position Information Control System
(PICS), PPDB and ORBITS (Budget) data have been added to this Datamart, and
many other transactional applications have been created that capture relevant
information that users can use to make better business decisions.

The Datamart provides a resource for easy reporting.

In 1997, the SCD developed a Datamart of accounting data from SFMA to meet the
ad-hoc reporting needs of state agencies. This became known as the SCD Datamart
and later known as the SFMA Datamart. In 1999, the SCD developed a Datamart of
payroll data from OSPA, which became known as the OSPA Datamart. The number
of active Datamart users has expanded over the past several years, from 145 users in
1999 to an average of 360 users per month in 2007 to over 800 users in 2013.

Many agencies are using these data sources on a regular basis to meet individual
agency reporting needs. Some agencies use the Datamart to replace system-generated
mainframe reports. This provides agencies with more meaningful, custom designed
reports and saves time since data does not need to be re-keyed from hard-copy reports
for various analyses.

The Datamart gives the user the ability to create custom reports.
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How does information get into the Datamart?

The DAS Datamart contains data from the following statewide systems:
SFMA (Statewide Financial Management Application)

SFMA data is updated weekly with a download Friday evening and an upload on
Saturday evening. (These dates are subject to change. See the Datamart Processing
Calendar for specific dates throughout the year.)

Mid-July through August (considered Period 13) the YE GL Detail, YE GL
Summary, and Profile tables are updated three times per week from SFMA. In
addition, the YE Active Accounting Event table is updated the last three Thursday’s
during this time period.

OSPA (Oregon Statewide Payroll Application)

The payroll or OSPA data is updated monthly after the Final Run 2, approximately
the 10™ of each month. The data is available the morning after Final Run 2 is posted
to R*STARS (Please view the OSPS Processing Calendar for specific load dates
throughout the year. This is located on the main Datamart website).

ORBITS (Oregon Relational Budget Information Tracking System)

The Orbits or budget data is loaded weekly along with the normal SFMA load process.

PPDB (Position & Personnel Database)

The PPDB data is loaded the first of every month.

PICS (Position Information Control System)

The PICS information is loaded weekly along with the normal SFMA load process.
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How can I get current information about the Datamart?

If you have any questions, suggestions, problems, or just plain comments, please
contact the Datamart Business Analyst listed below.

Datamart Business Analyst
155 Cottage Street NE, U50
Salem, OR 97301-3969
Phone: (503) 373-0269
Fax: (503) 378-3514

E-mail: Datamart.Support@oregon.gov

Datamart Main Website

The main Datamart site is dedicated to providing valuable information on everything
about the Datamart, as well as, the Hyperion application.

Please visit:
http://www.oregon.gov/DAS/Financial/AcctgSys/Pages/Datamart.aspx

Datamart Maintenance Website

The maintenance site is dedicated to helping users with their Datamart password, as
well as, has the capability to stop queries ran against the DAS Datamart. Please visit:
https://datamartapp.dasapp.state.or.us/

Datamart News List

To join the Datamart News List, please visit the main Datamart website, shown
above, and review the Datamart-News section. There is an additional link on the
website that goes to the E-Communications site. Follow the necessary instructions
and soon you will be receiving important communication from the Datamart team,
as well as, other Datamart users.

Datamart User Group Survey meetings
The Datamart team hosts various meetings where users gather to discuss the goals,

needs and direction of the Datamart. Meeting dates and times are announced through
the Datamart News List.
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History of Brio/Hyperion

Since the Datamart’s creation in 1997, the State of Oregon has come to rely on the
Brio/Hyperion query tool as its primary means of retrieving accounting, payroll and
other financial information.

The original application, which was called ‘Brio’ was created by the Brio Software,
Inc. and was used extensively throughout the state to access the Datamart. However,
in 2003, Brio was acquired by Hyperion Solutions Corporation. Hyperion continued
to update the software until March 2007, when Hyperion was acquired by Oracle.

Throughout these transition years, the State of Oregon continued to use the product.
In May 2010, the State of Oregon purchased an enterprise license for ‘Oracle
Enterprise Performance Management System 11’ also known as Hyperion Interactive
Reporting Studio (aka ‘IR Studio’). This purchase allows the state to use the
Brio/Hyperion/Oracle product for years to come.

Am I ready to work in Hyperion?

If you can answer “YES” to the questions below, you are ready to work in Hyperion.

[ ] Areyou a state employee?

Do you have a RACF ID?

Do you have an IBM DB2 Open Database Connection (ODBC)?
Do you have proper security access to the Datamart?

Is Hyperion installed on your PC?

Have you set up an Open Catalog Extension (OCE) for Hyperion?

OO 0O 0O o o

Have you completed Datamart training?
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Exercise

1. What is the primary function of the Department of Administrative
Services (DAS) Financial Datamart?

2. How often is the SFMA, OSPA, and PICS data updated with new
information on the Datamart?

3. Name 3 resources for Datamart information:

4. What are four things I need before I can access the Datamart?

5. What is the name of the newest Brio/Hyperion version?
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Lesson 2

OCE’s and Datamart Tables

v" What is an Open Catalog Extension (OCE)?
v' Setting up an OSPA Datamart OCE
v’ Setting up an SFMA Datamart OCE
v" Modifying an OCE
v’ Tables on the Datamart
o SFMA Financial Tables
o General Ledger Detail Tables
o General Ledger Summary Tables
o Other Special Financial Tables
o OSPA Datamart Tables
v" The Repository




Datamart & Hyperion: Payroll Lesson 2
OCE’s and Datamart Tables

What is an Open Catalog Extension (OCE)?

In Hyperion, you use an Open Catalog Extension (OCE) whenever you perform tasks
that require you to connect to a database. The OCE is simply a definition of the
connection required to view a particular database.

When you open Hyperion to begin a work session (as shown below), you must select
the correct OCE for the targeted database. You can select ‘A New Database
Connection File’, ‘Recent Database Connection Files’ or ‘Browse’ from your
directory.

Welcome to Hyperion Interactive Reporting Studio

Create a Mew Document

Local Documnent i /
O A Mew Databage Connection File

= Recent Databaze Connection Files:

CompleteD atamart.oce &
Ozpz.oce

Datamart. oce

b ainframe. oce

2 Other

& Blank Document b4

Open an Exigting Document
2 Recent Docurments

MewTest2_HB2500_Fy10_ExpData_Otherdge 201011173
MewTest_HB2500 Fv10_ExpData Otherdgy 20101117
MewT est HBE2500 Fr10_EwxpData Agqu100_20101117 b
NewTest HBE2500_Fv10_ExpData_AquB33_201017117 b
MewT est_ HBE2500 FY10_ExpData AgquB33_20101117 b
HBZ500 Fy10_ExpData Age833_201010714.bagy

T

You are allowed to save OCE’s with any desired naming convention, thus the
‘Recent Database Connection Files’ listed, in the above diagram, will probably have
different names than on your own computer directory. Standard practice is to title
the OCE whatever name helps you associate with the database it will access.
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Datamart & Hyperion: Payroll Lesson 2
OCE’s and Datamart Tables

Setting up an OSPA Datamart OCE

The following are steps to create an Open Catalog Extension (OCE) in Hyperion
Interactive Reporting Studio - Version 11.

Within the initial instructions, you will discover how to create a standard connection
to the OSPA Datamart.

1) Open the Hyperion application, you will see a similar “Welcome to Hyperion”
dialog box, as shown below.

Select> A New Database Connection File
Select=> OK

Welcome to Hyperion Interactive Fleporting Studio

Create a Mew Document

Local Document w

@ # Mew Database Connection File |

0 Recent Database Connection Files:

Completel atamart. oce
Ozps.oce
Dratamart. oce

b ainframe. oce

Browsze. ..

2 Other

&, Blank Document w

Open an Exigting Document
0 Recent Documents

MewTest2 HB2500_Fv10_ExpData_Otherdgy 20001115
MewTest_HB2500_Fv10_ExpData_Otherdgy 20101117,
MewT est_HE2500_Fv10_ExpData_sgel00_ 20101117 b
MewT est_HE2500_Fv10_ExpData_sgea3d 20101117 b
MewT est_HE2500_Fv10_ExpData_sgea33 20101117 b
HE2500_Fy10_E=pData_Agea33d 20101014 bagy

e T
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Datamart & Hyperion: Payroll

Lesson 2

OCE’s and Datamart Tables

2) The “Database Connection Wizard” will display, as shown below.
Select>ODBC from the ‘What connection software do you want to use?’
Select>DB2 from the ‘What type of database do you want to connect to?’

Check the following two boxes:
1. Show Meta Connection Wizard
2. Show advanced options

Select=>Next

Database Connection Wizard

HYPERION®*
INTERACTIVE
REPORTING
STUDIO

ORACLE

ENTERPRISE PERFORMANCE
MANAGEMENT SYSTEM

The wizard will help vou create a Connection File that pou
can uge to connect bo a data source.

YWwhat connection sofbware do pou want to uze?

|0DEBC v

YWhat type of databaze do you want to connect to?

DB2 v|

Show keta Connection Wizard
Show advanced options

[ ] Prompt for databaze name

Department of Administrative Services
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Datamart & Hyperion: Payroll Lesson 2
OCE’s and Datamart Tables

3) In the box labeled “User Name”, type your Datamart User Name (this is your
RACF ID).

In the box labeled “Password”, type your Datamart Password (not to be
confused with the SFMA password).

From the ‘Host’ dropdown menu list select>SFMSP

Select>Next
Database Connection Wizard
HYPERION®
INTERACTIVE Connect to the data source.
REPORTING Enter pour user name, pazzword, and zelect your IP addrezs
STUDIO or databaze hogt.
Uzer Marme: |dasl:|_l,l82 |
Paszward: |"""" |
Host | SFMSP v|
OoORACLE
ENTERPRISE PERFORMANCE
MANAGEMENT SYSTEM
Cancel ] [ ¢Back “ Meuts
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Datamart & Hyperion: Payroll

Lesson 2

OCE’s and Datamart Tables

4) Leave this screen just as it is shown. The “On the current connection’ selection

is correct. Click ‘Next’, to continue.

Database Connection Wizard

Meta Connection Wizard
HYPERION® & On the current connection
INTERACTIVE . ) :
REPORTING O Using a different connection
STUDIO
Select meta data OCE:
ORACLE | |
ENTERPRISE PERFORMANCE
MANAGEMENT SYSTEM

[ Cahcel ] [ <Back ][ Mext: ]

5) On the following “Meta Connection Wizard” screen, click ‘Next’.

Database Connection Wizard

Meta Connection *izard
HYPERION®

INTERACTIVE
REPORTING

STUDIO

‘what is the schema name or owner of the
meta data repository tables?

| Custom... w |

Metadata is 'data about data’, which descnbes where data
comesz from; the methodz uzed to consolidate it from
digparate gystems; if and where it has been updated; and
the logic used to derive computed items.

For business uzers, metadata can simplify arcane system

ORACLE terminalogy by presenting database information in the
TR FREFORBAANEE language of your buginess. Itiz aninvaluable catalog to the
MANAGEMENT SYSTEM lozation and classification of the warehouzed data.

Cancel ] [ <Back ” Mext» ]
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Datamart & Hyperion: Payroll Lesson 2
OCE’s and Datamart Tables

6) Check the boxes for “Allow SQL-92 Advanced Set Operations” and “Exclude
Hyperion Repository Tables”.

Next, select the middle Define button to the right of ‘Owner Name’.

Database Connection Wizard

Apply filters to restrict the tables that are displayed in
HYPERION® the table catalog.
INTERACTIVE
REPORTING _
STUDIO Define...

Deﬁne‘~

T~ Click this

box!
Define...

Allow SHL-92 Advanced Set Dperations

:Ehcclude Hyperion Repository T ablez

ORACLE [ &low Mom cined Queties

ENTERPRISE PERFORMANCE
MANAGEMENT SYSTEM

[ Cancel ] [ <Back ” MHext: ]
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Datamart & Hyperion: Payroll

Lesson 2
OCE’s and Datamart Tables

7) The following screen is where you can select the table schema you want the OCE

to display.

Select>Show Values

The ‘Show Values’ option displays all table schema available within the
Datamart. You can select more than one table by using “CTRL+Click”.

Select the following tables:

OSPSPUSR > All OSPA Tables
YEAREND- Year-End allows access to the Repository

Select> 0K

Then select>Next to continue

1. Show Values, and get your tables!

Apply filkers to restrict the tables that are dizplayed in

HYPERIDN® the table CEItEIlCIg.
INTERACI'IVE 2. OK
REPORTING
able O
[ Mat | =Equal v| oK,
Show Values | BTEEIENEE ~
PICSUSR i
)
PPDBELUSR Heln
Custom SGL FROCY44 =
SDEVAD M
Select Al SFrSARCH
SFMSP137 = 3. Next
SFMSPI74
Q]
ENTERPRISE PERFORMANCE
MANAGEMENT SYSTEM |lze SOL to Get T able Catalog
Cancel ] [ <Back ” Mexts ] Finizh
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Datamart & Hyperion: Payroll

Lesson 2
OCE’s and Datamart Tables

8) Update the next two screens as they appear below. Make changes as necessary.

Select>Next after selecting the proper options and verifying each screen.

Database Connection Wizard

HYPERION*®
INTERACTIVE
REPORTING
STUDIO

ORACLE

ENTERPRISE PERFORMANCE
MANAGEMENT SYSTEM

Chooze the data retrigval method.
& Rehieve data as Binary

' Retieve data as Stings

] Time Filter Minutes

] Auta Commit after Select
[] Save OCE Without Uzer Mame

] Use Quoted |dentifiers

[ Cancel l [ <Back ” Mexsts ]

Database Connection Wizard

HYPERION*
INTERACTIVE
REPORTING
STUDIO

ORACLE

ENTERPRISE PERFORMANCE
MANAGEMENT SYSTEM

Use large buffer query mode

Packet Size setting, 512 * |

Oracle huffer size |

Dizable asynchronous processing

|:| Disahle Transaction Mode

|:| Usze QODBC auter join syntax on fikers

|:| Use ODBC outer join escape syntax

Cancel ] [ =Back ]I Mext=
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Datamart & Hyperion: Payroll Lesson 2
OCE'’s and Datamart Tables

9) Select>Finish starting the completion of this process

Database Connection Wizard

HYPERION®
INTERACTIV,E Presz Finish to zave vour settings az a connection file so
REPDRTIN(‘ that they may be reused or modified later. The wizard zaves
STUDIO v file with the extension 'oce’ in the folder you specify.
ORACLE
ENTERPRISE PERFORMANCE
MANAGEMENT SYSTEM
[ Cancel ] [ <Back MHeuts

10) Select->Yes to save your OCE

I}Etabase Connection Wizard

HYPERION®
INTERALTI V,E Press Finish to save your settings a3 a connection file so
RE?ORT]N(’ that they may be reused or modified later. The wizard zaves
STUDIO your file with the extension ‘oce’ in the folder you specify.

Interactive Reporting Studio

Do pou want to save your OCE? Tes
ORACLE
ENTERPRISE PERFORMANCE
MANAGEMENT SYSTEM

Cancel ] [ <Back ] [ et

Department of Administrative Services Page 2-10



Datamart & Hyperion: Payroll

Lesson 2
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11) Give your OCE a name in the ‘File Name’ field, shown below.

Select->Save to finalize the saving of your OCE

Savein: ) Dpen Catalog Exdensions
~
D= Mame
-
che ‘-} Complete_Datamart.oce

RecentPlaces oy potamart PPDBA&SFMS.ace

! ‘-} Mainframe.oce
D ospa.oce

Desktop ‘-} 05PSColumnOrder.oce
— 2 Pics.oce
= 2 SFMABLOSPA.oce
Libraries ‘-} SFMAROSPA-ColumnOrder.oce
‘-} sfrma.oce
:;k ‘-} sfrma_100.0ce

My Computer ) sfma_257.oce
‘r} sfrma_SEC.oce

-

© # = @-

Date modified Type

5/3/72012 9:20 AM Interac
5372012 9:21 AM Interac
5/3/2012 9:22 AM Interac
4/26/2012 8:00 &AM Interac
2/26/2013 8:43 AM Interac
5/3/2012 9:25 AM Interac
4/26/2012 8:01 AM Interac
2/26/2013 9:04 AM Interac
4/26/2012 8:00 AM Interac
5/8/2012 1:52 PM Interac

7/16/2012 3:47 PM Interac
10/8/201210:32 AM  Interac

rs

m

A ) sfrmacolumnorder.oce 2/5/2013 8:10 AM Interac ™
1 | m | 3
Metwork
File name: Q5PA oce - Save |
Save as type: [Irrtemcti\re Reporting Studio OCE {*.oce) v] [ Cancel ]

You can save Open Catalog Extensions in any directory but best
practice is to save to a directory that is backed up. This allows for
easy access to all OCE files and provides file reliability.

The standard OSPA & SFMA OCE'’s are downloadable from the
Datamart website. (http://dasapp.oregon.gov/datamart/)

You can set up where the application looks for oce files. This will
allow for easy access.
Go to the ‘Tools’ menu, ‘Options’, ‘Program Options’, ‘File
Locations’ tab, and update the ‘Connections directory’.

Department of Administrative Services
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Setting up an SFMA Datamart OCE

‘ Follow the same steps as the OSPA Datamart OCE process through step 4.

5) On this “Meta Connection Wizard” screen select ‘Edit’.

Database Connection Wizard

Meta Connection YWizard

HYPERION®*
INTERACTIVE
REPORTING

STUDIO

“what iz the zchema name or owner of the
meta data repositony tables?

| Custom... w |

Metadata iz 'data about data’, which describes where data
comes fram; the methods uzed to consolidate it from
dizparate systems; if and where it haz been updated; and
the logic uzed to derive computed items.

For buginess uzerz, metadata can simplify arcane spstem
ORACLE terminology by preser]ting I:Iat._EIIJaSF-T information in the
I TERPISE PERFORMANGE IangL:lage of your b_L_,ISIr'l!E-'SS. It iz an invaluable catalog to the
MANAGEMENT SYSTEM location and claszification of the warehouzed data.

[ Cancel ] [ <Back ” Mext: ]

6) This next screen is the “Meta Data Table Definition”
Select the following tab from the top—>Joins

Metadata Definition

Tables l Columnz | Joins | Lookup | Remarks |

@ Uge Databaze Default: & Custom Definition a4
Meta Data T able Definition

Owner Mame *Physical Table Mame

Select | : | | |
Table Alias Table Type

| Help

From | |

YWhere
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7) Select->Custom (The grayed out fields now become white for data entry.)

Metadata Definition

Tables | Columne  Joins | Lopkaf | Remarks |
) BestGuezz @ E 0 Server Defined
Meta Data Jain Definition
Primary [ atabaze Name Prirary Owher
Sect | | s
Clear
“Primary T able “Primary Column _
|
Foreign D atabaze Mame Foreign Qwrer
“Fareign Table “Foreign Calumn
Fram | |
wihere

8) Fill in the fields accordingly:
Primary Owner PKEY_OWNER
Primary Table PKEY_TABLE NAME
Primary Column  PKEY_COLUMN_NAME
Foreign Owner FKEY_OWNER

Foreign Table FKEY TABLE NAME

Foreign column FKEY_COLUMN_NAME

From SFMSPUSR.SFMS_WHSE_JOINS
Where PKEY_OWNER=:0WNER

Metadata Definition

Tables | Columnz  Joins ] Lookup | Remarks |

1 BestGueszs & Custom & Server Defined
Meta Data Jain Definition
Frimary D atabasze Hame Prirary Owner
Select | | [PKEY_DWNER |
Clear
“Primary T able “Primary Calumt
|PKEY_TABLE_NAME | |PKEY_EDLUMN_NAME |
Fareign [ atabaze Mame Fareign Owner
| |FKEY_EIWNEFE |
“Foreign Table “Fareign Column
|FKEY_T.-’-'~BLE_N#1\ME | |FKEY_EE|LUMN_N.&ME |
From |SFMSPLISH.SFMS_WHSE_JDINS |
where |PKEY_OwMNER=OWMNER

Once input is complete, select-> OK.
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Database Connection Wizard % # Tams w0

R N W aaa—

Meta Connection Wizard

HYPERION®*
INTERACTIVE
REPORTING

STUDIO

What is the schema name or owner of the
meta data repository tables?

lCustcm... v]

| Metadata is 'data about data’, which describes where data
| comes from; the methods used to consolidate it from

disparate systems; if and where it has been updated; and
the logic used to derive computed items.

For business users, metadata can simplify arcane system

[ ORACLE terminology by presenting database information in the
ENTERPRISE PERFORMANGE language of your business. It is an invaluable catalog to the

| MANAGEMENT SYSTEM location and classfication of the warehoused data.

| Help [ Cancel | [ <Back |[ Net> | [ Firish

Select=>Next to continue

9) Check the boxes for “Allow SQL-92 Advanced Set Operations” and “Exclude
Hyperion Repository Tables”.

Next, select the middle Define button next to ‘Owner Name’.

Database Connection Wizard

Apply filters to restrict the tables that are displayed in
HYPERION® the table catalog.
INTERACTIVE
REPORTING )
STUDIO Defite. ..

oetne. ~__{[ Ctick this

box!

Define...

Allow SOL-92 Advanced Set Operations

:}ZHclude Hypenon Repository T ables

ORACLE’ [T Allove Morelgined Gueries
ENTERPRISE PERFORMANCE
MANAGEMENT SYSTEM
[ Cahcel ] [ <Back ]I I et
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10) Select the tables you want your OCE to access.
Select->Show Values

Next, select the table names you desire. You can select more than
one by using “CTRL+Click” .

Select the following tables for a standard SFMA oce:
SFMSPUSR>SFMA Accounting Tables (no archived data)
SFMSARCH->SFMS Archive Tables
YEAREND=- Year-End allows access to the Repository

Select=> 0K
Then select>Next to continue

1. Show Values, and get your tables!

Apply filkers to restrict the tables that are displaved in
HYPEHION® the table u:ataln:ug.
INTERALCTIVE
REPOR[ING 2. OK
Filte:r: Filter Table Cwner
[ Mot |=Equal v| ak, ‘
Show Values | FTELE e
SFMERUSH i
elp
Custonn SOL SFMSTEST
S054)86
Select Al S0O5AR15
SSTO0LS
IR SrSTOOLS &
YEAREMND —
3. Next
=
ENTERPRISE PERFORMANCE
MANAGEMENT SYSTEM Ilze SOL to Get T able Catalog

[ Cancel ] [ <Back ][ I ek Finizh

Finalize the SFMA oce process by continuing from step 8 of the OSPA oce
process on page 2-9.
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Modifying an OCE

When you create an OCE, you establish a working database connection for
querying. You may need to modify an OCE to reflect changes in your network or
hardware configuration, or to manage other connection information.

To modify an OCE:
1) Close any open Hyperion documents.
2) Select->Tools—>Connection>Modify

The Modify Connection dialog box appears.

Organize + Mew folder +~ [ '@'
» r Favorites 5_.} Complete_Datamart.oce :ﬁ.} Datamart_PPDB&SFMS.oce
) Mainframe.oce <) ospa.oce
> Bl Desktop ) OSPSColumnOrder.oce <) Pics.oce
2D SFMA&OSPA.oce <) SFMAROSPA-ColumnOrder.oce
o) sfma.oce <) sfrna_100.0ce
5_.} sfrma_257.o0ce :‘_.} sfrma_SEC.oce
<) sfmacolumnorder.oce <) SfmaColumnOrder2.oce
File name: *.oce - ’Open Catalog Connection (F.o¢ v]
[ Qpen |v] [ Cancel ]

3) Select the connection file you want to modify and select—=>Open

The ‘Database Connection Wizard’ appears and displays the information for the
OCE you selected.

4) Make any desired changes and then save the OCE when prompted.

Note: You can save an oce wherever you desire; however, it
is recommended to save it in a backed up directory.
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Tables on the Datamart

There are two types of tables on the Datamart: Financial and Profile.

The main difference between the two tables is that financial tables contain financial
information, such as General Ledger balances, and transaction amounts, while the
profile tables provide titles for various data elements, or allow a roll-up of data to a
higher level than the financial table can accomplish.

If you desire detail finer than what is on any of the financial tables, you are not going
to have much luck. The Datamart and the query tools can only slice and dice the
data as deeply as the data goes. Let’s say you want to get a subset of the comptroller
objects. There is not a way to tie that subset together using data on the Datamart.
You are going to be stuck (likely) having to go to the detailed records and the
original documents. The following is an example of ‘Meals and Lodging’. If you use
comptroller object only (no agency object), you will not be able to get a report out of
SFMA giving you a breakdown of Meal costs separate from Lodging. You might be
able to get something based on vendor, but you also might not.

SFMA Financial Tables

Accounting Event Tables

Active Accounting Event-> This table mirrors the data from the SFMA system.
Data is reflective of the current 3 months of active transactions.

All Accounting Event-> This table mirrors the data from the SFMA system. Data is
reflective of the current fiscal year and five prior years of transactions. This table may
contain up to two years of addition information depending on the purge timetable.

Archive Accounting Event-> This table mirrors the data from the SFMA system.
Data is reflective of the current fiscal year and seven prior years of transactions. This
table may contain up to two years of addition information depending on the purge
timetable.

YE Active Accounting Event-> This table mirrors the data from the SFMA system.
However, the data on this table is updated only the last three Thursdays during month 13
close. This table is updated with the current fiscal year only. At other times of the
year, this table contains zero data.

The accounting event tables are the lowest level of detail in the Datamart. All other
financial tables are various summaries of this information.
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Note: One thing to be aware, when dealing with ‘Date’ fields in the Datamart is that
they are actual date fields, while ‘Date’ fields in SFMA are ‘Text’ fields. While the
Datamart fields are edited to assure proper dates are being used, this allows SFMA to
contain dates not on the calendar. Period 13 identified through effective date is the
best example of this. In SFMA, period 13 is identified as 6/31/20XX. In the
Datamart, date fields are not allowed to have dates not on the calendar — a data
validation feature in DB2. In order for us to move data to the Datamart, we have to
do some “data washing”. Dates like 6/31/20XX are changed to 6/30/20XX, a new
data element is introduced called Batch Date Ci. The download program picks up
the last digit in the month and records it in this field. This way, any time an incorrect
date is entered into SFMA, it is corrected in the Datamart, and an indicator is
provided.

Note: To go along with the date note above, there is another data field, in the

Accounting Event tables, which will provide you with the fiscal month. The Fiscal
Month field identifies the appropriate fiscal month, including month 13.

General Ledger Detail Tables

Arch GL Detail-> This table mirrors the data from the SFMA system. The period
available is dependent on the date of agency implementation onto SFMA.

General Ledger Detail->This table mirrors the data from the SFMA system. This
table summarizes General Ledger balances, and summarizes at the object and agency
object level.

YE General Ledger Detail> This table mirrors the data from the SFMA system.
However, the data on this table is updated only during month 13 close. During the
period of mid-July to close in August, this table is updated with the balances in the
current fiscal year only. At other times of the year, this table contains zero data.
This table summarizes General Ledger balances, and summarizes at the object and
agency object level.
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General L.edger Summary Tables

Arch GL Detail-> This table mirrors the data from the SFMA system. The period
available is dependent on the date of agency implementation onto SFMA.

General Ledger Summary—> This table mirrors the data from the SFMA system.
This table summarizes General Ledger balances, but does not contain any object
level detail.

YE General Ledger Summary-> This table mirrors the data from the SFMA system.
However, the data on this table updates only during month 13 close. During the
period of mid-July to end of August, this table updates with the balances in the
current fiscal year only. At other times of the year, this table does not contain data.
This table summarizes General Ledger balances, but does not contain object level
detail.

Note: The General Ledger Tables are a higher level of summarization in the
Datamart from the Accounting Event tables. Balances for the tables are by month,
and are cumulative by month. This means that a balance in Month 03 Balance will
contain the total of months one, two and three in that field. Monthly information for
nominal GL accounts, except for month just closed, must be created using calculated
fields.

Other Special Financial Tables

Appropriation Financial Table

The Appropriation Financial table mirrors the data from the SFMA system. This
provides information similar to the “62” screen on SFMA.

Contract Financial Table

The Contract Financial table mirrors the data from the SFMA system. This provides
information similar to the “68” screen on SFMA.
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Grant Financial Table

The Grant Financial table mirrors the data from the SFMA system. This provides
information similar to the “66” screen on SFMA.

Project Financial Table

The Project Financial table mirrors the data from the SFMA system. This provides
information similar to the “80” screen on SFMA.

Receipt Extr Sum Table

The Receipt Extr Sum table mirrors the data from the SFMA system. This provides
information similar to the “12/13” screen on SFMA.

Document Financial Tables

Arch Doc Financial Table—> mirrors the data from the SFMA system. This provides
information similar to the “64” screen on SFMA.

Doc Financial Table—> mirrors the data from the SFMA system. This provides
information similar to the “64” screen on SFMA.

Payment Control Table

The Payment Control table mirrors the data from the SFMA system. This provides
information similar to the “47” screen on SFMA.

Currently, this table only contains archived data and is updated on a yearly basis. To
obtain current payment control data, please contact Datamart Support.
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Profile Tables

Agency
Agency Code 1
Agency Code 2
Agency Code 3
Agy GL

Agy Obj

Agy Obj Grp
Appn No

Appr Fund
Budget Obj
Cash Fund
Compt Obj
Compt Srce Grp
Contract

Fund D23
GAAP Fund
GL Acct

Grant No
Grant Obj
Grant Phase
Index No
Operator ID
Org Code
PCA

PCA Index Rel
Program Code

Project No
Project Phase
State Fund Grp
Sub Grantee
TDate

OCE’s and Datamart Tables

— D02 Screen

— D26 Screen

— D27 Screen

— D36 Screen

— D32 Screen

— D11 Screen

— D25 Screen

— 20 Screen

— D22 Screen
—DO01 Screen

— D73 Screen

— D10 Screen

— D09 Screen (this ties to ORBITS data)
— 30 Screen

— D23 Screen

— D24 Screen

— D31 Screen

— D47 Screen

— D48 Screen

— 29 Screen

— 24 Screen
—D96A/B Screen
— D03 Screen

— 26 Screen

— 21 Screen

— D04 Screen (contains the ORBITS Cross-Reference
Number)

— D42 Screen

— 27 Screen

— D20 Screen

— 31 Screen

— Generated — not on SFMA

Note: There are ‘special view’ tables that agencies request be created to help
lock or unlock specific data within the Datamart.
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OSPA Datamart Tables

The OSPA Datamart contains data processed through the Oregon Statewide Payroll
Application. Data is updated monthly following the close of the payroll month,
which is around the 14th of the following month. Check the OSPS Datamart
Processing Calendar for specific dates.

The OSPA tables on the Datamart do not contain profile table data as the SFMA
tables. These tables are each a flat-file database made from report output. This does
make querying a bit more difficult, as you really have to know exactly what you are
looking for, and where to find it.

OSPA DED Tables
OSPA Deductions
OSPA Ded -Contains the complete OSPS Datamart (four biennium)

OSPA JS Lab ADJ Tables
OSPA Job Status, Labor and Gross adjustments
OSPA JS Lab ADJ -Contains the complete OSPS Datamart (four biennium)

OSPA Labor Cost Tables
Labor Costs
OSPA Labor Cost -Contains the complete OSPS Datamart (four biennium)

OSPA LV Accrual Tables
Leave Accruals
OSPA LV Accrual -Contains the complete OSPS Datamart (four biennium)

OSPA Net Pay Tables
Net Pay amounts
OSPA Net Pay -Contains the complete OSPS Datamart (four biennium)

OSPA Work Sched Table
Work Schedule amounts  -Contains all users current work schedules

Note: The OSPA Datamart does not contain:

o Confidential Information, such as Social Security numbers, wage
withholding, garnishment info, bank account information or certain
insurance surcharges

e Data sourced from other applications such as salary range or employee
addresses

e Detailed daily time information if not using Online Daily Time

o Furlough savings information
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Note: When querying the OSPA tables, you must use a five-digit agency number in
order to obtain the desired results. For example, DAS is agency 107 for SFMS;
however, 10700 for OSPA purposes. Another example is Parks & Recreation’s
agency number on SFMS is 634; however, on OSPA, it is 63400.

Note: The OSPA Datamart security access is locked down to the specific
agency or agencies requested by the Agency Security Officer (ASO).

The Repository

The ‘Repository’ is a great tool to help share standard reports with users on a
statewide level. The purpose of sharing these reports is to allow agencies to have an
outlet to access reports created by different agencies. The Datamart team cannot
guarantee these reports will function properly for each agency, due to specific agency
structure setups; however, please feel free to make modifications to suit your agency.

The Repository contains many files, which access data from SFMA, ORBITS,
OSPA, etc. Thanks to users throughout the state, we continually obtain more reports
to help with our daily operations.

Below are instructions for accessing the Datamart Repository.

1. Open Oracle Hyperion Interactive Reporting Studio (Formerly known as Brio).
Click Cancel if you get a “Welcome’ dialog box requesting to open files or open
a database connection.

2. Select File > Open from Repository > Select. Select the Open Catalog
Extension (OCE) that connects to the Repository. (‘Year End’ table schema is
selected)

3. Select the proper OCE and click Open. In this example, the OCE is called

“Datamart”. Your OCE name may be different. You should see a screen
similar to the following:
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Select Connection @
Loak, ir: | |- Dpen Catalog Extenzions v| Q2 e O
iy =] COWD_kesk.oce i@ Pics.oce
4 23 Id CompleteDatamart, oce [# Sample OLAR PCW . oce
hy Recent = ¥Datamart, oce @ Sample OLAP.oce
Documents I Datamart_100.0ce @ Sample with metadata.oce
= Id Datamart_Mod.oce & Sample.oce
|_ Id Datamart_no_arch.oce

=] Dratamark_PPDE.oce
i Dratarnark_test.oce
- Id Datamart_web,oce
.—j i DD3 Sample.oce

Id Mainframe. oce
i new_test, oce

Desklop

My Documents

=] Ospa.oce
_i! Id Osps.oce
: Idl Osps_SEC_test.oce
My Computer
&g File name: |Datamalt.nce hd | I Open l
My Network. | Files of type: | Open Catalog Connection [*.oce) w | l Cancel ]

4. You will be prompted for your user name and password. Input your
information and click OK. You should see a screen similar to the following:

Datamart.oce

Hozt Uzer | I k. I

Host F"assw::nrd| I Cancel I

5. Ifno errors have occurred with your log in data, you should see a screen similar
to the following:

Open from Repository

i =] [ModelInfo

-] Data Model Urique Mame: el
Creator: |

“ ] Standard Quemy S

: reated;

B Standard Qusry with Feports ﬂl

"D ezcription

6. Click on the [+ next to “Standard Query with Reports”. Your screen should
look similar to the following (This may be somewhat different depending on
your OCE setup.
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Cpen from Repository

Lesson 2
OCE’s and Datamart Tables

-1 Repository
] Data Model
7] Standard Query
50

E &5 Screen Recon
E Budget vs. Actual
E D23 Balances
E DAFREE10 Month
E] DAFREE10 Period 13

%] DAFRE610 Period 13-Agy Object

%] DAFRE610 YE Period 13
%] DAFRE620 Marth
%) DAFRE620 Perind 13

Mode! Info Open

Unique Mame:

S

Created: Help
Description

7. Scroll down until you find the report you want to use. Once selected a
description field for the file will be shown on the right side. Click Open. Your
screen should look like the following:

Open from Repositony

=1 Repositary
] Data Model
7] Standard Queny
=[] Standard Query with Reports

E Budget vz, Actual
E D023 Balances
e AR0AFRESTO Marth
E] DAFREET0 Peniod 13

%] DAFREE10 Period 13-4y Object

%] DAFREE10YE Period 13
%] DAFREEZ0 Morth

%] DAFREEZ0 Period 13
%1 DAFRGE20YE Period 13

tadel Infa
Unique Mame:  DAFREET0 Manth _
Creatar: dazbyd2
Created: 08/05/10 12:00 At

Description

Replica of SFha DAFR 6610 Operating
Statement. Listz current year - lazst clozed
mohth totals as well az the corezponding
mohth fram the prior fizcal year.

Department of Administrative Services

Note: Once the Repository file is open, please review the ‘Dashboard Disclaimer’
information contained in the file, prior to running the query.
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Exercise

1. What is an Open Catalog Extension (OCE)?

2. How many OCE’s can I set up on my machine?

3. Can I modify an existing OCE on my machine?

4. Name the 2 types of tables on the Datamart.

5. Name 3 financial tables found in the Datamart.

6. Name 3 profile tables found in the Datamart.

7. Name 3 OSPA tables found in the Datamart.

8. Name two items the OSPA Datamart does not contain.

9. Name a resource, which provides a great tool to help share
standard reports with users on a statewide level.
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Hyperion Queries

Datamart & Hyperion Spider Web
BQY Documents, Sections, and Toolbars
Online Help
Opening and Saving BQY Documents
Processing and Stopping Queries
Adding, Duplicating, Renaming, and Deleting BQY
Sections
Hiding a BQY Section
Sending BQY Documents as Email Attachments
Printing BQY Sections
o Adjusting the Page Margins in Print Preview
o Adding Headers and Footers
o Printing Sections
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Datamart & Hyperion Spider Web

Lesson 3
Hyperion Queries

Let’s talk about the flow of data from the financial world to the Datamart. How does
it get to your machine and out on a piece of paper for your boss or meeting?

Microsoft Access,
Excel and Text files -
Data brought into
Hyperion

R
N

DAS
Datamart

Y2

Orbits &
PICS

Hyperion
Document

Query

Results

Table

Pivot

Chart

Report

Dashboard

Department of Administrative Services

Mainframe:
OSPA
SFMA

PPDB

Microsoft Excel,
Microsoft Access,
Crystal Reports, etc.
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BQY Documents, Sections, and Toolbars

BQY Documents

A BQY document is a reporting file created in Hyperion and has the file extension of

.bgy. A .bqy can contain queries, results, tables, pivots, charts, reports, and
dashboards.

BQY Sections

Queries—> Used to create questions against the Datamart.

Results—> Used to display the rows returned/retrieved from a query built in the
query section. You can take the results of the query and develop filters, sorts,
computed items, and format.

Tables—> Used to create organized subsets of your query results. These are tabular-
styled simple reports. You can develop filters, sorts, computed items, and format this
data.

Pivots—> Used to create cross-tabular style reports in which you can analyze data.
You can focus or drill-down on data items in this area. Data facts are combined in
this area.

Charts—> Used to create various types of charts, such as horizontal, vertical bar, line,
pie, cluster, scatter, and ribbon. You can format all areas of your charts.

Reports—> Used to develop free-form reports where result sets are displayed in a
combined area. This is where you can integrate foreign results that have been
imported into your .bqy with current information from the Datamart.

Dashboards—> Used to create an interactive user-friendly approach to querying and
manipulating queries, pivots, charts, reports, etc. Users are able to check boxes,
access drop-down lists, select radio buttons, and filter results based on their specific
needs and criteria.
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BQY Toolbars

The following figure shows the sections and toolbars of a Hyperion .bqy.

Standard
Toolbar

Menu Title Bar

Bar

Formatting

Toolbar Section Title

Bar

) Hyperion Interachye Reporting Studio - [Untitl

) File Edit View\ Insert Format Query D; Window Help
DSd|as| e @ @ A P 23 E | o

S Query =
Sections

|i#] Dashboard

|% ALLREPORT
| RDCREPORT

odel  Tools

> | (| = = @0 | @ || [30f 9 Barcoce R R I IR A
[P Request(s) ¥ Filters(4) =] Sor2)

Request Line

e Filter Line

o
% ||| Requsst | Agency Num| Employes Neme | Ly Type | Ly Hours | Pay Proc Date | Rept Dist Code
Fiter 3] Agency Num V(1) AND 1 | Transaciion Code| AND 1| Ly Type V@) | AND 1| Fay roc Date (3)

Sort | Rept Dist Code | Employee Name #

i OspsLvAccual

oA Results Adj Base Rate

@ Pivot

Agency Num [
Appnt Type Code =
Base Pay Rate

Benefit Pkg Code
Chssified Code

Concrnt Job Num

Double Fil Cd

Employee Name

Flsa Subj Flag

Hourly Pay Rate

Job End Date

Job Start Date

Sort Line

Leave Accrl Cde
Load Date

Lv Activity Date
Lv Balance Date

Content Pane

Lv Continuous Date
Lv Cost Amt

Lv Hours

Lv Hours Advanced
Lv Hours Lost

Lv Liabilty Amt.

Lv Type

Ovrtime Eligbl

Pay Code

Pay Option Code
Pay Proc Date

Pay Rate

Pay Type Code

Elements

i Tables

Percnt Position
Position Num
Range Optn Code
Recog Service Date
Represent Code
Rept Dist Code
Separation Code
Transaction Code
Work Frequency
Pay Dist Code
Fronlovea Hum

el ;

No Resuts Yet Combined View: 1 topic =T

Status Bar

Your Section and Elements Catalog Pane will vary depending upon the .bqy you are
developing.
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The application allows you to hide and unhide the various sections as much as
desired. If you can’t visually see a toolbar or section, you can select View from the
Menu Bar and choose what you would like to see.

% Hyperion Interactive Reporting Studio, - [Untitle
:ﬂ Eile  Edit

3 __3 v Section/Catalog
v Section Title Bar

\Jﬂ Query = Toolbars 3
sections | 7 O Ea“_ Drag Topic tem You can view or hide sections
Cansole Window vag Fequesth and toolbars by selecting the

‘View’ menu option.

nsert  Format  Query DataModel T

#2 query
dﬂ Results

G0 To Section v [Diag Topic o C
Hide Section

Query Log

Wiew | Insert Format Results Tools Window Help

| ¥ Section/Catalog 'v| ol AT il
|

Additional view options are
v Standard / shown in the ‘toolbars’ section

I v Section Title Bar

-

Toolbars

¥ Status Bar v Formatting .
View->Toolbars

Section

Console Window

Execution Window

Go To Section »
Hide Section

Unhide Section...

Query Log

Foom 3
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Online Help

Online help is available through Hyperion.

To access help:

From the Menu Bar (Note: Must have bqy started)
Help->Help on Content

Or

Select the ‘F1’ key

This will take you to Hyperion online help. You can search for help by three
methods:

Contents—> Allows the user to search for help on a pre-defined topic
Index-> Search for help on predefined topics alphabetically

Search—> Type your help issue in the search box for results
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Opening and Saving BQY Documents

A .bqy document is just like any other document you would create, edit, save, close,
or open; only it lives in Hyperion. The .bqy is the file extension for a Hyperion
document.

Opening a BQY Document

You can double-click on an existing .bqy to open it or you can go through Hyperion.
Below is an example of the opening dialog box you will see when you open
Hyperion.

Welcome to Hyperion Interactive Reporting Studio

Create a New Document Select->Browse to open and
Local Document % work from a desired OCE that
© 4 New Database Connection File is not shown in the Recent
0 Recent Databaze Connection Files: Database Connection Files.

Datamart. oce
CompleteD atamart. oce
Ozps.oce

b4 ainframe. oce

O Dther

& Blank Docurment b

Open an Exigting D ocument Select%Browse to open and
2 bzeeitleemeiis work on a desired .bqy
09-11 OPS 55 Detail_testv2 bay . .
0911 Manthly E xp Rep SFY11 by document that is not shown in

Grbal SFv11.bay
Ag100_0SPS_Mois_20010112 bay the Recent Documents.

0OSPS.bgy
MewTest2 HB2800_Fv10_ExpData Otherdgy 201011717

o) (e

You can choose a Recent Document from the bottom half of this screen or open an
OCE from the upper half of this screen.
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Starting a new .bqy using the OSPS.oce:
Open Hyperion from your Start Menu
Select->Browse from Recent Database Connection File

Select=>0OSPS.oce> 0K

Type—>User Name and Password (this is your assigned Datamart user name and
password)

You should now see the following screen:

) Hyperion Interactive Reporting Studio - [Untitled]
&) File Edit View Inset Format Query DataModel Tools Window Help

[ s s |0 1 1|=
DSH| S| @ # -8
A Query =

Sections x

& Resulls Fitter ﬂ\ Drzg Topic or Computed Request tems here to ereate Fiters

Sl A E%oy e

i | Process v | | < @@

[ Request(0) ¥ Filters(0) =] Sort(0)
Request ‘Dwagfpmblmshﬂ?!obﬁda@uﬁy

Elements

= I;i Tables
@ 05PS_DED
@ 05PS_DEDN_TBL
@ 05PS_1S_LAB_AD]
@ 0SPS_LABOR_COST
i 05PS_LV_ACCRUAL
@ 0SPS_NET_PAY
@ 0SPS_WORK_SCHED

You will have to click on the + next to Tables folder within the ‘Elements’ catalog
pane to see all the topics available to use.
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You can also right-click on top of the tables to see their full names. This shows you
what view or tables these topics are linked.

Elements Elements

-1-Egg Tables =g Tables
=] @ OSPSPUSR.05PS_DED
@ 05PS_DE SLlidEEE ETe @ OSPSPUSR.O5PS_DEDN_TBL
@ 05PS_Js @ OSPSPUSR.OSPS_JS_LAB_AD]

Full Mames S—

@ osps_LA @ 0SPSPUSR.OSPS_LABOR_COST
i osps_Lv Refresh i 0SPSPUSR.OSPS_LV_ACCRUAL
i@ OSPS_NET_PEY @ OSPSPUSR.OSPS_MET_PAY

@ 0SPS_WORK_SCHED @ 0OSPSPUSR.OSPS_WORK_SCHED
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Saving a BQY Document

Similar to other applications, you have several choices for saving your .bqy.

B Hyperion Interactive Reporting Studio - [Untitled]

-_.'\J 5N Edit Yiew Insert Format Query DataModel Tools  Window Help

Hevr. il 2@ s 3@ s - b e o @ O
Qpen... Chrl40

Close Chrl+y

Save ChrHS Request | Drag Fapds fems fare fo buitd a Quasy

1
Sawe Query Results with Document. .. ffrea
whork, offline in web Client
v Compress Document
Password Protect Document. ..
Import Data ¥ Password Protect Design Mode. ..
Export 3

«Bly %l

wf fears freve fo creafe Filfers

Open from Repository

You can save a .bqy by selecting the various options:

File->Save
This saves the .bqy under the existing name and updates any changes you have
made to the opened document. This does not create a new .bqy document unless
it is newly created.

File>Save As
This takes an existing .bqy document and saves it as a new document with the
changes you have made. Use this option when saving a .bqy for the first time or
when you desire to keep the existing .bqy document and a new .bqy document.

File->Save Options->Save Query Results With Document
Use this if you want to perform off-line data analysis of your .bqy.

File->Save Options—=> Compress Document
This features results in smaller file sizes and enables you to send your file quickly
through the email system.

File->»Save Options->Password Protect Document
Users will need a password to access this document. Be careful! You need to

remember your password.

File->Save Options>Password Protect Design Mode
Password protection used to guard Dashboard designs.
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Processing and Stopping Queries

Processing Queries

This process refreshes the data in the .bqy document based on your requested items
and filters specified. When a query is processed Hyperion goes back to the Datamart
and retrieves this information for your query. The process time depends on the data
you are asking the Datamart to retrieve and the power of the Datamart server and
connection to the server.

Because your .bqy document could have more than one query, there are three
process options to choose from:

-_.‘I-J File Edit Wiew Insert Format Query DataModel Tools  Window  Help

UoHdH 3% @ E A- &P = EE Heoes -| 8 -

\Jﬂ Query = M Process Current
J.'l, Process all
Sections 53 Request | Agency Jl Process Custom, ..

Process Current—>Processes the query that is currently active.

Process All->Processes all queries that exist in the .bqy document.

Process Custom—>Opens a Process Custom dialog box so you can choose which
queries to process. Simply put an X in the box next to the query.

Process Custom

- Quers
Clueny

Quew?

Guend

Process Order of Queries
It is important to remember how you develop your queries. If you create a .bqy with

multiple queries and some of those queries depend upon others in that .bqy, you will
want to make sure you order them to process in a certain order.
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Tools>Process Query=>Process Order

Query Processing Order

Select a query and uze the Up/D own buttons to arrange the
query processing order

G, Click on the up and down

u <4 | .

Query3 arrows to alter the processing
ﬂ order of the queries.

Double-click on anitem to add/remove it from the processing order.
[Only quenes with an ™ are processed duning Process All actions. ]

I 0K ][ Cancel ]

Prior to processing a query, you must complete the following steps:

Add a ‘Table’ to your query section:

Bring a Table over from the Elements Pane to the Content Pane. You can drag and

drop or double-click.
Sections X Request | Orag Topic fems here fo
% quey  JE— o
o4 Results Sl et J| Drag Topic or Computed
Elements
= i OspsDed hd
=I-Eg Tables - Agency Num ~
" ROSPS DED Benefit Brd Cd M
@ 05PS_DEDN_TBL Brd Shr Prem m
Code Pay Trans
@ 0SPS_JS_LAB_AD] Code Run Pay
B 0s5Ps_LABOR_COST Comment
@ 0SPS_LV_ACCRUAL SD‘EEHE; gﬂde
@ 0SPS_NET PAY Dodn B pﬂ;‘:"
i 0SP5_WORK_SCHED Dedn Desc
Dedn Pct Gross
Dedn Pct Met

Department of Administrative Services
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Add fields in a Table to the Request line:

Lesson 3
Hyperion Queries

All Fields: Right-click->Table Name—> Left-click=> Add Selected Items
Individual Fields: Right-click->Field Name-> Left-click> Add Selected Items

Agency Mum | Benefit Brd Cd | Brd Shr Pren

Reguest

Dedn Plan Code | Dedn Plan Desc| Dedn F

Fitter i|| Brag Tapic or Computed Request kems here

iz OspsDed
Agency Ny
Benefit Br|
Brd Shr Pr
Code Pay
Code Run
Comment
Coverage
Dedn Adj
Dedn Ben
Dedn Desq
Dedn Pct
Dedn Pct

Dedn Pkg
Nadn Phnl

<,

Add Selected Items
Remaowve
Show Remarks

Promote to Meta Topic

Structure View
Detail View

Icon View

Properties...

Create a Filter for your query:

Request | Agency Num
Fiter j| Drag Topic or Computed Reguest ke

= Osps Ded
P e

Bene
Brd §
Code
Code
Cormi
Cove
Dedn ik
Dedn
Dedn
Dedn
Dedn
Dedn
Dedn
Dedn

-

Add Selected tems
Filter...

Show Remarks

Structure View
Detail View

Icon View
Mumber...

Properties...

Double-click->Field Name. A ‘Filter’ dialog box pops up.

Manually input a value in the ‘Custom Values’ section and Click>OK or;
Click->Show Values—>Select an option—=>Click>OK

Filter: Agency Mum

MName:

[T Mot
M| WS

|Fa.gen|:'_.r Mum
[T Include Nulls

[= Equal
10700

Show Values
Custom Values
Custom SGL

Select Al

ave

i

Select>

JJ. Process -

Filter: Agency Num

Name: Agency Mum
[ Include Mulls

=] Not | = Equal
[ Show Values ] 10000
10700
10800
Custom SGL 10900
11400
Select All 11500
11500
12000

from the Standard Toolbar

You will now see your results under the Results section of the Section Pane.

Department of Administrative Services

Page 3-13



Datamart & Hyperion: Payroll Lesson 3
Hyperion Queries

Stopping Queries

Sometimes when you process a query or queries in a .bqy document you may find
the data is not being returned from the Datamart in a timely manner. Users want to
be conscious of their query/process time to keep up top performance. It is important
that you use the process listed below to stop the query. Exiting out of Hyperion does
not stop the query process to the Datamart and it will continue to use resources to
process the query.

To stop a query:

Open the Internet
Go to—> https://dasapp.state.or.us/DatamartApp

Log in using your Datamart user name and password
Select from top menu->Query
Select->Cancel All Queries

Query Change Password

Datamart

These are the queries currently running for dasby82
Rows Read CPU Time (seconds)
255 0.002

Cancel All Queries Refresh

Sometimes after you stop a query, you may notice a ‘Results’ set of data is returned.
This is called ‘partial data’ and you must be careful because these results are not
complete.

You can also stop a query once it starts providing results.
Hold down the ‘alt’ key along with the ‘End’ key

Sorting (Alt-End to cancel)

Hyperion application ‘Status’ bar:
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Adding, Duplicating, Renaming, and Deleting BQY Sections

You can add, duplicate, rename, or delete a .bqy section at any time.

To add a new section:

Insert->New->Select the Section you want to add

Your choices are:

% Hyperion Interactive Reporting Studio -

ﬂ File Edit Wiew BGE=ZE8 Format Results  Tool

|_J j H j = New Query

@ Mew Table L
dﬂ Results = [ Mew Pivat
i Mews Chart
S %5l Mew Report 7F
dﬂ Query Eﬁ Mew Dashboard »
SLECLERN  Page Header... =
JZI Quen Page Footer. .. .

To duplicate a new section:

Edit>Duplicate Section

% Hyperion Interactive Reporting Studi
_ﬂ File Nasl¥ Yiew Insert Format Query [

4 g

dﬂ Que
Section

dﬂ Fes

A u

dﬂ Fes

A u

4 Res  Delete Section. .,
~ | Rename Section...

Duplicate Section

v Duplicatable

Department of Administrative Services

Right-click on the Section you
want to duplicate

& Hyperion Interactive Reporti

ﬂ File Edit Wiew Insert Faormat

OSH IS 9

A queny -

Sections = Rer

dﬂ R Delete Section, ..
£5L
Rename Section...

d:'l WY Duplicate Section
J2 Results2

Page 3-15



Datamart & Hyperion: Payroll

To rename a section:

Edit>Rename Section

% Hyperion Interactive Reporting Studio

ﬂ Filz Nl Yiew Insert Formatb Query  Dal

A que
Section Qe
e »
= Fes
e
dg Qu
2 Ree
dg Qu
H pe:  Delete Section... E
Renarne Section, .. |
Duplicate Section g:
v Duplicatable Gr

To delete a section:

Edit>Delete Section

% Hyperion Interactive Reporting Studio
ﬂ File Bas[$ View Insert Format Query Dal

E -

WA que

Section ge

Delete Section...

Rename Seckion... Al
Duplicate Section g
v Duplicatable Gr

Department of Administrative Services
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Right-click on the Section you
want to rename

& Hyperion Interactive Report
| Eile Edit Wiew Insert Format

S H S8

A query -

Sections x Fes

&

5 Deleke Section...
d:l Fesult:

Rename Section. ..

dz Queryz  Duplicate Section

dﬁl Fesults2

=]

Right-click on the Section you
want to delete

& Hyperion Interactive Reporting
) File Edit View Insert Format Q

3 SH L 2P E
WA Query -

Sections x Reque

= Delete Section, ..
le Fesults - .
———  Rename Section,..

d?l Queryd Duplicate Section
JEI Fesulks?
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A Quenga -
sections » In the standard Hyperion
= application (version 11),
dfl Queny you cannot re-arrange the
WA Results various sections
dﬂ Quen

dﬂ Fesults2

Quend

dﬂ Fesults3
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Hiding a BQY Section

Often it is helpful to hide a section on the Section Pane for security reasons or
making your .bqy more user friendly for the end user.

To hide a section:

Select View—=>Hide Section

8 Hyperion Interactive Reporting Stud
)| File Edit

Section/Catalog
FR=N - R
v Section Title Bar

WEEN Insert  Format  Query

dﬂ Quend - Toolbars 3
v Status Bar
Sections !
dz Consale Window
. Query "
dﬂ Results
G0 To Seckion [
= Query? =
d? Query Hide Section
di—l Results2
(¢7 cuers
dﬂ Resultss

To show your hidden section:

Select View->Unhide Section Select>Query> 0K

ﬂ File Edit m Insert Format R

Seckion/Catalog f
FRF= -

S | w Seckion Tite Bar

dﬂ Fesults3 = Toolbars 3

w Status Bar
Sections

B Consale Window
A Query

dZI Results Luer [—]DK

Resulkz3

G0 To Seckion 4
2 Digery2 = Cancel
d? Query Hide Section
dﬂ Results2

Unhide Sections

Unhide Section...
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Sending BQY Documents as Email Attachments

Hyperion Interactive Reporting Studio has the capability of sending .bqy as email

attachments.
To send a .bqy as an email attachment:

Select File=>Send

‘3 [] Send Results

Unititled3. by Send Compreszed
&dditional Messzage:

[ Send it! ] [ Cancel

Use To, CC, Bcc, and Subject
the same way you do in your
regular mail program.

Notice you can see the name of
your .bqy in the middle of the

screen.

Select ‘Send Results’ to include
the results section with your file.

Select ‘Send Compressed’ to zip
your file prior to email.

Notice, you can also type an
Additional Message.

Send it!

Department of Administrative Services
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Printing BQY Sections

Adjusting the Page Margins in Print Preview

When your .bqy is complete, you may want to view your finished product and adjust
the margins, add page numbers, and headers and footers before to printing or
emailing. Prior to Print Preview, you must select the section you want to preview in
the Section Pane. Please note: The Report & Dashboard Sections do not have a
Print Preview mode.

To Print Preview a section:
File>Print Preview
To adjust the page margins:

Just put your mouse pointer over the dashed margin lines and click and drag
to get your desired margins. You can do this both vertically and horizontally.

<+—>
I I I I I I I I I I
Code Code Dedn Dedn Dedn
AEE;? EIB::S%I'E Brd Shr Prem Pay Run Adj Ben D;Egn Plan E')rigg
Trans Pay Type Pkg Code
1 10700 N 0.00 C 0 MK KD 555 KOMNN
= 10700 M 0.00 C 0 M AG 001 AGHNM
3 10700 M 0.00 C 0 MM AH 001 AHMNN
4 10700 M 0.00 C 0 MK AH 001 AHMM
5 10700 M 0.00 C 0 NN Do DOMNN
3 10700 N 0.00 C 0 NN Do DOMNN
7 10700 5 507 C 0 NN KM AAA KMNN
2 10700 5 (154.00) C 0 MM oo 001 QONN
3 10700 5 (0.61) C 0 F NN oT 102 OTHMN
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Adding Headers and Footers

Adding a Header or Footer to your .bqy section gives you the opportunity to add
page numbers, file names, date and time, and query filters.

To add a Header or Footer:

Select Insert->Page Header or Page Footer

Edit Header:

Type your custom

text in this area.

H5 o 4 & & 9

Date Time File Page Page Query
Name # Total Limits

Printing Sections

You can print any section of your .bqy.
To print a Section:
Click Section->Select File>Print

You can select the correct printer, printer properties, number of copies, and range
you would like to print.
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Exercise

Name the 6 sections you can create in a .bqy.

Mmoo an o

1. Start a new .bqy using an oce that accesses OSPS data.
2. Expand the Table list on the Element Pane.
3. Bring the ‘OSPS Ded’ Table over to the Content Pane.

4. Sort the table fields alphabetically. (Hint: Right-click on the title of
the table and select properties).

5. Add the following Items to the Request Line:
Agency Num

Employee Num

Tax Year

Dedn Type

Dedn Desc

Dedn Plan Desc

Pay Dist Code

Ee Dedn Amt

SR Mo a0 o

6. Filter the following Items:
a. ‘Agency Num’ equal to your own agency
b. ‘Tax Year’ equal to the current year
c. ‘Ee Dedn Amt’ not equal to zero
d. ‘Employee Num’ equal to your own employee number.
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7. Process the query. Does your query return proper data?

10.

11.

Request | Agency Mum | Employee Num

Fitter j| Agency Mum | AND o | Tax Ye:

iz Osps Ded

Agency Num
Benefit Brd Cd
Brd Shr Prem
Code Pay Trans
Code Run Pay
Comment
Coverage Code
Dedn Adj Type
Dedn Ben Pkg
Dedn Desc
Dedn Pct Gross
Dedn Pct Met
Dedn Pkg
Dedn Plan Code
Dedn Plan Desc
Dedn Plan Distr
Dedn Type

Ee Dedn Amt

| 4

Lesson 3

Hyperion Queries

Agency
Mum

10700
10700
10700
10700
10700
10700
10700
10700
10700
10700
10700
10700
10700
10700
10700
10700
10700

Employee
Mum

OR0143638
OR0002521
OR0003950
OR0010838
OR0014282
OR0016210
OR0018718
OR00204789
OR0022332
OR0025255
OR00258300
OR0029237
OR0031548
OR0032022
OR0033546
OR0040510
OR0046334

Tax
Year

2013
2013
2013
2013
2013
2013
2013
2013
2013
2013
2013
2013
2013
2013
2013
2013
2013

Dedn
Type

AEMM
ADMNM
ADMNM
ADMM
ADMM
ADMM
ADMM
ADMM
ADMM
ADMM
ADMM
ADMNM
ADMNM
ADMM
ADMM
ADMM
ADMM

Pay Dist
Code

2001
1131
2009
1120
1131
2003
2021
1130
1131
2006
18649
1140
1134
1240
1131
1600
2022

Rename your Query section as “Query - OSPS Deduction” and
rename your Results section as “Results - OSPS Deduction”.

. Duplicate your “Query - OSPS Deduction” section. Notice it
automatically alters the name of the new sections.

Add a page header to your ‘Results-OSPS Deduction’ section
called “Results - OSPS Deduction”.

Alert the instructor after correctly completing the exercise. In

addition, close the bqy document and do not save.

Department of Administrative Services

Page 3-23






Lesson 4

Hyperion Query Building Processes

v" BQY Process

v' Managing your Table
o What can I do to the Table Properties?

v Append Queries

v Understanding Joins

v' Building the Request Line

v' Maximizing the Query Building Process
o Setting Restrictions on your Query Properties
o Estimating the Size of your Query




Datamart & Hyperion: Payroll Lesson 4
Hyperion Query Building Processes

BQY Process

BQY documents are files you create and use to retrieve information from a database,
analyze the information, and build reports. Because Hyperion is an integrated query,
analysis, and reporting tool, documents have multiple sections, each of which
governs one part of the query and reporting process. You create sections
progressively: first, you query a database, then retrieve results, and last generate
reports.

Documents can contain data from any number of relational databases queries,
multidimensional database queries, and/or from imported data. Documents usually
include one or more of the following items:

e A DataModel, which is a visual representation of the actual database tables.
Note: Using the ‘Sync with Database’ operation, within the ‘DataModel’ menu,
can be very helpful to sync your query with the current database and make sure
you have all fields available.

e A query or multiple queries for retrieving a subset of data from the database.

e Join options, including local joins between different data sets within a single
document, local join filters, and optional join path generation.

o A results and table set displayed in a table-style format.
e Multidimensional pivots that permit drill-down analysis of data results.

o  Charts that graphically display your query results and allow different angles of
vision on the data.

e Reports presenting customized hierarchical views of your data.
Most Hyperion documents have at least one ‘query’ section and one ‘results’ section.

From the results section, you can create multiple Table, Pivot, Chart, and Report
sections to analyze and present data.
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Managing your Table

Shown below is a Table also known as a Topic. By double-clicking on the Topic
Title Bar you will open the Properties of the particular Table. You can also right-
click on the Title Bar to open the Properties.

i OspsJslabAd] <~
Activity Desc -

Adj Base Rate
Adjust Type Cd
Agency Mum

Double-click or
Right-click on the
Title Bar.

Appnt Type Cd
Appointmnt Date

Auth Mumber

Base Pay Rate

Benefit Pkg Cde

City Code

Classified Code

Co Rec Rem Ma

Code Pay Trans o

Below you can see the Properties of the ‘OSPS Js Lab Adj’ table. Notice the Table
Name is more user-friendly than the Physical Name. This is a transition change that
happens when the data is uploaded from OSPA to the Datamart.

Topic Properties: Osps Js Lab Ad)

oK

Physical Name: [OSPSPUSR.OSPS_JS_LAB_AC Cancel

Topic Mame: Isp Aud

Show All * Activity Desc -
*  Adj Base Rate
* Adjust Type Cd
*  Agency Mum
- Apprt Type Cd
*  Appoirtmrt Date
* Auth Number il
* Base Pay Rate
Sort *  Benefit Pka Cde

[C] Set as Dimension
Allow lcon View Help

Detail View Options
Allow Detail View

[C] Cause Reload Fows to Load: 10
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What can I do to the Table Properties?

Table Name—> It is possible to change this name to something that is more
understandable.

Physical Name-> Normally, you would not alter this name. This is the full name of
the underlying database table.

Hide/Show All-> Hides or actively show all table items.
Up/Down—> Moves selected item up or down one space in the topic display.
Sort> Alphabetically sorts listed items.

Set As Dimension—> Defines the drill-down path or hierarchy for dimensional
analysis as shown in the data model.

Allow Icon View—> Enables the icon view option for the table.
Allow Detail View-> Enables the detail view option for the table.

Cause Reload-> Specifies automatic reloading of server values the next time ‘Detail
View’ is activated.

Rows to Load-> Specifies the number of rows to be loaded and displayed in ‘Detail
View’.

Icon View - Be Careful! Icon View deactivates a table and reduces it to an icon in
the Content frame. This feature will break joins.

Detail View, Cause Reload & Rows to Load: If you choose ‘Detail View’, you
will see the amount of rows identified in ‘Rows to Load’. You will get an updated
value if ‘Cause Reload’ is checked or ‘Rows to Load’ is altered.
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Understanding Joins

Tables in relational databases share information through a conceptual link, or join,
between related columns in different tables. These relationships are displayed in
Hyperion through visual join lines between fields.

Joins enable you to connect or link records in two tables by way of a shared data
field. Once a data field is shared, other data contained in the joined tables can be
accessed. In this way, each record can share data with another record; however, it
does not store and duplicate the same kind of information.

Joins can be automatically created for you, or you can manually join topics.

To manually create a join:
1. Select a field within a table to join. The field must have a relationship or link
to another chosen field.
2. Drag the desired field from the initial table to the other table and drop it on
the other common field. This automatically creates a ‘simple’ join type.

Join types determine how data is retrieved from a database; however, not all database
servers support all join types.

To specify a join type:

1. Select a join line and select the ‘View’ menu, then ‘Properties’ or select a join
line, right-click on the join line and select ‘Properties’. The ‘Join Properties’
dialog box is displayed.

2. Select a join type and click OK.

Four types of joins are supported:

e Simple join (=, <>, <, >, >= <=): A simple (linear) join retrieves the records
in both tables that have an identical data in the joined columns. You can
change the default join setting for simple joins by choosing an operator from
the drop-down box. The default setting, Equal, is preferred in most situations.

e Leftjoin (+=): A left join retrieves all rows from the topic on the left and any
rows from the topic on the right that have matching values in the join column.

e Right join (=+): A right join retrieves all rows from the topic on the right and
any rows from the topic on the left that match values in the join column.

e Quter join (+=+): An outer join combines the impact of a left and right join.
An outer join retrieves all rows from both tables matching joined column
values, if found, or retrieves nulls for non-matching values. Every row
represented in both topics is displayed at least once.
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Building the Request Line

As you build your query, you can reorder, remove, or hide items on the Request line.
This allows you to change the way in which the query processes and displays.

Reordering Request Items
You can move Request items to reorder them for viewing results.
» To reorder items on the Request line, select the item to be moved and drag it
to a new location on the Request line.

Removing Request Items
You can remove items from the Request line to exclude the data from your query or
Results set.
» To remove an item from the Request line, select the desired item and

complete one of the following actions:

¢ (lick the Delete button on the standard toolbar.

¢ (lick Remove on the shortcut menu.

e Press the Delete key.

If you have not yet processed the query, Interactive Reporting removes the item from
the Request line.

If you have previously processed the query, the Report Refresh dialog is displayed
with this message: “The section XXXX (section) references the following removed
column(s): XXXX (column name). Do you want to keep references to these columns
or turn off auto-refresh or remove them with the query is next processed?” You can
select to keep the references, or remove them.

Caution! Removing items can cause issues with computed items or reports that draw
from the item you delete.

Hiding Request Items

You can hide items that are displayed on the Request line. This allows you to
incorporate data in the results set without displaying it. Hidden request items cannot
be referenced for computations.

» To hide a request item, complete one of the following actions:
e Select the item and click Hide on the shortcut menu.
e Select the item and choose View, then Hide Request Items.
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» To show a hidden request item:
1. Complete one of the following actions:
e Right-click in the Request line and click Unhide on the shortcut menu.
e Select the ‘View’ menu, and then select ‘Unhide Request Items’.
The Unhide Columns dialog box is displayed.

2. Select the items to unhide and click->OK.
When you have identified the fields to include in the query, you can perform a
number of other operations before processing the query. You can add filters to the

filter line, as well as, add computed items to the Request line, or you can use a
Request line fields to specify a sort order within the Sort line.

Maximizing the Query Building Process

It 1s good practice to routinely manage your query process. Often, you may be
processing a query for the first time and will be unsure of your results and want to
prevent a runaway query. There are properties you can control in order to view
smaller datasets of your query.

Setting Restrictions on Your Query Properties

This process allows you to put restrictions on your query process prior to running the
query. You can set a temporary constraint on the query to return a specific number
of rows or to process for a specific number of minutes and then stop. You can also
set the query to return only unique rows.

To access Query Properties:

Select Query—=>Query Options

Or

Double-click->Request on the Request Line

Query Properties

Process

_DK
[ Retum Unique B ows
Cancel
] Retun First 100 Fows
[ Time Limit ~ [1.00 Minutes

[ Auta-Process
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Return Unique Rows—> Eliminates duplicate rows from the dataset retrieved by the
query. Only unique rows are returned.

Return First=> Filters the number of database rows retrieved to the number entered.
You must enter a row filter and check mark the box.

Time Limit—> Limits the amount of time the query is allowed to run to the number
entered. Seconds are entered as a decimal number. Time limits work for
asynchronous (having only each operation started only after the preceding operation
is completed) database connections and cancel at the earliest opportunity for non-
asynchronous connections.

Estimating the Size of Your Query

Queries that sift through and retrieve enormous amounts of data can take a long time
to process, and may consume unnecessary system and server resources. If you
suspect these factors exist, you may want to limit the size of your query before you
hit the process button.

The ‘Estimate Query Size’ feature queries the database to see how many records
your query will retrieve. You can use this feature to test a questionable query or to
decide whether to prevent or postpone processing a large dataset during peak times.
The estimating process will return a count very quickly.

To Estimate the Size of Your Query:

Select Query—>Estimate Query Size

Query Count

ey will return 27033 row|=].
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Exercises
4A)

1. Start a new .bqy using an oce that accesses OSPS data.

2. Bring the ‘OSPS Labor Cost’ table over to the Content Pane.

3. Open the ‘Properties’ dialog box for the ‘Labor Cost’ table and sort
the fields alphabetically.

4. Hide any fields starting with a letter “S”. (Hint — Individually click
on the * in front of each item name.)

5. Enter 15 as the value of ‘Rows to Load’ and check the ‘Cause
Reload’ box.

6. Select OK.

7. Display the Table in ‘Detail View’. You should see 15 total rows
of data. Expand the table to view multiple columns.

8. Display the Table in ‘Structure View’.

9. Unbhide or show the previously hidden fields from step 4.
(Hint: Table properties and click the ‘Show All’ button).

10. Add all the fields, in the OSPS Labor Cost table to the Request
Line.

11. Estimate the size of this query. (Discuss answer with instructor)

12. Remove the Table from the Content Pane. This removes the fields
from the Request Line.

13. Once complete, close the bqy document and do not save. Continue

to the next exercise.
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4B)

1. Open an existing bqy file titled ‘OSPS-Lesson4b’. (See instructor
for location.)

2. Click on the ‘Query’ section and log into the Datamart using an
oce, which accesses both OSPA and SFMA data. (See instructor
for location.)

3. Expand the Tables folder within the Elements section and add the
SFMS ‘Agency’ table to the Content Pane.

4. Join the ‘Agency’ (profile) table to the ‘OSPS Labor Cost’ table.
Create a ‘simple join’ from ‘Sfms Agency’ (OSPS Labor Cost) to
‘Agency’ (Agency table). (Hint: Drag and Drop).

5. Add the following Items to the Request Line:
a. Agency table
1.Agency Title
b. OSPS Labor Cost table
1.Agency
i1.Appn Year
1i1. Employee Num
1v.Number of Hours

6. Reorder the items on the Request Line to the following:
Agency, Agency Title, Appn Year, Employee Num, Number of
Hours, and (Sum) Trans Amt.

7. Hide the ‘Employee Num’ field from the Request Line.

8. Process the query. (Note: This file contains a variable filter on
OSPS-Agency, which will need updated based on the user’s
current agency. Input 5 digit OSPS agency code) (Note: The file is
set to only retrieve 100 rows. A pop-up window will appear and let
you know when this limit 1s reached.)

9. Once complete, close the bqy document and do not save. Continue
to the next exercise.
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Filtering Queries

For most queries it is necessary to set a filter on the amount of data to be returned.
The Datamart contains massive amounts of data, and you want to avoid requesting
unnecessary information. Before processing a query, set the appropriate filters in the
Query Section.

In the Query Section, you can:

1. Manually specify filter values
2. Query the Datamart for filter values
3. Create custom lists of filter values
4. Define compound filter formulas on the Filter Line
5. Set filters as variables to prompt the user to select certain values

Setting Filters

To set a filter:
1) To show the Filter Line: Select-> Filters(0) from the Section Title Bar

2) Drag and drop the Table field you want to filter to the Filter Line
or double-click the Table field

The Filter dialog box will now be displayed on your screen, if your OCE is
active. Otherwise, you must log into your OCE, prior to moving forward.

Filter: Agency Mum

Mame: |JE"-EIEI'I'3".-’ Num OK ]
Comparison
Include Nulls Cancel— | Operator
A
X|v| e
Show Values -

Custom SGL

Select Al A
Remove Advanced
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3) From the drop-down list->Select a Comparison Operator
4) In the Edit text box->Type Values — Separated by commas

5) Select->Green v to add the values in the Edit text box to the Custom
Values List

6) Select>One or more values

7) Select>0OK

Name-> Displays the name of the filter — it defaults to the field name but you can
modify it to say whatever you like.

Include Nulls-> Check mark this box to include null values.

Operator-> Select an operator function from a drop-down list.

Operator Description

Equal = Retrieves records where the filtered item equals the
specified value(s).

Not Equal (=) Retrieves records where the filtered item does not
equal the specified values(s).

Less Than (<) Retrieves records where the filtered item is less than
the specified values(s).

Less or Equal (<=) Retrieves records where the filtered item is equal to
or less than the specified value(s).

Greater Than (>) Retrieves records where the filtered item is greater

than the specified value(s).
Greater or Equal (>=) | Retrieves records where the filtered item is equal to
or greater than the specified value(s).

Begins With Retrieves records where the filtered item begins
with the specified value(s) up to and including the
end value.

Contains Retrieves records where the filtered item contains
the specified value(s) regardless of location.

Ends With Retrieves records where the filtered item ends with

the specified value(s).
Like (with wildcards) Retrieves records where a text string appears and
reflects the placement of the specified values(s).

For example: Names Like %LI_ would retrieve
records for all employees whose names have the
letters li followed by a single character at the end.
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So, “%” represents multiple characters and “_”
represents a single character.

Is Null Retrieves records where the filtered item has no
value; for example, a field in which no data has
been entered.

Between Retrieves records where the value of the filtered
item lies between (and including) the specified
values.

Not (with operator) Negates the operator it precedes, reversing the

results of the equation.

Not-> Reverses (inverts) the operator selected from the drop-down list. For example,
if you select ‘Equal’ from the operator list and then choose Not, the operator is
effectively changed to ‘Not Equal’.

Edit Line-> Enter a value or multiple values (separated by a comma, no spaces) and
select the green v to add the item(s) to the custom values list to complete the filter
information. Select the red X to erase the contents of the Edit field.

Show Values—> Retrieves a list of values from the Datamart (or from the dataset in
the Results section) and allows you to choose a value based on the data available.
‘Show values’ cannot be used for filtering computed or aggregated items.

BE CAREFUL! Since ‘Show Values’ goes directly to the Datamart and searches

for the specified values it may take a while to return information. This means it

searches all the data for exact values. If you think what you are asking for might
be large, don’t select ‘Show Values’; manually type your request in the Edit Line.

If you are setting a filter while in the Result Section don’t hesitate to use Show
Values. Using Show Values in the Results Section only searches the information
within your file.

Transfer-> Displays after you've selected Show Values — moves values from the
Show Values section to the Custom Value list window, allowing the user to select the
value from a list.

Custom Values—> This is the default value when you set a filter. One reason to use
custom value lists within a document is many data items rarely change, if at all. For
example, an Agency field should stay constant when obtaining your own agency
data, while the Agency Object field may change periodically. When data stays
constant, it makes sense for users to select from a custom values list, rather than
continuously querying to show updated Datamart values.
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Select All-> Selects all values displayed in the displayed value area.

Remove—> Removes highlighted values from the custom value list or a filter.
Ignore> Temporarily suspends a filter without deleting it.

Custom SQL-> Displays the custom SQL dialog box for coding Filters directly in
SQL. The Custom SQL button appears only if you access the Filter dialog box from
the Query Section.

Advanced—-> Displays Loaded Value settings and Subquery Options.

Loaded Values Settings—> Toggles a custom values list to be read from a file or from
the Datamart. Change File allows you to specify the file name. If you read values

from a text file, vertical tabs or paragraph markers must delimit each value. Use
Show Values to display the file contents.
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Creating Custom Values List

When creating a custom value list, you do not always have to know your filters prior
to setting them up. You can directly query the Datamart for specific values to filter. It
is recommended to only use this on fields that rarely change.

Once filter values are retrieved from the Datamart, you can transfer them to a
Custom Values list so they are stored locally within the .bqy. Again, you should only
do this if the filter values rarely change. However, if those values change
occasionally, you will need to renew the Custom Values list to keep it current with
the values in the Datamart.

To create a Custom Values List:

1) Drag and drop the Table Item you want to filter to the Filter Line or double-click
the Table Item

The Filter dialog box will now be displayed on your screen, if your OCE is
active. Otherwise, you must log into your OCE prior to moving forward.

Filter: Agy Obj

Mame: |f-‘-.g1_.f Obj QK
Include Mulls Cancel

Not | = Equal i | Ignore
Show Values 311 il T —
Custom Values 3120 lLI
31N
Custom SGL 3150

3210

Select Al 312
— 1 | 3221
| Transfer | |35
3262 ——————
17963 Advanced

2) From the drop-down list->Select a Comparison Operator

3) Select>Show Values

4) Select->Select All or Select the specific values you want
5) Select->Transfer

6) Select->Values you want for the Filter

7) Select>0OK

Department of Administrative Services Page 5-6



Datamart & Hyperion: Payroll Lesson 5
Filters and Sorts

Modifying Filters

A Filter can always be modified. You can change the values and settings
permanently, temporarily ignore it, or delete it.

To modify a Filter Item:
1) Inthe Query Section=>Double-click the Filter Item
2) Make your changes to the Filter dialog box
Operator
Type and select new values
Show Values and select from a new values list

Remove values from the Custom Values List

3) Select>0OK

Ignoring Filters

You can temporarily ignore a filter without deleting it.
To ignore a Filter Item:
1) In the Query Section>Double-click the Filter Item

2) Select->Ignore

Removing Filters

You can permanently remove a Filter Item.
To remove a Filter Item:

Select the Filter-> Right-click-> Select Remove
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Filter Line Logic and Order of Operations

The Filter Line in the Query Section provides ‘AND’ and ‘OR’ operators, as well as,
parentheses to control the logic and order of operations of the filters. These features
are available only in the Query Section so keep this in mind when creating a query.

By using ‘AND’, ‘OR’, and parentheses, you can create complex filters and use an
item on the Filter Line as many times as needed. When you add duplicate items on
the Filter Line they are numbered consecutively.

Request | Agency Mum | Employee Name | Transaction Code | Lv Type | Lv Hours | Pay Proc Date | Rept Dist Code

Fitter ﬂ| Agency Num| AND o | Transaction Code| AND = | Lv Type | AND o | Pay Proc Date | OR ™ | Pay Proc Date2

The Filter Line above is asking for Transaction Code = 90,
Lv Type = SL ‘AND’ Pay Proc Date equal to 4/30/12 ‘OR’ Pay Proc Date2
equal to 5/31/12.
After processing this query and reviewing the Results section, you may be
surprised by the final data.
The results return the proper limited data for 4/30/12 based the filters
above; however, the data returned for 5/31/12 showed all the Transaction
Codes and Lv Types, due to standard operation of the ‘OR’ function.

The following rules apply to all Filter Line expressions:

—>By default, all equations are solved from left to right, when enclosed sub-operations
evaluated first.

—->AND is evaluated before OR.

—>The AND operator retrieves data that meets both conditions. Both conditions
have to be true to get information returned. For example, if you query agencies, and
filter ‘Agency Num’ to ‘10000’ AND ‘10700, the dataset returned will include both

agencies.
—>The OR operator retrieves data that satisfies either of two condition. For example,
if you filter ‘Agency Num’ to ‘10000’ OR Transaction Code to ‘90’, the dataset

returned would include Agency 10000 and information about Transaction code 90.

- Sub-Operations override the default evaluation order and may be required for
certain operations that involve both ‘AND’ and ‘OR’ operators.
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To set AND, OR, or parentheses on the Filter Line in the Query Section:

1) Drag two or more table items to the Filter Line-> Define individual filters in the
Filters dialog boxes. (The AND operator is displayed by default.)

2) Select> Filet ﬂ| on the left side of the Filter Line

3) Select from the filter controls to complete the equation
To toggle from ‘AND’ and ‘OR’, click the operator.
To enclose Sub-Operations, select items to be enclosed and then click the
parentheses button.
To remove parentheses, select them and click the parentheses button.
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Variable Filters

Once a filter is created in the Query Section, you can construct it using the variable
filter feature to prompt for values when the query is processed. Using variable filters
eliminates the need for multiple queries using different filter values. You can use one
query to return multiple datasets for different users.

Variable filters work great with Custom Values Lists. If a Custom Values List is
created, you can answer the prompt with a choice from the Custom Values List.
Each time a user processes the query, the filters are selected from the Custom Values
List rather than being recreated.

To create a Variable Filter:

1) In the Query Section make sure to display the Filter Line

2) Select> Filer ﬂ|

3) Select>Filter Item - Var on the Filter Line
Or
Right-click the Filter Item->Select Variable Filter

Fitter ﬂ| Agency Num | AND o |[RRFEERIO] AMD o | Pay Proc Date | OR = | Pay Proc Date2

The Filter Item is displayed with a V(1) next to it. If you increase the Variable
Filters, they incrementally change to V(2), V(3), etc.
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Customizing Variable Filters Dialog Box

The Custom Filter dialog box allows you to control access to the features available in
the Filter dialog box. This is useful when you distribute the .bqy to end users. It may
be preferable to disable or even remove such features as the ‘Ignore Button’ or the
‘Custom SQL’ option. However, don’t forget that customizing only affects a single filter.
To customize a variable filter:

1) Display the Filter Line in the Query Section

2) Select->Variable Filter Item to be customized->Right-click
- Select Customize Filter

Filter ﬂ| Agency Num| aND o | [T - B

Remove
@ Osps Lv Accrual - Filter...
Ad] Base Rate - v Variable Filter
= Agency Num ——
Appnt Type Code Customize Filter...

3) From the Customize Filter dialog box shown below you can do the following:

Customize Filter

e
|Fiher: Lv Type | Cancel
Prompt: e
Pt | Help
|F'Iease request a LV Type
Options
Values | Ignore Button
At least 1 is reguired. | Advanced Button
| Custom Values | Name Editor
| Show Values | Nulls Checkbox
Custom SGL V| Operator
¥| Type In Box

Prompt-> It adds a user-friendly message for display when prompted.
Values—> Select Values you are giving end users access to use.

Options—> If these are check marked, you are giving the end user access to
complete these options.
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Sorting Data

Use the Sort Line in the Query Section to sort data before it is returned from the
Datamart. You can only include items on the Sort Line that also exist on the Request
Line.

The appearance and functionality of the Sort Line is nearly identical in the Query,
Results, and Table Sections. In each section, the Sort Line uses a drag-and-drop
method similar to the Request and Filter Lines. Data sorted in the Results and Table
Sections are sorted on your desktop and not directly from the Datamart.

Request | Agency Mum | Employee Mame | Transaction Code | Lv Type | Lv Hours | Pay Proc Date
Fitter ﬂ| Agency Num | AND = | Lv Type V(1) | AND = | Pay Proc Date| OR ™ | Pay Proc Date2

Sort | Rept Dist Code #'| Employee Name #

To use the Sort Line in the Query, Results, or Table Sections:

1) Make sure to display the Sort Line if needed by selecting ‘Sort’ on the
Section Title Bar

2) Select->Table Item on the Request Line you wanted sorted-> Drag-and-drop
this Table Item onto the Sort Line

3) Select> 21 = on the Standard Toolbar or
- Double-click the Table Item on the Sort Line to toggle sort ascending or
sort descending

4) Review your Sorted Data
—>If you are sorting in the Query section, the data is sorted by the Datamart
server when you process the query.
—>If you sort in ascending order, an up arrow appears to the right of the item
name on the Sort Line; if you sort in descending order, a down arrow appears.
—>If you are sorting in the Results or Table Section, the ‘Sort Now’ button must
be selected before the data order is altered.

Sort Now || Agency Num #'| Employee Name %/ Lv Type #'| Pay Proc Date #
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Data Functions on the Requested Items

You can apply a data function to an Item on the Request Line in the Query Section
to compute an aggregated value. An aggregated value is a summarized value. You can
summarize items to show averages, sum, minimum, maximum, and count functions
to name a few. By setting these aggregated data functions in the request area you are
creating a smaller result group and demanding less of the Datamart.

If you need both summary data and increasing levels of detail breakdown in your
reporting or analysis, do not aggregate data in the Query Section.

Listed below are the data functions you can choose from using Hyperion. Although
most data functions are applied in the Query Section, you can use many of them in
the Pivot, Chart, or Results Sections. You cannot apply data functions to the Table
Section. In Report Sections, you can apply data functions only if you select a single
fact column. You can also change the way data functions are computed.

Data Description Where Can I Use This?
Function
None Returns unaggregated values as Query

stored in the database. This is the
default option in the Query

Section.
Sum Returns sum of underlying Query, Pivot, Chart,
values. Results, Report
Average Return average of underlying Query, Pivot, Chart,
values. Results, Report
Minimum Returns lowest of underlying Query, Pivot, Chart,
values. Results, Report
Maximum Returns highest of underlying Query, Pivot, Chart,
values. Results, Report
Count Returns number of underlying Query, Pivot, Chart,
values. Results, Report
Count Distinct | Returns the number of distinct Query, Pivot, Report

values in a column. This function
is not supported by all database
Servers.

Weight Use for computing weighted Query
items in pivot tables.
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Null Count Returns number of nulls among | Pivot, Chart, Report
underlying values
Non-Null Returns number of underlying Pivot, Chart, Report
Count values; null values excluded.
Non-Null Returns average of underlying Pivot, Chart, Report
Average values; null values excluded.
Standard Returns standard deviation of Query
Deviation values. This function is not
supported by all database servers.
Variance Returns variance of values. This | Query
function is available through
Oracle servers only.
% of Column | Returns sum of all underlying Pivot
values as a percentage of their
respective surface column.
% of Row Returns sum of underlying values | Pivot
as a percentage of their respective
surface row.
% of Grand Returns sum of underlying values | Pivot, Chart
as a percentage of all surface
values in the report.
% of Category | Returns group total percentage of | Report
the selected value.
Increase Calculates the increase between Pivot
the previous two rows or
columns.
% Increase Calculates the percentage Pivot
increase between the previous
two rows of columns.
Title Returns column names. Report

To use apply a data function on a Request Line Item in the Query Section:

1) Right-click on the Item on the Request Line->Select Data Function->Select
desired Data Function
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Here are some examples of non-aggregated data vs. aggregated data:
Example 1

This query shows non-aggregated data using the OSPS Labor Cost table.

Fegquest | Agency | Pca | Appn Year | Trans Amt | Agy Tranz Date

Fiter ﬂ| Agency| AND = | Employee Num| AND = | Trans Amt| AND = | Pay Period End

Agency Ag*_rj‘l;lrtaens .ﬂ:fepar: Pca Trans Amt
[ 110700 0272813 13 42020 5,304.00
[ 2 | 10700 0272813 13 42020 1.70
[ 2 | 10700 0272813 13 42020 0.95
[ 4 10700 0272813 13 42020 1,385.71
[ 5 | 10700 0272813 13 42020 93.10
[ & | 10700 0272813 13 42020 179
| 7 | 10700 0272813 13 42020 398.01
[ & | 10700 0272813 13 42020 337 96
g 10700 0272813 13 42020 830.21
Example 2

This query shows a ‘Sum’ Data Function on the ‘Trans Amt’ Item within the OSPS
Labor Cost table.

Request | Agency | Pca | Appn Year | SUM({Trans Amt) | Agy Trans Date

Fitter j| Agency | AND o | Employee Mum | AMD = | Trans Amt | AND o | Pay Perod End

| Agy Trans | Appn
Agency Date Year

1 (10700 0212813 13 42020 8,358.43

Pca Trans amt
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Filters and Sorts

Exercises
5A)

1. Start a new .bqy using an oce that accesses OSPS data.

2. Expand the Table Elements and add the ‘OSPS_Lv_Accrual’ table
to the Content Pane. (Sort the table fields alphabetically)

3. Add the following Items to the Request Line:

a. Agency Num

b. Employee Num

c. Pay Proc Date

d. Transaction Code

e. Lv Hours (Use the ‘Sum’ data function)
f. LvType

4. Filter on ‘Agency Num’ equal to your current agency, ‘Lv Type’
equal to ‘VA’, and ‘Transaction Code’ equal to 90.

5. Filter the maximum rows returned to 100 (**Hint: Lesson 4 —
‘Return First ; p.4-8 & 4-9).

6. Process the query.

7. Sort the Results Section by ‘Employee Num’ and ‘Pay Proc Date’.

8. Remove the ‘Return First - 100 Rows’ feature.

9. In the Query section, add a filter for ‘Pay Proc Date’. Use the
‘Between’ data function to show data between the current month
and two months prior. (Note: You can manually type in the dates,
separated by a comma or select dates from the ‘Show Values’
button.)

10. Process the query.

11. In the Results section, add a filter of ‘Lv Hours’ not equal to zero.

12. Once complete, close the bqy document and do not save. Continue

to the next exercise.
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5B)
1. Start a new .bqy using an oce that accesses OSPS data.

2. Expand the Elements Pane and bring the ‘OSPS Js Lab Adj’ table
to the Content Pane.

3. Sort the fields in the table alphabetically.

4. Add the following fields to the Request Line:
Agency Num

Pay Type Code

Pay Period End

Number of Units (Use the ‘Sum’ data function)
Classified Code

Hourly Pay Rate

me a0 o

5. Filter the ‘Agency Num’ to your current agency and ‘Pay Period
End’ equal to the current month.

6. Process the query.

7. In the Results section, set a Filter of ‘Number of Units’ not equal
to zero.

8. Go back to the Query section and create a Filter on ‘Pay Type
Code’ equal to ‘RG’, ‘VA’, and ‘SL.

9. Process the query.

10. In the Results section, sort by ‘Classified Code’ and then ‘Pay
Type Code’ in Ascending order.

11. Go back to the Query section, add ‘Pay Type Descr’ to the
Request Line.

12. In the Query section, set a Variable Filter on ‘Classified Code’.
a. Set the ‘Custom Value’ to Begins with ‘C’ and click ‘ok’.
b. Right-click on the ‘Classified Code’ Filter and select ‘Variable
Filter’.
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13. Process the query. (The Variable filter window for ‘Classified
Code’ will pop up. Verify step 12 is complete and click ‘ok’)

14. Alert the instructor after correctly completing the exercise.
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What’s the difference between Results and Table Sections?

The Results and Table Sections are identical in functionality and appearance.
Therefore, what is the difference? Let’s consider the Results Section is the gas tank
for your .bqy. This is where all your queried data lives. The Results Sections allows
you to review your data produced by the Query. The Table section, on the other
hand, allows you the option to separate the Results data into smaller sections. Think
of a Table Section as a filing cabinet with different files. It is a way to organize your
data into smaller sub-sections and then develop Pivots, Charts, and Reports from
these sub-sets. In other words, a Table keeps you better organized.

Sections Structure:

Sections x
2i| Dashbaard Notice the indenting or
%] report non-indenting for the
% report2 different Sections. It is
A query good practice to rename
A Resuits your sections for easier
i Table identification.

[ Pivat

Dashboard—> This section does not indent and can contain information from
multiple Queries, Results, Tables, Pivots, Charts, and Reports. It appears at the top
of the Section Catalog.

Report=> This section does not indent and can contain information from multiple
Results, Tables, Pivots, and Charts. It appears directly below Dashboard Sections
and above all other sections.

Query-> This section does not indent and is a stand-alone section in your .bqy. This
section comes straight from the Datamart and is the building block for all the other
sections.

Results> This section does not indent but resides directly below the Query Section it
is dependent upon. This section is directly related to the Query Section.

Table-> This section does not indent and resides directly below the Results Section it
is associated with. You can have more than one Table Section related to a Results
Section. Used primarily for creating tabular-style reports.

Pivot—=> This section does indent and resides below the Table Section it is associated

with. You can have more than one Pivot Section related to a Results Section. The
Pivot Section is used to create cross-tabular style reports called Pivot Reports.
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Chart—> This section does indent and resides below the Table and/or Pivot Section it
is associated with. You can have more than one Chart Section related to a Results
Section. Chart Reports are fully interactive, three-dimensional views of data.

Below shows a Table Section before any data is added to the Content Pane. Notice
the Data Layout Section.

WA Table -

Sections x Soit

] Doshboars Fiter | Dvag Aeport Cotbmrs heve io create Fiters
%] Report

%] Report2

A query

@B Results
@ pivot
| chart

W Eitters) =] Sort) G5 Data Layout
| Drag Aequest rems heve to sort them

Data
Layout

Elements
¥ Results (Query]
[l Aaency
|1 Gl Aot
|14 Project Mo
[ Project Phase
P

ca
18] Stms Trans Amt

To create a Table Section (based on the Results section data):

1) From the Results section, select Insert->New Table

2) Ifthe table Data Layout is not already displayed-> Click Data Layout on the

Section Title Bar

3) Drag Result fields from the Elements Catalog Pane to the Data Layout area to

build your Table. (Hyperion automatically populates the table columns.)
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Formatting Data in Results and Table Sections

Use the following techniques to format data in both a Results and a Table Section.

Format

Options

Resize a column

v

v

To resize a column manually, drag the right
margin of the column.

To auto size a column, double-click the column
margin or select Format-> Column-> Auto-Size
Width (or Standard Width).

Resize a row

To resize a row manually, select a row (click in
the left margin), position the cursor on the
bottom of the row, and then drag the margin up
or down.

To resize a row to a standard size, select a row
and then select Format->Row->Standard
Height.

Modify the font

Select a column, select Format->Font, and then
select a font type, style, size, and effect.
Columns can have different fonts.

Modify a number, date,
or time format

For numeric formatting only, select a column
and then on the Formatting toolbar, select
numeric formatting options.

For a complete set of formatting options, select
a column, select Format->Number, and then in
the Category group box, select a format.

Justify data

Highlight columns, and then on the Formatting
toolbar, click a justification button.

Display row numbers

To toggle row numbers on and off, select
Format->Row Numbers.

Format grid lines

Select Format—>Grid Lines, and then select
properties for horizontal and vertical grid lines.

Display or hide column
titles

Select Format=> Column Titles.

Wrap text in a column

Select a column, and then select Format-> Text
Wrap.

Modify the border
around a table

Select Format->Border and Background, select
properties for the border, and then click OK.
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Modify the table fill v Select a column, multiple columns, or the entire
table, select Format->Border and Background,
select background properties, and then click
OK.

Modify the text color v’ Select a column, and then on the Formatting

of a column toolbar, select a text color.

The following table provides a listing of commands available on the Format Menu.

Results  Tools  Windo

Fonk...

Skyle *
Humbet. ..

Juskify 3
Colurmnn r
Raw [

v i_olumn Titles

v Row Mumbers
Texk Wrap
Suppress Duplicates

arid Lines., ..
Border and Background. ..

Conditional Formatting. ..
Expott Properties., ..

Format Menu Command Function

Font v Opens the Font page of the Properties
dialog box.

Style v" Choose between Plain, Bold, Italics,
Underline, Overline, Double Underline.

Number v Opens the Number page of the Properties
dialog box.

Justify v Choose between Left, Center, Right and

Top, Middle, Bottom.
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Column

By default, Results columns are evenly
sized without regard to the length of
data. Numeric data that does not fit is
replaced with pound signs (#).

To manually resize a column, drag the
right edge of the column to a new
position.

To automatically size all columns so that
the column width fits its contents, press
[Ctrl+A] [Ctrl+E].

Auto-Size Width

Resizes the selected column to the width
of the contents.

Standard Width Resizes the selected column to the
standard column width.
Row Resizes all rows to the standard row

height.

To resize all rows in a table, drag the
bottom edge of a row to a new position.
All rows in the table are resized.

Column Titles

Toggles the display of column titles.

Row Numbers

Toggles the display of row numbers.
Row numbers are printed on reports, but
are not copied to the clipboard or
exported to a file.

Text Wrap

Woraps text in a column.

Suppress Duplicates

Suppresses duplicate values in a column.
Use this feature if you want to display
only the first instance of a duplicate value
when individual database records include
redundant information.

Grid Lines Opens the Gridlines page of the
Properties dialog box.
Border and Background Opens the Border and Background page

of the Properties dialog box.

Conditional Formatting

Opens the Conditional Formatting dialog
box. Use to highlight important values.

Export Properties

Opens the Export Properties dialog box.
Use to set the number of rows that
should be included on an HTML page
before the data breaks to another page,
and to export data that does not contain
any quote to a tab-delimited text file.
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Sorting Data in a Table Section

You can sort data in the Table Section using the sort options on the Standard
Toolbar or the Sort Line.

To sort data using the Standard Toolbar:

1) Select=>Column you want sorted

2) Select> A= Sort Ascending or Sort Descending
AE B | a3 | Mrroces | | = < 3¢
Sort | [ N [ledn Pleg % Dedn Plan Code #'| Dedn Desc #
Dedn
Agency Benefit Dedn Dedn
Num BrdCd Pkg Flan Type Dedn Desc Ee Dedn Amt
Code
1 (10700 M AE 050 AEMM  EMPADED 5.00
Z (10700 M AE 100 AEMM  EMPADED 22.00
2 (10700 M AH 001 AHMM  LOMGTERM DIZ 184 44
4 (10700 M DL 3 DLMM 2 CENTEC a0.00

To sort data using the Sort Line:

1) Make sure the Sort Line is visible; if it isn’t select->Sort on the Section
Title Bar

2) Drag and drop Items from the Content Pane to the Sort Line. By default items
will be sorted in ascending order.

3) Double-click->Table Item on the Sort Line to toggle sort ascending

. Sort Jedn Type & 5 £
or sort descending || *° | Dedn Pkg */| Dedn Plan Code

4) Select->Sort Now on the Sort Line

/

Sort Now || Dedn Pkg | Dedn Plan Code 7

Department of Administrative Services Page 6-7



Datamart & Hyperion: Payroll

Suppressing Duplicate Values
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You use the ‘Suppress Duplicates’ option to suppress duplicate values in a column.
Use this feature if you want to display only the first instance of a duplicate value
when individual database records include redundant information. In order to use this

feature correctly, you must first sort your data.

Sort

| Dedn Type % Dedn Pkg % Dedn Plan Code # Dedn Desc #

Mum  Brd Cd

10700 M
3
M

Ga | =i | & | kn | | fa | ka

MR

= W =m

(=4 il Il B el e

o

To suppress duplicate values:

Agency Benefit Dedn

Fkag

KD
V3
LI
B
LA
D

SW
ST
SP
sSL
FK

o1
oo

LT
D3
oo

Dedn
Plan
Code
B4
oD
020
CCC

111
112
DoD
001
LoD
001
333
444
LoD
AAA
CCC
001

Dedn
Type

HOMM
VEMM
LIMMM
LIBMM
LIAMM
TOMNM

SWHMN
STMM
SPMM
SLMM
PEMM

OTMM
OCaMM

LTMM
D3SMM
DOMM

Dedn Desc

DIRECT DEFP

V3P

SPIDP 40-44

EMP LF/35-39
EMP LF/30-34
SEIU 8503155

PSWP
SHORTERM D13
FEWP PIT
BASIC LIFE
FARK PRETAX

ODs TRD DENMT
0ODS DENT PIT

DEP LIFE
SEIUB03 F/S
SEIU 503 DUE

1) Sort the data in the Results or Table Section

Ee Dedn Amt

34, 786.56
5.04
30.30
46.56
8.04
33.87
3.45
354 52
216.53
626.71
0.80
71.00
877.00
2877
58.35
3696
24.51
67.73
719.10

2) Select the columns you want to suppress values on-> Right-click

- Select Suppress Duplicates
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Setting and Removing Local Filters in Results and Table
Sections

When you set a filter in the Results or Tables Section, you can locally filter the
dataset returned from a query. You are not accessing the Datamart. This is different
from setting a filter in a Query Section. When you set a filter in a query, you are
sending this filter directly to the Datamart. Because local filters only hide data, it is a
good way to test hypothetical situations without accessing the Datamart. You can
always reverse the effects of your filter and bring your query back to its original state.

To set a filter in a Results or Table Section:

1) In a Results or Table section, double-click a column and a Filter dialog box is
displayed. Or, drag and drop the Table Item you want to filter to the Filter Line

The Filter dialog box will now be displayed on your screen.

Filter: Batch Agy

M ame: (]

[ Include Mulls Cancel
[ Nat | =Equal o lgnare
X

udlis

Help

Show Values

Cuztom Yalues

Select All

Remove

1l

Options

2) From the drop-down list=>Select a Comparison Operator
3) In the Edit text box->Type Values — Separated by commas

4) Select>Green v to add the values in the Edit text box to the Custom
Values List

5) Select=>OK
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To remove a filter in a Results or Table Section:

1) Right-click the Filtered Item->Select Remove

To remove all filters in a Results or Table Section:

Filter ﬂ|

1) Right-click the icon on the Filter Line-> Select Remove
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Creating Date Groups

This feature separates regular date type columns into Month, Year, and Quarter
columns. This feature only works on columns of a date type. Please notice the before
and after diagrams shown below.

Before Date Groups

| |
F'aéF'trnc: TLu Ly Hours ' —
| ale ype The first diagram is without Date
T oononz w220 Grouping.
— : ' The second diagram creates the Date
2 103112 WA, 24 27 g 00
— Group and now contains additional
4| 1E0M2 WA, 33N 1 brok by Month. Y
s | 4273112 VA 24 45 columns broken out by Month, Year,
6| 013113 | VA 4179 and (calendar year) Quarter.
_7 | 0212813 WA 3913
& 033113 WA 42 97
Date Groups Applied
| | I | |
Pay
PayProc | Lv PayPIoc  oayproc Proc
Lv Hours Date
Date Type Date Year Date
Month
Quarter
(1] 08312 VA 1459 Aug 2012 Q3
| 2 | 09/30M12 WA 2293 Sep 2012 Q3
|3 | 103112 WA 2427 Oct 2012 04
| 4 | 1103012 WA 33N Moy 2012 Q4
| 3 | 123112 WA 34 45 Dec 2012 04
| & | 0113113 WA 4179 Jan 2013 Q1
| 7 | 02/28M13 WA 3913 Feb 2013 o1
& | 033113 WA 42 97 Mar 2013 Q1

To create a date group:
1) Select a regular Date column in the Results or Table Section

2) Right-click>Add Date Groups
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Creating Grouping Columns

Grouping columns is a way of creating new data in your results set by grouping data
from a column. You can use grouping columns to consolidate non-numeric data
values into more general group values and map the group values to a new column in
the data set. Grouped columns are new items added to the Results Section and are
available for use in Report Sections.

Steps to create a Grouping Column:

1) Notice the Table Section below. The goal is to create an additional new
column called Quarter.

2) Select the Column you want to group-> Right-click-> Select Add
Grouping Column

Y A

Pay
Pay Proc Lw Pay Proc Pay Proc Proc
LvHours Date
Type Date Year Date
Maonth
Quarter
WA, 14.59 Aug 2012 Q3
WA, 2293 Sep 2012 Q3
im 24 97 it 2012 04
Filter... 012 Q4
Sort Ascending 012 a4
013 a1
Sort Descending 013 o
013 Q1
Add Computed tem...
Add Grouping Column...
3) The Grouping Column dialog box opens
Pay
Pay Proc Lv Lv Hours F'agaF'téoc Pay Proc Proc
Date Type Month Date Year  Date
! Quarter
WA 14.59 Aug 2012 3
Grouped Column: Pay Ilroc Date ;
Column Mame; Group of Pay Proc Date
Groups: tems in Group: Available Values:
CGluarter 1 . - 08312
09/30/12
J 10/3112
1153012
12/31/12
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Column Name-> Names the new grouping column in the Results/Table window.
This is the column header.

New Group—> Creates a custom group to be displayed as a value in the new
grouping column.

Groups—> Select a custom group to define by adding or removing items.
Items in Group—> Removes an item from a selected custom group.
Available Values> Add items to a selected custom group.

Options—> Indicates how to signify unassigned values within the grouping column.
Options include:
Null-> Leaves the values ungrouped and unaggregated.
Default-> Allows you to specify a default name to assign to all ungrouped
values.
Individual Group—> Assigns each ungrouped value the name originally
assigned to it.

4) In the Column Name field>Name your Grouping Column

5) Select New Group—>Enter New Group Name->OK
Do this process until you have all the new groups set up.

Pay
Pay Proc Group of
Pay Proc Lv Lv Hours gate Pay Proc Proc Pay F'proc:
Date Type Month Date Year Date Date
Quarter
083112 || Grouped Column: Pay Proc Date -
09/30/12
102112 Column Name:  Group of Pay Proc Date
113012
12031112
0133
02/2813 Help
0313113 Groups: ftems in Group: Available Values:
Quarter 1 - - 08/31/12 -
Quarter 2 09,3012
L.110/31412

New Group

Mame: Guarer 3

6) Select Group in Group Column->Move Available Values by selecting them and

click on ﬂ to move them over to the Items in Group Column.
Continue this process until you have all your groups set up.

Department of Administrative Services Page 6-13




Datamart & Hyperion: Payroll Lesson 6
Tables and Formatting

7) Select>0OK

Pay
Pay Proc Group of
UGS gy Lidows Da - PRToC POC Fayproc
Manth Date

CQuarter
0813112 WA 14.59 Aug 2012 Q3 Quarter 1
0943012 WA 22893 Sep 2012 Q3 Quarter 1
10031012 WA 24 27 Ot 2012 Q4 Quarter 2
113012 WA 331 Maw 2012 Q4 Quarter 2
1203112 WA 34.45 Dec 2012 Q4 Quarter 2
0143113 WA 41.79 Jan 2013 Yy Quarter 3
0212813 WA 3913 Feb 2013 iy Quarter 3
0303113 WA 42 97 Mar 2013 21 Quarter 3

To modify a Grouping Column:

1) Right-click the Grouping Column->Modify Column

Removing and Hiding Data

You can either Remove or Hide items from your Query, Results, and/or Table
Sections. Use caution when removing items from any section! Once an item is
removed, you can’t use it in a Pivot, Chart, or Report. If you hide an item it is still
usable in all these sections.

To remove an item in the Query or Table Section:

Remove the Table Item from the Request Line from the Query Section or the Data
Layout Section in the Table Section.

To hide an item in the Results or Table Section:

Select the Column->»Right-click->Hide Column
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Creating Grand Totals and Break Totals

Results and Table Sections can display grand totals and break totals. You can display
multiple totals each utilizing a different data function. While a grand total would
appear at the bottom of a column, a break total will appear at a specified break in the
dataset.

To display a grand total:

1) Select column you want to total->»Right-click->Select Grand Total
The Insert Grand Total dialog box appears.

I ly

Insert Grand Total

-
PE'E;;:": TLUE Lv Hours Grand total function:
v [Sum »| [ ok ]
08/31/12 YA Add grand total to: Cancel
09,3012 WA Pay Proc Date .

103112 VA
1113012 WA
120312 VA
013113 WA
022813 WA
033113 WA

Lv TEE Help

Pay Proc Date Morth

Pay Proc Date Year emor M
Pay Proc Date Guarter

Group of Pay Proc Date -

You have a choice of Grand and Break Total functions:

Function Description

Sum Returns sum of underlying values.

Average Returns average of underlying values.

Minimum Returns lowest of underlying values.

Maximum Returns highest of underlying values.

Count Returns number of underlying values.

Other Allows you to create a custom function using
JavaScript.

2) Select—>’Grand total function’, you desire
3) Select>Where to ‘Add grand total to’

4) Select=>0K
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Pay Proc Lv Pay Proc Pay Proc

Diate Type LvHours Date Crate Year

Month You may find that you need

08/3112 VA | 1459 Aug 2012 to format your numbers
09/30M12 VA 2293 Sep 2012 during this process. Do you
10/3112 VA 2427 Oct remember how to do this?
113012 WA CX b Mow
1213112 WA 34.45 Dec
013113 WA 4179 Jdan 2013
02/28M13 WA 3913 F 2013
033113 WA 42 97 Mar 2013

You can also create a SUM grand total using an icon on the Standard Toolbar:

1) Select->Column you want to total

2) Select> on the Standard Toolbar

To remove a grand total row:
1) Select>Row containing the grant total

2) Right-click>Remove Row

Pay
Pay Proc Group of
URIE e bows | Date BRI PR parr
Month Date

Quarter
083112 WA 14.59 Aug 2012 Q3 Quarter 1
0973012 WA 2293 Sep 2012 Q3 Quarter 1
1003112 VA 2427 Oct 2012 04 Quarter 2
1113012 WA 33 Now 2012 Q4 Quarter 2
1213112 VA 34.45 Dec 2012 04 Quarter 2
01/3113 WA 4179 Jan 2013 Q1 Quarter 3
0212813 VA 3913 Feb 2013 o1 Quarter 3
033113 VA 42 .97 Mar 2013 Q1 Quarter 3

I I

Add Computed Itemn...

Remove Row

Font...
To add a custom title in the grand total row, not the grand total cell:
1) Double-click on a cell in the same row as the grand total

2) In the Custom Function dialog box enter the title you desire surrounding by
quotes “’’ as shown below:
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Pay Proc

L

Date Type

093012

WA
WA
WA
WA
WA
WA
WA
WA

Lv Hours

14.59
2293
24.27
33.11

34.45
41.79
39.13
42,97

253.24

2013

—_—

"Total Lv Hours: "

Quarter 3

3) Select>0OK

4) From the Modify Total Function dialog box select-> Other

Meodify Total Function l

Grand total function:
|Other... v
Help
5) Select>0OK
Pay
Pay Proc
Pay Proc Date Lv Lv Hours Date Pay Proc Proc
Type Date Year Date
Manth
Cluarter
a1z WA 14 .59 Aug 2012 Q3
09/30M2 WA 2293 Sep 2012 Q3
1003112 WA 24 27 Oct 2012 Q4
13012 WA 331 Mow 2012 Q4
1203112 WA 34 .45 Dec 2012 Q4
0173113 WA 41749 Jan 2013 1
02/28M3 WA 3913 Feb 2013 1
0373113 WA 42 97 Mar 2013 1
Total Lv Hours: 263.24
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To add a custom title in the grand total cell:

1)
2)

3)

4)

5)

6)

Double-click on the grand total cell

From the Modify Total Function dialog box->Select Other

Modify Total Function

larand total function: il 4

oK |
Otker...

Help

Enter your desired title surrounded by quotes “”, for example “Total: ”.
Make sure to insert a space after your title!

Concatenate text and functions with a plus sign (+)
“Total: ”+Round(Sum(Lv_Hours),2)
Select>OK

In the Modify Total Function dialog box->Select OK
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To display break totals:

1) Select column you want to total->»Right-click->Select Break Total
The ‘Insert Break Total’ dialog box appears.

| | Insert Break Total
At every break in:
Group of Pay
Pay Proc Date Proc Date Lv Hours [Gmupaf o Boe Eoie v] [ oK ]
Break: total function:
0813112 14.59 | [Sum -]
09/30/12 22.93 | Help
10/31/12 Quarter 2 ¥y LimoaT o
11/30112 0 3311 | | [Pay Proc Date ~ [ Remove A
1213112 Cuarter 2 34 45 T
= 3 1 v [ype
0113113 [j r 3 41.79 | Pay Proc Date Month
02/28/13 Quarter 3 39.13 | | |Pay Proc Date Year
033113 4297 Pay Proc Date Cuarter
2) At every break in drop-down->Select your break column criteria
3) Break total function—>Select function
4) Select one or more columns—>Add Break total to
5) Select>0OK
Pay
Pay Proc
FPay Proc Date Group of Pay Lv Hours Lv Date Pay Proc Proc
Proc Date Type Date Year Date
Maonth Quarter
03 N2 Cluarter 1 1459 VA Aug 2012 Q3
093012 Quarter 1 2293 | VA Sep 2012 Q3
Total Quarter 1 37.52
1003112 Quarter 2 2427 | VA Oct 2012 04
1113012 Quarter 2 3311 A Maow 2012 L4
1213112 Quarter 2 3445 WA Dec 2012 Q4
Total Quarter 2 91.83
0113113 Quarter 3 4179 WA Jan 2013 Q1
02128123 Quarter 2 3913 VA Feb 2013 o1
033113 Quarter 2 4297 WA Mar 2013 o1

Total Quarter 3 123.89
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Tables and Formatting

Exercise

1. Start a new .bqy using an oce that accesses both OSPS and SFMA
data. (Ask instructor for oce location.)

2. Expand the Elements Pane and bring the ‘OSPS Labor Cost’,
SFMS ‘Agency’ and ‘Pca’ table to the Content Pane.

3. Sort the fields in all the tables alphabetically.

4. Join the SFMS and OSPS tables as follows:
a. Labor Cost. ‘Sfms Agency’ to Agency: ‘Agency’
b. Labor Cost: ‘Sfms Agency’ to Pca: ‘Agency’
c. Labor Cost. ‘Pca’ to Pca: ‘Pca’
d. Labor Cost. ‘Stms Appn Year’ to Pca: ‘Appn Year’

5. Add the following fields to the Request Line:
a. Labor Cost - table:
1. Agency
1. Appn Year
1i. Pca
1v. Pay Period End
v. Number of Hours
vi. Trans Amt (Use Data Function: Sum)
b. Agency - table:
1. Agency Title
c. Pca - table:
1. Pca Title

6. Arrange the fields from step 5 on the ‘Request Line’ to look like
the following:

Reguest |;‘-‘-.genc'_.r Agency Title | Appn Year | Pca | Pca Title | Pay Perod End | Mumber Of Hours | SUM{Trans Amt)

4. Filter the query to OSPS Labor Cost: ‘Agency’ equal to your
current agency and ‘Pay Period End’ equal to the current pay
period.
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Tables and Formatting

5. Process the query.

6. Filter the ‘Results’ Section to ‘Number of Hours’ greater than zero.

7. Insert a new ‘Table’ Section.

8. Drag and drop the following fields to the ‘Data Layout’ section to
allow the data to show on the Content Pane of the ‘Table’ Section:

me a0 o

Agency

Pca

Pca Title

Pay Period End
Number of Hours
Trans Amt

9. Within the Table section:

a.

b.

Sort by ‘Pca’ & ‘Number of Hours’, in Ascending Order.

Change the font of every column on your Table to Arial -
size 10 and auto size the width of your columns. (Hint: To
auto size use ‘Ctrl A’ & ‘Ctrl E).

Suppress Duplicate values of the ‘Agency’, ‘Pca’, ‘Pca Title’
and ‘Pay Period End’ columns.

10. Within the Table section:

a.

b.

Add a ‘Date Group’ using the ‘Pay Period End’ column.

Move the ‘Pay Period End Quarter’ column next to ‘Pay
Period End’.

Format the justification of each new column to ‘Center’.

Format all column titles to ‘underline’ with black font. In
addition, add a background color (your choice).

11. Within the table section, create a ‘Grouped column’ called ‘Pca
Groups’, based on the ‘Pca’ column.
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12.

13.

14.

15.

16.

17.

Tables and Formatting

Create the following ‘New Group’ names within the grouped
column:

a. Pca-1

b. Pca-2

c. Pca-3

d. Pca-4

e. Pca-5+

Next, assign the ‘Available Values’ to the New Groups as follows:
a. Pca-1: All Pca beginning with 1
b. Pca-2: All Pca beginning with 2
c. Pca-3: All Pca beginning with 3
d. Pca-4: All Pca beginning with 4
e. Pca-5+: All Pca beginning with 5 through 9

Within the pop up window for the ‘Group of Pca’ grouped
column, click on the ‘Options’ button. Update the ‘Grouping
Options for Ungrouped Columns’ to show all unassigned values as
Default->’Other’. Click ‘Ok’ when finished.

Note: This will allow any unassigned ‘Available Values’ to show
within an ‘Other’ category, so that you do not forget to assign the

value.

Select ‘Ok’ to finalize the grouped column creation, then format
the new column the same as step 10c & 10d.

Within the ‘Table’ section, under the ‘“Trans Amt’ column, input a
summed ‘Grand Total’.

Alert the instructor after correctly completing the exercise.
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	Lesson 1
	What is a Datamart?
	The Datamart provides a resource for easy reporting.
	The Datamart gives the user the ability to create custom reports.
	Datamart Business Analyst
	The main Datamart site is dedicated to providing valuable information on everything about the Datamart, as well as, the Hyperion application.  Please visit: http://www.oregon.gov/DAS/Financial/AcctgSys/Pages/Datamart.aspx
	Datamart Maintenance Website
	The maintenance site is dedicated to helping users with their Datamart password, as well as, has the capability to stop queries ran against the DAS Datamart. Please visit: https://datamartapp.dasapp.state.or.us/
	Datamart News List
	Datamart User Group Survey meetings
	History of Brio/Hyperion
	Am I ready to work in Hyperion?
	Lesson 2
	The following are steps to create an Open Catalog Extension (OCE) in Hyperion Interactive Reporting Studio - Version 11.
	1)  Open the Hyperion application, you will see a similar “Welcome to Hyperion” dialog box, as shown below.
	Select(A New Database Connection File
	Select(OK
	2) The “Database Connection Wizard” will display, as shown below.
	Select(Next
	3)  In the box labeled “User Name”, type your Datamart User Name (this is your RACF ID).
	Select(Next
	5)  On the following “Meta Connection Wizard” screen, click ‘Next’.
	6)  Check the boxes for “Allow SQL-92 Advanced Set Operations” and “Exclude Hyperion Repository Tables”.
	Next, select the middle Define button to the right of ‘Owner Name’.
	Select(OK
	Then select(Next to continue
	8)  Update the next two screens as they appear below. Make changes as necessary.
	9)  Select(Finish starting the completion of this process
	10) Select(Yes to save your OCE
	Setting up an SFMA Datamart OCE
	5)   On this “Meta Connection Wizard” screen select ‘Edit’.
	6)  This next screen is the “Meta Data Table Definition”
	7)  Select(Custom (The grayed out fields now become white for data entry.)
	Once input is complete, select(OK.
	Select(Next to continue
	9)   Check the boxes for “Allow SQL-92 Advanced Set Operations” and “Exclude Hyperion Repository Tables”.
	Next, select the middle Define button next to ‘Owner Name’.
	Select(OK
	Then select(Next to continue
	Modifying an OCE
	To modify an OCE:
	Tables on the Datamart
	SFMA Financial Tables
	Accounting Event Tables

	General Ledger Detail Tables
	General Ledger Summary Tables
	Other Special Financial Tables
	Appropriation Financial Table
	Contract Financial Table
	Grant Financial Table
	Project Financial Table
	Receipt Extr Sum Table
	Document Financial Tables
	Payment Control Table
	Profile Tables

	OSPA Datamart Tables
	OSPA DED Tables
	OSPA JS Lab ADJ Tables
	OSPA Labor Cost Tables
	OSPA LV Accrual Tables
	OSPA Net Pay Tables
	OSPA Work Sched Table
	Below are instructions for accessing the Datamart Repository.


	Lesson 3
	Datamart & Hyperion Spider Web
	BQY Documents, Sections, and Toolbars
	BQY Documents
	BQY Sections
	The following figure shows the sections and toolbars of a Hyperion .bqy.
	Online Help
	Online help is available through Hyperion.
	From the Menu Bar (Note: Must have bqy started)
	Help(Help on Content
	Or
	Select the ‘F1’ key
	Contents( Allows the user to search for help on a pre-defined topic
	Index( Search for help on predefined topics alphabetically
	Search( Type your help issue in the search box for results
	Opening and Saving BQY Documents
	Opening a BQY Document
	Open Hyperion from your Start Menu
	Select(Browse from Recent Database Connection File
	Select(OSPS.oce(OK
	Similar to other applications, you have several choices for saving your .bqy.
	File(Save
	File(Save As
	File(Save Options(Save Query Results With Document
	Use this if you want to perform off-line data analysis of your .bqy.
	File(Save Options(Compress Document
	File(Save Options(Password Protect Document
	File(Save Options(Password Protect Design Mode
	Password protection used to guard Dashboard designs.
	Processing and Stopping Queries
	Processing Queries
	Process Current(Processes the query that is currently active.
	Process Order of Queries
	Tools(Process Query(Process Order
	Prior to processing a query, you must complete the following steps:
	Add a ‘Table’ to your query section:
	Create a Filter for your query:
	Double-click(Field Name. A ‘Filter’ dialog box pops up.
	Click(Show Values(Select an option(Click(OK
	Select( from the Standard Toolbar
	Open the Internet
	Go to( https://dasapp.state.or.us/DatamartApp
	Log in using your Datamart user name and password
	Select from top menu(Query
	Select(Cancel All Queries
	You can add, duplicate, rename, or delete a .bqy section at any time.
	Insert(New(Select the Section you want to add
	Your choices are:
	Hiding a BQY Section
	Select View(Hide Section
	Select File(Send
	Printing BQY Sections
	Adjusting the Page Margins in Print Preview
	File(Print Preview
	To adjust the page margins:
	Adding Headers and Footers
	Select Insert(Page Header or Page Footer
	Printing Sections
	You can print any section of your .bqy.
	Click Section(Select File(Print
	Lesson 4
	BQY Process
	Managing your Table
	What can I do to the Table Properties?
	Hide/Show All( Hides or actively show all table items.
	Up/Down( Moves selected item up or down one space in the topic display.
	Sort( Alphabetically sorts listed items.
	Allow Icon View( Enables the icon view option for the table.
	Allow Detail View( Enables the detail view option for the table.
	Icon View - Be Careful! Icon View deactivates a table and reduces it to an icon in the Content frame. This feature will break joins.
	Understanding Joins
	Building the Request Line
	Maximizing the Query Building Process
	Setting Restrictions on Your Query Properties
	Select Query(Query Options
	Double-click(Request on the Request Line
	Estimating the Size of Your Query
	Select Query(Estimate Query Size
	Lesson 5
	Filtering Queries
	In the Query Section, you can:
	1. Manually specify filter values
	1)  To show the Filter Line: Select(Filters(0) from the Section Title Bar
	2)  Drag and drop the Table field you want to filter to the Filter Line  or double-click the Table field
	The Filter dialog box will now be displayed on your screen, if your OCE is active. Otherwise, you must log into your OCE, prior to moving forward.
	3)  From the drop-down list(Select a Comparison Operator
	5)  Select(Green ( to add the values in the Edit text box to the Custom
	Values List
	6)  Select(One or more values
	Include Nulls( Check mark this box to include null values.
	Operator( Select an operator function from a drop-down list.
	Select All( Selects all values displayed in the displayed value area.
	Remove( Removes highlighted values from the custom value list or a filter.
	Ignore( Temporarily suspends a filter without deleting it.  Custom SQL( Displays the custom SQL dialog box for coding Filters directly in SQL. The Custom SQL button appears only if you access the Filter dialog box from the Query Section.
	When creating a custom value list, you do not always have to know your filters prior to setting them up. You can directly query the Datamart for specific values to filter. It is recommended to only use this on fields that rarely change.
	Once filter values are retrieved from the Datamart, you can transfer them to a Custom Values list so they are stored locally within the .bqy. Again, you should only do this if the filter values rarely change. However, if those values change occasional...
	To create a Custom Values List:
	1)  Drag and drop the Table Item you want to filter to the Filter Line or double-click the Table Item
	The Filter dialog box will now be displayed on your screen, if your OCE is active. Otherwise, you must log into your OCE prior to moving forward.
	2)  From the drop-down list(Select a Comparison Operator
	3)  Select(Show Values
	4)  Select(Select All or Select the specific values you want
	5)  Select(Transfer
	6)  Select(Values you want for the Filter
	7)  Select(OK
	Modifying Filters
	A Filter can always be modified. You can change the values and settings permanently, temporarily ignore it, or delete it.
	To modify a Filter Item:
	1)  In the Query Section(Double-click the Filter Item
	2)  Make your changes to the Filter dialog box  Operator
	Type and select new values
	Show Values and select from a new values list
	Remove values from the Custom Values List
	3)  Select(OK
	Ignoring Filters
	You can temporarily ignore a filter without deleting it.
	To ignore a Filter Item:
	1)  In the Query Section(Double-click the Filter Item
	2)  Select(Ignore
	Removing Filters
	You can permanently remove a Filter Item.
	To remove a Filter Item:
	Select the Filter(Right-click(Select Remove
	Filter Line Logic and Order of Operations
	The Filter Line in the Query Section provides ‘AND’ and ‘OR’ operators, as well as, parentheses to control the logic and order of operations of the filters. These features are available only in the Query Section so keep this in mind when creating a qu...
	By using ‘AND’, ‘OR’, and parentheses, you can create complex filters and use an item on the Filter Line as many times as needed. When you add duplicate items on the Filter Line they are numbered consecutively.
	The following rules apply to all Filter Line expressions:
	(By default, all equations are solved from left to right, when enclosed sub-operations evaluated first.
	(AND is evaluated before OR.
	(The AND operator retrieves data that meets both conditions. Both conditions have to be true to get information returned. For example, if you query agencies, and filter ‘Agency Num’ to ‘10000’ AND ‘10700’, the dataset returned will include both agencies.
	(The OR operator retrieves data that satisfies either of two condition. For example, if you filter ‘Agency Num’ to ‘10000’ OR Transaction Code to ‘90’, the dataset returned would include Agency 10000 and information about Transaction code 90.
	(Sub-Operations override the default evaluation order and may be required for certain operations that involve both ‘AND’ and ‘OR’ operators.
	To set AND, OR, or parentheses on the Filter Line in the Query Section:
	1)  Drag two or more table items to the Filter Line(Define individual filters in the Filters dialog boxes. (The AND operator is displayed by default.)
	2)  Select( on the left side of the Filter Line
	3)  Select from the filter controls to complete the equation  To toggle from ‘AND’ and ‘OR’, click the operator.
	To enclose Sub-Operations, select items to be enclosed and then click the parentheses button.
	To remove parentheses, select them and click the parentheses button.
	Variable Filters
	Once a filter is created in the Query Section, you can construct it using the variable filter feature to prompt for values when the query is processed. Using variable filters eliminates the need for multiple queries using different filter values. You ...
	Variable filters work great with Custom Values Lists. If a Custom Values List is created, you can answer the prompt with a choice from the Custom Values List. Each time a user processes the query, the filters are selected from the Custom Values List r...
	To create a Variable Filter:
	1)  In the Query Section make sure to display the Filter Line
	2)  Select(
	3)  Select(Filter Item (Var on the Filter Line
	Or
	Right-click the Filter Item(Select Variable Filter
	The Filter Item is displayed with a V(1) next to it. If you increase the Variable Filters, they incrementally change to V(2), V(3), etc.
	Customizing Variable Filters Dialog Box
	The Custom Filter dialog box allows you to control access to the features available in the Filter dialog box. This is useful when you distribute the .bqy to end users. It may be preferable to disable or even remove such features as the ‘Ignore Button’...
	To customize a variable filter:
	1)  Display the Filter Line in the Query Section
	2)  Select(Variable Filter Item to be customized(Right-click
	(Select Customize Filter
	3)  From the Customize Filter dialog box shown below you can do the following:
	Prompt( It adds a user-friendly message for display when prompted.
	Values( Select Values you are giving end users access to use.
	Options( If these are check marked, you are giving the end user access to complete these options.
	Sorting Data
	Data Functions on the Requested Items
	Lesson 6
	What’s the difference between Results and Table Sections?
	Formatting Data in Results and Table Sections
	The following table provides a listing of commands available on the Format Menu.
	Sorting Data in a Table Section
	Suppressing Duplicate Values
	Setting and Removing Local Filters in Results and Table Sections
	The Filter dialog box will now be displayed on your screen.
	2)  From the drop-down list(Select a Comparison Operator
	4)  Select(Green ( to add the values in the Edit text box to the Custom
	Values List
	5)  Select(OK
	To remove a filter in a Results or Table Section:
	1)  Right-click the Filtered Item(Select Remove
	To remove all filters in a Results or Table Section:
	1)  Right-click the  icon on the Filter Line(Select Remove
	Creating Date Groups
	This feature separates regular date type columns into Month, Year, and Quarter columns. This feature only works on columns of a date type. Please notice the before and after diagrams shown below.
	Before Date Groups
	Date Groups Applied
	To create a date group:
	1)  Select a regular Date column in the Results or Table Section
	2)  Right-click(Add Date Groups
	Creating Grouping Columns
	Steps to create a Grouping Column:
	1)  Notice the Table Section below. The goal is to create an additional new
	column called Quarter.
	2)  Select the Column you want to group(Right-click(Select Add
	Grouping Column
	3)  The Grouping Column dialog box opens
	Column Name( Names the new grouping column in the Results/Table window. This is the column header.
	New Group( Creates a custom group to be displayed as a value in the new grouping column.
	Groups( Select a custom group to define by adding or removing items.
	Items in Group( Removes an item from a selected custom group.
	Available Values( Add items to a selected custom group.
	Options( Indicates how to signify unassigned values within the grouping column. Options include:      Null( Leaves the values ungrouped and unaggregated.
	Default( Allows you to specify a default name to assign to all ungrouped
	values.
	Individual Group( Assigns each ungrouped value the name originally
	assigned to it.
	4)  In the Column Name field(Name your Grouping Column
	5)  Select New Group(Enter New Group Name(OK
	Do this process until you have all the new groups set up.
	6)  Select Group in Group Column(Move Available Values by selecting them and click on  to move them over to the Items in Group Column.
	Continue this process until you have all your groups set up.
	7)  Select(OK
	To modify a Grouping Column:
	1)  Right-click the Grouping Column(Modify Column
	Removing and Hiding Data
	You can either Remove or Hide items from your Query, Results, and/or Table Sections. Use caution when removing items from any section! Once an item is removed, you can’t use it in a Pivot, Chart, or Report. If you hide an item it is still usable in al...
	To remove an item in the Query or Table Section:
	Remove the Table Item from the Request Line from the Query Section or the Data Layout Section in the Table Section.
	To hide an item in the Results or Table Section:
	Select the Column(Right-click(Hide Column Creating Grand Totals and Break Totals
	Results and Table Sections can display grand totals and break totals. You can display multiple totals each utilizing a different data function. While a grand total would appear at the bottom of a column, a break total will appear at a specified break ...
	To display a grand total:
	1)  Select column you want to total(Right-click(Select Grand Total
	The Insert Grand Total dialog box appears.
	You have a choice of Grand and Break Total functions:
	2)  Select(’Grand total function’, you desire
	3)  Select(Where to ‘Add grand total to’
	4)  Select(OK
	You can also create a SUM grand total using an icon on the Standard Toolbar:
	1)  Select(Column you want to total
	2)  Select(  on the Standard Toolbar
	To remove a grand total row:
	1)  Select(Row containing the grant total
	2)  Right-click(Remove Row
	To add a custom title in the grand total row, not the grand total cell:
	1)  Double-click on a cell in the same row as the grand total
	2)  In the Custom Function dialog box enter the title you desire surrounding by quotes “” as shown below:
	3)  Select(OK
	4)  From the Modify Total Function dialog box select(Other
	5)  Select(OK
	To add a custom title in the grand total cell:
	1)  Double-click on the grand total cell
	2)  From the Modify Total Function dialog box(Select Other
	3)  Enter your desired title surrounded by quotes “”, for example “Total: ”.
	Make sure to insert a space after your title!
	4)  Concatenate text and functions with a plus sign (+)
	“Total: ”+Round(Sum(Lv_Hours),2)
	5)  Select(OK
	6)  In the Modify Total Function dialog box(Select OK
	To display break totals:
	1)  Select column you want to total(Right-click(Select Break Total
	The ‘Insert Break Total’ dialog box appears.
	2)  At every break in drop-down(Select your break column criteria
	3)  Break total function(Select function
	4)  Select one or more columns(Add Break total to
	5)  Select(OK

