APM APPENDIX 4A - CRASH ATTRIBUTION AND
AUTOMATION
The Visum safety analysis add-in procedure described below requires a license of
both Visum and the add-in tool. Contact PTV for purchase of licenses. The
procedures below also assume a working knowledge of ArcGIS and Visum.

This guidance addresses automating crash data network analysis using the ODOT Crash
Graphing Tool, ODOT Crash Decoder Tool, ArcGIS, and Visum. Advantages and limitations of
each tool are provided along with recommended guidance and procedures for their use.
The Newport travel demand model build project was used for the evaluation using recently
collected counts, crash data and the developed Visum model network. The Newport travel
demand model build project was used as a ‘sandbox’ to evaluate data sources and new tools and
processes.

Analysis of Network Crash Patterns

Crash pattern recognition is an important part of safety analysis. The identification of patterns
gives the analyst information to help guide engineering decisions to help reduce the probability
of future crashes. Also the ability to establish high frequency injury crash locations can help
municipalities spend their limited resources in an educated manner. Tools developed and used by
ODOT help analysts make quick, well-educated decisions to improve safety on Oregon roads.
For guidance on performing a detailed on-site investigation and diagnosis of a safety trend, refer to
the ODOT Safety Investigations Manual.
ODOT Crash Graphing Tool (ODOT Only)
The ODOT crash graphing tool is an Excel add-in that can be used to create graphs and some
basic summaries of crashes on state highways; this tool cannot be used on local streets. The
ODOT Crash Graphing tool utilizes the Vehicle Direction report type.

In order to use this tool, the report must be in Excel format and saved to a destination chosen by
the user. Once the file is saved in the preferred location the user simply opens the crash report,
goes to the “Add-Ins” tab on the Excel ribbon and chooses “Create Crash Graphs.” This creates
many different crash graphs and tables that are helpful in analysis. The graphs and tables created
are listed below.
1. Crashes by Year
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2. Crashes by Severity
3. Crashes by Collision Type
4. Crashes by Time of Day
5. Crashes by Day of Week
6. Crashes by Surface Condition
7. Crashes by Light Condition
8. On-Roadway Crashes by Road Character
9. Off-Roadway Crashes by Road Character
10. Crashes by Milepost/Roadway
11. Travel Paths of Vehicles Involved in Crash
Many of these crash graphs and tables are helpful in an overview of the crash history of the
project area. The main downside of this tool is that it is only compatible with the Oregon State
Highway System and cannot be used on the local street system. Also because of the type of
report it uses it is not possible to dig down into one particular crash, crash type or crash location
without having to pull another crash report. The other downside is there is no way to tell the
location of given crashes. Rather it looks at the entire report pulled, and therefore gives you an
overview of the project area rather than at an intersection or location level overview. This does,
however, give the analyst a big picture idea of what the crashes within the project area look like
as a whole.
Figure 1: Example Outputs from the ODOT Crash Graphing Tool

The ODOT Crash Graphing tool works best when the user wants a high level overview of the
crashes on a specific highway in their project area. This tool is helpful in creating basic
repeatable graphics for reports but lacks any major details or insights into crashes within a
project area.
A Region 1 version of the Crash Graphing Tool adds speed and alcohol involved crashes and
bicycle and pedestrian involved crashes to some of the graphs, as well as the ability to pull LRS,
latitude and longitude. Contact Region 1 Traffic for a copy.
ESTIMATED TIME FOR USE: 10-20 minutes
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HELPFULNESS OF DATA PROVIDED: Great for crashes on state highways
RESULT DETAILS PROVIDED: Minimal
ODOT Crash Decoder Tool
The ODOT Crash Decoder tool is a macro enabled spreadsheet that utilizes the Comprehensive
PRC (CDS380) report. This tool is fully functional for state highways. It is also functional for the
local system except for milepoint graphs and crash rates on Oregon State Highways. The more
detailed crash report required for this tool can be confusing and overwhelming to someone who
is not familiar with the data and details involved. The Decoder Tool provides crash-level details
in a printable format. Numerical crash codes are translated in the printable report using the Crash
Code Manual from the CAR Unit. This is a feature not provided in the Crash Graphing Tool.

The ODOT Crash Decoder Tool, much like the Crash Graphing tool, gives the analyst a glimpse
into the crash history within a project area. Unlike the Crash Graphing tool, the Crash Decoder
Tool gives the analyst a more in-depth graphical view of the crash history. For instance, one
graph that is helpful is the “Crashes by Milepoint and Injury Severity” graph. This graph allows
the analyst to see the location of the more serious crashes, and allows them to zero in if one MP
in particular is having a high instance of severe crashes. The graphs created using the Crash
Decoder Tool are slightly more in-depth than the Crash Graphing Tool. The graphs created using
the Crash Decoder tool are listed below.
1. Crash Plot By Injury and Severity
2. Crashes by Milepoint and Injury Severity
3. Crashes by Milepoint and Collision Type
4. Crashes by Milepoint and Surface Conditions
5. Crashes by Milepoint and Weather
6. Crashes By Milepoint and Road Characteristic
7. Crashes by Milepoint and Day of Week
8. Crashes by Milepoint and Time of Day
9. Crash Frequency by Milepoint
10. Crash Frequency by Injury Severity
11. Crash Frequency by Collision Type
12. Crash Frequency by Day of Week
13. Crash Frequency by Tim of Day
14. Crash History by Month and Year
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Figure 2: Example Outputs from Crash Decoder Tool
Crashes by Milepoint and Injury Severity
US 20 | Hwy 033 Corvallis-Newport | Milepoint 0.00 to 3 | 01/01/2007 to 12/31/2011
Mainline | Both Add and Non-Add Mileage Alignments
Mileage Type(s): Regular
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Crashes by Milepoint and Collision Type
Hwy 033 Corvallis-Newport | Milepoint 0.00 to 3 | 01/01/2007 to 12/31/2011
Mainline | Both Add and Non-Add Mileage Alignments
Mileage Type(s): Regular
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By creating graphs that are broken out by milepoint the ODOT Crash Decoder gives the analyst
even more information than the ODOT Crash Graphing Tool. The break down by milepoint
allows the user to not only see if there are crash patterns within the project, but also the ability to
pick out milepoints that appear to have a high number of crashes.
ESTIMATED TIME FOR USE: 20-30 minutes
HELPFULNESS OF DATA PROVIDED: Great for repeatable, graphs and tables for projects
and for location of problem areas by milepoint.
RESULT DETAILS PROVIDED: Moderate
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HSM Screening Analysis

The Highway Safety Manual (HSM) was first published in 2010 and allows analysts to
quantitatively evaluate crash data to inform decision making. The HSM gives transportation
officials the methodologies and technology to guide decision making while aiming to identify
options to reduce crash severity and frequency1.
The following two HSM screening methods are best used in conjunction with one another. The
critical crash rate requires AADT while Excess Proportion just requires a breakdown of crash
types. Using the two gives the analyst a better picture of what is occurring at study intersections.
For example if an intersection is above the calculated critical crash rate for its reference
population, running the excess proportion of specific crash types on the same set of intersections
may give the analyst a better view of what crash types are causing concerns at the intersection.
See APM Chapter 4 for more information on these methods.
Application of the HSM with Available Spreadsheet Applications
Due to the type of crash report and data provided within the report, neither the Excess Proportion
of Specific Crash Types nor the Critical Crash Rate can be applied when pulling crash data on a
corridor. In order to apply these methods, the crash data must be pulled in multiple steps.
Critical Crash Rate
A spreadsheet on the Transportation Planning Analysis Unit (TPAU) website is available for
the calculation of the critical crash rate. This tool requires AADT for each incoming leg of an
intersection and for each segment in a project study area. It does not require a breakdown of
crash types or severities; therefore the most data intensive portion of this is the calculation of
the AADTs. The spreadsheet calculator performs crash rate analysis and identifies priority
intersections or segments for further safety analysis. In addition the calculator identifies
when the reference population size is insufficient and therefore intersection crash rates must
be compared to the statewide 90th percentile crash rates in Exhibit 4-1 of the APM.
Instructions for use are available with the spreadsheet and more details are available in the
APM chapter 4.
ESTIMATED TIME FOR USE: 90-180 minutes (Dependent on study area and knowledge of
crash data).
HELPFULNESS OF DATA PROVIDED: Great for repeatable crash rates and flagging
potential safety concerns.
RESULT DETAILS PROVIDED: Moderate
Excess Proportion of Specific Crash Types
This calculation is an extension of the Probability of Specific Crash Types Exceeding a
Threshold Proportion calculation in the HSM. Similar to the Critical Crash Rate calculation,
there are spreadsheet tools available to help with the calculation of this HSM Method. There
are two available spreadsheets, for those familiar with and access to ArcGIS there is a dbf
compatible spreadsheet and for those more familiar with PRC (CDS380) crash reports there
1

Highway Safety Manual. (2010). Washington, D.C.: American Association of State Highway
and Transportation Officials.
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is a separate spreadsheet. For those with a different type of crash data, hand entering needed
data is available in the PRC (CDS380) compatible spreadsheet. More information and
instructions on use of these spreadsheets is available in the APM Chapter 4.
ESTIMATED TIME FOR USE: as experience with this spreadsheet increases, time to use it
decreases substantially.
HELPFULNESS OF DATA PROVIDED: Great for repeatable crash analysis and flagging
potential safety concerns.
RESULT DETAILS PROVIDED: Moderate
Application of the HSM with ODOT Visum Safety Add-In
The ODOT Visum Safety Add-In tool allows the user to attribute crashes to the Visum network,
and aids in the calculation of two HSM screening methods. The Visum add-in method relies on
an approximate assignment of crashes to intersections, and therefore should be used for planning
level studies only, not for project level safety analysis. After the user attributes the crashes to the
network, they must add the needed information to the network, or calculate it from available
attributes and their working knowledge of the network area.
The analyst can choose between a Critical Crash Rate analysis, an Excess Proportion of Specific
Crash Types analysis or both. The visualization mappers (graphic parameter files) that are
provided with the tool allow the analyst to visualize the calculated results. Crash Analysis in
PTV Visum covers the use of the Add-in which includes the attribution of the crashes to the
network as well as calculating the Critical Crash Rate and Excess Proportion of Specific Crash
Types.
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Attribution of Count and Crash Data to the Network
Count Data
APM Addendum F OTMS User Guide provides guidance on how to identify and pull multiple
counts from ODOT Traffic Monitoring System (OTMS) program. APM Appendix 17A provides
guidance on attribution of traffic count and volume data into networks in ArcGIS or Visum.

Volumes should generally be from traffic counts. Raw travel demand model volumes
may only be used for planning-level screening evaluations. All other safety analysis
must use count based or post-processed AADT volumes.

Crash Data
The three most common methods of obtaining Crash data are: 1) annual statewide crash
geodatabases or TransGIS Crash data layers which can be queried using ArcGIS; 2) MS Access
annual “Decode” databases available on the CAR Unit’s share drive; or 3) contacting the Crash
Analysis Reporting (CAR) Unit. The full data file is available, allowing analysts to query on
state roads, local roads, or both.
Another option is to use the TDS – Crash Reports online query tool (website) provided by the
CAR Unit. However, query options and the number of available reports are limited because this
tool hits the master Crash Data System. (Queries that return a large number of records would
slow the System down and impact CAR Unit data entry production.) Separate tabs are provided
to query on state highways, local roads, or all road types. Instructions on how to use the tool,
and explanations of the reports, are available via the “Help” link.
Note that, because the software for each of these query tools differs, the resulting report designs
also differ. This can lead to confusion when looking at data retrieved from different tools and
different reports. The CAR Unit provides supporting files for users who are inexperienced with
the Crash Data System and reports, so it’s recommended to refer to the supporting files provided
by the CAR Unit, or to contact the CAR Unit crash analysts for assistance.
Using ArcGIS and the data available by utilizing the ODOT data toolbar is the quickest way to
retrieve crash data. The data on the GIS server is crash level data that not only includes the
coding information but has also been partially decoded. Annual statewide geodatabase files,
containing all levels of crash data including vehicles and participants, are available for download
from the GIS Unit’s external FTP Directory here:
ftp://ftp.odot.state.or.us/tdb/trandata/GIS_data/Safety/. Although ArcGIS doesn’t provide a
means for querying on related classes (VHCL, PARTIC_VHCL (occupants), and
PARTIC_NON_VHCL (pedestrians, bicyclists & other non-motorists) tables), the records can be
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exported to Excel for further analysis. GIS data is available on both state and local roads, and can
easily be separated out by year.
The data available in this format is NOT continually updated. This dataset is not
updated if there is an error found in the crash data. Therefore it is important to
use engineering judgment to determine if it is necessary to use a database pull
from the CAR Unit, as it is the most accurate crash account.

The MS Access “Decode” databases are robust database management tools. Users may develop
custom queries, tables, charts, reports, or export the raw data tables to other preferred software,
including Excel. However, the relationships between the master tables are complex and should
be understood before attempting to query on dependent data tables (i.e. querying for crashes
involving certain vehicle events, participant errors, crash causes, etc.). Contact the CAR Unit
crash analysts if you have questions.
Another way to retrieve crash data is to request the data from the CAR Unit. Standard turnaround time for data requests is two weeks. Data for all roads are available; the query criteria are
highly customizable; and over 30 kinds of reports are available, including raw data extracts.
Some reports are available in Excel. Examples of reports available from the CAR Unit can be
found here (ODOT users only): \\wpdotfill03\6213shar\CDS_Data_Report_Samples.
One report type that can be requested is a CDS380, PRC Report. A PRC report contains three
levels of data. Each vehicle involved in a crash is a row of data. Each row of data contains crash
level, vehicle level and participant level crash information. Another comprehensive dataset that
can be requested is the data extract, CDS501 report. The CDS501 is a report contains similar
information to a PRC Report. In this report type there are a minimum of three rows for each
crash. For each crash there is a row that contains crash information, for each vehicle involved in
the crash there is a row for vehicle information and finally for each person in each car there is a
row containing participant information. This type of report needs to be translated from crash
codes and flags to useful information by using the crash code manual.
The final way to acquire crash data is by pulling data from the online TDS – Crash Reports web
tool. 2 Datasets pulled using the TDS Crash Report web query tool are different from the ArcGIS
report. It is possible to pull raw data extracts in the form of an Excel worksheet (CDS501 report)
or MS Access “Decode” database from the website. You can also pull a PRC report (CDS380),
which is a partially decoded crash report. These types of reports provide the most detailed crash
information. Regardless of the type of tool used to query crash data, a good understanding of the
software (ArcGIS, MS Access, etc.), data table relationships, query operations, and careful
review of the Crash Analysis and Code Manual will enhance the analyst’s ability to retrieve
crash data accurately and interpret the resulting reports.

2

https://hwynetintra.odot.state.or.us/tvc/ for ODOT users, or https://zigzag.odot.state.or.us/ for
non-ODOT users.
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In order to map local crashes the ArcGIS method, or the CDS 501 report from the CAR Unit are
the most accurate way. This report details how crashes were mapped using a CDS501 report
received from the CAR Unit and a GIS report. The reason for this is because when pulling local
crashes from the crash reports website when analyzing state and local streets it is easy to
accidentally pull identical crashes in multiple ways, causing double counting of crashes.
Therefore it is recommended that the analyst use a CDS501 report from the CAR Unit, an
already coded GIS file for crash attribution in ArcGIS, or be extremely familiar with the crash
data and project area.
As with all data, it is important that the analyst understand the limitations and
nuances of the data. The Crash Analysis and Code Manual, available online,
provides background information on the coding of the crashes.

Crash Data Attribution in ArcGIS
The process of attributing the crashes to a network in ArcGIS can be done in one of two ways and
is determined by the type of the crash data pulled from the online system, received from the CAR
Unit or pulled from the ArcGIS database. The bonus in using the ArcGIS dataset in this case is
that the crashes are already interpreted and geographically coded. If the analyst chooses to do so,
the data from the CAR unit can also be coded to the network. The CDS501 report from the CAR
Unit must not only be attributed using its latitude and longitude, but it must also be deciphered
using the crash code manual. For this reason it is recommended that the analyst use the already
interpreted data that is in layer file to visualize crash data in ArgGIS. The process using the ArcGIS
data, as well as using a CDS501 report are covered in Attachment A of this report.
Using Pre-Geocoded GIS Unit Data
Pre-geocoded crash data allows the analyst to quickly visualize many different crash patterns. It
also allows the analyst to make a quick analysis of the number of crashes. Information on the
TransGIS website has data that “sits behind” the visualizations. This means that there is already
geocoded crash information available for analysts to use. The process below details how to begin
using some of this information.
Step 1. Open your mxd with all of
your shapefiles (boundary,
network etc), and then load in the
years of crashes you want to
analyze using the ODOT data
toolbar. In Newport, 2007-2011
crashes were analyzed. Each
crash year is loaded as a group of
layers, and within each group are
that year’s local crashes and state
crashes in two files.
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a. Make sure your mxd also contains some sort of boundary shapefile. In the
case of Newport, crashes that were within the Federal Aid Urban
Boundary (FAUB) were the crashes that were to be analyzed. (The FAUB
boundary for Newport was also loaded using the GIS Data catalog.)
Step 2. Use a spatial select to select the crashes from each of the years that fall within
your chosen boundary.
a. After each of the layers is selected, the easiest way to join the layers (into
any number of layers but two are suggested, one for local and one for state
with all years aggregated into one file) is to right click on each layer and
choose selection→create layer from selected feature. This creates a “new
layer” (doesn’t create a shapefile) of only those crashes that were selected
(instead of the entire state).
b. Then you can join these “new layers” all into a new shapefile that
aggregates all the local roadway crashes from multiple years into one
shapefile, and all the state roadway crashes for multiple years into one
shapefile.
i. In Newport one way that was chosen to look at the crashes was to
combine the five years, but keep them separated into state and
local files for calculation. This resulted in a total of two shapefiles
(one for state and one for local; it is easy to join or clip the
shapefiles in the future should you choose to change how you want
to analyze the data)
Step 3. Once you have the shapefiles created for your choice of years and within your
boundary, you can remove the statewide crash information and only look at those
that you created using your spatial selection.
Step 4. You can now change the ways that you visualize the different types of crashes
by changing the color, size etc. of the crashes.
a. For example, you could create a gradient of crashes and show higher
severity injury crashes as red and PDO cashes as green and make the
higher severity crashes larger.
b. You could also make each type of crash a certain color to look for a
pattern of a type of crash at any of the intersections.
c. You could separate out by the time of day (TOD) or the day of week
(DOW).
By changing the visualization of the crash data you can look for different patterns. The crash
data in the case of Newport was used to help choose count locations. The crashes in Newport
were looked at in multiple ways like by day of week, by time of day, by severity, by type of
crash etc.
Using CAR Unit or Online Crash Data
All crashes entered into the Crash Data System as of 1/1/2007 contain spatial coordinates
(Lat/Longs). This allows the crashes to be placed in the correct locations. Neither the crash data
from the CAR unit or from the online system connects the crashes to the roadways system in any
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way. The best report to use to geo-locate the crashes is the CDS501 report. This report contains
the latitude and longitudinal data fields which can be combined into the needed information to
place the crashes in the correct spot. This type of report can be pulled from the online system or
by request from the CAR Unit.
1. Open the CDS501 report in Excel or a similar program. (If you pulled the crash report on
your own you will need to add the headings to the columns which are available as a
download on the web tool page; if you received the crash report from the CAR Unit these
have already been added.)
a. The CDS501 report contains a minimum of three records for each crash. It
contains a record at the crash level, vehicle level (for each vehicle), and at the
participant level (for each person involved).
i. For example if there was a three vehicle crash with two vehicles with only
a driver, and one vehicle with four people in it there would be a total of 10
records. Six (6) records for the people involved, three (3) records for each
vehicle involved and one (1) record for the crash.
b. Each record contains the same Crash ID, each vehicle involved has a vehicle
number and each passenger has a participant number.
2. Use the six columns containing Latitude Degree, Latitude Minute, Latitude Second,
Longitude Degree, Longitude Minute, and Longitude Second information to create two
new fields that contain the Latitude and Longitudinal information.
a. Depending on the information you want to keep you will need to process the data
differently.
i. In the case of Newport the analyst wanted to be able to look at TOD,
DOW and severity of the crash. For this reason the only information
needed to be kept is the Latitude Degree, Minute, and Second information
for each crash along with the date and time of the crash as well as the
highest severity injury sustained in the crash.
b. The processing of the data before it is graphed can be done in many ways;
therefore, this is not specifically covered in this report. The goal for the “final”
spreadsheet is for one record for each crash with the necessary information for the
type of analysis that needs to be done, and the latitude and longitudinal
information for graphing. For the Newport Project below is an excerpt of the final
spreadsheet.
Crash ID Crash Date Severity
1231225
1237833
1237839

3/4/2007 FAT
1/25/2007 PDO
1/19/2007 PDO

Day

Sunday
Thursday
Friday

TOD

5:00 PM
4:00 PM
3:00 PM

Latitude

Longitude

44.62703 -124.03177
44.63142 -124.05984
44.64090 -124.04671

i. If you are not sure of the extent you will want to analyze the data, it is
better to leave more information than you think you will need.
3. Open the ArcGIS .mxd file that contains your newly created roadway network shapefile,
and boundary file.
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4. Click File→Add
Data→XY Data

5. Navigate to your file location and if it doesn’t automatically select your latitude and
longitude columns, navigate to those as well.
6. If the XY data does not plot in the correct location, check the projection and projected
coordinate system to make sure they are correct. (If they are incorrect the Lat and Long
fields will map incorrectly).
7. Once the crashes are mapped correctly you can choose how to display them to visualize
patterns in the crash data, as shown in Analysis of Network Crash Patterns.
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VISUM CRASH ATTRIBUTION
The ODOT Safety Add-In tool allows the user to utilize shapefiles of crash data in Visum.
The analyst is able to bring the crash data in from a shapefile as a POI layer. The POI Snap
tool allows the analyst to attribute the crash information to a link or a node depending on the
settings set by the user. The crash data can then be visualized in different ways, using both
the preset graphic parameters as well as creation of custom graphic parameters. The attributes
allow for different visualizations. In the figure below, the graphic parameters have been set to
identify the different locations of bike and pedestrian crashes. More information can be found
in Attachment B.
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Crash Analysis in PTV Visum
DISCLAIMER
These instructions describe the process to use PTV America proprietary software. This add-in
works within the PTV Visum platform. It requires not only a license for PTV Visum but also
requires purchase of the add-in. Contact PTV for purchase information.
Installing the Safety Module
This module is an Add-in developed by PTV for ODOT and works with PTV Visum. In order to
utilize this tool, the user must contact PTV America to acquire the licensing associated with the
tool. These instructions assume some user familiarity with PTV Visum and the PTV product line.
Download the Safety Add-in Folder
ODOT users contact TPAU for download information. See Attachment D for more information.
Outside users must contact your PTV representative for purchase options.
1.1. Once you have the tool downloaded open PTV Visum on your machine.
In the Visum Program
go to File→Project
Directories→Edit
Project Directories
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In the project directories dialog, click the […] next to the Add-ins

In Windows explorer open this location.
1.2. Copy and paste the Safety and POISnap folder into the Add-in folder of the appropriate
version of Visum. 3

3

This add-in will need to be reinstalled for each new version of Visum
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Preparing the Data for Visum Analysis
Pre- coded crash shapefiles and CDS501 data from the CAR unit or from the data system online
are both possible for use in Visum. Using pre-coded GIS crash data is the quickest and easiest
way to place crash data in Visum. Using CDS501 data requires an extra step in ArcGIS to create
a shapefile to import into Visum. Refer to ‘Using CAR Unit or Online Crash Data’ and
'Network Shapefile Creation in ArcGIS' in Attachment A. Visum requires projection information
to be associated with the points that are being imported. Therefore one of the easiest ways to
import point data into Visum is through a shapefile. The steps below are a brief overview of
importing crashes from a shapefile into Visum. A working knowledge of the data, the crash
screening methodologies, and both ArcGIS and Visum is assumed. See also Attachment A,
Network Shapefile Creation in ArcGIS, as well as main body of report under Crash Data. See
Attachment D for an example of the use of the ODOT Visum add-in.
•
•
•

Use ArcGIS to clip the statewide crash datasets for your years of crashes down to the
project area.
o Typically five years of both state and local crash data are analyzed.
Join all years and types (state/local) crashes into one shapefile and save it in a
location that is easily accessible.
Another option is to bring each shapefile into the same POI layer, requiring multiple
imports into Visum. The ArcGIS method is suggested because it leaves less room for
error when importing the data to Visum.
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Restart Visum
1.3. Now the Safety Add-in should
be available in the procedures
menu like the other add-ins.
1.4. It must be restarted because
each time you open Visum it
points to a folder and grabs a
snapshot of the contents of that
folder. Therefore it will not
reflect the change of the new
add-in until it is restarted.

Crash Analysis Using Visum
The workflow using this crash add-in expects two steps.
• Preparation of the crash and network data
• Specification of the safety calculation parameters and running the safety calculations
These instructions assume that the network being used for the crash analysis has already been
prepared. See Attachment A, Network Creation. It can begin with a model network in Visum or
can begin with a shapefile in ArcGIS that has been brought into Visum and attributed as
necessary. These instructions are based on crash shapefiles that have been joined before analysis
in Visum. See Attachment D for an example of the use of the ODOT Visum add-in.
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Creating POI Categories
1.1.In your current network file
go to Network→POI
Categories

1.2.Click create

1.3.Name the POI category
something meaningful to you
(such as crashes), and choose
“no superior category” for
the super category.
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1.4.Go to
File→Import→Shapefile
and navigate to the location
that you have your shapefile
of crashes saved.

1.5.In the “Read Shapefile”
popup use the dropdowns to
choose “POI” as the Read
as, and your newly created
category for the POI
Category.
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1.6.In the next popup
choose the target
attributes for your
new crash data.
Simply click
“Generate” and
the […] under
“Target attr” will
become whatever
Visum recognizes
within your
shapefile. Then
click ok to import
your new file.

If raw unedited data from the GIS server is being used there will be errors that pop up while
importing the crash data. Some of the Crash Event columns contain ‘;’ or ‘$’ or line breaks.
Visum does not allow these characters so those cells will not be filled when brought into
Visum. This is normally not an issue as the code does not rely on them. If the analyst needs
them for the analysis being performed, the shapefile can be edited in ArcGIS first to
eliminate these characters.
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1.6.1. Your crashes will automatically import formatted as stars. If you choose to you
can change the viewing parameters to match your desired settings.

Running POI Snapping Tool
The POI snapping tool allows the user to “join” the POIs to the base network. This tool is meant
for high level screening only, and if a deeper level is desired, there are other tools that may be
better suited.
The POI Snapping tool is done by DISTANCE ONLY. The tool does not look at
crash coding to decide to attribute a crash to a node or a link. It simply looks at
the distance from a node or link set by the user.

1.7.Open the Procedure Sequence
tab Calculate→Procedure
sequence

1.7.1. Click the create plus
sign in the operations box.
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1.7.2. In the Add-in drop
down folder choose the
POI Snapping Tool

1.8.Go back to the Network
Editor Screen and turn on
filters for nodes. The point
of this is to filter out those
points with less than three
legs. In most cases nodes
with two or fewer legs are
shaping nodes and do not
represent an intersection.
Being familiar with the
roadway network will speed
up this step.

1.9.Go back to the procedure sequence tab and double click the grey section under reference
object(s) to open the settings for the tool.
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1.9.1. This will bring up
settings for the POI
Snapping Tool in a
popup window. The
node and link buffer
distance default values
are 50 feet and 100
feet, respectively, but
can be changed as
needed.
1.9.2. Use the dropdown
under POI category to
choose the one you
stored your crashes in.
Then set the distance
buffer to your desired
distance. Any crash
that is within the node
buffer will be
attributed to the closest
node. Any crash that is
not within the node buffer but is within the set link buffer will be attributed to a link.
Any crash that does not meet either of the buffer distances will not be attributed.
1.10. After clicking okay to set the options,
make sure there is an “X” in the active
box next to the POI Snapping tool (and in
nothing else) and click the play button in the top left corner to run the process.

1.10.1. Notice the grey arrows
showing you where the crashes
are being attributed to, node and
link wise.
1.10.2. The arrows on the segment indicate which directional link the crash was attached
to. This is again done by location and which side of the link the crash falls, not by
looking into the coding and seeing the directionality of the crash. Directionality of the
crash does not affect the calculation of critical rate or excess proportion of crash
types.
1.11.

Open the List(Links) and List(Nodes), then go back to the network editor.
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The next step is to establish the reference population types of nodes. There are two user defined
attributes (UDA) that need to have values, one on the link and one on the node. For the nodes,
the needed UDA is a population type. It is suggested that filters and multi-edit is used to ensure
that the proper POPTYPE on the nodes being analyzed. For example in Newport, the user knows
that the signals are only on the state highway system and are correctly called out in the control
type of the node. Therefore a filter narrowing down to these nodes was used to create a
POPTYPE of Hwy Sig.

Then a filter was used to separate out unsignalized intersections on the highway system and that
POPTYPE was called Hwy_UnSig. In this case the user knew that the plan numbers
corresponded to the functional classification of the roadway and therefore the state highway was
going to have a classification of 2.
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The user of this network knew that at this point the only nodes without a POPTYPE would be
either nodes with less than two legs or those that would be local classified as Local_UnSig.
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In the screenshot at right,
each colored node
represents a different
population type.

For links, the needed UDA is volume. According to the HSM, this volume should be the AADT
of the link although a different volume could be used based on engineering judgement. The link
volumes are also used to determine intersection Total Entering Volume for intersection crash rate
calculations.
Once the user is confident that their input values of Volume and POPTYPE have been attributed
correctly it is time to move on to the crash calculations.
Crash Calculations Using the Safety Add-in
1.12. Open the
procedure sequence
tab and create a new
procedure. This time
choose to bring in the
HSM Safety
Calculator
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1.13. Double click the grey bar next to the safety calculator under the Reference objects
column.

1.13.1. Under the POI
dropdown, choose
the layer with
your crash data.
Input the number
of years of data
that have been
imported using
this layer
(typically five).
Use the dropdown
to choose the
crash attribute to
calculate the
excess proportion
of critical crash
rate on. See the
APM and HSM
for more
information on
this calculation.
Choose the crash
types (that are
within the selected
crash attribute) to
analyze. 4 Choose the calculations you want performed, the confidence interval you
want them preformed at and the Excess Proportion Threshold you would like it
calculated at. All of these variables and expressions are explained in the appropriate
chapters in the HSM and APM Chapter 4. Give your scenario a name and choose an
output directory. Then click OK.

4

Although it is possible to choose multiple “Crash Types To Analyze” it should be noted that the
results shown in Visum are always the last calculation made. Therefore when multiple types are
analyzed, they are overwritten within Visum. The outputs are labeled as the correct type but
within Visum the results are ever changing.
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1.14. Make sure the “X”
under the active column is
selected for the HSM
Safety Calculator (make
sure to remove it from the
POI Snapping tool), and
push the play button, to
the right is an example of
what it looks like while it
is running.

1.15. The messages box
(View→Messages) will give you
a play by play for what the tool
is doing.
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Once the HSM procedure sequence has been run, html files containing results are generated and
saved to the project folder. An example critical crash rate summary html file is shown below for
signal and TWSC reference populations.

The graphic parameter files that are provided with the tool are used to visualize your results. For
example, the screen captures below show the Visum network editor map and List (Nodes) view
displaying the intersections with crash rates exceeding the critical rate. Other attributes such as
crash rate or MEV can be displayed as well.

Intersections Exceeding
Critical Crash Rate
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For excess proportion of crash types, html files of results are generated. The percentage of
crashes by type is displayed as a pie chart for each intersection, as shown in the example below.
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In addition, an Excess Proportion Summary at Intersection Level html is also generated, as well
as a csv file. This shows the excess proportion as well as total and target crashes, as shown
below. In this example, rear-end crashes are the targeted crash type.

The excess proportion of crash types for each intersection can then be plotted in Visum as shown
below.
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Each parameter file that relates to a UDA may have to be adjusted for your project. These will
give the user a starting point to get good results for their analysis. As with any tool there is a
need to fully understand the calculations being completed and the risks that come with using the
tool.
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Attachment – PTV Visum Safety Addin User Document

To:

From:

Datum/Date:

ODOT Safety AddIn User

PTV America Inc.

19.05.22

For attention

Confidential

Consultation

To do by:

ODOT Safety AddIn User Document
This document is illustrates the use of the ODOT Safety AddIn for Visum based on an example
implementation. The network and the corresponding crash data in the example file is located in Newport,
OR. The safety AddIn is an implementation of a subset of safety analysis calculations from the Highway
Safety Manual (HSM).
These calculations are also adopted and described in the Analysis Procedures Manual published by
ODOT APM: https://www.oregon.gov/ODOT/Planning/Pages/APM.aspx
The following calculations are implemented in the AddIn:
1) Crash rate
2) Critical crash rate
3) Excess proportion calculation
The user is encouraged to peruse both the HSM and APM for details related to the calculations.
Installation of the AddIn

The safety AddIn comprises of two separate AddIns. One AddIn performs the key calculations
and the other AddIn is provided as a ‘helper’ AddIn for enabling the user to prepare the data for
the safety calculations.
There are two folders containing the AddIns, these are named:
1) Safety (this is the main safety calculation AddIn)
2) POISnap (this is the helper AddIn described above)
Follow the steps below to install the AddIns:
1) Copy or download the two AddIn folders on your local drive
2) Start Visum
3) Go to File > Project directories > Edit project directories
4) Note down the directory path that corresponds to AddIn in the dialog
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5) Paste the two AddIn folders into the AddIn directory
6) Restart Visum
7) If the installation was successful, you will see the two AddIns appear in the Scripts >
VisumAddIn menu
Using the AddIn

The typical workflow of the safety calculations is expected to have two steps,
1) Preparation of the crash and network data
2) Specification of the safety calculation parameters and running the safety calculations
Preparation of crash and network data
1) Three datasets are provided for the calculation example:
a) GIS shp file with crash data - HSM_Mimic.shp (and associated files)
b) Visum version file containing the network - Example_NewportModel.ver
c) Input_PopType_Vols.xlsx – Population type and link volumes
2) Start Visum and open Example_NewportModel.ver
3) Go to Network > POI categories
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4) Click Create and add a new category named: Crashes |This is the placeholder for
importing the data from the - HSM_Mimic.shp file.

5) Go to File > Import > Shapefile…
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6) Select HSM_Mimic.shp and read this file in as a POI mapped to the Crashes POI created
earlier
7) Click OK
8) In the attribute mapping, click Generate to auto generate all the user defined attributes
required for importing the shp file data and click OK

9) To view the imported data, right click the POI layer in the network layers and select List
10) To see some relevant data, you may drag and drop the ViewCrashPOI.lla file to get a preconfigured table view
11) To connect/join these POI crash point data to the nodes in the network, Go to Calculate >
Procedures
12) Check procedure step 1: POI Snapping Tool to active and click Edit
13) Select [9|Crashes] and set a buffer of 50ft for node snapping and 100ft for link snapping
14) Click OK and Run the procedure step
15) After the procedure finishes running, the crash POIs will be allocated to nodes in the
given buffer distance. This procedure also generates the required user defined attributes
for storing the results of the safety calculations
Specification of the safety calculation parameters and running the calculation
1) The safety calculations require two key inputs at the intersection and link level. These are
intersection Population type and link Volume entering the intersection.
2) To input the intersection Population types, open the Input_PopType_Vols.xlsx
spreadsheet, copy and paste the data in the PopulationType tab in the spreadsheet in a
Visum node listing | you may use the PopulationTypes.lla file to view these volumes in a
node listing
3) To input the link Volume entering the intersections, copy and paste the data in the
Volume tab in the spreadsheet in a Visum link listing | you may use the
LinkEnteringVolumes.lla file to view these volumes in a link listing
Analysis Procedures Manual
37
Appendix 4A - Crash Attribution and Automation

03/2021

4) Go to Calculate > Procedures, check step 2 | HSM Safety Calculator to make it active and
check-off step 1 | POI Snapping Tool to make it inactive
5) Select step 2 | HSM Safety Calculator and click Edit and input the parameters shown in
the figure below and click OK

6) Run the procedure and explore the outputs in html and csv formats in the output directory
specified in the AddIn parameters
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