Datamart & Hyperion:
A Cut Above
(An Intermediate Level Training Manual)

Last Updated: 3/20/2014
About the Department of Administrative Services - Training:

The Department of Administrative Services (DAS) trainings provide courses with a focus on helping our customers improve their financial and technological skills.

The training materials are for the students’ use both during the course and as a reference guide after the course is complete.

For more information and a list of other available products, please visit us at our website at [http://egov.oregon.gov/DAS/](http://egov.oregon.gov/DAS/).

Copyright & Trademarks

Copyright © 2011 by DAS. All rights reserved.

Trademarked names appear throughout this book. Rather than list the names and entities that own the trademarks or insert a trademark symbol with each mention of the trademark name, DAS states that it is using the names for editorial purposes and to the benefit of the trademark owner with no intention of infringing upon the trademark.

Disclaimer

The DAS Datamart team has taken every effort to ensure the accuracy of this manual. If you should discover any discrepancies, please notify us immediately.

Department of Administrative Services
155 Cottage St., NE, Salem, OR 97310
Datamart: (503) 373-0269 – Fax: (503) 378-3514
E-mail: [Datamart.Support@state.or.us](mailto:Datamart.Support@state.or.us)
Table of Contents

Complex Queries ................................................................. 02
  Creating Local Results and Local Joins ................................. 02
    Lesson 1a Exercise ....................................................... 03
    Lesson 1b Exercise ....................................................... 04
  Limitations of Local Results and Local Joins .......................... 05
  Derivable Queries ............................................................ 06
  Creating Derivable Queries ................................................ 06
  Derived Tables Rules and Behavior ...................................... 08
    Lesson 1c Exercise ....................................................... 09
  Derived Query - Conversion .............................................. 10
    Lesson 1d Exercise ....................................................... 10

Pivot Reports ................................................................. 13
  Creating a Pivot Report .................................................... 14
  Reorganizing a Pivot Report .............................................. 14
  Formatting Pivot Reports .................................................. 15
    Lesson 2a Exercise ....................................................... 17
  Creating Totals on Pivot Reports ....................................... 18
  Adding a Data Function to a Pivot Report ............................... 20
    Lesson 2b Exercise ....................................................... 22
  Creating Cumulative Totals ............................................... 23
  Sorting Pivot Reports ..................................................... 24
  Conditional Formatting of Values in a Pivot ............................ 25
  Grouping in a Pivot ........................................................ 27
    Lesson 2c Exercise ....................................................... 28

Free-Form Reports ............................................................ 30
  Report Section Elements .................................................. 31
  Creating a Free-Form Report .............................................. 33
  Formatting Free-Form Reports ............................................ 34
  Free-Form Report Properties ............................................. 36
  Table Gridline Properties ............................................... 38
    Lesson 3a Exercise ....................................................... 39
  Adding Totals to Report Group Headers .................................. 40
  Sorting Free-Form Reports ............................................... 40
  Data Functions, Expressions, and Appending Text ....................... 42
  Graphic Tools ............................................................... 46
    Lesson 3b Exercise ....................................................... 49
  Resizing and Aligning Labels ............................................ 50
  Report Headers and Footers .............................................. 51
  Inserting Report Page Breaks and Repeating Headers .................. 53
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multiple Data Sources in a Report</td>
<td>54</td>
</tr>
<tr>
<td>Smart Reports</td>
<td>55</td>
</tr>
<tr>
<td>Printing Report Prep</td>
<td>56</td>
</tr>
<tr>
<td>Lesson 3c Exercise</td>
<td>58</td>
</tr>
<tr>
<td>Computed Items</td>
<td>60</td>
</tr>
<tr>
<td>Computed Items Dialog Box</td>
<td>60</td>
</tr>
<tr>
<td>Computed Items in the Query Section</td>
<td>62</td>
</tr>
<tr>
<td>Computed Items in the ‘Results’ and ‘Table’ Sections</td>
<td>65</td>
</tr>
<tr>
<td>Modifying a Computed Item</td>
<td>67</td>
</tr>
<tr>
<td>Creating Computed Items in a Pivot Report</td>
<td>68</td>
</tr>
<tr>
<td>Types of Computed Items</td>
<td>69</td>
</tr>
<tr>
<td>Lesson 4a Exercise</td>
<td>72</td>
</tr>
<tr>
<td>Lesson 4b Exercise</td>
<td>75</td>
</tr>
<tr>
<td>Creating Computed Items in the Report Section</td>
<td>76</td>
</tr>
<tr>
<td>Dashboards</td>
<td>78</td>
</tr>
<tr>
<td>Dashboard Elements</td>
<td>79</td>
</tr>
<tr>
<td>Creating an EIS Page or Dashboard Section</td>
<td>80</td>
</tr>
<tr>
<td>Layout Tools</td>
<td>81</td>
</tr>
<tr>
<td>Dashboard Section Toolbar</td>
<td>82</td>
</tr>
<tr>
<td>Renaming a Dashboard Section</td>
<td>83</td>
</tr>
<tr>
<td>Command Buttons</td>
<td>84</td>
</tr>
<tr>
<td>Adding Radio Buttons to Display Values</td>
<td>88</td>
</tr>
<tr>
<td>Add a Drop Down Box to Display Values</td>
<td>90</td>
</tr>
<tr>
<td>Add a Hyperlink to a Dashboard</td>
<td>92</td>
</tr>
<tr>
<td>Setting Dashboard Properties</td>
<td>94</td>
</tr>
</tbody>
</table>
Lesson 1

Complex Queries

- Creating Local Results and Local Joins
- Limitations of Local Results and Local Joins
- Derivable Queries
- Creating Derivable Queries
- Derived Tables Rules and Behavior
- Derived Query - Conversion
Complex Queries

When working in Hyperion and using data from the Datamart it is often necessary to create complex queries to gather the necessary results you need. These complex queries can help join data together in ways that will make your data easier to gather. Discussed below are a few types of complex queries, which can use data from various locations to create dynamic queries.

**Local Results** are a snapshot of a ‘Results’ section shown in topic format. They are used to add the results of one query to another in a BQY file.

**Local Joins** are results of one query added to results of another query in a BQY file. Rows from the data sources are joined in the ‘Results’ section.

**Creating Local Results and Local Joins**

1. Open ‘A Blank Document’ in the Interactive Reporting Studio application, select **Insert**, then **New Query** to create the first query in the BQY file.

2. Select the desired database connection (Ex: SFMA.oce) and login.

3. Select the table from the Elements pane to add to the Content pane.

4. Build the Request Line, and add filters, data functions, and computations to the query, as needed.

5. Select **Process**.

   *Tip: Queries that use 'local results' and 'local joins' should be put in the proper 'processing order' to obtain the correct results.*

6. Select **Insert**, then **New Query** to create the second query.

7. Select the necessary database connection. (Note: This query will access a different set of data than the first query.)

8. In the Elements pane of the second query, add the necessary tables to the Content pane to help build the Request Line, add filters, data functions, and computations, as needed.

9. Select **Process**.

10. Select **Insert**, then **New Query** to create the third query, a database connection is not necessary.
11. Right-click in the Elements pane of the third query to view Local Results. Expand the Local Results to display the Results table.

12. Double-click the Results from both sets of data or drag them to the Content pane. The Results set from the first and second queries are displayed as topics in the Content pane.

13. In the Content pane, manually create ‘Local Joins’ between the common fields of each Result set.


If necessary, update the ‘Processing Order’. Once complete you can use the ‘Process All’ feature to process the queries.

**Lesson 1a Exercise**
Create a query that pulls data from two separate data sets.

1. Open a file titled, ‘Local_Results_Exercise.bqy’. Instructor will provide file location.

2. Review the ‘SFMS’ and ‘OSPS’ queries and results sections. Discuss with instructor.

3. Insert a third query section. *Note:* An oce connection is not necessary.

4. Input both the SFMS and OSPS Local Result tables into the Contents pane.

5. Create Local Joins between the two Result tables. Create joins from ‘Agency’ to ‘Sfms Agy’, ‘PCA’ to ‘PCA’ and ‘Agy Obj’ to ‘Agy Obj’.

6. Add all fields from both Local Result tables to the Request line.

7. Process the query.

8. Verify you have 58 rows of data and a ‘Trans Amt’ total of $60,983.97.

9. Review and discuss results with the instructor.
**Lesson 1b Exercise**

Create a dynamic query that automatically inputs the current Fiscal Year, Appr Year and Fiscal Month.

1. Open a file titled, ‘S&S by AgyObject_Original.bqy’. Instructor will provide file location.

2. Insert a new query with an SFMA oce connection.

3. Insert the ‘GL Detail’ table into the Contents pane of the new query.

4. From the ‘GL Detail’ table, add the following fields to the request line. ‘Rpt Appn Yr’, ‘Rpt Fiscal Mm’, ‘Rpt Fiscal Mm Name’ and ‘Rpt Fiscal Yr’. (Hint: Sorting the table will help find fields easier)

5. Alter the query to only Return Unique Rows and Process the query.

6. Return to the original query and insert the Local Results table (called ‘Results2’) into the Contents pane.

7. Within the original query section, create simple joins from the Local Results table (‘Results2’) to the ‘All Acct Event’ table. Create the following simple joins: ‘Rpt Appn Yr’ to ‘Appn Yr’; ‘Rpt Fiscal Mm’ to ‘Fiscal Month’; and ‘Rpt Fiscal Yr’ to ‘Fiscal Year’.

8. Remove the filters for ‘Fiscal Year’, ‘Fiscal Month’, and ‘Appn Year’.

9. Add the following fields to the request line:
   - **Results2 Table**:
     a. Rpt Fiscal Yr
     b. Rpt Appn Yr
     c. Rpt Fiscal Mm
     d. Rpt Fiscal Mm Name

10. **Process** the original query.

11. Update the ‘Report’ section. Within the ‘Header’ of the report, eliminate the previous ‘Text Label’, which shows the ‘Month’ and the ‘expression’ that shows ‘Fiscal Year’, then input the ‘Rpt Fiscal Mm Name’ and format, accordingly.

12. Alter the ‘Processing Order’ of the queries, so Query2 processes before Query1. Note: This allows the proper data to be obtained in the file.

13. Alert instructor after successfully completing the exercise.
**Limitations of Local Results and Local Joins**

The following limitations apply to local results and local joins:

1. You cannot set query filters on local results table fields. Filters must be set in the query/result sections of the query that produces the local results. Attempting to set a query filter on a 'local results' table field invokes the following error message: “Unable to retrieve value list for a computed or aggregate request item”.

2. You cannot access or change properties for local results tables. Properties include remarks, number formatting, aggregate/date/string functions, data types, and name.

3. You cannot have query request line computed columns from local results topic items. The ‘Add Computed Item’ menu option is not available for local results topic items.

4. You cannot use ‘Append Query’ features with local results table items. The Append Query menu option is not available when a local result field is part of a query.

5. You cannot change the view (structure, detail, or icon) of a local results table.

6. You cannot use the ‘Query Options’ functions with local results as part of the query. The following are functions accessed from the Query Options dialog box:
   - Returning Unique Rows
   - Return First
   - Time limit
   - Auto-Process
   - Custom Group by

7. You cannot join more than one ‘Profile’ table to the ‘Local Results’ table.
Derivable Queries

Derivable queries execute on the Database server where Local Results will execute on the Desktop when using the Desktop client. Derivable queries essentially create a temporary table in the current SQL transaction that is then accessed in a proceeding query. This structure has several advantages in the Oracle environment.

Advantages of Derivable Queries

- Data always current
- Runs faster than complex ‘standard’ built queries
- Create improved query functionality by allowing additional joins

Examples of situations to use Derivable Queries

- Use when standard query uses multiple joins
- Use when querying large amounts of data over multiple years

Creating Derivable Queries

To build a query that uses a derived table:

1. Build the query that will use the ‘derived table’ and process the query.

2. Insert a new query by choosing New Query on the Insert menu.

3. Build the ‘Derived Table’ query by right clicking in the Elements Catalog pane and selecting Derivable Queries on the shortcut menu.

Note: The ‘Derivable Queries’ option only displays, if the query sections qualify to be used as a derivable query.

To display as a ‘Derivable Query’, the query section must contain the following:
• have the same connection information as the current Query section
• have at least one item on the Request line
• do not use local joins
• does not contain derived table topics

The topic name, when a derived table is added to the work area, is the same as the source query section name, and the column names are the same as the names of the items on the Request line in the original query section being added with the exception of any (data) function component.

4. Include another table and create a join. This is accomplished by dragging a field from at least one table to another.

Once the derived table becomes joined, items from it can be added to the Request, Filter, or Sort lines of the containing query. It can be referenced in 'computed fields' as well.

5. Add the necessary fields to the request line for the desired results.

6. Process the query, which contains the derived table.

You can also use the ‘Process All’ command to process all queries within the BQY. The query containing the derived table will process, unless it is explicitly removed using the Query ‘Processing Order’ dialog. Using the ‘Process All’ function will allow you to compare your newly created derived query with the base source query.

Additions to the Request line of the source Query are reflected in the derived table item list the next time it is displayed.

Once a Derived Query table has been added to another Query, changes to the source query section will check for dependencies and warn you of any discrepancies that might occur. For example, you might receive a warning if an item was removed from the source query's Request line, which is used somewhere else (Request, Filter, Sort, etc.) in a Query that is deriving a table from the source query.
**Derived Tables Rules and Behavior**
The rules and behavior of a derived table include:

- You cannot change the view (structure, detail, or icon) of a ‘Derived’ table.

- A derived table has only two menu options: ‘Add Selected Items’ and ‘Remove’.

- Derived tables are available for connections to Teradata, DB2, Oracle, and Microsoft SQL Server. The standard connection to the DAS Datamart is DB2.

- If you remove all items from the request line of the original query, the fields are displayed as empty within the derived table.

- If you rename items in the original query section, it will update the derived table automatically. You must ensure that the new name is a valid name for the database to use.

- Fields from the ‘Local Results’ table cannot be added to the derived query.

- Both the original referencing query and the derived table query must use the same data source even if one or the other is not connected. For example, assume Query1 is accessing the State of Oregon's Financial system (SFMA); therefore, Query2 (derived query) would also have to be able to access the same system, even if it was not necessary. That is, you must be sure that both Query1 and Query2 can connect to the same data source name. In other words, the open catalog extension, used in this case, would both need to access the SFMA system.
Lesson 1c Exercise
Create a derivable query.

1. Open a file titled, ‘S&S by AgyObject_Derivable_Original.bqy’, then review the ‘Dashboard’ and ‘Query’ sections. This will help you become familiarized with the file.

2. Insert a new query with an SFMA oce connection.

3. Insert the Derivable Queries table called ‘Query’ into the Contents pane of the new query.

4. Add all the fields from the derivable ‘Query’ table to the request line.

5. Insert the SFMA table called ‘Agency’ into the Contents pane.

6. Create a ‘simple’ join from the derivable query table to the ‘Agency’ table. You only need to join from ‘Agency’ to ‘Agency’. (Note: The original query shows the proper joins needed for the new query)

7. Review the original query and remove the ‘Agency’ table from the content pane.

8. Review the second ‘Query’ and add the following item to the request line.
   
   **Agency** Table
   
   a. Agency Title

9. **Process** the second ‘Query’. (Answer: 3056 of 3056 rows)

   *Note: In the above exercise, to view the proper results of the derived query, within a report, the original report needs altered or a new report needs created to contain the new data.*

   "Note: Filters from the original results section do not automatically flow to the derived query results section."

10. Filter the ‘Results’ section of the ‘derivable query’. Set ‘Agy Obj’ to greater than 3999.

11. How many rows are returned? (Answer: 2376 of 3056)

12. Alert instructor after successfully completing the exercise.
**Derived Query - Conversion**
How to change a standard query into a derivable query.

**Purpose:**
The following instructions are designed to help Datamart users, within the State of Oregon, update their standard Hyperion queries and create derivable queries. Derivable queries allow for better functionality, quicker processing, and many other benefits. These instructions allow a user to keep their original tables, pivots, reports, dashboards and charts, intact, while updating the query to run as a derivable query.

**Standard query set up:**
- A file with one standard query containing multiple joined tables (Standard practice is to alter queries that have multiple joins, so the derived process will have the desired improvement).
- Any filters can be set within the original query section.
- Any fields can be selected for the request line of the original query.
- The file may contain multiple tables, pivots, charts, dashboards or reports.

**Lesson 1d Exercise**
Create a derivable query using an established Hyperion file.

1. Open a file titled, ‘Lesson1-Exercise-1D_Original.bqy’. Review the various sections within the file to become familiar.

2. Insert a second query within your file by *duplicating* the original query. (Hint: Right-click on the original query)

3. Add, to the original query, a derived table, which is obtained from the duplicated query. Note: To accomplish this, click on the original query section, right-click on Tables (within the Elements section) and click ‘Derivable Queries’. Expand the Derivable queries folder then drag and drop query2 into the contents pane.

4. Create the same joins, as the original query contains; however, the joins will link from the profile tables to the new derived table. Note: If a join field is not within the derived query, you must add it to the duplicated query request line, which automatically adds it to the original query request line. This allows the queries to contain the proper fields to join.

5. Remove the main ‘financial’ table from the original query. Note: This removes all the original financial table fields from the request line.
6. Remove all the ‘profile’ tables from the duplicate query. Note: This removes all the original profile table fields from the request line of the duplicate query.

7. Within the original query section (query1), add ‘all’ fields from the derived query table, to the request line. Note: Re-order the request line, if necessary.

8. Alter the processing order of the two queries (Tools, Process Query, Processing Order) to allow query2 (duplicate query) to run before query1 (original).

9. Select the ‘Process All’ button to run both queries.

10. Verify the ‘Result’ section filters are the same in both queries

11. Verify both queries ‘Result’ sections are the same data (in total).

   Note: It is a valuable option; to set the duplicate query filters to variable because it allows a user to alter the filters when only processing the new derived query.

   Note: After the derived query is fully created, you can either ‘Process Current’ on the derived query or select ‘Process All’. The ‘Processing All’ feature will allow you to compare the two queries and verify if any of your joins have dropped data.

   Note: If your original ‘Results’ section contains ‘Grouping’ or ‘computed field’ columns, you must verify the columns formula’s in the updated derived ‘Results’ section, once the derived query creation is complete.
Lesson 2

Pivot Reports

- Creating a Pivot Report
- Reorganizing a Pivot Report
- Formatting Pivot Reports
- Creating Totals on Pivot Reports
- Adding a Data Function to a Pivot Report
- Creating Cumulative Totals
- Sorting Pivot Reports
- Conditional Formatting of Values in a Pivot
- Grouping in a Pivot
Pivot Reports

The Pivot section is used to create cross-tabular style reports. This section enables you to extract meaningful data from your results.

The following example uses the file titled, ‘ORBITS Intermediate Lesson 2 & 3’.

Hint: A user can move the Data Layout section around by double clicking to pop it out from its location and then drag and drop.
**Creating a Pivot Report**

1. **Select**→**Insert**→**New Pivot**.

   Note: Make sure to click on the desired ‘Results’ or ‘Table’ section, prior to inserting the Pivot. The Pivot uses the data from the specified section.

   If necessary, on the Section Title bar, click **Data Layout** to display the Data Layout area below the Pivot Content pane.

2. Drag items from the Elements Pane to the Row, Column, and Fact label panes to generate the report automatically.

   - You can add multiple items to any Data Layout pane.
   - Items are ordered in the way they are displayed in the Data Layout panes.
   - Row and Column labels are usually in the form of text.
   - Fact labels are summed by default. (e.g. SFMS Trans Amt).

**Reorganizing a Pivot Report**

Once the Pivot Report is created you can reorganize, add, and remove items.

   - You can move items for either the Column and/or Row labels by clicking and dragging the items to a new label location in the Data Layout Section. The report will automatically recalculate. You are only able to move the Row and Column labels items from one label to another. You can even move the Facts label items to another label area.
   - You can reorganize all label items (Row, Column, and Facts) within their panes.
   - To add a new Facts label, you must add it from the Elements Pane.
   - To remove an item from a pane, right-click on the item in the Data Layout pane, and then select→**Remove**.
### Formatting Pivot Reports

You can apply many formatting techniques to your Pivot.

<table>
<thead>
<tr>
<th>Format</th>
<th>How To</th>
</tr>
</thead>
</table>
| Resize a column   | ○ To resize a column manually, drag the report column margin to the left or right.  
               | ○ Double-click the report column boundaries to auto-size the column.  
               | ○ To resize the column to the standard size, select the column label in the report and then select **Format → Auto-Size Width**. |
| Resize a row      | ○ To resize a row manually, drag the report row margin up or down.  
               | ○ Double-click the report row boundaries to auto-size the row.  
               | ○ To resize the column to the standard size, select the row label in the report and then select **Format → Auto-Size Height**. |
| Modify font       | ○ Select a report element you wish to alter.  
               | ○ Select **Format → Font**, select a font type, size, style, and effect, and then click **OK**.  
               | ○ Use the Formatting toolbar for quick formatting.  
               | ○ Right-click on the column, row, fact or title in the report and then select **Font**.  
               | Labels can have distinctive styles. |
| Modify a number, date, or time format | o For numeric formatting, select a numeric label or fact on the report, and then use your Formatting toolbar to select numeric formatting options.  
o For additional options, select the numeric label or fact in the report, then select **Format→Number**, select your numeric options, and then click **OK**.  
o Right-click on the numeric label in the report and then select **Number**. |
| Justify data | o Select a report element, and then use the Formatting toolbar by clicking **Justify→Left, Center, Right, Top, Middle, or Bottom**. |
| Display border lines | o Select the report element and select **Format→Borders**. There are various border options to choose. |
| Change the position of data labels | o Select **Format→Data Labels→None, Column, or Row**. |
| Display corner labels | o Select **Format→Corner Labels→None, Column, Row, or Both**. |
| Format an entire column or row | o Press **Alt** (for Windows), **Option** (Mac), or **Ctrl+Alt** (UNIX). Select a label, and then apply a format. |
| Rename a label | o Double-click a label, type a new name in the dialog box, and then click **OK**. |
| Add color | o Select a report element, and then on the Formatting toolbar, select your line, fill, and text colors. |
Lesson 2a Exercise

1. Open ‘ORBITS Intermediate Lesson 2 & 3’.

2. Click on the ‘ORBITS Results’ section and then insert a ‘New Pivot’.

3. Add the following to the Data Layout area:
   Row Labels:
   a. Compt Source Group
   b. Compt Source Group Title
   c. Program Code
   Column Label:
   a. Fiscal Year
   Facts:
   a. Leg Approved Budget
   b. Fy Cum

4. Format – Corner Labels – Both (Hint: Right-click in content pane.)

5. Practice adding and removing labels and resizing your columns.

6. Justify all column titles to ‘Center’ and ‘Bottom’.

7. Change the ‘Leg Approved Budget’ and ‘Fy Cum’ to Number Format without decimal places.

8. Alter the background color of the ‘Leg Approved Budget’ and ‘Fy Cum’ titles to orange.

9. Change the name of ‘Fy Cum’ to ‘FY Cum’.

10. Once finished, you need to leave the file open, so you can complete lesson 2b.
Creating Totals on Pivot Reports

Select the title label you want to total then **Pivot→Add Totals**.

In addition, you can right-click on the title label, then select→Add Totals.

You can calculate totals for both columns and rows in a Pivot. When inner dimensions are totaled, subtotals are created for each of the label values in the outer dimensions.

To delete a total, select the total you wish to delete and press the delete key on your keyboard.

The following two examples show adding ‘Totals’, which display at the bottom of the column you selected within the pivot.
The next two examples show inner dimension (or break) totals.

<table>
<thead>
<tr>
<th>Grant No</th>
<th>Grant No Title</th>
<th>Grant Phase</th>
<th>Fund</th>
<th>0014</th>
<th>0024</th>
<th>0034</th>
</tr>
</thead>
<tbody>
<tr>
<td>416994</td>
<td>INDEPENDENT LIVING SERVICES</td>
<td>06</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>PART B</td>
<td>07</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Payroll</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Total</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Payroll</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Total</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Services &amp; Supplies</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Staff Dev &amp; Training</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Utilities, Rent, &amp; Other Exp</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Total</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The table contains financial details for grants with categories such as Payroll, Services & Supplies, Staff Dev & Training, and Utilities, Rent, & Other Exp. The totals are calculated for each category across different funds (0014, 0024, 0034).
Adding a Data Function to a Pivot Report

You can add additional columns to a Pivot report showing facts utilizing different data functions.

1. Notice the example below. ‘Leave Hours’ is displayed once in the Facts Data Layout section.

2. Watch what happens when you add it to the Facts Data Layout section for a second time and apply a data function to the column.

3. To add a data function, highlight & right-click on the column you want to convert to a data function, select Data Function →% of Column (can be any desired data function).
4. Double-click on the label name in the Pivot report and change the name to what you desire. Click → OK.

5. The Facts Data Layout section and the Pivot report now reflect the new name.
Lesson 2b Exercise

1. Continue using the Pivot you created for Lesson 2a within the ‘ORBITS Intermediate Lesson 2 & 3’ bqv file.

2. Select the ‘Compt Source Group’ column – right-click – Add Totals.


4. Alter the Font Size of the entire ‘Total’ row to 12. In addition, change the entire ‘Total’ row to **Bold**. (Hint: Hold down ‘Alt’ to select the entire row.)

5. Create a break total within the ‘Program Code’ column. Select the column - right-click – Add Totals. Change the format of the ‘Total’ labels to **Bold**, as well as, alter the ‘Fill Color’ to a color of your choice.

6. Add a second ‘Fy Cum’ to the ‘Facts’ section. (Note: Whenever you add a second fact that is the same as a previous fact, it will automatically alter the name.)

7. Highlight and right-click on the new ‘Fy Cum’ column then change the ‘Data Function’ to ‘% of Column’. Also, change the new ‘Fy Cum’ title label to ‘FY Cum Percentage’. Resize the title label width, if necessary. Alter the column number format to a ‘Percentage’ with two decimal places.

8. Once finished, you need to leave the file open, so you can complete lesson 2c.
Creating Cumulative Totals

You can create cumulative totals in a Pivot report. You will need to select the dimension and define the scope. They start at zero for each new dimensional group, which is referred to as the scope. You may find the need to rearrange your Pivot report to accommodate a cumulative total.

1. Right-click on the column you want as a cumulative total. Select→Add Cume.

2. Name your new column and define your desired scope.

3. The result, in the end, is a new column, which contains a cumulative total.
## Sorting Pivot Reports

There are two ways to sort the data in a Pivot report:

- Select sort buttons on the Standard Toolbar to sort labels alphabetically in ascending or descending order.

- Configure the Sort line in the Pivot section to sort labels alphabetically or based on fact in the report.

### Below are the steps to sort your Pivot report:

1. On the Section title bar, click → **Sort** if the sort line is not displayed.

2. On the Sort line, from the first drop-down list, select a label to sort. The labels, which are available in this list, are those displayed in the Pivot. (Note…the Pivot will always primarily sort by the first column in the Pivot.)

3. From the second drop-down list, select ‘Label’ to sort the label alphabetically; or select a fact item to sort the labels based on the values of the fact.

4. From the third drop-down list, select a data function if a fact item is selected in the second drop-down list. (Note…the third drop-down list is not available for selection if Label is selected in the second drop-down list.)

5. On the Sort line, click → **Sort Ascending** or **Sort Descending** button to specify the sort order.

### Table

<table>
<thead>
<tr>
<th>Sort Source Group</th>
<th>Compt. Source Group</th>
<th>Lag Approved Budget</th>
<th>Current of Lag Approved Budget</th>
</tr>
</thead>
<tbody>
<tr>
<td>0500 GENERAL FUND</td>
<td>0500 GENERAL FUND</td>
<td>8,652,295</td>
<td>8,652,295</td>
</tr>
<tr>
<td>3110 CLASS/SPECIAL</td>
<td>3110 CLASS/SPECIAL</td>
<td>8,195,079</td>
<td>14,767,374</td>
</tr>
<tr>
<td>0730 OTHER SALES</td>
<td>0730 OTHER SALES</td>
<td>1,172,758</td>
<td>16,536,132</td>
</tr>
<tr>
<td>1910 TRANSFER</td>
<td>1910 TRANSFER FROM OTHER FUNDS</td>
<td>1,270,741</td>
<td>17,940,405</td>
</tr>
</tbody>
</table>
**Conditional Formatting of Values in a Pivot**

The Conditional Formatting function allows important values to be emphasized in a Pivot. You can apply conditions to fields, which apply different font color and styles. The Conditional Formatting feature is available in the Results, Table, Pivot, and Report sections.

**To add Conditional Formatting: (See diagram on following page)**

1. Select the section to format.

2. Select→**Format→Conditional Formatting** from the menu bar. The Conditional Formatting dialog box is displayed.

3. Choose a Conditional Format item from the drop down menu within the Conditional Formatting dialog box.

4. Choose a comparison Data Function from the Operator drop down menu.

5. Enter a comparison value in the Value field.

6. Choose exception text formatting such as bold, italics, underline, background color, and/or font color.

7. Click the ‘apply’ button to update the Conditional format while within the Conditional Formatting dialog box.

8. Select ‘Ok’ to close the dialog box. The format is automatically applied.
To remove Conditional formatting:

1. Select \textit{Format} \textarrow{Conditional formatting} from the menu bar. The Conditional formatting dialog box is displayed.

2. In the Conditional Formatting item drop down menu, select the item with the Conditional formatting. The Conditional formatting dialog box will display current applied formats.

3. In the Conditional formatting ‘Operator’ drop down menu, select a \textbf{blank} format. This clears the previous applied condition.
Grouping in a Pivot

You can combine labels in a Pivot by using the Group feature. When you combine the data, the facts are aggregated, displaying a new summary of information.

To group data in a Pivot:

1. Select the label/labels you wish to group together.

2. From the Standard toolbar, use the Group Items icon. Your selected labels will now be consolidated into one group and their data will be combined. You will need to change the label name to reflect the new group. You will also notice an asterisk on the new label.

3. Double click the label to change the name. The label dialog box will appear as shown above. Enter your new name and click OK.
To ungroup data in a Pivot:

1. Select the grouped label.

2. From the Standard toolbar, use the Group Items icon. Your selected label will now be ungrouped.

Lesson 2c Exercise

1. Continue using the Pivot you created for Lesson 2a within the ‘ORBITS Intermediate Lesson 2 & 3’ bqty file.

2. Create a ‘Cumulative Total’ column for ‘FY Cum’ and format the title and data of the new column the same as the original ‘FY Cum’ column.

3. You will notice ‘Compt Source Group’ is the primary ‘Sort’ default, since it is the first Row Label. Use the ‘Sort line’ function to also sort by ‘Program Code’, in ascending order and ‘by label’. This will allow ‘Program Code’ to be sorted within ‘Compt Source Group’. (Hint: Highlight the ‘Program Code’ column to start this task). Next, change the ‘by’ sort order from ‘label’ to ‘Fy Cum’ and compare the difference.

4. Create a ‘Conditional Format’ on any values in your Pivot. Go to Format – Conditional formatting, set your condition (be creative), view your results.

   Note: When using a conditional format of a percentage, you need to input it as a decimal.

5. Practice removing your Conditional Format by opening Format – Conditional formatting – then select the condition to alter and change the Operator drop down to a blank field.

6. Practice ‘Pivot Grouping’ with ‘Compt Source Group’. Group all the 3000's series of ‘Compt Source Group’ together and change the label to ‘Payroll’.

   Note: As soon as you complete the label change to ‘Payroll’, the program automatically sorts the new group.

7. Alert instructor after successfully completing the exercise.
Lesson 3

Free-Form Reports

- Report Section Elements
- Creating a Free-Form Report
- Formatting Free-Form Reports
- Free-Form Report Properties
- Table Gridline Properties
- Adding Totals to Report Group Headers
- Sorting Free-Form Reports
- Data Functions, Expressions, and Appending Text
- Graphic Tools
- Resizing and Aligning Labels
- Report Headers and Footers
- Inserting Report Page Breaks and Repeating Headers
- Multiple Data Sources in a Report
- Smart Reports
- Printing Report Prep
Free-Form Reports

You can create free-form report styles in the Report section. With a free-form structure, you can set up reports to match your needs. In the Report section, you have the ability to work with flexible page sizing and can preview your work for an accurate image of what your finished product will look like. Many graphic and field items are available to aid in your report design. *Save your report design often to preserve your changes.* This is the one section where you can combine different sections of your Hyperion document.
Report Section Elements

Expression Line – Accessed by the Expression button on the Section title bar, the Expression line allows you to build computed expressions using JavaScript.

Elements Pane – Contains all of the drag-and-drop selections you can use to create custom reporting.
  o Query Section – Contains all the sections related to a selected query, including Result, Pivot, and Chart sections. You can drag individual Result columns from the Result and Table sections to a report page, as well as entire Pivot and Chart sections to embed Reports.
  o Graphics Section – Contains graphic text labels and pictures. Includes line, horizontal line, vertical line, rectangle, round rectangle, and oval options. To insert a graphic, select Report→Insert Graphic or to insert a picture, select Report→Picture.
  o Fields Section – Consists of predefined fields, which can be dragged to different areas of your report. You can find filter, page number, date, and time fields to name a few.
    • Field – Inserts a computed field.
    • Query Filter – Inserts a select query filter.
    • Results Filter – Inserts a selected results filter.
    • Query SQL – Inserts the last SQL sent to the database when you process the query.
    • Page Number – Inserts a page number.
    • Number of Pages – Inserts the total number of pages.
    • Page X of Y – Inserts the current page of the total number of pages.
    • Last Saved – Inserts date on which the report was last saved in default date format.
    • Last Printed – Inserts the date on which the report was last printed in the default date format.
    • Date – Inserts and stamps the current date in default date format.
    • Time – Inserts and stamps current time in default time format.
    • Date & Time – Inserts the current date and time in default date and time format.
    • Date Now – Inserts the current date in default date format.
    • Time Now - Inserts the current time in default time format.
    • Date & Time Now – Inserts the current date and time in default date and time format.
    • File Name – Inserts the Hyperion document name (.bqy).
    • Path Name – Inserts the full path name of the document.
    • Report Name – Inserts the report name.
Data Layout Pane – Contains the Report Group, Table Dimensions, and Table Facts Panes.

- **Report Group** – Defines the overall or highest levels used to group data in a report.

- **Table Dimensions** – Includes the *descriptive data* as a column in a table. This area is in the *Body* of the report and is usually displayed next to Facts.

- **Table Facts** – Includes the measurable or *quantifiable data* as a column in the report. This data usually resides in the *Body* of the report next to the Table Dimensions data.
Creating a Free-Form Report

Warning… The Undo option rarely is available in Hyperion. Since reports are creation intense and involve many formatting steps, you should save often. General rule… save when you feel you do not want to redo what you just did.


2. Reports are much easier to work with if you remember to turn on the ‘Section Boundaries’. To do this, select Report→Section Boundaries.

3. If you do not see the Data Layout section, on the bottom of your screen, click the Groups and/or Table buttons to view the sections. These two toggles are located on the Section Title bar.

4. Drag non-quantifiable items to the ‘Report Group’ pane. You will notice these items are immediately displayed on your report.

5. Drag non-quantifiable items to the ‘Table Dimensions’ pane. These items are visible in a column format in the body of the report.

6. Drag quantifiable items to the ‘Facts’ pane. These items are automatically aggregated in the body of the report.
**Formatting Free-Form Reports**

Use the table below for some common formatting techniques.

<table>
<thead>
<tr>
<th>Format</th>
<th>How To</th>
</tr>
</thead>
</table>
| Number format                       | o Select a report element, and then on the Formatting toolbar, select a number format.  
 o Select a report element, right-click, and then select→**Number**. In the Properties dialog box select a number format, and then click→OK. |
| Resize a table column               | o Select a column in a table, place the mouse pointer over the column margin, and then double-click to auto-size it.  
 o Select a column in the table, and then drag the margin to the desired width.                                                                 |
<p>| Resize a table row                  | o Select the left side of the first column in a table to highlight the row, position the mouse pointer over the bottom row margin and then drag the margin to the desired height. All rows in that table will be resized. |
| Resize a report group header        | o Select a report group header (do not select any objects inside the header), position the mouse pointer over the row margin, and then drag the margin to the desired height. |
| Display or hide column titles in a  | o Select any column in a table, right-click, and then select→<strong>Show Column Titles</strong>. A check mark indicates the column titles are visible.                                                                    |
| table                               | Repeat report group headers if report is multiple pages | o Select a report group header (do not select any objects inside the header), right-click, and select→<strong>Repeat Header</strong>. |</p>
<table>
<thead>
<tr>
<th>Task</th>
<th>Instructions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move an object</td>
<td>Position the mouse pointed over an object. When the mouse pointer changes to a 4-header arrow, select the object and drag it to another location.</td>
</tr>
<tr>
<td>Show or hide the Table Facts total</td>
<td>In a report, select a table fact, right-click, and select → <strong>Show Column Total</strong>. A check mark indicates the total is visible. Select a table fact, and then on the Standard toolbar, click → <strong>Grand Total</strong> icon.</td>
</tr>
<tr>
<td>Suppress duplicate column values in a table</td>
<td>In the report, select a column in a table, right-click, and then select → <strong>Suppress Duplicates</strong>.</td>
</tr>
<tr>
<td>Insert table</td>
<td>In the body of the report, right-click, and select → <strong>Insert Table</strong>. Find the desired location to input the table and left click.</td>
</tr>
<tr>
<td>Insert a computed item</td>
<td>In the body of the report, select a table column, right click, and then select → <strong>Add Computed Item</strong>.</td>
</tr>
<tr>
<td>Display Header and Footer sections</td>
<td>Within a Report section, select the Report main menu, and select <strong>Header and Footers</strong>, finally select the desired view of the header and footer sections.</td>
</tr>
</tbody>
</table>
**Free-Form Report Properties**

You can modify the number, font, alignment, border and background of any report group label. The Properties tab might be different based on what you select.

1. Double-click the report group label and the Properties dialog box will open or highlight the report label, right-click and select Properties.

2. Select the Font tab and set your desired font style, which includes font type, text style, font size, effects, and text color.

3. Select the Number tab and set your desired Number format.
4. Select the Alignment tab. This tab allows you to select horizontal and vertical alignment. Also included are rotation and text wrapping control.

5. Select the ‘Background and Border’ tab. Use this tab to select the border color, width, and style. Also, choose background colors and patterns.
Table Gridline Properties

You can also modify the gridline properties of a report.

To modify the gridlines:

1. Select a table in the report.

2. Select → Format → Grid Lines.

3. The Gridlines dialog box will open. Use the gridline tab to set color, width, and style for the vertical and horizontal gridlines.
Lesson 3a Exercise


2. Alter the view of the report to show your ‘Section Boundaries’, Report ‘Header and Footer’ and Page ‘Header and Footer’.

3. Set the ‘Page Setup’ to Landscape. (Hint: This is done through the ‘File’ menu.)

4. Pull fields from the ‘ORBITS Results’ section to set up your ‘Data Layout’ section as follows:
   a. Report Group 1 – Agency
   b. Report Group 2 – GL Account, GL Account Title
   c. Table Dimensions – Program Code, PCA, PCA Title, Agency Object, Agency Object Title
   d. Table Facts – Legislatively Approved Budget, FY Cum

5. Within the ‘body’ section, change the number format of the ‘Legislatively Approved Budget’ and ‘FY Cum’ to currency with two decimal places. In addition, resize all columns within the ‘body’ section to fit the column data, properly.

6. Within the ‘body’ section, change the ‘PCA Title’ column to ‘Text Wrap’ by selecting the column, right clicking – ‘Text Wrap’. Then make the column smaller and view the results.

7. Within the ‘body’ section, format your ‘Horizontal’ and ‘Vertical’ gridlines to dark blue. Review your results.

8. Alert instructor after successfully completing the exercise.
Adding Totals to Report Group Headers

Obviously, you get totals in the tables of a report body. However, did you know you could also generate totals in the ‘report group header’ sections?

To add a total to a report group header:

1. Drag the item/field from the Elements pane to the desired ‘report group header’ section.

Sorting Free-Form Reports

You can sort report group labels and table columns alpha-numerically or based on formulas.

To sort the labels of a report group alpha-numerically:

1. On the section title bar, click→Sort to view the Sort line, if needed.
2. Select a report group label.
3. Once highlighted, drag the report group header to the Sort line.
4. On the Sort line, reorder the Sort items to set the sort order and double-click Sort items to toggle between ascending or descending sort orders.
To sort report group labels based on a total value:

1. In a report group header, select a total value associated with a report group label.

2. Once highlighted, drag the total value to the Sort line.

To sort the row in a table alpha-numerically:

1. Select the column in a table.

2. Once the column is highlighted, drag the column to the Sort line.

3. You are able to add multiple columns to the Sort line to create a nested sort.
Data Functions, Expressions, and Appending Text

Creating a ‘Data Function’ in the Report section is very similar to other sections. You start by using ‘Table Facts’, which are automatically summarized in a report, based on the ‘Table Dimensions’ and ‘Report Groups’. You can alter the data in various ways by changing the data function. In addition, you can change the displayed name of the additional column by altering the expression or appending text.

To modify the data function of a table fact:

1. Drag the field from the Elements pane to the Table Facts pane in the Data Layout Table section.

2. You can add the same field more than once to the facts pane knowing you will change the data function and expression attached to the field. You do this because you might want to see the same data in a different light.

3. Select the ‘Table Fact’ in the body section (not the data layout table section), right-click, and then select the desired data function.
Creating data functions in the Report Section:

The following exercise is shown in the file titled ‘585 Grant’ (See instructor).

In the example below, we have started to build a report. We are creating additional analysis of the ‘SFMS Trans Amt’ for a second view of the fact data. This example uses a slightly different way to add a data function, then described on the previous pages.

1. Within the ‘Report Group1’ header section, drag ‘SFMS Trans Amt’ within the ‘Elements’ section over to the ‘Table Facts’ as shown below.

2. Highlight the new ‘SFMS Trans Amt’ column. If the Data Function info is not visible, click the ‘Expression’ toggle to view the formula. Note: The Data Function line allows you to view the field formula.
3. Click on the drop-down arrow next to Data Function to view the different options available. Select % of Category.

4. Select the green checkmark to accept your new computed item.

5. Click on the newly added ‘SFMS Trans Amt’ column and rename the column.

6. Type in the new name, entitled ‘Percent of category’ in the expression field and select the green checkmark to accept the change.
To modify the expression or name of a table column:

1. On the Section title bar, click ‘Expression’ if the Expression line is not displayed.

2. Select a column name in the report.

3. On the Expression line, replace the text in quotation marks with new text, and then click the green check mark.

To append text to a report group label:

1. Select the report group label.

2. On the Section title bar, click ‘Expression’ if the Expression line is not displayed.

3. On the Expression line, enter text in quotation marks before and after the equation, type a plus sign ‘+’ to concatenate the text, and then click the green check mark to accept the changes.
Graphic Tools

The graphics section of the Elements pane contains graphic designs, text labels and pictures. The graphic design includes line, horizontal line, vertical line, rectangle, round rectangle, and oval options. If you have ever used any of these tools in Word or PowerPoint, you will not have a problem in Hyperion.

To add a graphic to a report:

1. Drag a shape from the Graphics folder in the Elements pane to the desired area of your report.

2. Resize the graphic to make it the dimensions you desire.

3. You can alter the properties of the graphic by double-clicking and changing the properties.
To add a text label to a report:

1. Drag the Text Label from the Graphics folder to the desired location in your report.

2. Select the label and enter your text.

3. You can move the text label when the boxes are displayed as shown below. You need to make sure and hold down the left mouse click while selecting the label to obtain the boxes shown. Drag and drop the label to the desired area.
To add a picture to a report:

1. Drag the Picture from the Graphics folder within the Elements pane to the desired location in your report. This option is great for your agency logo. The report can support the following file formats:
   - Bitmap (.bmp)
   - Graphics Interchange Format (.gif)
   - Joint Photographic Experts Group (.jpeg, .jpg)
   - Portable Network Graphic (.png)

2. The Select Image dialog box will open. Browse to find your picture.

3. Click → Open.
Lesson 3b Exercise


2. Within the newly created ‘Lesson 3b Class Report’, sort the following:
   a. ‘Report Group2’ header section – GL Account  
   b. ‘Body’ section – Program Code, PCA, then Agency Object

3. Input the ‘Leg Approved Budget’ total within the ‘Report Group1’ header section. Include a ‘Text Label’ titled ‘Grand Total:’ next to total amount (format, if necessary).

4. Modify the name of **Fy Cum** to **FY Cum** using the Expression line. Note: Do not forget to click the green check mark! ☺

5. Within the ‘Report Group1’ header section, append the following text (“**Agency:** ”+) to the beginning of the ‘Agency’ expression field. (See p.43 for reference). In addition, increase the font size, make the font style **bold** and **italic** and alter the font color for the ‘Agency’ field.

6. Within the ‘Report Group2’ header section, append the following text (“**GL Account:** ”+) to the beginning of the ‘GL Acct’ expression field.

7. Open the ‘Graphics’ folder within the Elements pane. Drag the ‘Hz Line’ to the ‘Report Header’ section. Place it near the bottom of the section to create a divider line. You can change the format of this line by going into properties and altering the width and color.

8. Add a picture to the ‘Report Header’ section. First, make the section taller, so you have room to add the picture. (Hint: Change the height by dragging the lower section boundary line). Next, bring over the ‘Picture’ field from the ‘Graphics’ Folder within the Elements pane. Insert the ORBITS image, which already exists in the Resource Manager. (Note: You may need to move and resize the ‘Hz line’ to align it below your image.) Finally, change the background color of this section (not the picture) to light blue.

9. Create a report title field within the ‘Report Header’ section. Bring over the ‘Text Label’ from the ‘Graphics’ Folder in the Elements pane. Alter the label name of the report to ‘Budget Actual by GL Account’. Increase the font size to 24, change the Font style to **bold** and **italic**, and alter the text label background to light green.

10. Alert instructor after successfully completing the exercise.
Resizing and Aligning Labels

When you drag and drop a text label from the Graphic folder or bring items into your report it is normally necessary to resize the labels, so all text is visible. Remember that just because you can see the complete text for one PCA or ‘Employee Name’, it does not mean it will display the same for a longer name.

Often you have many labels added to your report. It is good housekeeping to align the labels so they have the same margins.

To resize a label:

1. Make sure you have the boxes highlighted around your label.
2. Get the double-headed arrow and drag the label to the desired size.

To align labels:

1. Select all the labels you want aligned. (Note: Hold the CTRL key and then click on each item you want to select.)
2. Select → Format → Align → Your desired alignment from the menu bar.
Report Headers and Footers

Report headers and footers are treated as normal report sections allowing full customization of the contents. Usually, report headers and footers are summarizing information. Report headers print on the first page of the report. Report footers print only on the last page of the report.

To add a report header or footer:

1. Turn on the Section Boundaries first. Select → Report → Section Boundaries.

2. Select → Report → Headers and Footers → select one of the below Options.
   a. To display the report header, select → Report Header.
   b. To display the report footer, select → Report Footer.
   c. To display both report headers and footers, select → Show Both.

3. You can add multiple fields to the report header or footer by dragging objects from the Elements pane. See examples within the following table.
<table>
<thead>
<tr>
<th>Item to Insert</th>
<th>How to</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>o Select → <strong>Text Label</strong> from the Graphics folder and drag the text label to the header or footer section.</td>
</tr>
<tr>
<td>Graphics/Pictures</td>
<td>o Select the graphic from the Graphics folder and drag it to the report header or footer section.</td>
</tr>
<tr>
<td></td>
<td>o Select → <strong>Report → Insert Graphic</strong>.</td>
</tr>
<tr>
<td></td>
<td>o Select Report → Picture. Use your mouse to draw the area in which you want your picture. Select your image from the Select Image dialog box.</td>
</tr>
<tr>
<td>Smart Charts/Pivot reports</td>
<td>o Drag and drop pre-built Pivot or Chart reports, from the Elements pane, into the report header or footer sections.</td>
</tr>
<tr>
<td>Empty field (computed field)</td>
<td>o Select a field from the Fields folder in the Elements pane and drag it to the report header or footer section.</td>
</tr>
<tr>
<td></td>
<td>o Select <strong>Report → Insert Field</strong>.</td>
</tr>
<tr>
<td>Predefined fields</td>
<td>o Select a predefined field from the Fields folder in the Elements pane and drag it to the report header or footer section.</td>
</tr>
<tr>
<td></td>
<td>o Select <strong>Report → Insert Predefined Fields</strong> and select the predefined field from a drop-down list.</td>
</tr>
</tbody>
</table>
Inserting Report Page Breaks and Repeating Headers

Often your report is greater than one page and you may find the need to keep certain data together under one label or repeat headers labels to identify your data. You can place page breaks before or after a report body or report group label. In addition, you can repeat headers, allowing headers to show on multiple pages.

To group objects on a page and insert a page break:

1. Decide what objects in the report need to stay together on the same page. Select those objects, right-click, and select→**Keep Together**.
   a. **Keep Together** – Instructs Hyperion not to split a band when a break is encountered. When a break is encountered, the entire band is moved to the next page.

2. Decide if there is a ‘report group’ label that should be displayed on the same page as the next ‘report group’ label. If so, select the report group label (the first one), right-click, and select→**Keep With Next**.
   a. **Keep With Next** – Instruct Hyperion to keep bands within a group, together, when paginating a report. If the lower band cannot fit on the page when the report is paginated, both bands are moved to the following page.

3. Insert the page break. Select the report group header section, right-click, select→**Page Break Before** or **Page Break After**.

To remove a page break:

1. Select the ‘report group header’ section, with the page break applied.

2. Right-click, and select→**Page Break After** or **Page Break Before**.

To Repeat a Header:

1. Select the ‘report group header’ section, without selecting an object in the report group header.

2. Right-click on the blank area within the section, and select→**Repeat Header**

*A check mark is displayed next to the selected page break option to indicate that it is active. Choose this option again to clear the check mark and remove the page break.*
Multiple Data Sources in a Report

The formality presentation of a report is the one reason users opt for this section. However, did you know another reason is because you can add data from multiple queries, Pivot, and Charts to one report? This is a nice feature if you are utilizing local result sets.

How to incorporate multiple data sources in one report:

- Report group headers require a common value that belongs to all results or table sets included in the report. If you bring in a unique value to one results or table set, nothing is returned for any data below that group header.

- Table dimension items can only come from one data source. This means you can only use one results set per table dimension area.

- Values from multiple data sources can be included in table Facts.

- The Results column you place as a table dimension determines the Facts used. For example, you have two Results sets:

<table>
<thead>
<tr>
<th>Results 1: Fiscal Year</th>
<th>Grant No</th>
<th>Results 2: Fiscal Year</th>
<th>PCA</th>
</tr>
</thead>
<tbody>
<tr>
<td>2009</td>
<td>10000</td>
<td>2009</td>
<td>46203</td>
</tr>
<tr>
<td>2010</td>
<td>20000</td>
<td>2010</td>
<td>58913</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2011</td>
<td>69751</td>
</tr>
</tbody>
</table>

If you place 'Fiscal Year' from Results 1 into the Table Dimensions and then place Results1: Grant No and Results 2: PCA into the Table Facts, you will get the following table:

<table>
<thead>
<tr>
<th>Fiscal Year</th>
<th>Grant No</th>
<th>PCA</th>
</tr>
</thead>
<tbody>
<tr>
<td>2009</td>
<td>10000</td>
<td>46203</td>
</tr>
<tr>
<td>2010</td>
<td>20000</td>
<td>58913</td>
</tr>
</tbody>
</table>

Note...the Fiscal Year 2011 data is not shown.

- Smart charts and Pivot tables added to a multiple data source report are subject to the same restrictions as described above.

Building a multiple data source report:

1. Build the various queries you want to include in the report. Make sure each data source has a common value to combine in the report.


3. Expand the Elements pane area to show all the Results and Table sets you may want to include in your report.
4. Select→Groups on the Section title bar to show the Group Data Layout section, if necessary.

5. Select→Table on the Section title bar to show the Table Data Layout section, if necessary.

6. Build the Report Group header by dragging the item(s) from the various sections of the Elements pane to the Groups Data Layout.

7. Build the column dimensions of the report, drag the item(s) from the various sections of the Elements pane to the Table Dimensions in the Data Layout pane.

8. Build the column numeric values of the report by dragging the item(s) from the various sections of the Elements pane to the Table Facts in the Data Layout pane.

**Smart Reports**

One of the most powerful abilities of the Report section is the capacity to combine Pivot reports and Charts in a single report. Pivots and Charts are inserted into Report Group headers and bodies intelligently, meaning they reflect only the data for that report group level in which they are inserted.

**To add a Pivot or Chart to a report:**

1. Drag a Pivot or Chart from the Query folder in the Elements pane to a report group header or body. You may have to make this section larger to accommodate the newly added Pivot or Chart.

2. You will have to work on resizing the Pivot or Chart to make them look appropriate. Do not get discouraged…this might take some time.
**Printing Report Prep**

To prepare a report for printing you can adjust the page size, set page margins, set up page columns, add headers and footers, insert page breaks, and set page numbering. Once these tasks are completed, you are ready to print.

**To access Report Setup:**

1. Select → **Report** → **Report Setup**… from the menu bar. You can also double-click the ruler in the Report section.

2. Select → **Page Size** tab, specify whether to use the printer dimensions or custom dimensions. If you use custom dimensions, you will need to set up the width and height of the page.
3. Select the **Margins** tab, and then specify top, bottom, left, and right margin sizes.

![Report Page Setup](image)

4. Select the **Columns** tab, and then select the number of columns per page and enter a column width and spacing size between each column, if needed.

![Report Page Setup](image)
**Lesson 3c Exercise**


2. Within the ‘Report Group2’ header section, increase the width of the ‘GL Account Title’ label. Look through your report to make sure all titles are visible.

3. Move the ‘GL Account Title’ to the right of the ‘GL Account’ number. Align ‘GL Account’ number and ‘GL Account Title’ by the ‘Top’ function. Note: It will align with the field that is closest to the top of the section.

4. Turn on the ‘Repeat Header’ option within the ‘Report Group2’ section. To accomplish this task, right-click in the blank area of the ‘Report Group2’ header section, which contains the ‘GL Account’ number and Title. Select ‘Repeat Header’. This allows the ‘Report Group2’ header section to follow the ‘body’ section on the following pages of the report. Scroll down to take a look at how this repeats.

5. Eliminate the ‘Page 1’ fields from the ‘Page Header’ and ‘Page Footer’ sections. Next, input the ‘File Path’ field into the ‘Page Header’ section by dragging it over from the ‘Fields’ folder in the Elements pane. (Resize if necessary.) Next, add the ‘Page X of Y’ field, from the ‘Fields’ folder in the Elements pane, to the ‘Page Footer’ section. (Resize if necessary.) Note: You can practice adding other fields if you desire.

6. Make your ‘Report Group 2’ header section taller, so you can add a chart…about 2 inches or so. Find the Chart, within the Elements pane, named ‘Chart for Lesson 3’. Drag it to the newly expanded header area and resize, as necessary.

7. Alert instructor after successfully completing the exercise.
Lesson 4

Computed Items

- Computed Items Dialog Box
- Computed Items in the Query Section
- Computed Items in the ‘Results’ and ‘Table’ Sections
- Modifying a Computed Item
- Creating Computed Items in a Pivot Section
- Types of Computed Items
- Creating Computed Items in the Report Section
Computed Items

When working in Hyperion and using data from the Datamart it is often necessary to create computed items to get the data results you need. You can create computed items in the Query, Results, Table, Chart, and Pivot sections. Computed items can use existing data in their calculations or produced entirely on their own. This feature works the same in all sections of Hyperion.

*Please make sure you know the final computed figure you are requesting.* You will definitely need to verify you’re scripting with the figure you are trying to capture.

**Computed Items Dialog Box**

You will see virtually the same computed items dialog box in each section of Hyperion. You will see fewer operator buttons in the Query section than other sections.

**Name** – Name of computed item field. Please make sure another user can understand your name.

**Definition** – Displays the expression of the computed item. You do not need to type an equal sign (=) at the beginning of the expression.
**Functions** – Shows a list of function categories. Within each category are several functions available for use.

**Reference** – Displays the items requested in the query section. Use this to grab the correct field name for your computed item.

**Options** – The Options button enables you to define the data type for the computed item.
Computed Items in the Query Section

In the Query section, a computed item is a set of instructions to the Datamart server. For this reason, the Query section allows you to use computed items in a way that is not possible in other sections. Instead of creating a new data item or field, the new values simply replace the original values in the data item as they are retrieved from the Datamart.

*The following example is shown in the file titled, ‘Left Function Lesson 4’.*

To add a computed item to the Query section:

1. Right-click on the Request line, select **Add Computed Item**. The computed item dialog box will open.

2. Name your computed item. Make sure it is something other people will understand.
3. It is now time to fill in the definition area. You can either create your computed item from scratch, by using JavaScript syntax, or you can select–>Functions...for specific function categories. Within these function categories are functions you can use without knowing JavaScript.

![Image of Functions window]

4. Select the function category and function within the category you want to complete. In this example, we are using the ‘Left’ function within the ‘String functions’ category. This will return a set number of characters from the left of the field.

5. You will now have to fill in the blank fields appearing below your selection. In this option, you are able to pick a reference field, using the reference button. This way you will not make a mistake typing in the field name. This option also has the choice to enter integer data.

![Image of Reference window]
6. Notice your computed item is now scripted automatically. Click→OK.

7. The computed item is now on the Request line. To test your results, filter your Request line to agency 10700 as well as ‘return unique row’ and then process your query. This will make sure the results are what you expected.
Computed Items in the ‘Results’ and ‘Table’ Sections

When you create a computed item in the Results or Table sections, you are performing calculations on your desktop and not on the Datamart server. This differs from creating a computed item in the query section.

In the below example, we are setting rates for grants to show how much federal money is received for each grant. This is done by assigning a percentage to the ‘SFMS Transaction Amount’ based on Grant Number.

In addition, the example file below has already been processed and is ready to create a computed item. Results must be present, to create computed items, in the table and results sections.

The following example is shown in the file titled, ‘If Else Lesson 4’.

To create a computed item in the Results or Table sections:

1. Click on the ‘Result’ section called ‘If/Else Results Practice’, right-click in the body of the ‘Results’ section, select→Add Computed Item. The computed item dialog box will open.

2. Name your computed item ‘Federal Funds (10064000)’. Note: Best practice is to name it something you and others will understand.

3. Select the ‘if’ function from the computed item window. This will start the computed item formula.
4. You should put your insertion line in the first set of brackets and then select→Reference. This displays a list of fields from your Query section. Select the desired field, as shown below, in the first set of brackets.

5. Finish your computed item by using the operators and reference fields, as shown below.

Note: The “*” function is used for multiplication, as shown below.
Modifying a Computed Item

There may be times you have a need to modify a computed item, due to various reasons.

You can always tell if an item is a computed field, in the ‘Results’ and ‘Table’ sections, because they will appear in a royal blue text color and have italicized font, as shown in the ‘Data Layout’ example below.

<table>
<thead>
<tr>
<th>Agency</th>
<th>Appn Year</th>
<th>Fiscal Year</th>
<th>Budget Obj</th>
<th>Agy Obj</th>
<th>Agy Obj Title 1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Federal Funds (10064000)</td>
<td>Other Funds (10034000)</td>
<td>Agy Obj Title 2</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

To modify a computed item:

1. Highlight or select the computed item column, right-click, then select ‘Modify Column…’ or select ‘Modify…’.

Note: The modify option display varies depending on the section.

```
| Filter... |
| Sort Ascending |
| Sort Descending |
| Add Computed Item... |
| Add Grouping Column... |
| Modify Column... |
| Remove Column |
| Break Total... |
| Grand Total... |
| Hide Column |
| Number... |
| Alignment... |
| Font... |
| Border and Background... |
| Text Wrap |
| Suppress Duplicates |
| Modify... |
| Add Computed Item... |
| Add Cume |
| Data Function |
| Hide Items |
| Font... |
| Style |
| Number... |
| Justify |
| Data Labels |
| Corner Labels |
| Use Surface Values |
```

2. Make your desired changes. Click→OK.
Creating Computed Items in a Pivot Section

You can create computed items or new facts in a Pivot report. You may find it more useful to create these computed items in the Results section because it seems to be easier to use the data in a Report section. Computed items created in the Pivot or Report section are only usable in the specific area in which they were created.

The following example is shown in the file titled ‘ORBITS Intermediate Lesson 4’, and is located within the pivot section.

To create a computed item in a Pivot report:

1. Create a Pivot report, which contains ‘Row Labels’, ‘Column Labels’, and ‘Facts’. (Use the pivot report titled ‘Lesson 4 Pivot Computed Item Practice’ for this example.)

2. In the Content pane, right-click, then select Add Computed Item.

3. Set up your Computed Item called ‘Quarter1’ to display the combined total amount for M01, M02, and M03 Activity. Note: You have the option to use the “+” sign from the buttons shown below.

<table>
<thead>
<tr>
<th>Program</th>
<th>Log Approved Budget</th>
<th>M01 Activity</th>
<th>M02 Activity</th>
<th>M03 Activity</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total</td>
<td>745,612.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>Total</td>
<td>8,652,295.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>Total</td>
<td>149,740.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>Total</td>
<td>1,772,250.00</td>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>2009</td>
<td>0.00</td>
<td>2,698.00</td>
<td>1,144.00</td>
<td>970.00</td>
</tr>
<tr>
<td>2009</td>
<td>0.00</td>
<td>4,606.00</td>
<td>3,450.00</td>
<td>2,803.00</td>
</tr>
</tbody>
</table>

Summary:

This is a basic computed item example. We are simply adding together activity for Months 1, 2, and 3 to make a new column called ‘Quarter1’.
Types of Computed Items

There are many types of computed items and a few will be described on the following pages.

Concat Function

This function will join two strings or fields together to form an additional field. Use the plus (+) symbol to join multiple items together. The function is in the String category. The example below uses the PPDB Datamart and joins Work Phone and Extension.

Ir_Work_Phone + ' ', Ext. ' + Ir_Work_Phone_Ext

Left Trim and Right Trim Functions

LTRIM is the left trim function, which returns a string with specific characters removed from the beginning. These functions are in the String category. The example below uses the PPDB Datamart and removes the ‘OR’ from the employee number.

Ltrim (Ir_Emp_No, 'OR')
RTRIM is the right trim function, which returns a string with specific characters removed from the end. The example below uses the PPDB Datamart and removes the ‘00’ from the end of the (5 digit) Agency Number.

\[ \text{Rtrim (Ir_Agency,'0')} \]

### SUBSTRING Function

Use this function to return a portion of an input string beginning at a specified starting point and defining the length. This function is in the String category. The example below uses the PPDB Datamart and displays the ‘Job Group Description’ without the ‘Job Group Code’.

\[ \text{Substr (J_Jobgrp_Ds, 5, 50)} \]
### Date Functions

Several date functions are available to use in the Results and Table sections. The following table describes some examples of date functions. Many more are available within the Hyperion application.

<table>
<thead>
<tr>
<th>Date Function</th>
<th>Description and Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>AddMonths</td>
<td>o Add a specified number of months to a given date.</td>
</tr>
<tr>
<td></td>
<td><strong>AddMonths ( Ir_Appt_Dte, 6 )</strong></td>
</tr>
<tr>
<td>DayofMonth</td>
<td>o Returns the day number in a month for a given date. Possible values range from 1 to 31.</td>
</tr>
<tr>
<td></td>
<td><strong>DayOfMonth ( Proc_Date )</strong></td>
</tr>
<tr>
<td>ToYear</td>
<td>o Returns the year number in the date field. You may have to format this field to accommodate the fiscal year date.</td>
</tr>
<tr>
<td></td>
<td><strong>ToYear ( Proc_Date )</strong></td>
</tr>
<tr>
<td>MonthsBetween</td>
<td>o Returns the number of months between two given dates.</td>
</tr>
<tr>
<td></td>
<td><strong>MonthsBetween ( Effective_Date, Report_Date )</strong></td>
</tr>
<tr>
<td>Sysdate</td>
<td>o Returns the current date and time recorded on the user's computer.</td>
</tr>
<tr>
<td></td>
<td><strong>Sysdate()</strong></td>
</tr>
</tbody>
</table>

### Math Functions

Many math functions are available within Hyperion, which help to alter numbers. The following table describes some examples of math functions. Many more functions are available within the Hyperion application.

<table>
<thead>
<tr>
<th>Math Function</th>
<th>Description and Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Floor</td>
<td>o Rounds a real number down and to zero decimal places.</td>
</tr>
<tr>
<td></td>
<td><strong>Floor ( Fy_Cum )</strong></td>
</tr>
<tr>
<td>Round</td>
<td>o Rounds a real number to a specified number of decimal places. If the number of decimal places is not specified, the number is rounded to zero decimal places.</td>
</tr>
<tr>
<td></td>
<td><strong>Round ( Deb_Pos_Trans_Amt,2 )</strong></td>
</tr>
<tr>
<td>Ceil</td>
<td>o Rounds a real number up and to zero decimal places.</td>
</tr>
<tr>
<td></td>
<td><strong>Ceil ( Deb_Pos_Trans_Amt )</strong></td>
</tr>
<tr>
<td>Trunc</td>
<td>o Returns a number truncated to a specified number of decimal places without rounding the number.</td>
</tr>
<tr>
<td></td>
<td><strong>Trunc ( Deb_Pos_Trans_Amt, 1 )</strong></td>
</tr>
</tbody>
</table>
Lesson 4a Exercise

The following exercise is shown in the file titled ‘ORBITS Intermediate Lesson 4’. Start within the ‘ORBITS Results’ section.

1. Within the ‘ORBITS Results’ section, create a computed item named ‘Concat Compt Source’, which joins the ‘Compt_Source_Group’ and ‘Compt_Srce_Grp_Ttl’ fields together (Hint: Concat function).

   Include a dash (‘–’) between the two fields to show separation within the final column data.

2. Create an additional computed field, which uses the ‘Substr’ function on the ‘Cross Reference Number’ field. It should pull the 1st digit through the 5th digit of original data. Title the new field ‘Partial Cross Ref’.

3. Align the newly created computed fields to ‘left’ justify, as well as, auto size the width of the columns.

4. Create a new computed field called ‘Update Day’, which will display the day of the month. Use the ‘DayofMonth’ function and reference the ‘Update Date Time’ field. In addition, align the new field to ‘center’, as well as, alter the format to no longer show decimals.

5. Alert instructor after successfully completing the exercise.
Cumulative Function

There may be the occasion when you want a column that shows a cumulative total. Hyperion contains the ‘Cume’ function within the ‘Numeric Functions’ category.

When you create a cumulative column, you have an option to assign a break total. The cumulative amount will start at zero at each break. Make sure you sort your data set by the break column.

In the example below, the cumulative total is based on ‘SFMS Trans Amt’ and sorted by ‘Project No’.

<table>
<thead>
<tr>
<th>Project No</th>
<th>Sfms Trans Amt</th>
<th>Cumulative by Project Number</th>
<th>Vendor No</th>
<th>Project Phase</th>
</tr>
</thead>
<tbody>
<tr>
<td>S10000</td>
<td>1,590.00</td>
<td>1,590.00</td>
<td>1232084784</td>
<td>03</td>
</tr>
<tr>
<td>S10000</td>
<td>45,843.99</td>
<td>47,433.99</td>
<td>1840273800</td>
<td>00</td>
</tr>
<tr>
<td>S10000</td>
<td>3,281.47</td>
<td>50,715.46</td>
<td>1840273800</td>
<td>00</td>
</tr>
<tr>
<td>S10000</td>
<td>15,494.61</td>
<td>66,210.07</td>
<td>1363328437</td>
<td>00</td>
</tr>
<tr>
<td>S10000</td>
<td>2,468.06</td>
<td>68,678.13</td>
<td>1840273800</td>
<td>00</td>
</tr>
<tr>
<td>S10000</td>
<td>179.28</td>
<td>68,857.41</td>
<td>1840273800</td>
<td>00</td>
</tr>
<tr>
<td>S25700</td>
<td>13,325.53</td>
<td>13,325.53</td>
<td>1840273800</td>
<td>00</td>
</tr>
<tr>
<td>S25700</td>
<td>955.26</td>
<td>14,280.79</td>
<td>1840273800</td>
<td>00</td>
</tr>
<tr>
<td>S29100</td>
<td>284.38</td>
<td>284.38</td>
<td>1840273800</td>
<td>00</td>
</tr>
<tr>
<td>S29100</td>
<td>4,978.78</td>
<td>5,263.16</td>
<td>1840273800</td>
<td>00</td>
</tr>
<tr>
<td>S29100</td>
<td>354.48</td>
<td>5,617.54</td>
<td>1840273800</td>
<td>00</td>
</tr>
<tr>
<td>S29100</td>
<td>3,083.00</td>
<td>8,700.04</td>
<td>1930681263</td>
<td>00</td>
</tr>
<tr>
<td>S29100</td>
<td>3,994.11</td>
<td>12,694.75</td>
<td>1840273800</td>
<td>00</td>
</tr>
</tbody>
</table>
Numeric Functions

Numeric functions are available in the Results and Table sections. The following table describes some examples of numeric functions; however, there are many more available within Hyperion.

<table>
<thead>
<tr>
<th>Numeric Function</th>
<th>Description and Example</th>
</tr>
</thead>
</table>
| Sum              | Returns the sum of the values in the column.  
|                  | \texttt{Sum ( Sfms\_Trans\_Amt, Invoice\_No )} |
| Count            | Counts the number of rows in a column, including duplicates.  
|                  | \texttt{Count ( Employee\_Num )} |
| CountDistinct    | Counts the number of distinct values in a column.  
|                  | Nulls are counted as 1.  
|                  | \texttt{CountDistinct ( Employee\_Num )} |
| Avg              | Returns the average of the values in the column.  
|                  | \texttt{Avg ( Hours, Pay\_Type\_Code )} |

Text Functions

You can use Text functions to change the text case in the Results or Table sections. Text functions are available in the String category. The following example is using the \texttt{Initcap} function. This function returns a string with the first character of each word in upper case and the remaining character in lower case. Many more Text functions are available within Hyperion.
Lesson 4b Exercise

The following exercise is shown in the file titled ‘Lesson 4 Agency Count’.

1. Within the ‘Results for Count Practice’ section, create a ‘Count’ Numeric Function called ‘Count of Transactions’. Use ‘SFMS Trans Amt’ as the referenced column and use ‘Fiscal Month’ as the break column, as shown in the example below.

![Count Function Example]

Note: The Results section data is sorted by ‘Fiscal Month’.

2. Within the ‘Results for Count Practice’ section, create a ‘Round’ Math Function called ‘Rounded SFMS Trans Amt’. Use the ‘SFMS Trans Amt’ column and set to no decimals, as shown in the example below. Update the column format to show no decimals.

![Round Function Example]

3. Within the ‘Results for Count Practice’ section, create a ‘Cume’ Numeric Function called ‘Cume by Fiscal Month’. Use ‘SFMS Trans Amt’ as the column value and ‘Fiscal Month’ as the column break, as shown in the example below.

![Cume Function Example]

4. Alert instructor after successfully completing the exercise.
Creating Computed Items in the Report Section

You can create computed items in a Report section in various ways; however, you may find it more useful to create these computed items in other sections, such as the results, table or pivot sections. Creating it sooner will allow the data to be analyzed earlier in the process as well as allow use in multiple sections. Computed items created in the Report section are only usable in the specific area in which they were created.

The following example is shown in the file titled ‘ORBITS Intermediate Lesson 4’. A ‘Computed Item’ formula will be created in the body section of the Report, which will subtract ‘Leg Approved Budget’ from ‘FY Cum’.

To create computed items in a Report section:

1. In the Report, click within the table data area (body section). Then right-click and select ‘Add computed item…’.
2. Select the necessary fields from the Reference column list (‘Leg Approved Budget’ & ‘FY Cum’). Double-click to input them into the formula definition area.
3. Include a subtraction symbol (–) between the two fields.
4. Rename the computed item to ‘Variance’. Click ‘ok’ to complete.
5. Format the new computed column as necessary.
Lesson 5

Dashboards

- Dashboard Elements
- Creating an EIS Page or Dashboard Section
- Layout Tools
- Dashboard Section Toolbar
- Dashboard Section alteration
- Command Buttons
- Adding Radio Buttons to Display Values
- Adding a Drop Down Box to Display Values
- Add a Hyperlink to a Dashboard
- Setting Dashboard Properties
Dashboard

A Dashboard or an Executive Information System (EIS) page is an analytical tool a user can create to help users’ readily access data. The Dashboard can be as simple as directions on how to use the query or as complex as drop down option buttons and setting query filters.

You can include the following in a Dashboard:
- Result, Table, Pivot, and Chart sections
- Reports
- Hyperlinks to content
- Graphic and text

One of the main priorities of having a Dashboard is it hides the underlying sections of a BQY document and the inexperienced user does not have to understand how to move through all the different sections of the document. You can include graphics and instructions to improve the usability of the underlying query. It could also provide a timeline of changes that have happened to the document.

*The following example is shown in the file titled, ‘Building Interactive EIS Screens’.*
Dashboard Elements

Sections – Results, Chart, Pivot, and Table sections from the active document. When you embed an existing section in Dashboard, the section is automatically resized to fit. You can resize the embedded section in the Dashboard pane if needed. In addition, data in embedded sections are automatically updated to reflect any changes made in the original section.

Graphics – Lines, rectangles, ovals, and pictures for which you can set colors and border properties.

- **Line** – Creates a line that you can rotate.
- **Hz Line** – Creates a horizontal line.
- **Vt Line** – Creates a vertical line.
- **Rectangle** – Create a rectangle.
- **Round Rectangle** – Creates a rectangle with rounded corners.
- **Oval** – Creates an oval.
- **Text Label** – Creates a text label you can use as a caption.
- **Picture** – Enables you to insert bitmaps (.bmp extensions).

Controls – Objects to include in the application interface for which you can set fonts and default values. Controls provide users a way to interact with the application and can be populated with values at design time or dynamically populated using JavaScript.

- **Command Button** – To initiate or activate a process.
- **Radio Button** – To select one from a group of choices.
- **Check Box** – To toggle an option on/off or true/false. A check box either contains a check mark or is empty.
- **List Box** – To list multiple values from which users can make one or more selections.
- **Drop Down** – To list multiple values form which users can make only one selection.
- **Text Box** – To gather and display user input.
- **Embedded Browser** – To display external content by way of a browser.
- **Hyperlink** – To link external content by way of a hyperlink.
- **Slider** – A control that drives the data on an associated gauge or Live Chart.
Creating an EIS Page or Dashboard Section

You will often see this section called an EIS Page, as well as, Dashboard. In Hyperion, these titles are referencing the same thing.

Note: The ‘Undo’ option does not always work in Hyperion. Save your changes often to prevent having to do your work over again.

1. Create the necessary Query, Results, Pivots, Charts, and Report sections.

2. Select **Insert**→**New Dashboard**.

3. You will now be in a new Dashboard section. You will be in Design Mode, which enables you to view the Sections, Graphics, and Controls in the Elements pane. You can verify Design Mode by making sure there is a checkmark under **Dashboard**→**Design Mode**. You can only design your Dashboard section in Design Mode.

The following example uses the file titled, ‘Building Interactive EIS Screens’.

Don’t forget...You must be in ‘Design Mode’ to create your Dashboard section.

There are two modes for working in the Dashboard section. You can toggle back and forth from **Design Mode** and **Run Mode**. The checkmark next to Design Mode means you are working in Design Mode. If you don’t see a checkmark it means you are in Run Mode and the Elements section will not be visible.

Run Mode is the default for end users.
**Layout Tools**

Under the Dashboard menu option, resides a group of layout tools to help you create great looking Dashboard sections.

**Design Guides** – Horizontal and vertical lines that you place in your section to help line up objects. Design guides are similar to grids in that objects automatically snap to align to the design guides. If you have your rulers visible, you can click the ruler and drag one or more design guides from both the horizontal and vertical rulers.

Select **Dashboard→Design Guides**.

A checkmark display next to Design Guides means they are visible. Toggle this option to turn them off.

**Grids** – A layout that automatically snaps all objects to the closest grid spot.

Select **Dashboard→Grid**.

A checkmark display next to Grid means they are visible. Toggle this option to turn them off.

**Rulers** – Horizontal and vertical rulers help you line up items based on units of measure. Available units of measurement include inches, centimeters, and pixels. You select a unit by clicking the measure indicator at the intersection of the top and left rulers.

Select **Dashboard→Ruler**.

A checkmark display next to Ruler means they are visible. Toggle this option to turn them off.
Dashboard Section Toolbar

The Dashboard section toolbar provides icons, which enable quick use of the multiple Dashboard objects.

**Design/Run Mode** – Toggles between Design and Run mode.

**Align** – Aligns several objects at the same time. Objects are aligned to the first object you select. Select the first object, then hold down [Ctrl] and select the remaining objects. Click the arrow on the Align icon and choose an alignment option: left, center, right, top, middle, or bottom.

**Make Same Size** – Resizes the selected objects to the same size. Objects are resized to match the first object selected. Select the first object, then hold down [Ctrl] and select the remaining object. Click the arrow on the Make Same Size icon and choose a resizing option: width, height, or both.

**Layer** – Stacks a single object in relative position to other objects. Layer includes four arrangement options: Bring To Front, Send To Back, Bring Forward, and Send Backward. Use this feature to layer multiple object so only the sections of the objects you want visible are shown.
**Dashboard Section alteration**

The first Dashboard section inserted in a document is given a default name of Dashboard. Additional Dashboards are named Dashboard2, Dashboard3, Dashboard4, etc. You have three options of altering the Dashboard section and those are ‘delete’, ‘rename’ and ‘duplicate’.

1. In the Section pane, select the Dashboard section you want to alter.

2. Select the **Edit** menu and choose from the following options: \(\rightarrow\) **Delete Section**, \(\rightarrow\) **Rename Section**, or \(\rightarrow\) **Duplicate Section.** You can also right-click the Dashboard section and click any of the above options.

If renaming the Dashboard Section, a dialog box displays:

![Section Label](image)

Type in your desired new name and click \(\rightarrow\) **OK**.
Command Buttons

A ‘Command’ button is typically used to initiate or activate a process or action. Command buttons are actually very easy to set up and use. You can add command buttons to process queries, display Pivots and Reports, and to accomplish general maintenance of your document.

Note: You will want to remember that the ‘Undo’ button does not always work in Hyperion, so it is good practice to save often, as well as, test your command button to make sure it works properly, prior to moving forward.

Add a Command Button to Process and Display Data:

*The following example uses the file titled, ‘ORBITS Intermediate Lesson 5’.*

1. Open the file titled, ‘ORBITS Intermediate Lesson 5’, click on the section called ‘Dashboard Practice’ and make sure you are in ‘Design Mode’.

2. Open the ‘Controls’ folder from the Elements pane.

3. Drag and drop the ‘Command button’ item from the Elements pane to the dashboard. The dashboard will display a button titled, ‘CommandButton1’, as shown below.
4. Rename the command button. To accomplish this task, highlight and right-click the command button and select **Properties**.

5. Within the ‘Properties’ dialog box, change the Object ‘Title’ field to ‘Process Action’. This is what will display on the button within the Dashboard. Note: It is unnecessary to alter the ‘Name’ field.

6. Now you are ready to add ‘script’ to start the action process of the document. To accomplish this task, highlight and right-click on the command button and select **Scripts**.
7. Use the Object browser area on the left of the Script Editor to navigate to **Application**→**Methods** and double click **ExecuteBScript**, then inside the brackets of the new script, type: “**process doc root**”. Following the new script, click→**Enter** two times to create space for the next script.

![Script Editor](image)

8. Continue to use the Object browser area on the left of the 'Script Editor' to navigate to **Application**→**ActiveDocument**→**Sections**. Then find the report titled, ‘LAB/Actuals by Compt Source Group’.

![Script Editor](image)

9. Continue using the Script Editor and below the report ‘LAB/Actuals by Compt Source Group’, open the section folder called 'Methods' and double-click→**Activate**. The scripting code will appear in the scripting pane, as shown below. Click→**OK**.

![Application.ExecuteBScript("process doc root")] Application.ExecuteBScript("process doc root")
ActiveDocument.Sections["LAB/Actuals by Compt Source Group"]:Activate()
10. Do not forget to change to Run Mode and test your button. You should be able to click the button and view a finished report.

11. If you have not logged into an oce, it will prompt you at this time.

![Login prompt](image1.png)

12. If you have a ‘Variable Filter’ set up on your query, it will prompt you to select a filter value. If not, it will process your query with the current selected filters.

![Filter configuration](image2.png)

13. Verify the process worked correctly. Note: You should be viewing the ‘LAB/Actuals by Compt Source Group’ report.

14. Alert instructor after successfully completing the exercise.
Adding Radio Buttons to Display Values

The following example uses the file titled, ‘ORBITS Intermediate Lesson 5’. This exercise is created to display various Radio buttons with optional chart types.

Radio buttons are typically used to allow a user to select one option from a group of options. When one button in the group is selected, the others in the same group are cleared. In the example below, we will give the user an option to pick different chart types.

1. Open the file titled, ‘ORBITS Intermediate Lesson 5’, click on the section called ‘Dashboard Practice’ and make sure you are in ‘Design Mode’.

2. From the Elements pane section, drag and drop the ‘LAB by Cross Reference Num’ Chart over to the Dashboard (format, if necessary).

3. From the Controls folder in the Elements pane section, drag and drop the Radio Button to the Dashboard area.

4. Open the ‘Properties’ of the radio button and change the title to reflect the type of chart you desire (For this example input ‘LAB Line chart’).

5. Once your button is named, you can open the ‘Scripts’ editor by right clicking on the Radio button and selecting→Scripts.

6. Use the Object browser area on the left of the script editor to navigate to Application→ActiveDocument→Sections. Find and expand your Chart section (In this example we will pick ‘LAB by Cross Ref Num Chart’.) Next, expand the Properties folder, and then double-click→Chart Type. The scripting will appear in the scripting pane. Do not click OK yet!

7. Next, scroll down to the main option called ‘Constants’ and expand it. Then, expand the BqChartType group.

8. In the Scripting pane, at the end of the first script language, type an equal’s sign (=) (It should show immediately after ‘ChartType’).

9. Double-click→bqChartTypeLine. Click→OK. Review the screen shot on the following page to confirm the correct script code.
10. Toggle to Run Mode and test your Radio button.

11. Add two additional Radio buttons for this group. Add chart types for ‘Pie’ and for ‘Vertical Bar’. Follow the instructions above to complete this task.

12. Review and test each Radio button to make sure they are functioning properly.
**Add a Drop Down Box to Display Values**

Use a Drop Down Box to display different data or reports to view. In the example below, we will develop a drop down list so we can click and view our Reports.

*The following example uses the file titled, ‘ORBITS Intermediate Lesson 5’.*

Note: Be careful while inputting code into Hyperion ‘Script Editor’ because it is **case sensitive**.

1. Click on the dashboard section and make sure you are in design mode.

2. From the Controls folder in the Elements pane, drag and drop the ‘Drop Down’ function to the Dashboard area.

3. Open the ‘Properties’ of the Drop Down box and change the Object name. Change it to **Report_List**; however, do not get out of properties section just yet.

![Properties - Report_List](image)

4. Click on the ‘Values’ tab and add the exact names of a few reports within the file. Once finished, click OK. Note: Resizing the width of your ‘drop down box’ will help allow visibility of each report name.

![List Value](image)

5. Once your button is named, you can open the ‘Script Editor’ by right clicking on the Drop Down Box and selecting →**Scripts**.
6. Type the following script in the scripting pane. When complete, click \textbf{OK}.

Note: Any item in \textit{italics}, in the script below, is dependent upon how you labeled your reports and drop down box.

Note: Copying script from another program can cause issues with the coding. Best practice would be to use the ‘Script Editor’ functions or manually input the code.

\begin{verbatim}
//Open the report
var x=Report_List.SelectedIndex
string1=Report_List.Item(x)

var MySection=ActiveDocument.Sections[string1];
MySection.Visible=true
MySection.Activate()
\end{verbatim}

7. Do not forget to toggle to Run Mode and test your Drop Down Box. If any of your report selections do not work, double check the spelling of the names. If you did not type them exact, the selection will not work.
Add a Hyperlink to a Dashboard

Often, it is helpful to have web site links just a click away, so that you can access data at a moment’s notice. The following steps provide detailed instructions on how to include a website (URL) link on a Dashboard.

The following example uses the file titled, ‘ORBITS Intermediate Lesson 5’.

1. Click on the dashboard section and make sure you are in design mode. Note: ‘Ctrl D’ toggles to design mode.

2. From the Controls folder, in the Elements pane, drag and drop the ‘Hyperlink’ function to the Dashboard area.

3. Open the ‘Properties’ of the Hyperlink to change the Object ‘Title’ and add the web address URL.

Note: To open the properties, click once on the ‘Hyperlink’ icon, then right-click and select ‘Properties’.

Change the Object ‘Title’ to State of Oregon website and add the URL: http://www.oregon.gov/Pages/index.aspx.
4. Do not forget to toggle to Run Mode and test your Hyperlink.

State of Oregon website
Setting Dashboard Properties

The following example uses the file titled, ‘ORBITS Intermediate Lesson 5’.

Use the ‘Properties’ dialog box to set properties for an entire dashboard section or for specific objects within a dashboard section. Many dashboard objects have unique properties. For example, a radio button has a Radio Group property and a List Box has a Multiple Selection property. Tab-order properties are section-wide, but are accessible in the Properties dialog boxes for both the overall dashboard section as well as for the individual objects.

1. Click on the dashboard section and make sure you are in design mode.

   Note: For a specific object selection, click the individual object in the dashboard pane. To select the entire dashboard right-click on a blank area in the dashboard, making sure not to select a specific object.

2. Alter the entire dashboard from the menu bar → Dashboard → Properties.

3. The Properties dialog box will display. Move through each tab and alter various settings, as desired. Note: The following page displays and describes various property options of the dialog box.

4. When finished, click → OK and review the changes.
Available properties include:

- Alignment – Horizontal and vertical alignment, text wrapping, and rotation.

- Border and Background – Border color, width, style, shadow, background color, and pattern.

- Font – Family, style, size, effects (underline, overline, double overline), and color.

- Object – Name, title, visible, enable (control objects only), locked, scroll bars always shown, and auto-size. For embedded sections, view-only, active, or hyperlink.

- Picture – File name, size, and effects for Dashboard background and graphic object pictures.

- Tab Order – Object path an end user follows when they press the [Tab] in Run Mode.

- Accessibility – User defined and auto generated descriptive text for each embedded section or graphic.

- Values – User defined values that populate a list box, drop down, or text box controls.